Skip to content

Changelog zsh-syntax-highlighting (0.6.0-3)

2018

zsh-syntax-highlighting (0.6.0-3) unstable; urgency=medium

   * Team upload to work around upload issues with the previous upload.
   * Declare compliance with Debian Policy 4.1.5. (No changes needed.)
   * Set Rules-Require-Root to "no".
   * Bump debhelper compatibility level to 11, too.

zsh-syntax-highlighting (0.6.0-2) unstable; urgency=medium

   * Bump Standards-Version to 4.1.1.
     + §4.11: Verifying upstream's tags' signature is currently a todo,
       see debian/watch and lintian output.  (Not a pressing issue since the
       Debian maintainer and the upstream maintainer are currently the same
       person.)
     + §9.2.3: Patch unit test to use /nonexistent.  No functional change.
   * Bump debhelper dependency to 11.3 and rely on new dh_installchangelogs
     deduplication features. Closes: #902526.

2017

zsh-syntax-highlighting (0.6.0-1) unstable; urgency=medium

   * New upstream release.

zsh-syntax-highlighting (0.6.0~rc1-2) experimental; urgency=medium

   * New upstream pre-release.
     - [upstream 2dce602727d7] Aliases in the calling scope are no longer
       expanded.  (Closes: #842994)
   * Packaging changes:
     - Bump Standards-Version to 4.0.0 (no changes needed).

zsh-syntax-highlighting (0.5.0-2) unstable; urgency=low

   * Cherry-pick upstream commit 9523d6d49cb3d4db5bd84c3cec6168a2057fe3ab
     to fix a test suite error on zsh>=5.4~.  (Closes: #872017)

2016

zsh-syntax-highlighting (0.5.0-1) unstable; urgency=medium

   * New upstream release.
   * Packaging changes:
     - Bump Standards-Version to 3.9.8 (no changes needed).
     - d/control: Use secure protocol (https) for Vcs-Git.

zsh-syntax-highlighting (0.4.1-1) unstable; urgency=medium

   * New upstream release.
   * Packaging changes:
     - Declare 'Enhances: zsh'.

2015

zsh-syntax-highlighting (0.4.0-1) unstable; urgency=low

   * Initial release. (Closes: #802758)