Skip to content

Changelog zope.testing (4.9-1ubuntu1)

2022

zope.testing (4.9-1ubuntu1) jammy; urgency=medium

   * Allow output to stderr during autopkgtest to prevent failure due
     to deprecation warnings with Python 3.10

2021

zope.testing (4.9-1) unstable; urgency=medium

   * QA upload.
   * New upstream version.

2020

zope.testing (4.7-1) unstable; urgency=medium

   * QA upload.
   * New upstream version.
   * Bump standards and debhelper versions.

2019

zope.testing (4.6.2-3) unstable; urgency=medium

   * QA upload.
   * Drop Python 2 tests (Closes: #940316)
   * Increase verbosity of Python 3 tests

zope.testing (4.6.2-2) unstable; urgency=medium

   * QA upload.
   * Orphan the package. Closes: #869471.
   * Stop building the Python2 package: Closes: #938918.
   * Update build dependencies. Closes: #928150.
   * Fix lintian warnings.

2017

zope.testing (4.6.2-1) unstable; urgency=medium

   * New upstream release.
   * Add support for Python 3.6.  (Closes: #867777)
   * d/control:
     - Bump to Standards-Version 4.0.0 with no other changes needed.
     - Bump Python versions to >= 2.7 and >= 3.5
     - Remove redundant XS-Testsuite header.

2016

zope.testing (4.6.0-1) unstable; urgency=medium

   * New upstream release.
   * d/control: Bump Standards-Version with no other changes needed.

2015

zope.testing (4.5.0-3) unstable; urgency=medium

   * debian/rules:
     - Revert the previous change regarding egg-info removal.  (Closes: #802157)
     - Remove the unnecessary override of dh_auto_install.
     - Don't call dh_installchangelogs twice.

zope.testing (4.5.0-2) unstable; urgency=medium

   * d/rules: Be sure to remove any leftover python3.X/dist-packages.

zope.testing (4.5.0-1) unstable; urgency=medium

   * New upstream release.
   * d/copyright: Remove Files-Excluded header after upstream fixed their
     tarball to not include __pycache__ artifacts.

zope.testing (4.4.1-1) unstable; urgency=medium

   * New upstream release.
   * d/patches/lp1467644.patch: Removed; applied upstream.
   * d/copyright: Added a Files-Excluded header to remove __pycache__
     directories containing .pyc files that aren't already automatically
     purged.  See LP: #1484964 for details.

zope.testing (4.2.0-2) unstable; urgency=medium

   * d/patches/lp1467644.patch: Added for Python 3.5 compatibility.

zope.testing (4.2.0-1) unstable; urgency=medium

   * New upstream release.
   * d/control: Bump Standards-Version with no other changes necessary.
   * d/watch: Use pypi.debian.net redirector

2014

zope.testing (4.1.3-2) unstable; urgency=medium

   * d/tests/control: Update DEP-8 test dependencies.

zope.testing (4.1.3-1) unstable; urgency=low

   * Team upload.
 
   [ Gediminas Paulauskas ]
   * New upstream release
     - Removes the deprecated zope.testing.doctest. (Closes: #555436)
     - Adds Python 3 support.
   * Add python3-zope.testing package.
   * debian/rules: install upstream changelog.
   * debian/docs: README.rst was renamed.
   * debian/control:
     - enable autopkgtest (Closes: #692694).
     - use canonical URI for Vcs-Svn and Vcs-Browser.
     - bump Standards-Version to 3.9.4
   * Drop the use of python-van.pydeb
 
   [ Arnaud Fontaine ]
   * debian/source/options: ignore .egg-info directory.
 
   [ Barry Warsaw ]
   * Bumped version to 4.1.3.
   * d/compat: Bumped to version 9.
   * d/control:
     - Added myself to Uploaders.
     - Updated Build-Depends.
     - Tweaked long descriptions.
     - Bumped Standards-Version to 3.9.5 with no other changes necessary.
   * d/rules:
     - Converted to --buildsystem=pybuild and simplify.
     - Fix override_dh_installchangelogs rule.
   * d/tests/all{,-3}: Updated.
   * d/python-zope.testing.install: Removed; unneccesary.
   * d/test_helper: Removed; unnecessary.

2011

zope.testing (3.10.2-1) unstable; urgency=low

   * Team upload.
 
   [ Arnaud Fontaine ]
   * Switch to 3.0 (quilt) source format.
   * debian/docs:
     + Add README.txt.
   * debian/control:
     + Rename deprecated XS-Python-Version to X-Python-Version.
     + Add Vcs-Browser and Homepage fields.
     + Rename XS-Vcs-Svn to Vcs-Svn (dpkg supports it).
     + Bump Standards-Version to 3.9.2. No changes needed.
   * debian/copyright:
     + Update to the last revision of DEP5 format.
 
   [ Brian Sutherland ]
   * New upstream version.
   * Upload fixes dependency on python2.5 (Closes: #623922).
   * Use dh_python2 instead of python-central (Closes: #617180).
   * Add python-all to debian/tests/control as we test against all python
     versions.
   * Specifically depend on python-zope.testrunner, even though upstream
     doesn't, to provide backwards compatibility.

zope.testing (3.9.4-0ubuntu2) natty; urgency=low

   * debian/rules: do not mess with scripts, install only
     /usr/bin/zope-testrunner using default python (LP: #761680).
   * debian/test_helper: adapt to changed name of zope-testrunner, execute it
     with different python interpreters instead.
   * debian/tests/all: use our own test_helper.

2010

zope.testing (3.9.4-0ubuntu1) maverick; urgency=low

   * New upstream release.
   * debian/rules: Build-Depends on python-all, not its -dev variant.
   * debian/copyright: update, convert to dep5 format.

zope.testing (3.8.3-4) unstable; urgency=low

   * Fix test path on python2.6.

2009

zope.testing (3.8.3-3) unstable; urgency=low

   * Convert to debhelper 7 and the pydeb dh7 extension.

zope.testing (3.8.3-2) unstable; urgency=low

   * debian/control: build-depend on python-van.pydeb >= 1.3.0-2.
     (Closes: #552923)

zope.testing (3.8.3-1) unstable; urgency=low

   * New upstream release.

zope.testing (3.8.2-1) unstable; urgency=low

   [ Matthias Klose ]
   * New upstream version.
 
   [ Brian Sutherland ]
   * Set priority to optional as we are depended on by python-zodb which is
     priority optional.

zope.testing (3.8.1-3) unstable; urgency=low

   * Add a conflict with python-zodb (<< 2.9). LP: #422428.

zope.testing (3.8.1-2) unstable; urgency=low

   * Set section to zope.
   * Rebuild against van.pydeb 1.3.

zope.testing (3.8.1-1) unstable; urgency=low

   * New upstream release.
   * Standards-Version: 3.8.3, no changes required.
   * debian/rules: fixed FTBFS with Python 2.6. (Closes: #543230)
   * debian/control: added conflict with zope3.

zope.testing (3.7.4-4) unstable; urgency=low

   * Port revision 101026 from upstream: add a zope-testrunner binary.
     http://mail.zope.org/pipermail/checkins/2009-June/035183.html
   * Add a test_helper shell snippet that can be included in testing files
     to ease writing autopkgtest scripts.
     See /usr/share/python-zope.testing/test_helper

zope.testing (3.7.4-3) unstable; urgency=low

   * Fix test script again: one of the subtleties of grep is that it's exit
     status is 1 if no match is found.

zope.testing (3.7.4-2) unstable; urgency=low

   * Ignore spurious and not so spurious messages printed in stderr of
     test script

zope.testing (3.7.4-1) unstable; urgency=low

   * Change source package name.
   * Standards version 3.8.0.
   * Add watch file.
   * Support all python versions.
   * Convert to use python-van.pydeb for dependency generation
   * Expand Description
   * Add copyright

python-zope.testing (3.7.0-1.1) lenny; urgency=low

   * Non-maintainer upload.
   * Rebuild for lenny

2008

python-zope.testing (3.7.0-1) etch-devel; urgency=low

   * New upstream release

python-zope.testing (3.5.1-1ubuntu2.1) etch-devel; urgency=low

   * Non-maintainer upload.
   * Rebuild for etch-devel

python-zope.testing (3.5.1-1ubuntu2) hardy; urgency=low

   * Re-build for hardy

python-zope.testing (3.5.1-1ubuntu1) gutsy; urgency=low

   * Rebuild the package with proper dependencies

2007

python-zope.testing (3.5.1-1) gutsy; urgency=low

   * Inital Release