Skip to content

Changelog snappea (3.0d3-24)

2017

snappea (3.0d3-24) unstable; urgency=medium

   * QA upload.
   * Add the missing dh-python build dependency.
   * Add .desktop file from Vassilis Pandis. (Closes: #375773)

2014

snappea (3.0d3-23) unstable; urgency=medium

   * QA upload
   * use dh-autoreconf to build. Thanks to Fernando Seiti Furusato for the
     patch! (Closes: #755929)
     - debian/control: add build-dependency on dh-autoreconf
     - debian/rules: call dh-autoreconf in the targets build-stamp and
       clean

2012

snappea (3.0d3-22) unstable; urgency=low

   * QA upload.
   * Switch from a very odd combination of the utterly obsolete dh_python and
     the merely deprecated dh_pycentral to dh_python2 so dependencies are
     generated correctly (Closes: #663989)
     - Adjust python related build-depends, drop python-central from build-
       depends, and change the obsolete XS-Python-Version: current field to
       X-Python-Version to the correct Python is used
     - Update debian/rules to use dh_python2

2011

snappea (3.0d3-21) unstable; urgency=low

   * QA upload.
   * Package has been orphaned, set maintainer to Debian QA.
   * Remove duplicate section field from debian/control.
   * Update gonfig.{sub,guess}. Closes: 539972.
   * Stop shipping la file.

2010

snappea (3.0d3-20.1) unstable; urgency=low

   * Non-maintainer upload.
   * Set PYTHONPATH in a secure way. (Closes: #605151)
   * Change doc-base section to Science/Mathematics.
   * debian/control: Add ${misc:Depends}.

2007

snappea (3.0d3-20) unstable; urgency=low

   * Updated for new debian menu layout.  Menu entries have moved from
     Apps/Math to Applications/Science/Mathematics.
   * Replaced ${Source-Version} with ${binary:Version} in snappea-dev's
     dependency list.
   * Other lintian fixes: move DH_COMPAT to debian/compat; only allow
     $(MAKE) distclean to fail if the Makefile is missing.

2006

snappea (3.0d3-19) unstable; urgency=low

   * Updated to new python policy (finally!), using python-central
     (closes: #380954).
   * Changed hard-coded dependency on python2.3 to dependency on the
     default python version.
   * Switch to debhelper compatibility level 5.
   * Bumped standards-version to 3.7.2.1.

2005

snappea (3.0d3-18) unstable; urgency=low

   * Updated copyright file to include more comprehensive statements
     regarding licensing and funding.
   * Updated closed orientable census data with new data that has recently
     been made available by the author.  The new data has documentation, more
     invariants and greater detail, as well as a couple of minor corrections
     (which are noted in the documentation).  The file itself has been
     renamed from ClosedOrientableDistinct.txt to ClosedCensusInvariants.txt.
   * Minor aesthetic changes to short package descriptions.
   * Greetings from the ICE-EM/AMSI Summer School!

2004

snappea (3.0d3-17) unstable; urgency=low

   * Switched from python2.1 to default version of python (in this case 2.3).
   * Using python-pmw from debian instead of shipping our own older pmw code.
   * Patched sources to use OptionMenu.getcurselection() instead of
     OptionMenu.get(), as required by newer python-pmw.
   * Using dh_python to handle bytecode compilation.
   * Re-libtoolised to fix some build errors that have recently appeared.
   * Using Replaces instead of Conflicts for files that moved from
     snappea into snappea-dev way back in version 3.0d3-10.
   * Quoted 'needs' and 'section' fields in the debian menu file.

2003

snappea (3.0d3-16) unstable; urgency=low

   * Updated upstream website and upstream author email.
   * Changed -dev package section to libdevel.
   * Bumped standards-version to 3.6.1.

snappea (3.0d3-15) unstable; urgency=low

   * Minor manpage updates.
   * Bumped standards-version to 3.6.0.

snappea (3.0d3-14) unstable; urgency=low

   * Reworked to use python2.1 since in its current state SnapPea does not
     support python2.2.
   * New maintainer email address.
   * Bumped standards-version to 3.5.8.

2002

snappea (3.0d3-13) unstable; urgency=low

   * Applied libtool patch to cope with one snappea library linking against
     another (closes: Bug#164232).
   * Wrapped unix_kit prototypes in extern "C" for C++ users.
   * Bumped standards-version to 3.5.7.0.

snappea (3.0d3-12) unstable; urgency=low

   * Updated libtool (closes: Bug#163608).
   * Updated author's website.

snappea (3.0d3-11) unstable; urgency=low

   * Default version of python is now 2.2.

snappea (3.0d3-10) unstable; urgency=low

   * Happy new year!
   * Added autoconf/automake infrastructure.
   * Added shared library plus snappea-dev package (closes: Bug#126531).
   * Moved from python1.5 to python2.1.
   * Shaved README.Debian.

2001

snappea (3.0d3-9) unstable; urgency=low

   * Updated to conform to new python policy (closes: Bug#117539).

snappea (3.0d3-8) unstable; urgency=low

   * Suggests regina-normal.

snappea (3.0d3-7) unstable; urgency=low

   * Depends on python instead of python-base.

snappea (3.0d3-6) unstable; urgency=low

   * Removed broken links from HTML documentation.
   * General cleanup in debian/.

snappea (3.0d3-5) unstable; urgency=low

   * Upped standards-version to 3.5.6.

snappea (3.0d3-4) unstable; urgency=low

   * Cosmetic changes to the man page.

snappea (3.0d3-3) unstable; urgency=low

   * Updated debian/rules to DH_COMPAT=3.
   * Build-Depends: required version (>> 3.0.0) of debhelper.
   * Updated Standards-Version to 3.5.2.
   * Removed dh_testversion from debian/rules.
   * Miscellaneous tidying in debian/.

snappea (3.0d3-2) unstable; urgency=low

   * Added the SnapPea icon to the corresponding debian menu item.

snappea (3.0d3-1) unstable; urgency=low

   * Initial Release (closes: Bug#84996).
   * Added a top-level Makefile.
   * Added program execution scripts /usr/bin/snappea and
     /usr/bin/snappea-console.
   * Hard-coded the census location as /usr/share/snappea/CuspedCensusData.