Skip to content

Changelog ruby-whitequark-parser (3.0.2.0-3)

2021

ruby-whitequark-parser (3.0.2.0-3) unstable; urgency=medium

   * Team upload.
   * d/control: Add Breaks against rubocop << 0.89.1+dfsg-2~ as well.

ruby-whitequark-parser (3.0.2.0-2) unstable; urgency=medium

   * Team upload.
   * d/control: Add Breaks against ruby-rubocop-ast << 0.5.0.

ruby-whitequark-parser (3.0.2.0-1) unstable; urgency=medium

   * Team upload.
   * New upstream release.
     - Adds Ruby 3.0 support (closes: #996524).
   * d/control (Standards-Version): Bump to 4.6.0.
     (Build-Depends): Add racc, ragel, and ruby-cliver to create the lexers.
     (Depends): Handle dependencies with ${ruby:Depends}.
     (Description): Update text.
   * d/copyright (Copyright): Add team.
   * d/rules: Add target to create the lexers running the generate task and
     clean them too. Install upstream changelog.
   * d/watch: Update file and use github sources.
   * d/patches/git-in-gemspec.patch: Remove obsolete patch.
   * d/patches/series: Remove empty file.
   * d/upstream/metadata: Update Changeog URL.

2020

ruby-whitequark-parser (2.7.1.4-2) unstable; urgency=medium

   * Tighten dependency on ruby-ast

ruby-whitequark-parser (2.7.1.4-1) unstable; urgency=medium

   [ Debian Janitor ]
   * Set field Upstream-Contact in debian/copyright.
   * Remove obsolete field Contact from debian/upstream/metadata (already
     present in machine-readable debian/copyright).
 
   [ Utkarsh Gupta ]
   * New upstream version 2.7.1.4
   * Add myself as an uploader
   * Bump debhelper-compat to 13
   * Refresh d/patches

ruby-whitequark-parser (2.7.0.2-1) unstable; urgency=medium

   * Team upload.
 
   [ Miguel Landaeta ]
   * Update Vcs-* fields to use salsa.debian.org URLs.
 
   [ Utkarsh Gupta ]
   * Add salsa-ci.yml
 
   [ Balasankar C ]
   * New upstream release, with support for Ruby 2.7
   * Bump Standards-Version to 4.5.0
   * Bump DH compat level to 12
   * Add upstream metadata file

2018

ruby-whitequark-parser (2.4.0.2-1) unstable; urgency=medium

   * New upstream release:
     - Fix FTBFS bug with Ruby 2.5. (Closes: #888174)
   * Bump Standards-Version to 4.1.3. No changes were required.
   * Bump DH compat level to 11.
   * Update copyright dates.
   * Set Rules-Requires-Root: no.
   * Update package description.

2016

ruby-whitequark-parser (2.3.3.1-1) unstable; urgency=medium

   * Initial release. (Closes: #849497)