Skip to content

Changelog python3-stdlib-extensions (3.6.5-3)

2018

python3-stdlib-extensions (3.6.5-3) unstable; urgency=medium

   * Fix again the package removals (Simon McVittie). Closes: #894685.

python3-stdlib-extensions (3.6.5-2) unstable; urgency=medium

   * Re-Add the 3.6.5~rc1-2 and 3.6.5~rc1-3 uploads. Closes: #894456.

python3-stdlib-extensions (3.6.5-1) unstable; urgency=medium

   * Update 3.6 extensions to the 3.6.5 release.
   * Update 3.7 extensions and modules to 3.7.0~b3.

python3-stdlib-extensions (3.6.5~rc1-3) unstable; urgency=medium

   * Bump the release string to satisfy dependencies. Closes: #894168.

python3-stdlib-extensions (3.6.5~rc1-2) unstable; urgency=medium

   * python3-distutils: Don't ship distutils/{__init__,version}.py

python3-stdlib-extensions (3.6.5~rc1-1) unstable; urgency=medium

   * Update 3.6 extensions to the 3.6.5 release candidate.
   * Update 3.7 extensions and modules to 3.7.0~b1.

python3-stdlib-extensions (3.6.4-4) unstable; urgency=medium

   * Update to 20180212 from the 3.6 branch.

python3-stdlib-extensions (3.6.4-3) unstable; urgency=medium

   * Update 3.7 extensions and modules to 3.7.0~b1.

2017

python3-stdlib-extensions (3.6.4-2) unstable; urgency=medium

   * Relax dependencies on python3.

python3-stdlib-extensions (3.6.4-1) unstable; urgency=medium

   * Update extensions to the 3.6.4 release.
   * Build a python3-lib2to3 package.

python3-stdlib-extensions (3.6.4~rc1-6) unstable; urgency=medium

   * python3-distutils: Depend on python3.6-2to3.
   * Loosen dependency on python3 version.

python3-stdlib-extensions (3.6.4~rc1-5) unstable; urgency=medium

   * python3-tk: Don't ship the tkinter test files. Closes: #884414.

python3-stdlib-extensions (3.6.4~rc1-4) unstable; urgency=medium

   * Re-upload, with binaries built.

python3-stdlib-extensions (3.6.4~rc1-3) unstable; urgency=medium

   * Loosen the dependencies on the python3 version.

python3-stdlib-extensions (3.6.4~rc1-2) unstable; urgency=medium

   * python3-tk: Ship the tkinter module in this package.
   * python3-distutils: Split out from the Python standard library.

python3-stdlib-extensions (3.6.4~rc1-1) unstable; urgency=medium

   * Update extensions to the 3.6.4 release candidate.
   * Add extensions for 3.7.

python3-stdlib-extensions (3.6.3-1) unstable; urgency=medium

   * Update extensions to the 3.6.3 release.
   * Drop extensions for 3.5. Closes: #880839.

python3-stdlib-extensions (3.6.2-1) unstable; urgency=medium

   * Update extensions to the 3.5.4 release.
   * Update extensions to the 3.6.2 release.
   * Bump standards version.

python3-stdlib-extensions (3.5.3-2) unstable; urgency=medium

   * Add extensions for 3.6.

python3-stdlib-extensions (3.5.3-1) unstable; urgency=medium

   * Update extensions to the 3.5.3 release.

2016

python3-stdlib-extensions (3.5.1-1) unstable; urgency=medium

   * Remove 3.4 extensions.
   * Update extensions to the 3.5.1 release.

2015

python3-stdlib-extensions (3.4.3-4) unstable; urgency=medium

   * Update extensions to the current 3.4 and 3.5 branches.

python3-stdlib-extensions (3.4.3-3) unstable; urgency=medium

   * Build extensions for Python 3.5.

python3-stdlib-extensions (3.4.3-1) unstable; urgency=medium

   * Bump version to 3.4.3.

2014

python3-stdlib-extensions (3.4.2-1) unstable; urgency=medium

   * Bump version to 3.4.2 release.

python3-stdlib-extensions (3.4.2~rc1-1) unstable; urgency=medium

   * Bump version to 3.4.2 release candidate 1.

python3-stdlib-extensions (3.4.1-3) unstable; urgency=medium

   * Build for blt 2.5. Closes: #753929.

python3-stdlib-extensions (3.4.1-2) unstable; urgency=medium

   * Require BLT version built for Tcl/Tk 8.6.

python3-stdlib-extensions (3.4.1-1) unstable; urgency=medium

   * Bump version to 3.4.1.
   * Remove python 3.3 sources.

python3-stdlib-extensions (3.3.4-1) unstable; urgency=medium

   * Bump version to 3.3.4.
   * Handle multiarch extension names. Closes: #735805.

2013

python3-stdlib-extensions (3.3.3-2) unstable; urgency=medium

   * Build for python3.4.

python3-stdlib-extensions (3.3.3-1) unstable; urgency=low

   * Bump version to 3.3.3.
   * Make the packages Multi-Arch: same. Replace the dependency on
     python3 with libpython3-stdlib.
   * Allow the package to cross-build.

python3-stdlib-extensions (3.3.2-1) unstable; urgency=low

   * Bump version to 3.3.2.

python3-stdlib-extensions (3.3.1-1) unstable; urgency=low

   * Bump version to 3.3.1.
   * Allow the package to cross-build.

2012

python3-stdlib-extensions (3.3.0-1) experimental; urgency=low

   * Python 3.3.0 release.

python3-stdlib-extensions (3.3.0~rc1-1) experimental; urgency=low

   * Python 3.3.0 release candidate 1.

python3-stdlib-extensions (3.3.0~a2-1) experimental; urgency=low

   * Python 3.3.0 alpha 2 release.

python3-stdlib-extensions (3.2.3-1) unstable; urgency=low

   * Python 3.2.3 release.
     - Remove uses of the C tolower()/toupper() which could break with
       a Turkish locale.
     - Improve _tkinter error message on unencodable character.
   * Bump standards version.
   * Remove Python 3.1 sources.

2011

python3-stdlib-extensions (3.2-4) unstable; urgency=low

   * Fix FTBFS with multiarch locations.

python3-stdlib-extensions (3.2-2) unstable; urgency=low

   * Stop building for python3.1.

python3-stdlib-extensions (3.2-1) unstable; urgency=low

   * Python 3.2 release.

2010

python3-stdlib-extensions (3.2~a3-1) experimental; urgency=low

   * Build for Python 3.2.

python3-stdlib-extensions (3.1.2-2) unstable; urgency=low

   * Fix build failure with changed site directory.

python3-stdlib-extensions (3.1.2-1) unstable; urgency=low

   * Python 3.1.2 release.

python3-stdlib-extensions (3.1.1-1) unstable; urgency=low

   * Bump to 3.1.1, update from the 3.1 branch 20100117.

2009

python3-stdlib-extensions (3.1-1) experimental; urgency=low

   * Build extensions for 3.1.

python3-stdlib-extensions (3.0.1-0ubuntu3) jaunty; urgency=low

   * debian/rules (clean): Update for 3.x.

python3-stdlib-extensions (3.0.1-0ubuntu2) jaunty; urgency=low

   * Build for python3.

python-stdlib-extensions (2.5.4-0ubuntu2) jaunty; urgency=low

   * Fix build dependencies.

python-stdlib-extensions (2.5.4-0ubuntu1) jaunty; urgency=low

   * Build extensions for 2.6.

2008

python-stdlib-extensions (2.5.2-1ubuntu1) intrepid; urgency=low

   * Fix build failure, linking with the correct BLT library.

python-stdlib-extensions (2.5.2-1) unstable; urgency=low

   * Bump the package version to 2.5.2.

python-stdlib-extensions (2.5.2-0ubuntu2) hardy; urgency=low

   * python-tk-dbg: Depend on python-tk, python-gdbm-dbg: Depend on python-gdbm.

python-stdlib-extensions (2.5.2-0ubuntu1) hardy; urgency=low

   * New upstream bugfix version.

python-stdlib-extensions (2.5.1-1ubuntu2) hardy; urgency=low

   * Build separate python-tk-dbg and python-gdbm-dbg packages. LP: #154020.

2007

python-stdlib-extensions (2.5.1-1ubuntu1) gutsy; urgency=low

   * Bump the package version to 2.5.1 (no code change).

python-stdlib-extensions (2.5-0ubuntu1) feisty; urgency=low

   * Bump the package version to 2.5.
   * Set Ubuntu maintainer address.

python-stdlib-extensions (2.4.4-3) unstable; urgency=low

   * python-*-dbg: Add dependency to the python-* package.

python-stdlib-extensions (2.4.4-2) unstable; urgency=low

   * Build separate python-tk-dbg and python-gdbm-dbg packages.

2006

python-stdlib-extensions (2.4.4-1) unstable; urgency=low

   * Update modules to the 2.4.4 and 2.5 releases.

python-stdlib-extensions (2.4.3-4) unstable; urgency=low

   * Update 2.5 extensions, taken from the 2.5c1 release.

python-stdlib-extensions (2-2) unstable; urgency=high

   * Remove the conflicts with the python2.x versions; now the python2.x
     packages conflict with python-tk (<< 2.3.4-2). Closes: #380597.

python-stdlib-extensions (2-1) unstable; urgency=low

   * Add 2.5 extensions, taken from the 2.5beta2 release.
   * Build the extensions for python2.5 as well. Closes: #380125.
   * Remove lib-tk from the package, moved to python2.x.

python-stdlib-extensions (1-1ubuntu1) edgy; urgency=low

   * Do build the extensions for the supported Python versions only.

python-stdlib-extensions (1-1) unstable; urgency=low

   * Build python-tk and python-gdbm from a separate source to
     include the extensions for all supported python versions into
     one binary package.
   * Initial release, split out from the python2.x packages.
     - 2.4 taken from the 2.4 branch (20060607).
     - 2.3 taken from the 2.3.5 release.