Skip to content

Changelog python-pylibacl (0.5.3-1build2+10.0trisquel1)

2021

python-pylibacl (0.5.3-1build2+10.0trisquel1) nabia-backports; urgency=medium

   * Forward-ported from bionic

2017

python-pylibacl (0.5.3-1build2) artful; urgency=medium

   * No change rebuild to drop Python 3.5 support.

python-pylibacl (0.5.3-1build1) artful; urgency=medium

   * No change rebuild to add Python 3.6 support.

2016

python-pylibacl (0.5.3-1) unstable; urgency=medium

   * Imported Upstream version 0.5.3; main changes:
     - improve FreeBSD support
     - fix qualifier overflow issues due to wrong types
   * Improve hardening of the package (all except pie, which breaks the
     build)
   * Switch debian/copyright to dep5
   * Switch debian packaging repo over to alioth
   * Switch build system to dh and pybuild
   * Split documentation into separate package, in order to reduce the
     dependencies for the python2 package
   * Add autopkg tests

2015

python-pylibacl (0.5.2-2) unstable; urgency=medium

   * Fix building with Sphinx 1.3 (Closes: #787172).

2014

python-pylibacl (0.5.2-1) unstable; urgency=medium

   * New minor upstream release: only fixes to unittests
   * Update watch file to point at the new downloads location
   * Standards version 3.9.5 (no changes needed)

2012

python-pylibacl (0.5.1-1) unstable; urgency=low

   * New upstream version: bugfixes for refcount leaks and possible
     NULL-pointer dereferences
   * Add packages for Python3
   * Switch from python-support to dh_python2/dh_python3
   * Standards Version 3.9.3 (no changes needed)

2010

python-pylibacl (0.5.0-3) unstable; urgency=low

   * Remove old Replaces/Breaks

python-pylibacl (0.5.0-2) unstable; urgency=low

   * Apply a modified version of the Ubuntu patch for enabling debug
     packages, thanks Bhavani Shankar R (Closes: #591367).
   * Standards Version 3.9.1 (Use Breaks instead of Conflicts).

python-pylibacl (0.5.0-1) unstable; urgency=low

   * New upstream release
   * Switch to my Debian address and remove DM-Upload-Allowed
   * Standards version 3.8.4 (no changes needed)
   * Switch to dpkg-source 3.0 (quilt) format

2009

python-pylibacl (0.4.0-3) unstable; urgency=low

   * Fixes "FTBFS on Debian GNU/Hurd [Patch]" (added patch by
     bdefreese@debian.org) (Closes: #534123)
   * Fixed lintian copyright format warning
   * Added Vcs-* and DM-* fields to debian/control
   * Update standard version to 3.8.2 (no changes required)

2008

python-pylibacl (0.4.0-2) unstable; urgency=low

   * Removed debian/pycompat (not needed with recent pysupport)
   * Fixed clean rule (Closes: #488763)

python-pylibacl (0.4.0-1) unstable; urgency=low

   * New Upstream Version, with license changed from GPL to LGPL
   * Update to Policy 3.8.0
   * Update the rules file for newer pysupport version
   * Update debhelper compat level to 7
   * Added watch file

python-pylibacl (0.3.0-1) unstable; urgency=low

   * New Upstream Version (more functionality implemented from libacl)
   * Fix lintian warnings

2006

python-pylibacl (0.2.2-1) unstable; urgency=low

   * New upstream release (add support for building on GNU/kFreeBSD, removes
     some warnings) (Closes: #401316).
   * Acknowledge NMU by Pierre Habouzit. Thanks! (Closes: #373342).

python-pylibacl (0.2.1-3.1) unstable; urgency=low

   * Non-maintainer upload.
   * Update package for the last python policy (Closes: #373342).

python-pylibacl (0.2.1-3) unstable; urgency=low

   * Stop building python 2.2 packages (closes: #351149)
   * Start building python 2.4 packages
   * Updated standards version to 3.6.2 (no changes)
   * Updated FSF address in copyright file

2004

python-pylibacl (0.2.1-2) unstable; urgency=low

   * Fixed missing dependency on python (closes: #258483)
   * Updates to standards version 3.6.1

2003

python-pylibacl (0.2.1-1) unstable; urgency=low

   * Initial Release.