Skip to content

Changelog parole (1.0.5-1)

2019

parole (1.0.5-1) unstable; urgency=medium

   * d/watch: update to use uscan special strings
   * New upstream version 1.0.5
   * d/control: update dh compat level to 12
   * d/control: update standards version to 4.4.1

parole (1.0.4-1) unstable; urgency=medium

   * New upstream version 1.0.2
   * New upstream version 1.0.4
   * d/rules: stop moving appdata to appstream folder
   * d/control: update dh compat level to 11

parole (1.0.2-1) unstable; urgency=medium

   [ Mateusz Łukasik ]
   * New upstream version 1.0.2
 
   [ Yves-Alexis Perez ]
   * d/control: drop Lionel from uploaders, thanks!
   * d/control: use debhelper-compat b-d and update to 10
   * d/control: add b-d on xfce4-dev-tools and gtk-doc-tools
   * d/rules: make sure m4/ exists before running autoreconf
   * d/rules: drop --parallel to dh
   * use HTTPS protocol where needed
   * d/control: drop suggests on gnome-codec-install
   * d/control: update standards version to 4.4.0

2018

parole (1.0.1-1) unstable; urgency=medium

   * d/gbp.conf added, following DEP-14
   * New upstream version 1.0.1

parole (1.0.0-1) unstable; urgency=medium

   * Moved the package to git on salsa.debian.org
   * Updated the maintainer address to debian-xfce@lists.debian.org
   * New upstream version 1.0.0
   * run wrap-and-sort
   * d/control: add missing b-deps on clutter
   * d/rules: move appdata files to /u/s/metainfo
   * Upload to unstable

2017

parole (0.9.2-1) experimental; urgency=medium

   [ Unit 193 ]
   * New upstream development release.
   * Update standards-version to 4.0.0.
   * d/rules:
     - Strip -Wl,-Bsymbolic-functions from LDFLAGS as it breaks plugins.
     - Drop override for --disable-silent-rules, it's default now.
     - Replace find-and-delete with -X .la to exclude '.la' files.
     - Use dh_missing instead of dh_install --fail-missing.

parole (0.9.1-1) experimental; urgency=medium

   * New upstream development release.
   * debian/control:
     - update standards version to 3.9.8.

2015

parole (0.8.1-1) unstable; urgency=medium

   [ Jackson Doak ]
   * New upstream release

parole (0.8.0-2) unstable; urgency=medium

   * debian/control:
     - add dependency on gstreamer1.0-plugins-base, gstreamer1.0-alsa |
     gstreamer1.0-audiosink and gstreamer1.0-plugins-good, parole doesn't start
     without them.
   * Upload to unstable.

parole (0.8.0-1) experimental; urgency=medium

   [ Mateusz Łukasik ]
   * New upstream release.
   * Bump standards-version to 3.9.6

2014

parole (0.6.1-1) experimental; urgency=medium

   [ Jackson Doak ]
   * New upstream release.
     - Properly use specified device, use correct URI (lp: #1098323)

parole (0.6.0-1) experimental; urgency=low

   [ Yves-Alexis Perez ]
   * debian/control:
     - update libxfce4ui-1-dev build-dep to libxfce4ui-2-dev
     - add depends on gstreamer1.0-libav.
 
   [ Lionel Le Folgoc ]
   * debian/control:
     - switch to gst1.0 since it's now the version used by default in parole.
     - change libgtk2.0-dev (b-)dep to libgtk-3-dev as libxfce4ui-2-dev uses
       gtk3.
 
   [ Jackson Doak ]
   * New upstream release (0.6.0) Closes: #729255
   * debian/control: Bump standards-version to 3.9.5
   * debian/copyright: Don't use symlink licenses

2013

parole (0.5.4-1) unstable; urgency=medium

   [ Jackson Doak ]
   * New upstream release
   * Replace autotools-dev with autoreconf
   * debian/rules: --disable-silent-rules
   * Update manpage
 
   [ Yves-Alexis Perez ]
   * debian/rules:
     - drop xdt-autogen and autoreconf calls.
   * debian/control:
     - drop build-dep on dh-autoreconf.

parole (0.5.2-1) unstable; urgency=low

   [ Evgeni Golov ]
   * Correct Vcs-* URLs to point to anonscm.debian.org
 
   [ Yves-Alexis Perez ]
   * New upstream release.
   * debian/rules:
     - include architecture.mk to get DEB_HOST_MULTIARCH.

parole (0.5.1-1) unstable; urgency=low

   * New upstream release.
   * debian/control:
     - add build-dep on autotools-dev.
   * debian/rules:
     - use autotools-dev dh addon to refresh config.{guess,sub}.

parole (0.5.0-1) unstable; urgency=low

   [ Lionel Le Folgoc ]
   * debian/patches: add missing DEP3 headers.
   * debian/control:
     - add b-dep on libxfconf-0-dev since parole now uses Xfconf
     - suggests gnome-codec-install for the missing codec feature.
 
   [ Micah Gersten ]
   * Update link to GPL license to appease lintian
     - update debian/copyright
 
   [ Yves-Alexis Perez ]
   * New upstream release.
   * debian/patches:
     - 01_fix-implicit-dso-linking dropped, not needed anymore.
   * debian/rules:
     - drop call to xdt-autogen, not needed anymore.
     - use parallel build.
     - use debhelper 9 / dpkg-dev 1.16.1 hardening support.
     - use multiarch paths.
   * debian/control:
     - update standards version to 3.9.4.
     - update debhelper build-dep to 9
     - drop hardening-includes build-dep.
     - drop xfce4-dev-tools, libtool and gtk-doc-tools build-deps.
     - replace libxfcegui4 build-dep by libxfce4ui.
     - drop Simon and Emmanuele from uploaders, thanks to them for their work!
   * debian/compat bumped to 9.
   * debian/parole.install:
     - update paths for multiarch.

2011

parole (0.2.0.6-1) unstable; urgency=low

   [ Lionel Le Folgoc ]
   * debian/control:
     - drop unneeded build-dep on xulrunner-dev.   closes: #594073
     - suggests a few useful gstreamer0.10 plugins.
     - build-depends on quilt.
   * debian/patches:
     - 01_fix-implicit-dso-linking.patch: added, fixes FTBFS with binutils-gold.
     - series: added.                                            closes: #615760
   * debian/rules: pass --with quilt to dh.
 
   [ Yves-Alexis Perez ]
   * New upstream release.
   * Switch to 3.0 (quilt) source format.
   * debian/control:
     - update standards version to 3.9.2.
     - drop browser-plugin-parole package.
     - drop quilt build-dep.
     - add build-dep on hardening-includes
     - bump xfce build-deps to 4.8.
   * debian/parole.install updated.
   * debian/rules:
     - use --fail-missing and manually remove spurious files.
     - drop quilt addon
     - pick build flags from dpkg-buildflags.
     - add -O1, -z,defs and --as-needed to LDFLAGS.
     - add hardening flags to build flags.
     - stop harcoding the shell to bash, it works fine now.      closes: #623830

2010

parole (0.2.0.2-3) unstable; urgency=low

   * debian/control:
     - add depends on gstreamer0.10-x.                           closes: #583610

parole (0.2.0.2-2) unstable; urgency=low

   * debian/control, debian/browser-plugin-parole: rename browser plugin
     package since it seems that's the preferred scheme.

parole (0.2.0.2-1) unstable; urgency=low

   * Initial release                                            closes: #549971