Skip to content

Changelog libreoffice (1:7.3.2-0ubuntu2)

2022

libreoffice (1:7.3.2-0ubuntu2) jammy; urgency=medium

   * Fix Qt5 Wayland popups (LP: #1968728)

libreoffice (1:7.3.2-0ubuntu1) jammy; urgency=medium

   * New upstream release
   * Use XDG_DOWNLOAD_DIR as location for temporary file for offline help
     (LP: #1951210)

libreoffice (1:7.3.2~rc2-1) unstable; urgency=medium

   * New upstream release candidate

libreoffice (1:7.3.2~rc2-0ubuntu1) jammy; urgency=medium

   * New upstream release candidate
   * Bump yaru source to "2022-03-12"
   * Demote Recommends to Suggests of requires browser as help viewer

libreoffice (1:7.3.2~rc1-0ubuntu2) jammy; urgency=medium

   * Restrict parallelism to 3 on amd64 to workaround insufficient builder
     resources

libreoffice (1:7.3.2~rc1-0ubuntu1) jammy; urgency=medium

   * New upstream release candidate

libreoffice (1:7.3.1-1) unstable; urgency=medium

   * LibreOffice 7.3.1 final release

libreoffice (1:7.3.1~rc3-0ubuntu1) jammy; urgency=medium

   * New upstream release candidate

libreoffice (1:7.3.1~rc2-0ubuntu1) jammy; urgency=medium

   * New upstream release candidate

libreoffice (1:7.3.1~rc1-0ubuntu3) jammy; urgency=medium

   * Fix header discovery with kf5coreaddons >= 5.91.0

libreoffice (1:7.3.1~rc1-0ubuntu2) jammy; urgency=medium

   * Recommend/Suggest firefox as first alternative while being the default
     browser in Ubuntu

libreoffice (1:7.3.1~rc1-0ubuntu1) jammy; urgency=medium

   * New upstream release candidate

libreoffice (1:7.3.1~rc1-1) unstable; urgency=medium

   * New upstream release candidate

libreoffice (1:7.3.0-1) unstable; urgency=medium

   * New upstream release
 
   * debian/watch: watch releases again

libreoffice (1:7.3.0~rc3-0ubuntu1) jammy; urgency=medium

   * New upstream release candidate
   * Bump yaru source to "2022-01-20"

libreoffice (1:7.3.0~rc2-3) unstable; urgency=medium

   * debian/tests/control.in:
     - comment out build-needing autopkgtests again by request of the release
       team; the infrastructure even on amd64 is not capable of handling it due
       due autopkgtest shortcomings
   * debian/control.help.in.
     - move the browser Depends to Recommends: (closes: #1003864)
   * debian/patches/apparmor-updates.diff: add patch to fix saving with
     enforced apparmor again, thanks Vincas Dargis (closes: #1004038)

libreoffice (1:7.3.0~rc2-2) unstable; urgency=medium

   * upload to unstable
 
   * debian/tests/control.in, debian/tests/uicheck-{sfx2,svx}:
     also run uitests in sfx2 and svx
   * debian/tests/control.in: try to optimize the order of the tests
     a bit (especially for uicheck-*) to try reusing the testbed and
     avoid costly copy(up|down)s

libreoffice (1:7.3.0~rc2-0ubuntu1) jammy; urgency=medium

   * New upstream release candidate
   * Enable dwz on amd64
   * Disable autopkgtests with build-needed to keep their runtime reasonable

libreoffice (1:7.3.0~rc2-1) experimental; urgency=medium

   * New upstream release candidate

2021

libreoffice (1:7.3.0~rc1-2) experimental; urgency=medium

   * debian/patches/fix-uicheck-tests-on-i386.patch: update
   * debian/patches/fix-Tdf126116-test.diff: add upstream patch from gerrit;
     fix upstream FTBFS timebomb found by reproducible builds
 
   * debian/tests/*: rename "uno" to "testtools-bridgetest", since it's
     more telling (and inside testtols anyway, uno is just the command
     ran)

libreoffice (1:7.3.0~rc1-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/rules:
     - add support (don't use it (yet)) for using --enable-cipher-openssl-backend
     - limit llvm build-dep to le/skia-using archs
     - build the mysqlc test only on the archs we run the actual test (at least
       for now)
     - bump liborcus-dev build-depends to >= 0.17.2 if we run the tests

libreoffice (1:7.3.0~beta1-4) experimental; urgency=medium

   * debian/rules:
     - add explicit Build-Depends on llvm since clang doesn't pull in
       llvm-xx-linker-tools anymore

libreoffice (1:7.3.0~beta1-3) experimental; urgency=medium

   * debian/patches/fix-mysqlc-test.diff: as name says, from gerrit
 
   * debian/rules:
     - build the connectivity mysqlc test with the rest of the tests so it
       doesn't do that in the actual autopkgtest test
     - stop hardcoding clang-12 for ppc64el, add build-dep on clang (>= 1:12)
       now that 13 is default in sid
   * debian/libuno-sal3.symbols: update

libreoffice (1:7.3.0~beta1-2) experimental; urgency=medium

   * debian/patches/revert-eabcfb3f18a6944d9ad89cecd3eb3ca7a2259cf3.diff:
     as name says; revert broken change/test; from upstream gerrit

libreoffice (1:7.3.0~beta1-1) experimental; urgency=medium

   * New upstream beta release
 
   * debian/patches/pdfium-support-system-libopenjpeg-and-libabsl.diff:
     don't use internal libabsl cody copy in pdfium; add conditionalization
     for it and openjpeg2
 
   * debian/rules:
     - switch WEBDAV_LIB to the curl backend since it now has the test
       coverage instead of neon and is default now anyways
     - actually only set TEST_TIMEOUT if we ignore the test results anyway...
     - add abseil and openjpeg2 to SYSTEM_STUFF if building pdfium

libreoffice (1:7.3.0~alpha1-6) experimental; urgency=medium

   * debian/tests/unitcheck.
     - remove broken mkdir -p of aboutbox.ui; add mkdir -p
       instdir/share/config/soffice.cfg/vcl/ui/.dir which was intended...

libreoffice (1:7.3.0~alpha1-5) experimental; urgency=medium

   * debian/tests/*, debian/tests/control.in: strip cppunit- from
     cppunit-slowcheck and -unitcheck (the latter contains junit checks, too).
     Keep it for cppunit-subsequentcheck since that ecplicitely disables
     junit (which is tested in junit-subsequentcheck)
   * debian/test/unitcheck:
     - also filter out the unoidl module (no idea why it
       worked in my run and not in ci, but...)
     - don't allow test as root, the sal test fails miserably as root
     - create missing instdir/share/config/soffice.cfg/vcl/ui/aboutbox.ui
   * debian/tests/cppunit-subsequentcheck: add missing cd $SRCDIR
   * debian/tests/control.in:
     - move smoketest up again (before the test-extension*) tests to stress
       it's importance  (and it's restricted on archs where we have the
       cpppunit tests having build-needed anyway)

libreoffice (1:7.3.0~alpha1-4) experimental; urgency=medium

   * debian/rules:
     - disable LTO on mips64el
     - also uncomment smoketest.jar move to -smoketest-data again (although
       effectively unused..) (closes: #998435)
     - don't check for AUTOPKGTEST_TMP, it seems to not been set in build stage
       already (add hack to grep for autopkgtest in pwd instead).
       Don't run the checks in build* if in autopkgtest builds (as they are run
       later anyway)
     - Separate RUN_MAKE_CHECK into BUILD_TESTS/RUN_MAKE_CHECK
     - use -g1 on autopkgtest builds (saving disc space/time on all those
       copies...)
     - don't specify --without-cppunit in CONFIGURE_FLAGS_INDEP per
       default (only explicit build-indep builds)
   * debian/tests/*, debian/tests/patches/*:
     - move cppunit part out of smoketest-standalone.diff into
       cppunit-standalone.diff
   * debian/tests/control.in:
     - make uno superficial, it only runs the bridgetest; remove it from
       cppunit-subsequentcheck
     - move smoketest after the cppunit tests and run it only on the
       architectures those, too (also make it build-needed); add missing
       libreoffice-smoketest-data dependency
   * debian/tests/*:
     - only create config_host.mk when not existing (e.g. architectures having
       no tests with build-needed and thus there is no build which created it)
     - don't try to run test-extension/odk-build-examples* as root, skip them
       if doing so
   * debian/tests/control.in, debian/rules:
     - don't use @ as dependency in cppunit-* since -nogui conflict with the
       "real" ones; populate by dh_listpackages but filter -nogui, -dev-doc and
       the l10ns/helps out
   * debian/control.in.
     - bump ure depends to >= 1:7.3.0~ (closes: #998746)
   * debian/tests/cppunit-*:
     - fix syntax; add more needed .dir's

libreoffice (1:7.3.0~alpha1-3) experimental; urgency=medium

   * debian/patches/cppunit-optional.diff: build more stuff in smoketest
     not related to cppunit itself (e.g. TestExtension.{jar,oxt})
 
   * debian/rules:
     - build smoketestdoc.sxw again

libreoffice (1:7.3.0~alpha1-2) experimental; urgency=medium

   * debian/rules:
     - use --without-cppunit in build-indep
     - use clang 12 on ppc64el (if building with LTO at least)
     - fix autopkgtest builds; explicitely set PACKAGE_SDK_DOCS=n

libreoffice (1:7.3.0~alpha1-1) experimental; urgency=medium

   * New upstream alpha release
     - fixes --enable-lto build with clang (filters out -flto=X)
       (closes: #985867)
 
   * debian/patches/filter-out-lto-flags.diff: remove, was incomplete since
     the revert in 1:7.2.1-1 anyway
 
   * debian/rules:
     - use --with-idlc-cpp=cpp to use cpp instead of ucpp and
       adapt IDLC_CPP_DEPENDS for -dev accordingly
     - build with LTO if we build with mergelibs
     - only test the apparmor profiles' syntax on build-indep builds
       (since that is where they are installed); move (dh-)apparmor build-deps
       to Build-Depends-Indep
   * debian/tests/* debian/rules::
     - run the cppunit tests (as superficial tests) and add
       a test for manually running CppunitTest_connectivity_mysql_test after
       preparing mariadb (also superficial)
     - run the smoketest again now that we have a needs-build test anyway and
       don't add a hacked smoketestdoc.sxw anymore into smoketest-data - use the
       the just-built one
   * debian/rules, debian/control.in, debian/joinctrl.py: add new
     Build-Depends-Arch: containing the nocheck build-deps needed for make check
     on arch-dep builds
   * debian/watch: watch alphas/betas

libreoffice (1:7.2.5~rc2-0ubuntu1) jammy; urgency=medium

   * New upstream release candidate

libreoffice (1:7.2.5~rc1-0ubuntu2) jammy; urgency=medium

   [ Rene Engelhard ]
   * debian/patches/fix-e_book_client_connect_direct_sync-sig.diff:
     as name says; from libreoffice-7-2 branch
   * debian/patches/mdds-2.0-and-orcus-0.17.diff: update
   * debian/rules:
     - bump liborcus-dev build-depends to >= 0.17.2 if we run the tests

libreoffice (1:7.2.5~rc1-0ubuntu1) jammy; urgency=medium

   * New upstream release candidate

libreoffice (1:7.2.4-0ubuntu1) jammy; urgency=medium

   * New upstream release

libreoffice (1:7.2.4-3) unstable; urgency=medium

   * debian/patches/fix-Tdf126116-test.diff: add patch from gerrit;
     fix upstream FTBFS timebomb

libreoffice (1:7.2.4-2) unstable; urgency=medium

   * debian/patches/fix-e_book_client_connect_direct_sync-sig.diff:
     as name says; from libreoffice-7-2 branch
   * debian/patches/mdds-2.0-and-orcus-0.17.diff: update
 
   * debian/rules:
     - bump liborcus-dev build-depends to >= 0.17.2 if we run the tests

libreoffice (1:7.2.3-0ubuntu1) jammy; urgency=medium

   * New upstream release

libreoffice (1:7.2.3~rc2-0ubuntu1) jammy; urgency=medium

   * New upstream release candidate
   * Bump yaru source to "2021-11-10"

libreoffice (1:7.2.3~rc1-0ubuntu1) jammy; urgency=medium

   * New upstream release candidate

libreoffice (1:7.2.3~rc2-0ubuntu1) jammy; urgency=medium

   * New upstream release candidate
   * Bump yaru source to "2021-11-10"

libreoffice (1:7.2.3~rc1-0ubuntu1) jammy; urgency=medium

   * New upstream release candidate

libreoffice (1:7.2.2-1) unstable; urgency=medium

   * LibreOffice 7.2.2 final release (identical to rc2)
 
   * upload to unstable
   * debian/liblibreoffice-java.lintian-overrides,
     debian/libreoffice-dev-common.lintian-overrides: override bogus
     repeated-path-segment
   * debian/control.in: s/the the/the/
   * debian/libreoffice-core{,-nogui}.lintian-overrides: remove, obsolete

libreoffice (1:7.2.2-0ubuntu0.21.10.1) impish; urgency=medium

   * New upstream release (LP: #1946558)

libreoffice (1:7.2.2~rc2-1) experimental; urgency=medium

   * New upstream release candidate

libreoffice (1:7.2.2~rc1-1) experimental; urgency=medium

   * New upstream release candidate
 
   [ merge from Ubuntu ]
   * debian/patches/arm-fp-mode.diff: Explicitly set fpu mode on armhf.
   (closes: #994698)

libreoffice (1:7.2.1-0ubuntu3) impish; urgency=medium

   * debian/patches/tdf-144412-Qt5-reset-m_nModKeyCode-on-key-input.patch
     - Qt5 reset m_nModKeyCode on key input
   * debian/patches/tdf-144585-Qt5-restore-old-VCL-popup-handling.patch
     - Qt5 restore old VCL popup handling (LP: #1944113)

libreoffice (1:7.2.1-4) unstable; urgency=medium

   [ merge from Ubuntu ]
   * debian/patches/arm-fp-mode.diff: Explicitly set fpu mode on armhf.
   (closes: #994698)

libreoffice (1:7.2.1-3) unstable; urgency=medium

   * debian/control.ure.in:
     - also add Breaks: to << 1:7.2.0 libreoffice-cores to ure...
       (closes: #994624)

libreoffice (1:7.2.1-2) unstable; urgency=medium

   * debian/control.in.
     - bump ure dependency for libreoffice-core to (>= 1:7.2.0~)
       (closes: #994624)

libreoffice (1:7.2.1-0ubuntu2) impish; urgency=medium

   * debian/patches/arm-fp-mode.diff: Explicitly set fpu mode on armhf.

libreoffice (1:7.2.1-0ubuntu1) impish; urgency=medium

   * New upstream release

libreoffice (1:7.2.1-1) unstable; urgency=medium

   * LibreOffice 7.2.1 release (identical to rc2)
 
   * debian/patches/qt5-fix-popups.diff: add patch from libreoffice-7-2 to
     fix popup menus in qt5
   * debian/patches/bison-3.8.diff: fix build with bison 3.8, from master
   * debian/patches/freetype-2.11.diff: fix (skia) build with freetype 2.11
 
   * debian/control.plasma.in: make -plasma recommend -kf5 (closes: #994445)
 
   * debian/rules, debian/clang_wrapper: remove again, doesn't work and
     prevents a clang build/a build of skia with clang
 
   * upload to unstable

libreoffice (1:7.2.1~rc2-0ubuntu1) impish; urgency=medium

   * New upstream release candidate
   * Bump yaru source to "2021-09-01"

libreoffice (1:7.2.1~rc2-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/tests/control.in: which doxygen -> command -v doxygen

libreoffice (1:7.2.1~rc1-2) experimental; urgency=medium

   * reupload with correct control...

libreoffice (1:7.2.1~rc1-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/watch: add uversionmangle for releases (7.2.0.4 -> 7.2.0)

libreoffice (1:7.2.1~rc1-0ubuntu1) impish; urgency=medium

   * New upstream release candidate
   * Drop disable-failing-arm-tests.diff from junit autopkgtests
   * Revert "Temporarily disable extension tests on armhf"
   * Drop upstreamed fix-arm-bridges.diff

libreoffice (1:7.2.0-3) unstable; urgency=medium

   * debian/patches/revert-raspberry-pi-buildfixes.diff: remove again
   * debian/patches/fix-arm-bridges.diff: add targetted upstream fix from
     gerrit
 
   * debian/watch: watch only releases again
   * debian/rules:
     - chmod 755 the clang wrappers since otherwise they
       are ignored
     - explicitely set ENABLE_JUNIT4=y in build-indep builds if
       BUILD_TEST_PACKAGES=y
 
   [ merge from Ubuntu ]
   * Add Conflicts/Replaces for move of liblosessioninstalllo.so
     (closes: #992779)

libreoffice (1:7.2.0-2) unstable; urgency=medium

   * upload to unstable

libreoffice (1:7.2.0-1) experimental; urgency=medium

   * LibreOffice 7.2.0 final (identical to rc4)
 
   * debian/patches/revert-raspberry-pi-buildfixes.diff: revert 32bit
     arm bridges back to 7.1.5 to revert all the
     "Fix some warnings for Raspberry pi 4" (sic!) commits which break armhf
     on runtime miserably

libreoffice (1:7.2.0-0ubuntu1) impish; urgency=medium

   * New upstream release (LP: #1940556)
   * Revert GDrive API v3 support to allow build with libcmis 0.5.2
   * Revert "Fix some warnings for Raspberry pi 4" changes to unbreak armhf

libreoffice (1:7.2.0~rc4-1) experimental; urgency=medium

   * New upstream release candidate

libreoffice (1:7.2.0~rc3-1) experimental; urgency=medium

   * New upstream release candidate

libreoffice (1:7.2.0~rc2-4) experimental; urgency=medium

   * debian/patches/fix-install-with-disable-cmis.diff: as name says...

libreoffice (1:7.2.0~rc2-3) experimental; urgency=medium

   * debian/rules:
     - explicitely add junit4 to Build-Depends-Indep

libreoffice (1:7.2.0~rc2-2) experimental; urgency=medium

   * debian/rules:
     - disable cmis since it now needs a patched cmis to even build

libreoffice (1:7.2.0~rc2-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/rules:
     - micro-optimiuation: add arch qualifiers to junit build-dep

libreoffice (1:7.2.0~rc1-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/patches/fix-uicheck-tests-on-i386.patch: update; fix
     uicheck again on i386 (make the test more tolerant)
 
   * debian/control.in:
     - remove obsolete libreoffice-officebean transitional package
   * debian/tests/uicheck-{sc,sw},
     debian/tests/patches/disable-uno-show-license-tests.diff: revert,
     replaced by upstream patch

libreoffice (1:7.2.0~beta1-4) experimental; urgency=medium

   * debian/tests/control.in:
     - make uicheck-sd depend on libreoffice-calc, now apparently tests with
       an embedded Calc document...
   * debian/tests/patches/disable-uno-show-license-tests.diff,
     debian/tests/uicheck-{sc,sw}: disable uno:ShowLicense openDialogs tests
     for autopkgtest since it complains about read-only LICENSE.html and waits
     for confirmation to open read-only ("hangs")...

libreoffice (1:7.2.0~beta1-3) experimental; urgency=medium

   * debian/patches/disable-flaky-tests.diff: add removal of
     sc/qa/uitest/calc_tests8/tdf126248.py; fails on close for unknown
     reasons
   * debian/rules:
     - if make check results are ignored anyway: add a timeout call to the
       test call

libreoffice (1:7.2.0~beta1-2) experimental; urgency=medium

   * debian/patches/fix-bigendian-builds.diff: as name says; from master
   * debian/patches/fix-32-bit.diff: as name says

libreoffice (1:7.2.0~beta1-1) experimental; urgency=medium

   * New upstream beta release
     - fixes opposite cropping issue on flipped images in Writer
       (closes: #934678)

libreoffice (1:7.1.5-0ubuntu1) impish; urgency=medium

   * New upstream release

libreoffice (1:7.1.5~rc2-0ubuntu1) impish; urgency=medium

   * New upstream release candidate
   * Bump yaru source to "2021-07-02"
   * Force noopt (thus also build with --disable-optimized) on armhf and
     build with default gcc (LP: #1931701)

libreoffice (1:7.1.4-0ubuntu1) impish; urgency=medium

   * New upstream release
   * Use gcc 8 on armhf to avoid autopkgtest failure with gcc 9
     (LP: #1931701)

libreoffice (1:7.1.4~rc2-0ubuntu1) impish; urgency=medium

   * New upstream release candidate
 
   [ Rene Engelhard ]
   * debian/patches/libstdc++11.diff: fix build with newer gcc (libstdc++)
     11s, from master

libreoffice (1:7.1.4~rc2-1) experimental; urgency=medium

   * New upstream release candidate

libreoffice (1:7.1.4~rc1-2) experimental; urgency=medium

   * debian/patches/fix-emfio-wmf-test.diff,
     emfio/qa/cppunit/wmf/data/TestPalette.wmf: fix emfio wmf test
     on arm64 (from libreoffice-7-1-4 branch)

libreoffice (1:7.1.4~rc1-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/patches/libstdc++11.diff: fix build with newer gcc (libstdc++)
     11s, from master
 
   * debian/control.in:
     - stop suggesting openclipart2-libreoffice (doesn't exist anymore
       in Debian) (closes: #987900)
   * debian/rules:
     - fix SYSTEM_GCC_VERSION detection for gcc 11 (and remove < 10 support)

libreoffice (1:7.1.3~rc2-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/patches/apparmor-gnupg-tofu.diff: apply patch to support tofu+pgp in
     apparmor profile (closes: #955271)
   * debian/control.in, debian/libreoffice-common.{maintscript,postinst.in}:
     apply patch from Adreas Beckmann to fix upgrade buster->bullseye
     - libreoffice-core: Copy some Conflicts from libreoffice-common for smoother
       upgrades from buster. Dpkg will otherwise ignore Conflicts that are
       encountered later against a package that is already deconfigured.
     - libreoffice-common: Do not use dir_to_symlink for
       /usr/lib/libreoffice/share/registry, the Breaks/Conflicts cascade does not
       work reliable here to ensure all packages previously shipping files there
       are either removed or upgraded first, but not just deconfigured. Fix up
       the symlink in postinst instead.  (Closes: #985297)

libreoffice (1:7.1.3~rc1-1) experimental; urgency=medium

   * New upstream release candidate

libreoffice (1:7.1.3-0ubuntu1) impish; urgency=medium

   * New upstream release

libreoffice (1:7.1.3~rc2-0ubuntu1) impish; urgency=medium

   * New upstream release candidate

libreoffice (1:7.1.2~rc2-0ubuntu2) hirsute; urgency=medium

   [ Heather Ellsworth ]
   * Re-enable startcenter and math application icons. (LP: #1696250)

libreoffice (1:7.1.2~rc2-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/patches/filter-out-lto-flags.diff: as name says, filter out LTO
     flags for clang-built skia, thanks Matthias Klose
   * debian/rules, debian/clang-wrapper: add clang wrapper for above, thanks
     Matthias Klose
   (closes: #985867)
 
   * debian/control.ure.in:
     - stop recommending liblibreoffice-java and a JDK in ure; ure-java
       is supposed to do it does it already

libreoffice (1:7.1.2~rc2-0ubuntu1) hirsute; urgency=medium

   [ Rico Tzschichholz ]
   * New upstream release candidate
   * Bump yaru source to "2021-03-14" and add yaru-mate styles
   * Fix signing documents with enforced apparmor (LP: #1886092)
   * Disable lto due to insufficient disc space on amd64 builder
 
   [ Matthias Klose ]
   * Fix lto build, avoiding to pass lto flags to the skia build.

libreoffice (1:7.1.2~rc1-0ubuntu1) hirsute; urgency=medium

   * New upstream release candidate
 
   * Disable JunitTest_dbaccess_complex on armhf for junit autopkgtests
   * Demote liblibreoffice-java from Recommends to Suggests of ure
     (LP: #1918308)

libreoffice (1:7.1.2~rc1-1) experimental; urgency=medium

   * New upstream release candidate
     - fixes CVE-2021-25633 "Double Certificate Attack"
     - fixes CVE-2021-25634 "Timestamp Manipulation with Signature Wrapping"
 
   * debian/tests/control.in: make uicheck-sw depend on -draw, the AutoRedact
     dialog test apparently needs it (hangs otherwise)
   * debian/rules:
     - build with -Wno-psabi on armel/armhf to suppress long obsolete
       warnings

libreoffice (1:7.1.1~rc2-2ubuntu1) hirsute; urgency=medium

   * Fix autopkgtest failures

libreoffice (1:7.1.1~rc2-2) experimental; urgency=medium

   * merge from Ubuntu:
     - Make test patches apply again

libreoffice (1:7.1.1~rc2-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/patches/no-openssl.diff: remove ...
   * debian/rules: ... and use --disable-openssl, thanks Rico
   * debian/rules, debian/control.ure.in: stop moving jvmaccess and jvmfwk to
     ure-java; libmerged depends on them so they probably should stay in ure,
     thanks Rico

libreoffice (1:7.1.1~rc2-0ubuntu1) hirsute; urgency=medium

   * New upstream release candidate

libreoffice (1:7.1.1~rc1-0ubuntu1) hirsute; urgency=medium

   [ Rico Tzschichholz ]
   * New upstream release candidate
   * Update yaru icon style "2021-01-31"
 
   [ Heather Ellsworth ]
   * Add timeout to uicheck-sw test to allow it to handle timeouts under
     load better (LP: #1785262)

libreoffice (1:7.1.1~rc1-1) experimental; urgency=medium

   * New upstream release candidate
     - fixes CVE-2021-25635 "Content Manipulation with Certificate Validation
       Attack"
 
   * debian/patches/pdfium-use-system-libopenjpeg.diff: as name says
   * debian/patches/apparmor-updates.diff: allow one more digit in temp
     files (closes: #982274)
   * debian/rules:
     - use java8_architectures instead of java6_architectures since 8 is LOs
       runtime baseline (no changes in architecture lists)

libreoffice (1:7.1.0~rc3-1) experimental; urgency=medium

   * New upstream release candidate

2020

libreoffice (1:7.1.0~rc2-1) experimental; urgency=medium

   * New upstream release candidate

libreoffice (1:7.1.0~rc2-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/rules:
     - don't rm LICENSE.html, it is used by
       Help -> License Information -> Show License
   * debian/control.mediawiki.in: remove Homepage: (closes: #978713)
   * debian/*.mime: stop quoting %s (closes: #950319)
   * debian/test/control.in: make uicheck-sc depend on libreoffice-writer, too
     (the openDialogs/uno.Show:License Dialog test opens a new "Writer/Web"
     document...)

libreoffice (1:7.1.0~rc1-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/patches/pdfium-m68k.diff: fix pdfium build on m68k
 
   * debian/rules:
     - set MYSQL_FLAVOUR=mariadb (as it's used anyway, and upstreams internal
       copy is mariadb-connector-c anyway) and build-depend on libmariadb-dev
       instead of libmariadbclient-dev-compat (closes: #975481)
     - build-depend on clang (>= 1:11) on armel
     - fix nocheck -b builds...
     - use nowindows build profile for (not) building unowinreg
   * debian/rules, debian/control*in:
     - honour noinsttest build profile for (not) building
       -subsequentcheckbase/-smoketest-test-data
   * debian/rules, debian/control*in:
     - move unowinreg.dll into /usr/lib/i686-w64-mingw32 (the mingw g++
       compiler installs its .dlls into /usr/lib/gcc/i686-w64-mingw32)

libreoffice (1:7.1.0~beta1-1) experimental; urgency=medium

   * New upstream beta release
     - adds pdf to DRAWDOCS for bash-completion (closes: #973682)
 
   * debian/rules:
     - remove obsolete SHLIBS_OVERRIDE += -Xunordf (closes: #966087, #968546)
     - enable l10n again
 
   * debian/tests/control: move ...
   * debian/tests/control.in: ... here and mark Java-using tests with
     Architecture:
   * debian/tests/odk-build-examples*: split non-Java and Java tests and mark
     Java test with Architecture:
   * debian/tests/junit, odk-build-examples-java: skip it if using a Zero-using
     architecture
   * debian/rules, debian/tests/control.in:
     - restrict tests using *-nogui to Architectures: where *-nogui
       actually is built
   * debian/control.in:
     - readd -sdbc-hsqldb Recommends as hsqldb is default again since some
       time...
     - bump fonts-opensymbol depends to >= 2:102.12 given new bullets used
       by DOCX documents

libreoffice (1:7.1.0~alpha1-1) experimental; urgency=medium

   * New upstream alpha release
 
   * debian/rules:
     - add conditional and build-dep for new box2d (again)
     - don't parse parallel=X manually but use dpkg-devs buildopts.mk
     - build only en-US for now
     - try to enable pdfium anywhere since configure says
       "Disable building PDFium. Results in unsecure PDF signature
       verification."
   * debian/control*in, debian/rules:
     - split Java parts of the URE to ure-java so that libreoffice-java-common
       can depend on that. (For possible future archs starting with
       no-java where this then isn't fullfillable instead of silently "working"
       without actual Java stuff in "ure")
     - stop building libjuh-java, libridl-java, libjurt-java and libunoil-java.
       Merge them (and provide them) in(to) liblibreoffice-java.

libreoffice (1:7.0.4~rc2-0ubuntu3) hirsute; urgency=medium

   * Build-depend on libclucene-dev (>= 2.3.3.4+dfsg-1ubuntu2~) to use
     libclucene's ABI defining float_t as float on s390x (LP: #1915927)

libreoffice (1:7.0.4~rc2-0ubuntu2) hirsute; urgency=medium

   * Revert "Re-enable coinmp (LP: #1905422)" until MIR is sorted out

libreoffice (1:7.0.4~rc2-0ubuntu1) hirsute; urgency=medium

   * New upstream release candidate
   * Update yaru icon style "2020-11-29"
   * Re-enable coinmp (LP: #1905422)
   * Disable flaky ui test (LP: #1785262)

libreoffice (1:7.0.4~rc1-1) unstable; urgency=medium

   * New upstream release candidate
 
   * debian/patches/unowinreg-static-libgcc.diff: use -static-libgcc, see
     LO master commit 01241113947fc7bd7f7b765dd897bb023c8ca99c
 
   * debian/rules:
     - set MYSQL_FLAVOUR=mariadb (as it's used anyway, and upstreams internal
       copy is mariadb-connector-c anyway) and build-depend on libmariadb-dev
       instead of libmariadbclient-dev-compat (closes: #975481)
     - build-depend on clang (>= 1:11) on armel
     - fix nocheck -b builds...
     - use nowindows build profile for (not) building unowinreg
   * debian/rules, debian/control*in:
     - honour noinsttests build profile for (not) building
       -subsequentcheckbase/-smoketest-test-data
   * debian/rules, debian/control*in:
     - move unowinreg.dll into /usr/lib/i686-w64-mingw32 (the mingw g++
       compiler installs its .dlls into /usr/lib/gcc/i686-w64-mingw32)

libreoffice (1:7.0.3-4) unstable; urgency=medium

   * debian/patches/bash-completion-DRAWDOCS-pdf.diff: add pdf to DRAWDOCS for
     bash-completion (closes: #973682)
 
   * debian/rules, debian/tests/control.in:
     - restrict tests using *-nogui to Architectures: where *-nogui
       actually is built
   * debian/control.in:
     - readd -sdbc-hsqldb Recommends as hsqldb is default again since some
       time...

libreoffice (1:7.0.3-0ubuntu1) hirsute; urgency=medium

   * New upstream release
   * Update yaru icon style "2020-10-25"

libreoffice (1:7.0.3-3) unstable; urgency=medium

   * debian/patches/icu-68.diff: fix build with ICU 68
 
   * more autopkgtest fixes/preparations for new architectures:
     - debian/tests/uicheck-{sc,sw}: revert timeout hack for armhf since it's
       ran on arm64 workers.
     - debian/tests/control: move ...
     - debian/tests/control.in: ... here and mark Java-using tests with
       Architecture:
     - debian/tests/odk-build-examples*: split non-Java and Java tests and mark
       Java test with Architecture:
     - debian/tests/junit, odk-build-examples-java: skip it if using a Zero-using
       architecture

libreoffice (1:7.0.3-2) unstable; urgency=medium

   * debian/patches/liborcus-0.16.diff: backport liborcus 0.16.1 patch
     from master, too to fix 32bit builds (e.g. on buster-backports)
   * debian/patches/oox-crypto-bigendian.diff: move ...
   * debian/patches/bigendian.diff: ... here and backport more upstream commits
     from master
 
   * debian/rules:
     - enable pdfium on all architectures since configure in master says
       "Disable building PDFium. Results in unsecure PDF signature
       verification."
   * debian/tests/uicheck-{sc,sw}: add timeout hack from smoketest also here
     for armhf

libreoffice (1:7.0.3-1) unstable; urgency=medium

   * LibreOffice 7.0.3 final release (identical to rc1)
 
   * upload to unstable
 
   * debian/patches/fix-non-pdfium-build.diff: backport from master; as name
     says
   * debian/rules:
     - remove obsolete SHLIBS_OVERRIDE += -Xunordf (closes: #966087, #968546)

libreoffice (1:7.0.3~rc1-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/rules:
     - make build-depends for libfoo-x.y.pc-using packages explicitely
       libfoo (>= x.y), libfoo (<< x.y+1) to help autopkgtest to find the
       right combination...

libreoffice (1:7.0.2-4) unstable; urgency=medium

   * upload to unstable

libreoffice (1:7.0.2-3) experimental; urgency=medium

   * debian/patches/liborcus-0.16.diff: build with liborcus 0.16
   * debian/rules, debian/shlibs.override.orcus: adapt for above

libreoffice (1:7.0.2-0ubuntu1) groovy; urgency=medium

   * New upstream release
   * Update yaru icon style "2010-10-11" (LP: #1899456)

libreoffice (1:7.0.2-2) unstable; urgency=medium

   * debian/control.in:
     - add Conflicts against pre-7.0 packages with configs (closes: #972043)

libreoffice (1:7.0.2-1) unstable; urgency=medium

   * LibreOffice 7.0.2 final release (identical to rc2)
 
   * upload to unstable

libreoffice (1:7.0.2~rc2-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/patches/oox-crypto-bigendian.diff: add patch from upstream master
     to fix oox crypto (and thus CppunitTest_sw_ooxmlencryption) on s390x

libreoffice (1:7.0.2~rc1-3) experimental; urgency=medium

   * debian/rules:
     - Actually add missing ifeq "$(DEB_HOST_ARCH)" "armhf"

libreoffice (1:7.0.2~rc1-2) experimental; urgency=medium

   * debian/rules:
     - fix SYSTEM_GCC_VERSION detection

libreoffice (1:7.0.2~rc1-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/rules:
     - also use --disable-skia on armel on buster-backports
     - force noopt (thus also build with --disable-optimized) on armhf and
       use default gcc again
     - stop creating /usr/lib/libreoffice/share/registry/README
   * debian/libreoffice-common.links.in:
     debian/libreoffice-common.maintscript: add a symlink
     /usr/lib/libreoffice/share/registry -> /etc/libreoffice/registry
     since some software (e.g. LibreOffice Onlines loolwsd) doesn't honour the
     path set in LOs config (closes: #969653)

libreoffice (1:7.0.2~rc2-0ubuntu1) groovy; urgency=medium

   * New upstream rc release

libreoffice (1:7.0.1-0ubuntu1) groovy; urgency=medium

   * New upstream release
   * Add Yaru style

libreoffice (1:7.0.1-1) unstable; urgency=medium

   * New upstream release
 
   * debian/liblibreoffice-java.poms: actually add to install the pom...
   * debian/control.in:
     - bump ure dependency for -core to (>= 1:7.0.0) (closes: #969244)
     - remove article from libofficebean-javas Description:
   * debian/*.lintian-overrides:
     - override "codeless-jar", manifest-only jar is intended here
     - update some overrides

libreoffice (1:7.0.1~rc1-2) unstable; urgency=medium

   * debian/control.in:
     - fix Conflicts against *-unbundled, actually AOO still calls it
       openoffice.org-unbundled and remove libreoffice-unbundled since it's
       apparently not used anymore
 
   * Merge from Ubuntu:
     - debian/rules:
       + Use gcc/g++-9 on armhf
     (only when running the tests, though)

libreoffice (1:7.0.1~rc1-0ubuntu2) unstable; urgency=medium

   * Rebuild with the new poppler soname

libreoffice (1:7.0.1~rc1-0ubuntu1) groovy; urgency=medium

   * New upstream release candidate

libreoffice (1:7.0.1~rc1-1) unstable; urgency=medium

   * New upstream release candidate
 
   * debian/rules: bump libnumbertext build-dep to 1.0.6 and use internal
     libnumbertext for buster-backports

libreoffice (1:7.0.0-1) unstable; urgency=medium

   * New upstream release
     - reverts the "Personal edition" nonsense (closes: #965235)
 
   * debian/patches/no-opencl-per-default.diff: as name says, disable OpenCL
     per default. Prompted by
     https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=954849#41 ff.
   * debian/tests/control: use libreoffice-l10n-zh-tw instead of
     libreoffice-l10n-ja to test a xx-YY locale so that stuff like #964944
     is noticed.
   * debian/rules:
     - remove Education;Science; from libreoffice-math.desktop (closes: #965338)
     - build-depend on qtchoser and export QT_SELECT_5 (again) for
       buster-backports

libreoffice (1:7.0.0~rc2-1) unstable; urgency=medium

   * New upstream release candidate
 
   * debian/control*.in:
     - fix "compatibility" spelling and one s/package/library/ for consistency.
     - add explicit depends on liblibreoffice-java for documentation purposes
   * debian/rules:
     - symlink oo-ldap.xcd.sample and oo-ad-ldap.xcd.sample to
       in /etc/libreoffice/registry so that they are not hidden in
       /usr/lib/libreoffice/share/.registry
     - move /usr/lib/libreoffice/share/registry/README creation later in rules
       so that it doesn't get hidden in /usr/lib/libreoffice/share/.registry
     - fix adding the ucf snippets to zh-CN,zh-TW etc (closes: #964944)
     - update jh_classpath calls for libreoffice.jar

libreoffice (1:7.0.0~rc1-5) unstable; urgency=medium

   * debian/control.in:
     - fix whitespace

libreoffice (1:7.0.0~rc1-4) unstable; urgency=medium

   * debian/patches/disable-shortcuts_tab_navigation-uitest.diff: as
     name says, hangs in autopkgtest (or chroot), works in the build...
 
   * debian/rules:
     - use --with-extra-buildid instead of --with-build-version
   * debian/control*.in:
     - make all packages having (moved) config files depend on
       libreoffice-common (>= 1:7.0.0~alpha~) (closes: #964471)

libreoffice (1:7.0.0~rc1-3) unstable; urgency=medium

   * debian/watch: follow rcs
 
   * debian/control*.in:
     - add Breaks:/Replaces: openclipart-libreoffice (<= 1:0.18+dfsg-17)
       (closes: #964251)
     - fix -dev-gui Breaks

libreoffice (1:7.0.0~rc1-2) unstable; urgency=medium

   * upload to unstable

libreoffice (1:7.0.0~rc1-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/tests/patches/java-subsequentcheck-standalone.diff: unfuzzy.
     use $(shell .. | sed) instead of $(subst ..) since the latter doesn't
     work anymore...
   * debian/patches/disable-sc-sw-ScriptOrganizer-test.diff,
     debian/patches/sc-disable-UITest_options.diff: remove, works
     now (probably because of java-common below..)
 
   * debian/rules:
     - remove unused/-needed CLANG= setting and export CLANG_CC/CLANG_CXX
       instead if needed (don't set it for default clang version)
     - fix adding {cjk,ctl,ctlseqcheck}_*.xcd to -l10n-* .ucf files
     - make make check failures fatal again (on amd64/arm64)
     - don't use clang for skia on armel and build-conflict against clang on
       it (see #963162, #963167)
 
   * debian/tests/control:
     - fix uicheck-*:
       - add new dependencies (cui needs -writer now, too,
         sw needs calc for uno.InsertObject)
       - add libreoffice-java-common to uicheck-{sc,sw} for RunMacros dialog
         test (doesn't fail without but just prints an exception but...)
     - disable "smoketest" for now
 
   * debian/control*.in:
     - s/progamming/programming/ (closes: #963753)
     - make -common break libreoffice-l10n (<< 7.0) (and other packages having
       config files moved) due to registry move to /etc
 
   * debian/libreoffice-l10n.ucf.in: handle
     /etc/libreoffice/registry/res/registry_@ISO@.xcd so that the respective
     language actually gets active
 
   * debian/*.symbols: remove ure (closes: #963895) even though it means
     r-deps need to add dependencies manually...

libreoffice (1:7.0.0~beta2-2) experimental; urgency=medium

   * debian/patches/apparmor-cleanups.diff: #include <abstractions/user-tmp>
     (closes: #962903)
 
   * debian/rules:
     - re-enable CoinMP

libreoffice (1:7.0.0~beta2-1) experimental; urgency=medium

   * New upstream beta release
     - fixes signing existing PDFs (closes: #955272)
     - sets A4 in extras/source/shellnew templates (closes: #961473)
 
   * debian/rules:
     - revert add conditional and build-dep for new box2d, not used in 7.0
     - use default libboost*-dev (>= 1.71) in gcc 10 case now that we have
       a matching default boost

libreoffice (1:7.0.0~beta1-1) experimental; urgency=medium

   * New upstream beta release
 
   * debian/rules:
     - build l10n again
     - add conditional and build-dep for new box2d
     - bump build-dependency to Java 1.9 for module-info support
     - make liblibreoffice-java depend on libunoloader-java
   * debian/copyright: add dtoa.
 
   * merge from Ubuntu:
     - Don't use main.xcd configured with --disable-gui

libreoffice (1:7.0.0~alpha1-2) experimental; urgency=medium

   * debian/patches/libreoffice.jar-pom.diff: add pom for new
     libreoffice.jar
   * debian/patches/bigendian-ustrbuf-hxx.diff: add missing include
     on bigendian architectures
   * debian/patches/skia-SkOpts_crc32.diff: add missing SkOpts_crc32
     to fix skia build on arm
 
   * debian/control*in:
     - make -librelogo, -sdbc-postgresql and -report-builder explicitly
       depend on libreoffice-common (>= 1:7.0.0~alpha~) as otherwise
       /etc/libreoffice/registry might not exist yet
   * debian/copyright:
     - remove tango, add sukapura
     - add skia
   * debian/rules:
     - install libreoffice.jar using mh_* instead of jh_installlibs now
       that it has a pom
     - build with --disable-skia on bigendian architectures since skia
       upstream doesn't care about bigendian and make clang build-dep
       little endian archs-only.

libreoffice (1:7.0.0~alpha1-1) experimental; urgency=medium

   * New upstream alpha release
 
   * debian/rules, debian/*.doc-base*: remove, optional now
   * debian/rules:
     - install opens___.ttf into /usr/share/fonts/libreoffice
       instead of /usr/share/fonts/openoffice
     - pretty-print /usr/lib/libreoffice/program/registry xcds for
       preparation of ucf usage; populate libreoffice-l10n-*.ucf
     - run dh_ucf; rename original registry from registry to .registry;
       make LO look directly in /etc/libreoffice/registry
     - add .bug-script files running ucfq
     - remove redland dependency workaround; apparently not needed anymore
     - the skia build picks up clang if present, explicitly build-depend on
       clang for it - even if building with gcc otherwise
     - make report-builder-bin-nogui depend on -base-nogui | -base instead
       of just -base...
     - build only with en-US for now
   * debian/control.in, debian/control.ure.in, debian/rules: adapt for
     jurt.jar,juh.jar,ridl.jar and unoil.jar being dummies for the new
     libreoffice.jar now, keep libjurt-java, libjuh-java, libridl-kava and
     libunoil-java as Depends/Recommends for compatibility for now
   * debian/rules, debian/control.sdk.in: create new libreoffice-dev-gui
     package only allowing -core as dependency and move gengal and
     ui-previewer there (closes: #952347)
   * debian/*.ucf, debian/*.ucf.in: add files for dh_ucf
   * debian/libreoffice-common.dirs: create /etc/libreoffice/registry{,/res}
   * debian/control.in: build libreoffice-nogui metapackage
   * debian/control.in, debian/rules: remove tango icon package, it's gone
     upstream (closes: #947489)

libreoffice (1:6.4.5-0ubuntu2) groovy; urgency=medium

   * Build with GCC-9 to work around 1891623

libreoffice (1:6.4.5-0ubuntu1) groovy; urgency=medium

   * New upstream release

libreoffice (1:6.4.5-0ubuntu0.20.04.1) focal; urgency=medium

   * New upstream release (LP: #1886692)

libreoffice (1:6.4.5-1) unstable; urgency=medium

   * LibreOffice 6.4.5 final release
 
   * debian/control.librelogo.in:
     - s/progamming/programming/ (closes: #963753)

libreoffice (1:6.4.5~rc1-2) unstable; urgency=medium

   * debian/patches/apparmor-cleanups.diff: #include <abstractions/user-tmp>
     (closes: #962903)
   * debian/rules:
     - re-enable CoinMP

libreoffice (1:6.4.5~rc1-1) unstable; urgency=medium

   * New upstream release candidate
     - sets A4 in extras/source/shellnew templates (closes: #961473)
     - fixes signing existing PDFs (closes: #955272)
 
   * debian/rules:
     - use default libboost*-dev (>= 1.71) in gcc 10 case now that we have
       a matching default boost

libreoffice (1:6.4.4-0ubuntu1) groovy; urgency=medium

   * Merge ubuntu-focal-6.4 to build for groovy

libreoffice (1:6.4.4-0ubuntu0.20.04.1) focal; urgency=medium

   [ Heather Ellsworth]
   * New upstream release (LP: #1881007)
 
   [ Rico Tzschichholz ]
   * Don't use main.xcd configured with --disable-gui (LP: #1869561)

libreoffice (1:6.4.4-1) unstable; urgency=medium

   * New upstream release
 
   * debian/rules:
     - make report-builder-bin-nogui depend on -base-nogui | -base instead
       of just -base...
 
   * merge from Ubuntu:
     - Don't use main.xcd configured with --disable-gui

libreoffice (1:6.4.4~rc1-1) unstable; urgency=medium

   * Merge ubuntu-focal-6.4 to build for groovy

libreoffice (1:6.4.4-0ubuntu0.20.04.1) focal; urgency=medium

   [ Heather Ellsworth]
   * New upstream release (LP: #1881007)
 
   [ Rico Tzschichholz ]
   * Don't use main.xcd configured with --disable-gui (LP: #1869561)

libreoffice (1:6.4.4~rc1-1) unstable; urgency=medium

   * New upstream release candidate
     - fixes size of gtk3 print dialog (closes: #955981)
 
   * debian/patches/gcc10-replace-boost::bimap-in-sdext.diff: backport from master;
     fix build with gcc 10 - see #957475
 
   * debian/watch:
     - add options for alpha, beta and rc "releases" using dev-builds.
   * debian/scripts/fix_component_tarballs.sh: add new - re-create the component
     tarballs after uscan/mk-origtgz
   * debian/rules:
     - use new scripts/fix_component_tarballs.sh after uscan in get-orig-source
     - use boost 1.71 (and internal mdds) if gcc is 10 - see #957475

libreoffice (1:6.4.3-0ubuntu0.20.04.1) focal; urgency=medium

   [ Heather Ellsworth ]
   * New upstream release (LP: #1874285)
 
   [ Rico Tzschichholz ]
   * libreoffice-common: Add Replaces libreoffice-base (<< 1:6.4.0~beta1-2~)

libreoffice (1:6.4.3-1) unstable; urgency=medium

   * LibreOffice 6.4.3 final release (identical to rc2)
 
   * upload to unstable
 
   * debian/patches/fix-lo-xlate-lang-nb.diff: norwegian -> norwegian_bokmal
     for nb
 
   * merge from Ubuntu:
     - libreoffice-common: Add Replaces libreoffice-base (<< 1:6.4.0~beta1-2~)
       (closes: #956450)

libreoffice (1:6.4.3~rc2-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/rules:
     - fix gdb helpers ending up in both libreoffice-core-nogui-dbgsym
       and libreoffice-writer-nogui-dbgsym

libreoffice (1:6.4.3~rc1-3) experimental; urgency=medium

   * tests/patches/uicheck-standalone.diff: make apply again
 
   * merge from Ubuntu:
     - libreoffice-math: Add Breaks/Replaces libreoffice-common
     - debian/patches/poppler-0.86.diff: Fix build with poppler 0.86.0

libreoffice (1:6.4.3~rc1-2) experimental; urgency=medium

   * debian/rules:
     - fix redland dependencies for libreoffice-core-nogui

libreoffice (1:6.4.3~rc1-1) experimental; urgency=medium

   * New upstream release candidate
 
   [ Rene Engelhard ]
   * debian/patches/Fix-build-with-boost-lesser-than-1.68.diff: add from
     gerrit, thanks Rico Tschichholz
 
   * debian/rules:
     - don't delete libuuilo.so in -core-nogui (closes: #954670)
     - don't ogltrans stuff in -impress, OGLTrans.so isn't built
     - use default boost (and thus system-mdds) again and revert
       BOOST_MINVER= (>= 1.68) change
 
   [ Jochen Sprickerhof ]
   * debian/control.in:
     - Prefer libreoffice-core-nogui for -nogui variants
       Closes: #954319
     - Drop -core-nogui in non -nogui packages (if -nogui exists)
     - Fix report_builder and firebird nogui depends

libreoffice (1:6.4.2-0ubuntu3) focal; urgency=medium

   * Prevent -nogui and non -nogui mix up (LP: #1869652)

libreoffice (1:6.4.2-0ubuntu2) focal; urgency=medium

   * Merge with debian
   * libreoffice-math: Add Breaks/Replaces libreoffice-common (<< 1:6.4.2~rc1~)
     (LP: #1869357)
   * debian/patches/poppler-0.86.diff: Fix build with poppler 0.86.0

libreoffice (1:6.4.2-2) unstable; urgency=medium

   * debian/control.in:
     - make libreoffice-common Breaks: libreoffice-core (<< 1:6.4.2~rc1)
       (closes: #954323)
     - also add Breaks/Replaces libreoffice-common (<< 1:6.4.2~rc1~) to
       -nogui (for now)
     - allow libreoffice-draw-nogui in -impress-noguis Depends:
       (closes: #954318)

libreoffice (1:6.4.2-0ubuntu1) focal; urgency=medium

   * New upstream release
   * Keep boost and mdds in ubuntu

libreoffice (1:6.4.2-1) unstable; urgency=medium

   * LibreOffice 6.4.2 final (identical to rc2)
 
   * debian/patches/gengal-message-core.diff: print message and exit with
     an error if -core-nogui (and not -core) is installed. See #952347
 
   * merge from Ubuntu:
     - Add armhf to OOO_NOGUI_ARCHS
 
   * upload to unstable

libreoffice (1:6.4.2~rc2-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/tests/control:
     - make smoketest depend on -writer and -math (not their -nogui variants)

libreoffice (1:6.4.2~rc1-2) experimental; urgency=medium

   * debian/patches/Revert-tdf130839-Corrects-second-level-left-margin-i.patch:
     remove again.
 
   * debian/tests/control: add missing python3-uno to uitest-cui and missing
     libreoffice-l10n-{he,ja} to uicheck-uitest tests
   * debian/rules:
     - explicitely build with libboost1.71-dev (and therefore use internal
       mdds for now) and set BOOST_MINVER= (>= 1.68)
   * debian/source/include-binaries:
     - include tarballs/mdds-1.5.0.tar.bz2

libreoffice (1:6.4.2~rc1-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/patches/disable-some-sc-tests-with-internal-cppunit.diff:
     cleanup - remove; affected only internal cppunit and stable(-backports)
     already builds with system one
   * debian/patches/Revert-tdf130839-Corrects-second-level-left-margin-i.patch:
     temporarily revert upstream patch until we either have boost >= 1.68 as
     default or it can be built with boost < 1.68
   * debian/patches/sc-disable-UITest_options.diff: temporarily disable options
     tests, hang (but works in a "normal" system)
 
   * debian/rules:
     - move soffice.cfg modules to corresponding packages and remove *.ui
       in the -nogui packages
     - package breeze_dark_svg and sifr_dark_svg into the respective
       packages
     - move /usr/lib/libreoffice/program/postgresql-sdbc.ini to
       /etc/libreoffice
     - remove fonts-alef from FONTS_RECOMMENDS again; no idea where I saw it
       - it's not in Debian (yet)
   * debian/control.in:
     - update for soffice.cfg moves
   * debian/tests/*: split uicheck into tests per module containing uitests.
     hopefully helps for arm64 test timeout

libreoffice (1:6.4.1-0ubuntu1) focal; urgency=medium

   * New upstream release

libreoffice (1:6.4.1-1) unstable; urgency=medium

   * LibreOffice 6.4.1 final release
 
   * debian/patches/disable-sc-ScriptOrganizer-test.diff: move ...
   * disable-sc-sw-ScriptOrganizer-test.diff: ... here and also disable it
     for sw; exhibiting on buster-backports
   * debian/patches/make-package-modules-not-suck.diff: add missing comma
     so that libsduilo.so is actually installed into -draw instead of
     -core
   * debian/patches/python3.8.2.diff: go sure; backport python 3.8.2
     initialization fix from master
 
   * debian/control.in:
     - make -draw Replaces: -core (<< 1:6.4.1~rc1-3)
     - make -base Pre-Depends: dpkg (>= 1.19.1) (closes: #951149)
   * debian/libreoffice-nlpsolver.bug-script.in: add analogous to
     wiki-publisher
   * debian/libreoffice-ogltrans.bug-script.in: remove ...
   * debian/libreoffice-impress.bug-scrip.in: ... and merge here.

libreoffice (1:6.4.1~rc1-2) unstable; urgency=medium

   * update Replaces: in -help-* to libreoffice-help-common (<< 1:6.4.1~rc1-1)
     (closes: #950833)

libreoffice (1:6.4.1~rc1-1) unstable; urgency=medium

   * New upstream release candidate
     - fixes opengl slide transitions with glm >= 0.9.9 (closes: #917927)
 
   * debian/patches/no-packagekit-per-default.diff: revert configure revert;
     add configuration item and use it (closes: #950225)
   * debian/patches/debian-vendor.diff: handle Debians vendor correctly, extracted
     from old no-packagekit-per-default.diff
 
   * debian/rules:
     - don't install libdbulo.so in -base-nogui (contains Base UI)
     - generailize OOO_VENDOR setting to use DEB_VENDOR/DEB_PARENT_VENDOR
     - add fonts-alef to he's FONT_RECOMMENDS
     - remove appdata files in *-nogui

libreoffice (1:6.4.0-0ubuntu6) focal; urgency=medium

   * No-change rebuild for icu update.

libreoffice (1:6.4.0-0ubuntu5) focal; urgency=medium

   [ Rico Tzschichholz ]
   * Add transitional packages for -gtk2 and -kde4 for upgrades from bionic

libreoffice (1:6.4.0-0ubuntu4) focal; urgency=medium

   * Temporarily disable extension tests on armhf

libreoffice (1:6.4.0-0ubuntu3) focal; urgency=medium

   * Add armhf to OOO_NOGUI_ARCHS

libreoffice (1:6.4.0-0ubuntu2) focal; urgency=medium

   * Remove dependency on universe package: libqrcodegencpp1

libreoffice (1:6.4.0-0ubuntu1) focal; urgency=medium

   * New upstream release
 
   [ Marcus Tomlinson ]
   * debian/patches/mysql-80-compatibility.patch: removed as upstream now accounts
     for this.
 
   [ Rico Tzschichholz ]
   * Drop obsolete .gitignore
   * Remove objects before install to reduce disk usage

libreoffice (1:6.4.0-1) unstable; urgency=medium

   * LibreOffice 6.4.0 final release (identical to rc3)
 
   * debian/patches/disable-sc-ScriptOrganizer-test.diff: disable sc
     ScriptOrganizer test uitest for now - fails on arm64 buildds
     (and only in sc, not in sw) but works on the porterbox...
   * debian/libreoffice-l10n-{in,kmr,za}.maintscript: fix (closes: #946470)

libreoffice (1:6.3.4-0ubuntu2) focal; urgency=medium

   * No-change rebuild to build with python3.8.

libreoffice (1:6.4.0~rc3-1) unstable; urgency=medium

   * New upstream release candidate

libreoffice (1:6.4.0~rc2-2) unstable; urgency=medium

   * oops, reupload with all languages in control....

libreoffice (1:6.4.0~rc2-1) unstable; urgency=medium

   * New upstream release candidate
 
   * debian/rules:
     - stop special-casing ure, uno-libs-private, libuno* epoch-wise to avoid
       confusion (especially since it was missed to apply that special-casing to
       lib*-java anyways)
     - use filter for setting BUILD_NOGUI_PACKAGES and add ppc64 to OOO_NOGUI_ARCHS
       (closes: #948120)
     - add missing dh_python3 call for python3-access2base
    * debian/control.*.in:
      - make libjuh-java Depends: ure since it loadLibrary()'s libjuh.so;
        same with libjurt-java (libjava_uno.so)
      - add some explicit dependencies on the new java packages to where they are
        mentioned in Class-Path:
      - suggest odbc-mdbtools instead of just mdbtools
      - remove obsolete alternatives from ${java-runtime-depends} and suggest that
        instead of java5-runtime in ure
    * debian/rules, debian/control.in:
      - make libofficebean-java arch-dep and install libofficebean.so there
        (into /usr/lib/jni with a symlink from /usr/lib/libreoffice/program);
        make libreoffice-officebean a transitional package for libofficebean-java

libreoffice (1:6.4.0~rc1-6) unstable; urgency=medium

   * debian/control.in, debian/control.ure.in:
     - fix typo: s/java:Depednds/java:Depends/g
   * debian/rules:
     - fix the URE/unoil/officebean jar splitout to actually work as
       expected (closes: #947909). Fix smoketest.jar move to
       -smoketest-data
     - don't try to remove the bogus base-files dependencies manually,
       use jh_depends -Xbase-files...
   * debian/control.in, debian/control.ure.in:
     - update Breaks:/Replaces: and add "reverse" Breaks:/Replaces:, too

2019

libreoffice (1:6.4.0~rc1-5) unstable; urgency=medium

   * debian/control.ure.in:
     - fix Breaks:/Replaces: on ure, it has no epoch... (closes: #947853)

libreoffice (1:6.4.0~rc1-4) unstable; urgency=medium

   * debian/rules:
     - limit parallelism for running the tests to 1 so one can see
       directly which test fails/hangs; keep the second run in case
       of a failure nevertheless for flaky tests...
     - disable coinmp for now, tests hang

libreoffice (1:6.4.0~rc1-3) unstable; urgency=medium

   readd test fixes which somewow got lost in preparation of -2:
 
   * debian/tests/control:
     - smoktest: add missing -nogui and add missing libreoffice-base-nogui
       to Depends:; but use calc and core since the test actually seems to want
       to use something from it
     - junit: use the "GUI" packages
   * debian/control*in:
     - add more Breaks:/Replaces: for the new split-out Java packages (and
       libreoffice-smoketest-data) (closes: #947446)
   * debian/libreoffice-common.doc-base: also add Files:

libreoffice (1:6.4.0~rc1-2) unstable; urgency=medium

   * debian/rules, debian/control*in:
     - make -nogui variant less confusing and create them for all "UI"
       packages (also saves some space since some (not needed for nogui)
       will be gone from -nogui)
   * debian/rules, debian/libreoffice-calc-nogui.lintian-overrides:
     - remove lib*uilo.so and *.desktop from *-nogui
   * debian/tests/control:
     - fix typo
     - use the new -nogui packages created above in the smoketest test

libreoffice (1:6.4.0~rc1-1) unstable; urgency=medium

   * LibreOffice 6.4.0 release candidate 1
   * upload to unstable
 
   * debian/patches/sc-opengl-optional.diff:  don't rely on
     isVCLOpenGLEnabled if HEAVE_FEATURE_UI isn't defined
 
   * debian/control.in, debian/rules: create a libreoffice-calc-nogui
     for use with libreoffice-core-nogui
   * debian/rules:
     - cleanup, introduce a BUILD_NOGUI_PACKAGES=y/n and only
       build -nogui on amd64/i386/arm64/s390x/ppc64el so save build cycles on
       the other architectures (more or less double build)
     - add explicit libgl-dev build-dep
 
   * debian/control.firebird.in: allow libreoffice-core-nogui
   * debian/control.in:
     - allow libreoffice-core-nogui for libreoffice-dev
     - move python-access2base to "python" and libreoffice-sdbc-mysql to
       "database" like the other -sdbc-*
   * debian/tests/control:
     - improve test depends for nogui:
       + make odk-test-examples/test-extension-* depend on
         libreoffice-core-nogui only
       + make smoketest and junit depend on libreoffice-{calc,core}-nogui
         instead of their GUI counterparts and use the needed packages
         instead of the "libreoffice" metapackage
     - make odk-test-examples depend on libofficebean-java instead
       of libreoffice-officebean

libreoffice (1:6.4.0~beta1-4) experimental; urgency=medium

   * re-enable introspection which was accidentially kept disabled after a
     python3.8 test rebuild...
   * re-enable building of the "test packages"
     (-smoketest-data, -subsequentcheckbase)

libreoffice (1:6.3.4-0ubuntu1) focal; urgency=medium

   * New upstream release

libreoffice (1:6.4.0~beta1-3) experimental; urgency=medium

   * debian/patches/fix-build-with-poppler-0.83.diff: as name says
 
   * debian/rules, debian/control: bump dh compat to 12 and use
     debhelper-compat (= 12) in Build-Depends ...
   * debian/compat: ... and remove this
   * debian/rules:
     - run dh_dwz again as it seems to work now
     - add hyphen-en-us <!nocheck> to Build-Depends; used by writer tests
   * debian/upstream/metadata: add
   * debian/*.maintscript: fix again and update version
     (closes: #946470) (thanks Andreas Beckmann)
 
   * merge from Ubuntu:
     - Recommend fonts-noto-extra (fixes various Impress templates)

libreoffice (1:6.3.3-0ubuntu2) focal; urgency=medium

   [ Rene Engelhard ]
   * debian/patches/Switch-mdds-to-1.5.0-and-liborcus-to-0.15.0.diff:
     as name says
   * debian/rules, debian/shlibs.override.orcus: adapt for above
 
   [ Marcus Tomlinson ]
   * Recommend fonts-noto-extra (fixes various Impress templates)

libreoffice (1:6.4.0~beta1-2) experimental; urgency=medium

   * debian/control*in, debian/*.lintian-overrides: fix some minor lintian
     stuff after the library splitout
   * debian/control.test-packages.in, debian/rules: move smoketest.jar into
     libreoffice-smoketest-data
   * debian/control.in, debian/rules, debian/libreoffice-base.p*.in:
     simplify and revert diversion of AccessBase basic stuff.
   * debian/libreoffice-common.docs, debian/libreoffice-common.doc-base,
     debian/patches/add-access2base-doc.diff: install
     www.access2base.com/access2base.html into libreoffice-common as doc

libreoffice (1:6.4.0~beta1-1) experimental; urgency=medium

   * debian/rules, debian/tests/control: revert -0reprotestX changes
   * debian/control*in, debian/rules, debian/*.symbols,
     debian/*.lintian-overrides:
     follow best practices and split the uno public libraries into extra
     package per library and move (supposed to be publically importable)
     access2base.py into python3-access2base
   * debian/rules: stop hacking changelog; install complete changelog
     everywhere

libreoffice (1:6.4.0~beta1-0reprotest1) experimental; urgency=medium

   * New upstream beta release
 
   * debian/rules:
     - add szl to (LANGPACK)ISOS so that we build a Upper Silesian
       l10n when languages get enabled again
   * debian/*.maintscript: fix

libreoffice (1:6.4.0~alpha1-0reprotest4) experimental; urgency=medium

   * debian/patches/ldl.diff: add missing -ldl for --disable-gui builds
     to fix build on 32bit archs...
   * debian/patches/disable-static_assert-on-AtomicCounter-on-armel.diff:
     fix build on armel

libreoffice (1:6.4.0~alpha1-0reprotest3) experimental; urgency=medium

   * debian/rules:
     - fix setting of --without-lxml

libreoffice (1:6.3.3-0ubuntu1) focal; urgency=medium

   * New upstream release

libreoffice (1:6.4.0~alpha1-0reprotest2) experimental; urgency=medium

   * debian/rules:
     - actually add explicit --no-automatic-dbgsym if BUILD_DBGSYM_PACKAGES != y

libreoffice (1:6.4.0~alpha1-0reprotest1) experimental; urgency=medium

   * New upstream alpha release
     - drops gtk2 support (closes: #885143)
     - fixes the postgresql driver with PostgreSQL 12 (closes: #943873)
 
   * debian/rules, debian/control*in:
     - follow upstream split of kde5 into kf5+plasma5. (But use -plasma
       only). Add transitional libreoffice-kde5 package
     - remove gtk3_kde5 support since it doesn't fit in the above structure
       now
     - adapt for Java baseline bump to >= 1.8
     - create libreoffice-core-nogui package
   * debian/rules, debian/control.in, debian/*.maintscript:
     stop using --link-doc=. a) for -style-* as they cause a circular dependency
     (closes: #940303) and b) since it doesn't work anymore with the -core-nogui
     alternative
   * debian/rules:
     - add option to build with --disable-gui (as it's now even included in
       upstreams distro-configs/LibreOfficeOnline.conf) for libreoffice-core-nogui;
       re-sort the "GUI-only" build-deps
     - support nojava build profile
     - stop trying --disable-dependency-tracking as we have even more build-steps
       now (nogui!), better safe than sorry
 
   * debian/rules, debian/tests/control:
     - temporarily disable all languages except en-US,de,he,ja, disable -g
       (and -dbgsym), don't run make check/build the test packages so that we
       hopefully don't timeout in the reproducible builds infrastructure

libreoffice (1:6.3.3~rc1-1) unstable; urgency=medium

   * New upstream release candidate
     - fixes images getting black in some circumstances
       (closes: #941655)
 
   * debian/scripts/gid2pkgdirs.sh:
     - stop installing /usr/share/mimelnk (closes: #941439)

libreoffice (1:6.3.2-0ubuntu2) eoan; urgency=medium

   * libreoffice-style-sifr should not conflict with the libreoffice-style-hicontrast
     transitional package (LP: #1846555)

libreoffice (1:6.3.2-0ubuntu1) eoan; urgency=medium

   * New upstream release

libreoffice (1:6.3.2-1) unstable; urgency=medium

   * LibreOffice 6.3.2 final release

libreoffice (1:6.3.2~rc1-1) unstable; urgency=medium

   * New upstream release candidate

libreoffice (1:6.3.1-0ubuntu2) eoan; urgency=medium

   * libreoffice-help should not depend on any particular browser (LP: #1844520)

libreoffice (1:6.3.1-0ubuntu1) eoan; urgency=medium

   * New upstream release

libreoffice (1:6.3.1-1) unstable; urgency=medium

   * LibreOffice 6.3.1 final release (identical to rc2)
 
   * debian/patches/set-Wl-no-as-needed-for-latomic.diff: move ...
   * debian/patches/latomic.diff: ... here and replace by full configure
     check
 
   * debian/rules:
     - explicitely build with --with-linker-hash-style=sysv on mips*,
       thanks Aurelien Jarno
 
   [ merge from Ubuntu ]
   * re-enable make check on armhf

libreoffice (1:6.3.1~rc2-3) unstable; urgency=medium

   * debian/patches/set-Wl-no-as-needed-for-latomic.diff: as name says,
     we need -Wl,--no-as-needed for -latomic (and gcc9 defaults to
     --as-needed..), thanks Adam Borowski

libreoffice (1:6.3.1~rc2-2) unstable; urgency=medium

   * reupload with complete control...

libreoffice (1:6.3.1~rc2-1) unstable; urgency=medium

   * New upstream release candidate
     - fixes Help-About with gtk2 plugin (closes: #934779)
     - fixes CVE-2019-9854/CVE-2019-9855
 
   * debian/control.in:
     - add kn and ne to libreoffice-l10n-ins depends (closes: #935632)

libreoffice (1:6.3.0-0ubuntu8) eoan; urgency=medium

   * Resolve component mismatches:
     - epiphany-browser <- libreoffice-help-zh-cn
     - fonts-dzongkha <- libreoffice-l10n-dz
     - fonts-hosny-thabit <- libreoffice-l10n-ar

libreoffice (1:6.3.0-0ubuntu7) eoan; urgency=medium

   * Rebuild for the new poppler soname

libreoffice (1:6.3.0-0ubuntu6) eoan; urgency=medium

   * No-change rebuild against new EDS ABIs

libreoffice (1:6.3.0-0ubuntu5) eoan; urgency=medium

   * Remove libjs-normalize.css dependancy from libreoffice-help-common (LP: #1841209)

libreoffice (1:6.3.0-0ubuntu4) eoan; urgency=medium

   * Move ${gstreamer-plugins-suggests} from Recommends to Suggests (LP: #1840966)

libreoffice (1:6.3.0-0ubuntu3) eoan; urgency=medium

   * Fix Breaks / Replaces versions for libreoffice-help-common
 
   * debian/patches/fix-noto-sans-in-templates.diff:
     - Font family for Noto Sans is "Noto Sans" not "Noto Sans Regular/Bold"
 
   * debian/patches/replace-source-sans-in-templates.diff:
     - Source Sans Pro fonts are not available on Ubuntu, use Noto Sans instead

libreoffice (1:6.3.0-0ubuntu2) eoan; urgency=medium

   * No-change rebuild for new EDS sonames.

libreoffice (1:6.3.0-0ubuntu1) eoan; urgency=medium

   * New upstream release
 
   * Sync closer to Debian:
     - Merge libreoffice and libreoffice-l10n (LP: #1791943)
     - Minimize diff between Debian and Ubuntu packages
 
   * debian/patches/disable-failing-arm64-tests.diff:
     - Temporarily disable 2 failing tests on arm64

libreoffice (1:6.3.0-2) unstable; urgency=medium

   * debian/control.in:
     - make -core Conflicts: against libreoffice-mysql-connector (<< 1:6.2.0~)
       (closes: #933835)

libreoffice (1:6.3.0-1) unstable; urgency=medium

   * New upstream release
     - fixes CVE-2019-9850/CVE-2019-9851/CVE-2019-9852/CVE-2019-9853
 
   * merge from Ubuntu:
     - patches/fix-uicheck-tests-on-i386.patch: fix rounding errors on i386
 
   * debian/rules:
     - be consequent and disable mergelibs and -g on i386, too
     - disable running make check on mipsel, mips64el, armel, armhf

libreoffice (1:6.3.0~rc2-1) unstable; urgency=medium

   * New upstream release candidate
 
   * debian/rules:
     - remove build paths in test.jars Class-Path:

libreoffice (1:6.3.0~rc1-2) unstable; urgency=high

   * mention fixed security bugs in 1:6.3.0~beta2-1
   * make upload urgency=high because of the above
 
   * debian/control.in:
     - move librelogo from Recommends to Suggests
     - bump math depends on fonts-opensymbol to >= 2:102.11

libreoffice (1:6.3.0~rc1-1) unstable; urgency=medium

   * New upstream release candidate
 
   * upload to unstable
 
   * merge from Ubuntu:
     - debian/patches/fix-flaky-bridgetest.diff: add safer float
       comparisons to bridgetest equals() (LP: #1832360)
 
   * debian/control.qt5.in:
     - recommend qtgstreamer-plugins-qt5
   * debian/rules:
     - handle java version suffixes (strip them), e.g. "-ea"
     - disable vlc avmedia plugin (bitrotting, unsupported on linux,
       low popcon
   * debian/rules, debian/control.in:
       and merge -avmedia-gstreamer into -core now that it is the
       only alternative

libreoffice (1:6.3.0~beta2-2) experimental; urgency=medium

   * debian/patches/link-with-latomic-on-mips-el-armel-powerpc.diff:
     as name says

libreoffice (1:6.3.0~beta2-1) experimental; urgency=medium

   * New upstream beta release
     - fixes CVE-2019-9848 and CVE-2019-9848

libreoffice (1:6.3.0~beta1-2) experimental; urgency=medium

   * debian/patches/0cf4e7f.diff: add from gerrit, fixes 32bit build for the
     Qt5 plugin

libreoffice (1:6.3.0~beta1-1) experimental; urgency=medium

   * New upstream beta release

libreoffice (1:6.3.0~alpha1-2) experimental; urgency=medium

   * debian/patches/c579879.diff: add from gerrit, fixes 32bit build for the
     Qt5 plugin

libreoffice (1:6.3.0~alpha1-1) experimental; urgency=medium

   * New upstream alpha release
     - now has ui prompt for printer authentication (closes: #795929)
 
   * debian/rules:
     - export JAVA_{SOURCE,TARGET}_VER to 1.7 if building with Java >= 12

libreoffice (1:6.2.5-0ubuntu1) eoan; urgency=medium

   * New upstream release

libreoffice (1:6.2.4-0ubuntu2) eoan; urgency=medium

   * debian/patches/fix-flaky-bridgetest.diff: add safer float comparisons to
     bridgetest equals() (LP: #1832360)

libreoffice (1:6.2.4-0ubuntu1) eoan; urgency=medium

   * New upstream release

libreoffice (1:6.2.4~rc2-1) UNRELEASED; urgency=medium

   * New upstream release candidate

libreoffice (1:6.2.4~rc1-1) experimental; urgency=medium

   * New upstream release candidate
     - supports JRE installations with unknown java.vendor property
 
   * debian/patches/java.vendor-Debian.diff: remove again as upstream now
     accepts unknown JDKs

libreoffice (1:6.2.3-0ubuntu2) eoan; urgency=medium

   * Rebuild against new poppler87.

libreoffice (1:6.2.3-0ubuntu1) eoan; urgency=medium

   * New upstream release

libreoffice (1:6.2.3~rc2-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/rules:
     - replace various $(findstring for arch checks by $(filter

libreoffice (1:6.2.3~rc1-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/patches/mention-java-common-package.diff: update message to
     reflect current config dir...
   * debian/patches/java.vendor-Debian.diff: make jvmfwk recognize "Debian"
     as java.vendor as that's what is set in openjdk 11 >= 11.0.3+4-2
     - see #926009 (closes: #926318)
 
   * debian/rules:
     - give up and disable running make check on mips
     - bump libxmlsec1 build-dep to >= 1.2.27-3 if building with ICU 64
     - remove i386 special-casing for openjdk-8 and -9 from old "stack clash
       fix broken on i386" days preventing removal openjdk-8
       (closes: #926281)

libreoffice (1:6.2.2-0ubuntu3) UNRELEASED; urgency=medium

   * debian/patches/java.vendor-Ubuntu.patch: update to also recognize
     "Private Build" as java.vendor (for custom PPA builds) (LP: #1822839)

libreoffice (1:6.2.2-0ubuntu2) disco; urgency=medium

   [ Rene Engelhard ]
   * debian/patches/java.vendor-Debian.diff: make jvmfwk recognize "Debian"
     as java.vendor as that's what is set in openjdk 11 >= 11.0.3+4-2
     - see #926009 (closes: #926318)
 
   [ Olivier Tilloy ]
   * debian/patches/java.vendor-Ubuntu.patch: also make jvmfwk recognize
     "Ubuntu" as java.vendor (LP: #1822839)

libreoffice (1:6.2.2-0ubuntu1) disco; urgency=medium

   * New upstream release
 
   [ Rene Engelhard ]
   * debian/control.gtk3.in:
     - make libreoffice-gtk3 recommend gstreamer1.0-gtk3 (LP: #1820062)

libreoffice (1:6.2.2~rc2-1) experimental; urgency=medium

   * New upstream release
 
   * debian/control.gtk3.in:
     - make libreoffice-gtk3 recommend gstreamer1.0-gtk3 (see LP: #1820062)

libreoffice (1:6.2.2~rc1-1) experimental; urgency=medium

   * New upstream release candidate

libreoffice (1:6.2.1-0ubuntu1) disco; urgency=medium

   * New upstream release
 
   * debian/tests/control: relax the !s390x conditional dependency on
     libreoffice-sdbc-firebird, now that it is also built there (LP: #1790165)

libreoffice (1:6.2.1~rc2-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/control.in:
     - move -sdbc-hsqldb from Recommends to Suggests given LO now defaults
       to firebird and there's a hsqldb->firebird migration running
 
   * merge from Ubuntu:
     - debian/rules: call dh_shlibdeps with absolute paths
     - tests/control: add allow-stderr restriction to test-extension{,-shared}.
       unopkg now prints out more errors, and it does so on stderr by default.

libreoffice (1:6.2.1~rc1-0ubuntu3) disco; urgency=medium

   * patches/fix-uicheck-tests-on-i386.patch: fix rounding errors on i386

libreoffice (1:6.2.1~rc1-0ubuntu2) disco; urgency=medium

   * tests/control: add allow-stderr restriction to test-extension{,-shared}.
     unopkg now prints out more errors, and it does so on stderr by default.

libreoffice (1:6.2.1~rc1-0ubuntu1) disco; urgency=medium

   * New upstream rc release
 
   * new packages:
     - libreoffice-style-karasa-jaga (contains the Karasa Jaga symbol style)
     - libreoffice-sdbc-mysql (replaces libreoffice-mysql-connector)
     - libreoffice-help-id (help files for Indonesian)
   * removed packages:
     - libreoffice-ogltrans (merged in libreoffice-impress)
 
   [ Olivier Tilloy ]
   * patches/add-lxqt-support.patch: removed, now upstream
   * patches/mysql-80-compatibility.patch: added to fix FTBFS against MySQL 8.0
   * debian/rules: call dh_shlibdeps with absolute paths
 
   [ Rico Tzschichholz ]
   * control.in:
     - demote libreoffice-sdbc-firebird to Suggests
     - recommend fonts-noto-* as it is in main
   * control{,.transitionals}.in: bump Breaks/Replaces against
     libreoffice-ogltrans to << 1:6.2.0~beta1~
   * control.transitionals.in: do not make transitional
     libreoffice-mysql-connector arch-specific
   * rules:
     - use --disable-build-opensymbol for tarball creation
     - update the postgresql tarball name
   * patches/kde5-32bit-build-fix.diff: added to fix KDE5 VCL build on 32 bit
     architectures
   * tests/control: mark pyuno-import, uno-import, test-extension,
     test-extension-shared, dk/util/check.pl and apparmor tests as superficial

libreoffice (1:6.2.1~rc1-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/rules:
     - enable id help (closes: #922187)

libreoffice (1:6.2.0-2) experimental; urgency=medium

   * patches/emfio-HAVE_MORE_FONTS.diff: add two more #if HAVE_MORE_FONTS
     to disable those tests (Calibri and Arial not necessarily present)
   * debian/rules: readd font build-dependencies since stuff apparently still
     rely on them (and vcl even abort()s if no fonts are installed)

libreoffice (1:6.2.0-1) experimental; urgency=medium

   * New upstream release
 
   * debian/patches/jdk-11.0.2-javadoc.diff: backport from master
     (closes: #920331)
   * debian/patches/tdf123077.diff: add from libreoffice-6-1 branch
     (closes: #920859)
 
   * debian/patches/aarch64-temporarily-disable-testgetCaughtException.diff:
     remove again ...
   * debian/patches/aarch64-call-__cxa_current_exception_type.diff: ... and
     replace with this (from master)
 
   * debian/control.transitionals.in: revert making libreoffice-mysql-connector
     'all'
   * debian/libreoffice-mysql-connector.maintscript: remove
     $DPKG_MAINTSCRIPT_PACKAGE and use -core instead of -common.
   (closes: #919298)
   * debian/control.kde*.in: Replaces: libreoffice-kde (<< 1:6.1.0~alpha1-1)
     (closes: #919103)
   * debian/rules:
     - add mesa-opencl-icd | beignet-opencl-icd as alternatives to
       ocl-icd-libopencl1
   * debian/control.in: recommend fonts-noto-{,ui}-core instead of transitional
     fonts-noto-hinted (closes: #920960)
   * debian/rules, debian/scripts/locale-gen: revert removal, still needed e.g.
     for sw_odfexports testSpellOutNumberingTypes::Import which hangs otherwise
 
   [ Vincas Dargis ]
   * debian/patches/apparmor-opencl.diff: Include OpenCL abstractions to fix
     OpenCL usage in Calc

libreoffice (1:6.2.0~rc2-1) experimental; urgency=medium

   * New upstream release candidate
     - belarussian -> belarusian (closes: #917795)
 
   * debian/patches/m68k-fix-parameter-type.patch: as name says,
     thanks John Paul Adrian Glaubitz (closes: #917539)
 
   * debian/rules:
     - revert 1:6.2.0~rc1-2 change
   * debian/rules, debian/control*in, debian/scripts/gid2pkgdirs.sh:
     merge -ogltrans into -impress
   * debian/control.in: bump recommends for apparmor to >= 2.13.1 and conflict
     against apparmor (<< 2.13.1~) (closes: #918499)
   * debian/control.in, debian/rules: make apparmor recommends/conflicts
     dependant on ENABLE_APPARMOR_PROFILES=y

2018

libreoffice (1:6.2.0~rc1-2) experimental; urgency=medium

   * debian/rules:
     - use "mariadb" as MYSQL_FLAVOUR and use libmariadb-dev directly
       until the mariadb-10.3-induced mess is solved

libreoffice (1:6.2.0~rc1-1) experimental; urgency=medium

   * New upstream release candidate
     - show partial signatures even if cert validation fails
       (CERT-Bund#2018100828000257)
 
   * debian/patches/aarch64-temporarily-disable-testgetCaughtException.diff:
     as name says; the test is new in 6.2, never worked on arm64 (so no
     regression) and the other, bigger tests (junit, uicheck) work fine.
   * debian/patches/patches/fix-build-with-poppler-0.71.diff: one more patch
     for poppler 0.71 (from master) (closes: #915726)
 
   * debian/libreoffice-base.{postrm,preinst}.in: remove manual
     --package $DPKG_MAINTSCRIPT_PACKAGE, since dpkg-divert defaults to it
     since 1.16.0 anyway if not specified (see #912140).
   * debian/control.in: update -core versioned Breaks: to -kde5, not -kde, thanks
     Julien Cristau
   * debian/libreoffice-mysql-connector.maintscript: add, thanks Andreas Beckmann
     (closes: #915019)
   * debian/rules:
     - remove LD_LIBRARY_PATH setting for dh_shlibdeps and use (more) -l's
     - fix running the odk/build-examples* tests on _all builds
     - disable gdrive stuff. chromium isn't in buster anymore and gdrive didn't
       work with chromiums id/secret anyway) (closes: #909152)
 
   * merge from Ubuntu:
     [ Evangelos Foutras ]
     - poppler-fix-build-0-70.patch: fix build failure with poppler >= 0.70

libreoffice (1:6.2.0~beta1-1) experimental; urgency=medium

   * New upstream beta release
 
   * debian/patches/apparmor-mesa.diff: #include mesa abstraction
     (closes: #905437)
   * debian/patches/jdbc-driver-classpaths.diff: add org.mariadb.jdbc.Driver
     classpath to /usr/share/java/mariadb-java-client.jar
   * debian/patches/disableClassPathURLCheck.diff: add workaround to
     fix build with openjdks with S8195874 included - add
     -Djdk.net.URLClassPath.disableClassPathURLCheck=true to JAVAIFLAGS;
     see https://gerrit.libreoffice.org/#/c/63118/2
   * debian/patches/disable-dbaccess_complex-for-now.diff: as name says;
     temporarily - to be investigated.
 
   * debian/control.transitionals.in: make libreoffice-mysql-connector 'all'
   * debian/patches/make-package-modules-not-suck.diff: update to move
     mysql_jdbc back to  -base-drivers
   * debian/patches/use-mariadb-java-instead-of-mysql-java.diff: as name says;
     use org.mariadb.jdbc.Driver instead of com.mysql.jdbc.Driver
   * debian/control.in:
     - add Replaces: for above
     - Suggest libmariadb-java instead of libmysql-java. See #912916 for more
       information.
   * debian/patches/jdbc-driver-classpaths.diff: add org.mariadb.jdbc.Driver
     classpath pointing to /usr/share/java/mariadb-java-client.jar
   * debian/libreoffice-base.bug-script.in: add libmariadb-java
   (closes: #913360, thanks Markus Koschany)
 
   * debian/libreoffice-base-drivers.NEWS: add NEWS about above change

libreoffice (1:6.2.0~alpha1-1) experimental; urgency=low

   * New upstream alpha release
     - doesn't jump to cursor anymore when saving (closes: #799428)
 
   * debian/rules:
     - stop enabling gtk3_kde5, enable qt5 and kde5
     - remove obsolete GCC_VERSION_5_OR_GREATER variable and checks
     - run make check on BE archs
   * debian/rules, debian/control.in:
     - package karasa_jaga iconset now that we need to go over NEW again
       because of libreoffice-qt5
   * debian/rules, debian/patches/*. debian/control*in:
     - the MySQL Connector isn't a extension anymore, rename to -sdbc-mysql
       and make -mysql-connector a transitional package; remove mysqlcppconn
       stuff; not used anymore
   * debian/rules, debian/control.firebird.in:
     - enable Firebird on BE archs
   * debian/uno-libs3.symbols: update
   * debian/tests/control: mark pyuno-import, uno-import, test-extension,
     test-extension-shared and the sdk/util/check.pl and apparmor tests as
     superficial

libreoffice (1:6.1.4-0ubuntu1) disco; urgency=medium

   * New upstream release
   * debian/patches/apparmor-mesa.diff: removed, as this requires apparmor 2.13

libreoffice (1:6.1.3-0ubuntu9) disco; urgency=medium

   * debian/tests/smoketest: revert previous change and skip the test altogether
     on s390x, where unit tests are intentionally not built (LP: #1808147)

libreoffice (1:6.1.3-0ubuntu8) disco; urgency=medium

   * debian/tests/smoketest: pass RUN_MAKE_CHECK=y to debian/rules to force
     enabling cppunit, which is needed to build the tests, and was disabled on
     s390x (LP: #1808147)

libreoffice (1:6.1.3-0ubuntu7) disco; urgency=medium

   * debian/control.in: update Vcs-Git to point to disco branch

libreoffice (1:6.1.3-0ubuntu6) disco; urgency=medium

   [ Evangelos Foutras ]
   * poppler-fix-build-0-70.patch: fix build failure with poppler >= 0.70
 
   [ Olivier Tilloy ]
   * debian/patches/poppler-dropped-gbool.patch: updated to patch an additional
     source file (sdext/source/pdfimport/xpdfwrapper/wrapper_gpl.cxx)

libreoffice (1:6.1.3-0ubuntu5) disco; urgency=medium

   [ Olivier Tilloy ]
   * debian/patches/poppler-dropped-gbool.patch: cherry-pick
     upstream commit to fix build failure with poppler >= 0.71
     (see https://gerrit.libreoffice.org/#/c/63625/)
 
   [ Rene Engelhard ]
   * debian/patches/disableClassPathURLCheck.diff: add workaround to
     fix build with openjdks with S8195874 included - add
     -Djdk.net.URLClassPath.disableClassPathURLCheck=true to JAVAIFLAGS;
     see https://gerrit.libreoffice.org/#/c/63118/2

libreoffice (1:6.1.3-0ubuntu4) disco; urgency=medium

   * No-change rebuild against libpoppler82

libreoffice (1:6.1.3-0ubuntu3) disco; urgency=medium

   * No-change rebuild for icu soname changes.

libreoffice (1:6.1.3-0ubuntu2) disco; urgency=medium

   [ Simon Quigley ]
   * Make LibreOffice under the LXQt desktop environment use the Breeze theme
     as the default (LP: #1799001).

libreoffice (1:6.1.3-0ubuntu1) disco; urgency=medium

   [ Rico Tzschichholz ]
   * New upstream release

libreoffice (1:6.1.3~rc1-1) unstable; urgency=medium

   * New upstream release candidate
     - accepts to insert empty field with 'not null' database constraint
       (closes: #910576)
 
   * debian/patches/DefaultLabel-only-for-interactively-created-OBJs.diff: add
     from master (closes: #907710)

libreoffice (1:6.1.2-0ubuntu1) cosmic; urgency=medium

   * New upstream release (LP: #1795580)
   * Drop upstreamed patches:
     - debian/patches/apparmor-fixes.diff
     - debian/patches/fix-gtk3_kde5-filepicker-infinite-loop.diff

libreoffice (1:6.1.2-1) unstable; urgency=medium

   * New upstream release

libreoffice (1:6.1.1-0ubuntu1) cosmic; urgency=medium

   * New upstream release (LP: #1792894)

libreoffice (1:6.1.1-1) unstable; urgency=medium

   * New upstream release
 
   * debian/patches/fix-gtk3_kde5-filepicker-infinite-loop.diff: add from
     libreoffice-6-1 branch: fixes possible infinite loop in gtk3_kde5
     filepicker (closes: #906987)

libreoffice (1:6.1.1~rc1-2) unstable; urgency=medium

   * debian/patches/apparmor-fixes.diff: add patch from master to
     allow printing to file
   * debian/patches/do-not-reset-permissions-on-save.diff: as name says,
     from libreoffice-6-1 branch (closes: #907476)
 
   * debian/rules: move libdbahsqllo.so from -base-drivers to -base-core
     (closes: #907397)
   * debian/control.in:
     - add Replaces: for above
     - bump ure Dependency in -core to (>= 6.1.1~) (closes: #907650)

libreoffice (1:6.1.1~rc1-1) unstable; urgency=medium

   * New upstream release candidate
 
   * debian/patches/apparmor-kde.diff: backport AppArmor KDE fixes from
     master
   * debian/control.in:
     - really recommend apparmor (>= 2.13)

libreoffice (1:6.1.0-0ubuntu2) cosmic; urgency=medium

   [ Olivier Tilloy ]
   * debian/tests/control: do not depend on libreoffice-sdbc-firebird on s390x
     (LP: #1790165)
 
   [ Rene Engelhard ]
   * debian/rules: move libdbahsqllo.so from -base-drivers to -base-core
     (closes: #907397) (LP: #1789202)
   * debian/control.in: add Replaces: for above

libreoffice (1:6.1.0-0ubuntu1) cosmic; urgency=medium

   * New upstream release (LP: #1786207, LP: #1789240)
   * debian/patches/apparmor-fixes.diff: remove patch as this requires apparmor
     2.13, which is not in ubuntu cosmic
   * debian/control.in: relax apparmor recommend

libreoffice (1:6.1.0-1) unstable; urgency=medium

   * Libreoffice 6.1.0 final (identical to rc3)
 
   * debian/patches/apparmor-fixes.diff: add patch from libreoffice-6-1
     branch to fix saving of documents in apparmor enforce mode
     (closes: #905442)
   * debian/patches/apparmor-cleanups.diff: use dri-enumerate abstraction of
     apparmor; add from https://gerrit.libreoffice.org/#/c/58589
 
   * debian/control.in:
     - recommend apparmor (>= 2.13) for above
     - make -common also depend on -style-colibre, since it apparently also
       is needed to have LO draw iit's check/radiobuttons correctly
       (closes: #904598, #905408, #905819)

libreoffice (1:6.1.0~rc3-0ubuntu1) UNRELEASED; urgency=medium

   * New upstream rc release

libreoffice (1:6.1.0~rc3-1) unstable; urgency=medium

   * New upstream release candidate
 
   * debian/patches/do-not-hide-test-output.diff: also do not hide PythonTests
     output
 
   * debian/control.in: add Breaks/Replaces: libreoffice-common (<<
     1:6.1.0~alpha1-1) to libreoffice-help-common (closes: #905185)
   * debian/tests/control, debian/tests/smoketest: use "skippable" restriction
     and return 77 instead of 0 if running into the timeout
   * debian/tests/*: use $AUTOPKGTEST_TMP instead of $ADTTMP
   * debian/rules:
     - don't suggest libreoffice-spellcheck-tr (for
       libreoffice-zemberek) anymore - dead upstream. thanks Muhammet Kara
     - support new "terse" in DEB_BUILD_OPTIONS
     - replace #!/usr/bin/env perl shebangs in some files by #!/usr/bin/perl
     - also fix up ../00/usr/share/libreoffice/help/... in doc-base....

libreoffice (1:6.1.0~rc2-3) unstable; urgency=medium

   * debian/tests/control:
     - "timeout" is in coreutils...
   * debian/rules:
     - add | firefox at the end of the -help browser depends (closes: #904312)

libreoffice (1:6.1.0~rc2-2) unstable; urgency=low

   * upload to unstable

libreoffice (1:6.1.0~rc2-1) experimental; urgency=low

   * New upstream release candidate
 
   * debian/patches/apparmor-allow-java.security.diff: allow
     /etc/java-??-openjdk/security/java.security read access, denied because
     it's a symlink (closes: #903900)
 
   * debian/tests/control: add missing libreoffice-dev dependency for the
     "smoketest" test
   * debian/tests/uno: run config_host.mk with (e.g.) BUILD_KDE=n to avoid
     configure failure because qmake is not correctly found
   * debian/rules:
     - don't depend on x-www-browser, only "qutebrowser" provides it.
       Use firefox-esr | epiphany-browser | konqueror | chromium which is
       the order xdg-open (which is used to actually open the help) does, too
       (closes: #904022)
     - temporarily disable dwz. fails since the change to gcc 8

libreoffice (1:6.1.0~rc1-2) experimental; urgency=medium

   * rebuild with correct control (all languages...)

libreoffice (1:6.1.0~rc1-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/rules:
     - make the tests fatal again (where they were before - amd64/arm64),
       the "broken" hsqldb->firebird auto-migration got disabled for 6.1
     - fix PYTHON_VERSION override to work again;
       export PYTHON_{CFLAGS,LIBS} ourselves
   * debian/control.transitionals.in: make libreoffice-kde "all" again since
     it its built everywhere since last upload
   * debian/uno-libs3.symbols: add sal PRIVATE_x.y* symbols (closes: #902898)

libreoffice (1:6.1.0~beta2-1) experimental; urgency=medium

   * New upstream beta release
     - fixes moving keyboard focus to sidebar styles panel after pressing F11
       (closes: #870476)
 
   * debian/patches/allow-opensymbol-rebuild.diff: from upstream
     https://gerrit.libreoffice.org/#/c/54938/, add new --enable-build-opensymbol
   * debian/patches/gtk3-kde5-32bit.diff: add patch from
     https://gerrit.libreoffice.org/#/c/55474 to fix gtk3_kde5 filepicker build
     on 32bit
   * debian/patches/do-not-hide-test-output.diff: don't use tee since that hides
     the failure (and -o pipefail doesn't work), just use plain 2>&1 and no log
 
   * debian/rules:
     - allow fontforge additionally to of fontforge-nox
     - remove custom build-opensymbol target; use new --enable-build-opensymbol
     - fix i386 conditional for not adding a (not fullfillable on stretch
       even with backports) default-jdk (>= 2:1.9) build-dep
     - don't enable dwz on stretch-backports, the needed debhelper conflicts
       against the (needed via libgpgmepp-dev) stable qt5-qmake :/
     - remove USE_DWZ_MULTIFILE conditional (which was disabled),
       default since debhelper 11.3
     - make BUILD_TEST_PACKAGES=y be based on DEB_BUILD_PROFILES, not
       DEB_BUILD_OPTIONS
     - enable gtk3_kde also on 32bit archs
     - ignore test failures for now; broke already in beta1-1 but was hidden by
       the do-not-hide-test-output.diff bug, so no regression. Needs to be
       investigated.
   * debian/control.test-packages.in:
     - add Build-Profiles: <!nocheck>
   * debian/control.sdk.in:
     - add Build-Profiles: <!nodoc> for -dev-doc
   * debian/control.in:
     - the colibre change was reverted; make -common depend on -style-tango

libreoffice (1:6.1.0~beta1-1) experimental; urgency=medium

   * New upstream beta release
     - allows rk on .gnupg/random_seed to fix hang on gpg encryption
       (closes: #899380)
 
   * debian/tests/patches/odk-build-examples-standalone.diff: make apply again
   * debian/patches/do-not-hide-test-output.diff: as name says. to prevent
     slow(er) archs/buildds timing about because e.g. the new uitests might take
     too long without an output
   * debian/patches/no-ant-check-if-unneeded.diff: as name says, only check
     for ant if we really need it for building something
 
   * debian/rules:
     - build-depend on fontforge-nox and rebuild opens___.tff from OpenSymbol.sfd
     - fix numbertext-data-recommends substvar
     - optimize the build-indep build a bit more
       + remove build-indep dependency on build-arch to not run the full
         testsuite on -A (build-indep) builds.
         Only run the odk "check" (SDK files) and build-example tests
       + build without --enable-symbols on build-indep builds
     - enable (gtk3_)kde5 (and qt5) only on 64bit archs for now
     - make -help-xx depend with = on -help-common and -help-common depend on
       x-www-browser, too, it already contains HTML
     - rebuild smoketestdoc.sxw; install it into libreoffice-smoketest-data
     - move ant to Build-Depends-Indep
   * debian/tests/odk-build-examples: fix
   * debian/control.in: move numbertext-data-recommends to Depends: as the
     numbertext stuff is used for ooxml im/export.. (theoretical, since
     libnumbertext depends on it already, but...)
   * debian/copyright: add the various (c)'s of OpenSymbol.sfd
   * debian/libreoffice-help-common.links: symlink normalize.css to
     /usr/share/javascript/normalize.css/normalize.css and depend on
     libjs-normalize.css (closes: #898788), but mention ./help3xsl/normalize.css
     in copyright
   * debian/tests/*:
     - remove build-needed in smoketest and build some needed parts ourselves.
       Add missing LD_LIBRARY_PATH and use
       /usr/share/libreoffice/smoketestdoc.sxw. Enable
     - honour $ADTTMP
     - rename junit-subsequentcheck to junit
     - add "uno" test running the bridgetest using /usr/lib/libreoffice/uno.
       only depends on "ure"
     - run "perl odk/util/check.pl /usr/lib/libreoffice/sdk"
   * debian/rules, debian/control.systray.in: the systray "Quickstarter" is
     finally gone upstream.

libreoffice (1:6.1.0~beta1~git20180507-1) experimental; urgency=medium

   * New upstream snapshot
 
   * debian/patches/disable-tests-somehow-needing-more-fonts.diff,
     debian/patches/tdf108963-test.diff: remove. Obsolete after Liberation
     fix
 
   * debian/libreoffice-help-common.doc-base: ... rename
   * debian/libreoffice-help.doc-base.in: ... here and only use as template.
     Update Index: for localized "index" (text/shared/main0108.html) and fix
     Section:
   * debian/rules:
     - move also the -help-common parts to /usr/share
     - create/populate libreoffice-help-xx .doc-base files
     - use internal libetonyek on stretch-backports
     - use -type f for pupulating Files: in .doc-base to leave out dirs...
     - stop special-casing i386 to explicitly use openjdk (9), use default-java
       again and add appropriate versioned build-depends
     - install the language-specific media/helpimg/xx into their correct packages
     - fix build with -B/all (unpackaged help) languages
     - add Build-Conflicts: against "broken" fonts-liberation
     - remove explicit SAL_USE_VCLPLUGIN="svp" from make check call since it's
       apparently unneeded (and even actually harmful) now
   * debian/rules, debian/control.in: add stuff for new libnumbertext usage
   * debian/lo-java-ref.in: move to Programming/Java
   * debian/tests/odk-build-examples: build also new split-out
     CustomTarget_odk/build-examples_java

libreoffice (1:6.1.0~alpha1-1) experimental; urgency=medium

   * New upstream alpha release
     - fixes cross-file links with xlsx files (closes: #658569)
     - apparently preserves conditional formatting with copy paste operations
       (again) (closes: #868349)
     - fixes crash on typing any character with IME in Wayland
       (closes: #898632)
 
   * debian/patches/no-packagekit-per-default.diff: use the new config options
     to disable the packagekit install stuff
   * debian/patches/odk-no-dot.diff: remove, see below
 
   * debian/rules:
     - install TestExtension.oxt into a new libreoffice-smoketest-data package
       which can be used by autopkgtests
     - enable gtk3_kde vclplug (closes: #752230) and "kde5" (kde5be)
     - re-enable pdfium on arm64 again; is now not using its internal allocator
       anymore
     - use new $(call java_dependency, default-jdk) for default-jdk builddep
     - add Build-Depends-Indep: on graphviz, since Debians doxygen sets
       HAVE_DOT to YES (see #818787) and upstreams configure.ac now checks for
       this and fails if "dot" isn't present.
   * debian/tests/*: add autopkgtest to test install TestExtension.oxt
     (user and shared)
   * debian/tests/*: add initial version of a autopkgtest to run the smoketest,
     build smoketestdoc.sxw here for now (and a full build...). Disabled for now.
   * debian/control.transitionals.in: add -kde -> kde5 transitional package
   * debian/libreoffice-sdbc-firebird.bug-script.in: remove, firebird not
     experimental anymore
   * debian/control.in:
     - update for new icon defaults, make -common depend on -style-colibre and
       -gnome recommend -style-elementary
   * debian/control*in, debian/rules, debian/libreoffice-help-common.doc-base:
     build with --with-help=html and split common files into a new
     libreoffice-help-common
 
   * merge from Ubuntu:
     - debian/patches/hide-maths-desktop-file.patch: hide
       math icon from the shell (see #883734)

libreoffice (1:6.0.4~rc1-4) unstable; urgency=medium

   * debian/patches/patches/disable-java-in-odk-build-examples-on-zero-vm.diff:
     as name says, the test builds many Java projects without a output and on
     Zero this is slow -> "hangs" gets killed because of inactivity
   * explicitely disable junit tests when determining that java uses the Zero VM

libreoffice (1:6.0.4~rc1-3) unstable; urgency=medium

   * debian/rules:
     - sigh. readd lost if to disable make check on big-endian archs.

libreoffice (1:6.0.4~rc1-2) unstable; urgency=medium

   * debian/rules:
     - clean up/simplify test on/off/fatal handling and use findstring
       as everywhere else
     - disable running make check on armel and mipsel. hangs.

libreoffice (1:6.0.4~rc1-1) unstable; urgency=medium

   * New upstream release candidate
 
   * debian/patches/appstream-ignore-startcenter.diff: add
     X-AppStream-Ignore=True to startcenter.desktop, thanks Olivier
     (closes: #892364)

libreoffice (1:6.0.3-0ubuntu1) bionic; urgency=medium

   * New upstream release

libreoffice (1:6.0.3-1) unstable; urgency=medium

   * New upstream release
 
   * debian/patches/gpg-overly-long-filenames-fix.diff: backport
     https://gerrit.libreoffice.org/#/c/50978/ fix to fix gpg encryption
     test ("File name too long")
   * debian/patches/disable-flaky-tests.diff: remove disabling of
     testODFEncryptedGPG.
   * debian/patches/check-for-gpgconf-and-run-user.diff: as name says,
     don't fail when gpgconf --create-socketdir doesn't work because
     /run/user/<uid> doesn't exist... Check for it.
 
   * debian/rules:
     - add explicit gpg-agent and gpgconf build-dependencies
     - add explicit python3-distutils build-dependency as
       python3.6 3.6.5~rc1-2 dropped its python3-distutils dependency...

libreoffice (1:6.0.2-0ubuntu1) bionic; urgency=medium

   [ Olivier Tilloy ]
   * branding/progress.conf: update to new Ubuntu Orange (LP: #1752372)
 
   [ Rico Tzschichholz ]
   * New upstream release
   * Drop upstreamed patches:
     - apparmor-senddoc-fixes.patch
     - fix-packageinfo-motarget-files.patch
     - solenv-Update-gb_PackageInfo_emit_l10n_for_one_lang.patch

libreoffice (1:6.0.2-1) unstable; urgency=medium

   [ Rene Engelhard ]
   * New upstream release
 
   * debian/patches/orcus-0.13.3.diff: backport patches to fix build/tests
     against orcus 0.13.3
   * debian/patches/disable-some-sc-tests-with-internal-cppunit.diff: update
 
   * debian/watch: update for the multiple tarballs
   * debian/copyright: remove Files-Excluded: for files already removed by
     upstreams pack script anyway to allow mk-origtargz doing --symlink
   * debian/scripts/mk-origtargz: own mk-origtargz..
 
   * debian/rules:
     - --disable-pdfium on arm64
     - actually build without -g if ENABLE_SYMBOLS=n
     - add get-orig-source target for "real" upstream tarballs
     - fix libvisio dependency
     - bump runtime (and test) depends for liborcus to >= 0.13.3
   * debian/control.in:
     - recommend xdg-utils in -common (for xdg-{open,email})
 
   [ Olivier Tilloy ]
   * debian/rules: define ${java-common-depends} when building
     libreoffice-wiki-publisher and libreoffice-nlpsolver (closes: #891765)

libreoffice (1:6.0.1-0ubuntu3) bionic; urgency=medium

   [ Olivier Tilloy ]
   * debian/patches/uitest-skip-test_text_direction.patch: removed
 
   [ Rene Engelhard ]
   * debian/patches/orcus-0.13.3.diff: backport patches to fix build/tests
     against orcus 0.13.3
 
   [ Rico Tzschichholz ]
   * debian/patches/solenv-Update-gb_PackageInfo_emit_l10n_for_one_lang.patch:
     Update gb_PackageInfo_emit_l10n_for_one_lang to add cjk_*, ctl_* and
     ctlseqcheck_$LANG.xcd files to install list (LP: #1750335)
   * Fix libvisio and libqxp shlibs dependency (Thanks Rene)

libreoffice (1:6.0.1-0ubuntu2) bionic; urgency=medium

   [ Olivier Tilloy ]
   * debian/patches/apparmor-senddoc-fixes.patch: updated to reflect upstream
     commit
   * debian/patches/uitest-skip-test_text_direction.patch: skip a UI test that
     is consistently failing (LP: #1750335)
 
   [ Rico Tzschichholz ]
   * debian/rules: Revert "explicitly use openjdk 9 on i386…"

libreoffice (1:6.0.1-0ubuntu1) bionic; urgency=medium

   [ Rico Tzschichholz ]
   * New upstream release
   * debian/patches/fix-packageinfo-motarget-files.patch: Fix make packageinfo
     to let "install-packages-l10n-*" targets work again (LP: #1748437)
 
   [ Olivier Tilloy ]
   * debian/patches/hide-startcenter-and-maths-desktop-files.patch: hide
     startcenter and math icons from the shell (LP: #1696250)
   * debian/patches/apparmor-senddoc-fixes.patch: apparmor fixes for the
     senddoc profile (LP: #1748895)

libreoffice (1:6.0.1-1) unstable; urgency=high

   * New upstream release
     - fixes CVE-2018-1055: libreoffice: Remote arbitrary file disclosure
       vulnerability via WEBSERVICE formula
 
   * debian/control.in: bump ure Depends for -core to (>= 6.0.0~)
     (closes: #889074)
   * debian/rules:
     - use internal mdds for stretch-backports
   * debian/tests/control: make uicheck depend on libreoffice-l10n-{he,ja}
     for the text direction UI Test
 
   * merge from Ubuntu:
     - Bump shlibs overrides for libvisio and orcus

libreoffice (1:6.0.0-1) unstable; urgency=medium

   * LibreOffice 6.0.0 final release (identical to rc3)
 
   * upload to unstable
 
   * debian/patches/glm-0.9.9.diff: fix build with glm 0.9.9 (closes: #888737)
 
   * merge from Ubuntu:
     - debian/patches/apparmor-fixes.diff: allow JVM execution
 
   * debian/rules:
     - re-enable system-glm; bump libglm-dev build-depdendency to
       libglm-dev (>= 0.9.9~a2) when using gcc >= 7.3
     - re-enable -systray. Actually in stock 6.0 upstream debs the feature *is
       still in the options...

libreoffice (1:6.0.0~rc3-2) experimental; urgency=medium

   * debian/patches/disable-flaky-tests.diff: disable testODFEncryptedGPG test;
     the signing parts work, so...

libreoffice (1:6.0.0~rc3-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/patches/apparmor-fixes.diff: add patch from master with syntax
     fixes. Also include X abstractions and allow .mozilla/firefox/** reading
   * debian/patches/apparmor-updates.diff: more gpg stuff: gpg(sm), .gnupg/*
   (both together closes: #887593)
   * debian/rules, debian/source/include-binaries: temporarily use internal glm;
     configure check fails since the gcc 7.3 upload

libreoffice (1:6.0.0~rc2-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/patches/poppler-0.62.diff: backport from master to fix build with
     poppler 0.62
 
   * debian/rules:
     - rename 30_opensymbol.conf to 30-opensymbol.conf for consistency

2017

libreoffice (1:6.0.0~rc1-1) experimental; urgency=medium

   * New upstream release candidate
     - fixes keyboard navigation for textboxes in slide layout (closes: #870387)
     - fixes Glue points in Draw (closes: #883989)
 
   * debian/patches/apparmor-usrmerge.diff: allow also /usr/bin/dash (etc.)
     - usrmerge...
 
   * debian/libreoffice-common.bug-script.in: revert running aa-status;
     Might not exist and actually displaying the status needs root. People
     shouldn't run reportbug as root, though...
   * debian/rules:
     - stop passing --disable-report-builder to build-archs configure since
       even though it's built the report builder doesn't work then. Move
       from Build-Depends-Indep: to Build-Depends: again (closes: #875688);
     - update ar FONT_SUGGESTS: fonts-arabeyes ->
       fonts-kacst, fonts-hosny-amiri, fonts-sil-scheherazade, fonts-hosny-thabit
   * debian/rules, debian/control*.in:
       s/REPORTDESIGN/REPORTBUILDER/ and
       control.reportdesign.in -> control.reportbuilder.in while we're at it
   * debian/copyright:
     - mention sysui/desktop/apparmor/* copyright/license
     - mention icon_themes/elementary*/* copyright/license
   * debian/control.in:
     - remove fonts-noto-unhinted from Recommends: again per
       upstream suggestion
     - recommend both fonts-liberation (LO ships 2 + Narrow from 1)
   * debian/rules, debian/control.in: recommend and build-depend against
     fonts-liberation2 instead of fonts-liberation since that is actually
     what LO upstream ships (see above)

libreoffice (1:6.0.0~beta2-1) experimental; urgency=medium

   [ Rene Engelhard ]
   * New upstream beta release
 
   * debian/patches/apparmor-complain.diff: set complain mode for oosplash
     and soffice.bin profiles
   * debian/patches/sal-fix-kfreebsd-build.diff: add from gerrit
 
   * debian/control.in: remove openjdk conflicts ...
   * debian/rules: ... and make them Depends in JAVA_RUNTIME_DEPENDS for the
     Java-using packages. Also allow openjdk-9 everywhere
   This doesn't prevent usage of the "broken" JDK but otherwise we "break"
   jodconverter/natbraille in testing... And linux 4.14.2-1 is also supposed to
   fix the regression finally...
   This also closes: #882436
 
   * debian/rules:
     - stop installing disabled symlinks for apparmor (closes: #883800)
     - actually install the OpenSymbol fontconfig snippet into a
       /etc/fonts.d/30_opensymbol.conf
     - change BRAND_BASE_DIR in fundamentalrc so that we don't get
       /usr/lib/libreoffice/program/../program/xpdfimport calls. We know
       the path and the apparmor profile doesn't allow this
   * debian/libreoffice-common.bug-script.in: run aa-status
   * debian/control.in: add gnupg to Suggests
 
   [ intrigeri ]
   * debian/README.Debian: document how to debug and customize the included
     AppArmor profiles

libreoffice (1:6.0.0~beta1-2) experimental; urgency=medium

   * debian/libreoffice-common.{triggers,postinst}.in,
     debian/shell-lib-lool.sh: add trigger updating LOOLs systemplate
   * debian/libreoffice-common.triggers.in: switch to interest-noawait triggers
 
   * merge from Ubuntu:
     - debian/patches/fix-includes-in-aarch64-bridge.patch: add from master

libreoffice (1:6.0.0~beta1-1) experimental; urgency=medium

   * New upstream beta release
 
   * debian/patches/ww8export-HAVE_MORE_FONTS.diff: move ...
   * debian/patches/disable-tests-somehow-needing-more-fonts.diff: ... here
     and patch also ooxmlexport4
 
   * debian/rules:
     - use (dh_)dwz and (if enabled) install the multifile file into
       uno-libs3-dbgsym.
       Thanks Matthias Klose for the hint.
       Make *-dbgsym depend on uno-libs3-dbgsym which should contain the above
       file and is recommended anyway because of the gdb helpers.
     - be consequent and enable the junit tests on arm64 now that
       those work.
     - stop passing --disable-database-connectivity for no-Base archs
       (closes: #874274)
     - explicitly use and depend on openjdk 9 on i386 now that #876069 is fixed.
     - replace some manual dpkg-parsechangelog calls with
       $(DEB_VERSION) and $(DEB_DISTRIBUTION) and fix logic for
       --disable-dependency-tracking
     - enable missed sr-Latn but merge into -sr
     - install the apparmor profiles disabled for now (closes: #882597)
   * debian/libreoffice-sdbc-firebird.maintscript: remove (redundant)
     $DPKG_MAINTSCRIPT_PACKAGE and update version (closes: #880426)
   * debian/rules, debian/libreoffice-common.maintscript: fix path in/for
     apparmor profiles (add missing /). mv_conffile the files to the new
     name...
   * debian/control.in: make -core conflict against openjdk-{6,7,8}-jre-headless
     on i386- -java-common would make more sense, but it's Arch: all..
   * debian/control.in:
     - add fonts-noto-hinted, fonts-noto-mono, fonts-noto-unhinted to
       Recommends
     - clean up mozilla suggests to just firefox-esr | thunderbird | firefox
     - add versions to openjdk-{7,8}-jre-headless conflicts now that they are
       also supposed to be fixed
   * debian/control.{kde.}.in: suggest the "certificate managers" for gpg:
     gpa, seahorse, kleopatra | kgpg

libreoffice (1:6.0.0~alpha1-1) experimental; urgency=medium

   [ Rene Engelhard ]
   * New upstream alpha release
 
   * debian/patches/tdf108963-test.diff: adapt test to what we get; the
     text _is_ rotated on export, so...
 
   * merge from Ubuntu, thanks Rico Tzschichholz:
     - Add "elementary" style package
 
   * debian/rules:
     - finally stop building -systray. GNOME 3.26 doesn't show it anymore,
       and in 6.0 the feature is not completely removed yet but the UI for
       setting it is already gone anyway....
 
   [ Rico Tzschichholz ]
   * Add Kannada (kn) langpack

libreoffice (1:5.4.4-0ubuntu2) bionic; urgency=medium

   [ Olivier Tilloy ]
   * New upstream release
   * debian/patches/apparmor-profiles-comments.patch: added
     (https://bugs.documentfoundation.org/show_bug.cgi?id=114915)
   * debian/patches/apparmor-allow-jvm-execution.patch: added
     (https://bugs.documentfoundation.org/show_bug.cgi?id=115208)
 
   [ Rene Engelhard ]
   * debian/rules, debian/libreoffice-common.maintscript: fix path in
     apparmor profiles (add missing /). mv_conffile the files to the new
     name...
   * debian/patches/poppler-0.62.diff: backport from master to fix build with
     poppler 0.62
 
   [ Rico Tzschichholz ]
   * debian/rules: update source location of fc_local.conf

libreoffice (1:5.4.3~rc1-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/patches/no-check-if-root.diff: remove (senseful, IMHO!) check
     given policy implies "build" should be able to run as root... :(
   * debian/patches/avoid-throwing-cpp-exceptions-across-libgpeg-c-frames.diff:
     add from master, fixing CppunitTest_vcl_filters_test on arm*
   * debian/patches/debian-hardened-buildflags-CPPFLAGS.diff: split this up,
     into the CPPFLAGS part here ..
   * debian/patches/debian-hardened-buildflags-no-LO-fstack-protector-strong.diff:
     and the removal of the explicit default -fstack-protector-strong here.
   * debian/patches/arm64-bridges-no-stack-protector-strong.diff: add from master:
     go sure that we build gcc3_linux_aarch64/cpp2uno.cxx only with
     -fstack-protector. Works for us by chance because of above
     debian-hardened-buildflags-no-LO-fstack-protector-strong.diff
   * debian/patches/arm64-disable-sc-functions-test.diff: add patch from master
     to disable the sc_*_functions_test on arm64 (as for x86).
 
   * debian/rules:
     - really fix -dbgsym 0775 permissions by manually fixing them after
       mkdir -p's (dh_fixperms doesn't run on -dbgsym) which apparently
       create them as 775 (at least on the buildds)
     - fix libreoffice-dev-doc.doc-base.lo-idl-ref (again)
     - add missing dependency to build-arch to install-arch
     - make armhf/arm64 test failures fatal now that above test is fixed which
       was the only one failing; upstream apparently also builds armhf/arm64
       flatpaks now for flathub
   * debian/copyright:
     - fix various missing-license-paragraph-in-dep5-copyright

libreoffice (1:5.4.2-3) unstable; urgency=medium

   * debian/patches/ww8export-HAVE_MORE_FONTS.diff, debian/rules: revert
     change of -2. Actually doesn't work. (Did in a testbuild, but...)

libreoffice (1:5.4.2-2) unstable; urgency=medium

   * debian/patches/ww8export-HAVE_MORE_FONTS.diff: remove again ...
   * debian/rules: ... and install LOs fc_local.conf to instdir before make
     check
 
   * debian/control.{lang,help},in: remove | language-support-translations-*
     Depends:/Recommends: to unconfuse piuparts

libreoffice (1:5.4.2-1) unstable; urgency=medium

   * LibreOffice 5.4.2 final release (identical to rc2)
 
   * upload to unstable
 
   * debian/patches/disable-flaky-tests.diff: disable chart2_dump test
     (closes: #877794)
   * debian/patches/ww8export-HAVE_MORE_FONTS.diff: temporarily(?) disable
     testTableKeep test, fails with --without-fonts even though Liberation
     is in Build-Depends:...
 
   * debian/libreoffice-sdbc-firebird.maintscript: restore, we need it
     from upgrades involving jessie since jessies version gets kept on
     jessie->stretch upgrades... (closes: #877494)

libreoffice (1:5.4.2~rc2-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/control.help.in: drop now obsolete Depends on
     libreoffice-style-default (closes: #877175)

libreoffice (1:5.4.2~rc1-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/patches/icu-no-icu-config.diff: don't use icu-config for
     determining the ICU version; doesn't exist in (Debian's) ICU 59.1 anymore
 
   * debian/rules:
     - move STRETCH_BACKPORT conditional for coinmp lower in rules so it
       gets honoured and make libwps/libmwaw internal unconditionally
       (RUN_MAKE_CHECK=n on BE archs)...
     - move images_helpimg.zip to usr/share like the others; remove obsolete
       helpimg mangling in the "other" images_*.zip
   * debian/control.in: remove -style-default provides since it doesn't help at
     all on default changes; depend on tango since that apparently is now the
     (last) fallback (closes: #874196)
   * debian/control.gtk?.in: remove -style-tango recommends, obsoleted by
     above

libreoffice (1:5.4.3-0ubuntu1) bionic; urgency=medium

   * New upstream release
   * debian/patches/icu-60-fixes.patch: refreshed

libreoffice (1:5.4.2-0ubuntu5) bionic; urgency=medium

   * debian/patches/icu-60-fixes.patch: added
     (https://bugs.documentfoundation.org/show_bug.cgi?id=113705)
   * debian/patches/skip-testLineBreaking-icu60.patch: removed, no longer needed

libreoffice (1:5.4.2-0ubuntu4) bionic; urgency=medium

   [ Rene Engelhard ]
   * debian/patches/disable-flaky-tests.diff: disable chart2_dump test
   * debian/patches/ww8export-HAVE_MORE_FONTS.diff: temporarily(?) disable
     testTableKeep test, fails with --without-fonts even though Liberation
     is in Build-Depends:...
 
   [ Olivier Tilloy ]
   * debian/patches/skip-testLineBreaking-icu60.patch: temporarily skip
     failing unit test with ICU 60

libreoffice (1:5.4.2-0ubuntu2) bionic; urgency=medium

   [ Rene Engelhard ]
   * debian/patches/icu-no-icu-config.diff: don't use icu-config for
     determining the ICU version; doesn't exist in (Debian's) ICU 59.1 anymore
 
   [ Rico Tzschichholz ]
   * debian/rules: Rely on -Npackage in DEBHELPER_OPTIONS to fix debhelper error

libreoffice (1:5.4.2-0ubuntu1) artful; urgency=medium

   [ Rico Tzschichholz ]
   * New upstream release
   * Drop debian/patches/java9.diff, included upstream
 
   [ Rene Engelhard ]
   * debian/rules:
     - move images_helpimg.zip to usr/share like the others; remove obsolete
       helpimg mangling in the "other" images_*.zip

libreoffice (1:5.4.1-0ubuntu1) artful; urgency=medium

   [ Olivier Tilloy ]
   * debian/rules: move usr/lib/libreoffice/sdk/settings/dk.mk from
     libreoffice-dev-common to libreoffice-dev (LP: #1712873)
 
   [ Rico Tzschichholz ]
   * New upstream release
   * Drop lo-xlate-lang-update.diff, add-libebook-1.2.so.19-in-EApi.cxx.patch,
     examples-fix-SDK_AUTO_DEPLOYMENT-check.diff, applied upstream
 
   [ Rene Engelhard ]
   * debian/patches/stop-shipping-mimelnk-desktop-files.diff: as name says
     (closes: #872001)
   * debian/patches/java9.diff: backport Java 9 patch from master
   * debian/rules:
     - run dh_strip_nondeterminism
     - set locale to en-US.UTF-8 also for make check, the dbaccess tests
       fail in some frenchy locale...
     - move pagein-{calc,draw,impress,writer} to their respective packages
   * debian/scripts/gid2pkgdirs.sh: fix move of types/*.rdb and services/*.rdb
     to core and move pagein-common there too. They reference libmergedlo.so
     which doesn't exist on all archs (closes: #873443)

libreoffice (1:5.4.0-0ubuntu2) artful; urgency=medium

   [ Rico Tzschichholz ]
   * New upstream release
   * Merge with debian 1:5.4.0-1
   * Use -tarballs.orig instead of -src.orig for external dependencies
   * Drop Recommends to libreoffice-pdfimport transitional
   * Suggest fonts-deva instead of unavailable ttf-devanagari-fonts
   * Add Kannada (kn) langpack (LP: #1705014)
   * Enable evolution, dconf and avahi support
   * Use system orcus and lp-solve
   * New build dependencies: dh-apparmor, fonts-dejavu, ghostscript,
     imagemagick, libavahi-client-dev, libboost-locale-dev, libdconf-dev,
     libe-book-dev, libebook1.2-dev, libetonyek-dev, libgpg-error-dev,
     libgpgme-dev, libgpgmepp-dev, liblpsolve55-dev, libmwaw-dev, liborcus-dev,
     libsuitesparse-dev, libwps-dev, libxmlsec1-dev, locales, lp-solve, pstoedit
   * New binary dependencies: lp-solve, libcolamd2, liborcus-0.12-0
 
   [ Olivier Tilloy ]
   * Make i386 make check notfatal for now given the i386 Java Stack Clash
     regression (LP: #1700692)

libreoffice (1:5.4.0-2) UNRELEASED; urgency=medium

   * debian/rules:
     - install appstream stuff into /usr/share/metainfo. sigh.
     - make -writer-dbgsym recommend -core-dbgsym as it wants some gdb stuff
       from it
     - set UNO_LIBS_DBG_ROOT to fix gdb helper installation for uno-libs3 again
       and make -core-dbgsym recommends uno-libs3-dbgsym (same reason as above)
     - generate and install apparmor profiles
     - be consequent and bump the build-dependencies for the DLP libs when
       we run the tests; based on patch by Rico Tzschichholz
     - run dh_strip_nondeterminism
     - disable -kde and the (unmaintained for LO) oxygen theme.
       Qt4 should go away. See
       https://lists.debian.org/debian-devel-announce/2017/08/msg00006.html
     - set locale to en-US.UTF-8 also for make check, the dbaccess tests
       fail in some frenchy locale...
     - remove libbz2-dev from Build-Depends, coinutils got fixed
     - move pagein-{calc,draw,impress,writer} to their respective packages
     - move dk.mk from -dev-common to -dev as it's not arch-indep, thanks
       Rico Tzschichholz
   * debian/scripts/gid2pkgdirs.sh: fix move of types/*.rdb and services/*.rdb
     to core and move pagein-common there too. They reference libmergedlo.so
     which doesn't exist on all archs (closes: #873443)
   * debian/control*in:
     - move to policy 4.0.1; extra -> optional
     - Breaks/Replaces for above

libreoffice (1:5.4.0-1) unstable; urgency=medium

   * New upstream release
 
   * upload to unstable
 
   * debian/patches/examples-fix-SDK_AUTO_DEPLOYMENT-check.diff: don't try
     to do "auto deployment" when SDK_AUTO_DEPLOYMENT = NO...
   * debian/patches/libebook-1.2.so.19.diff: backport from master; adds
     libebook-1.2.so.19 (e-d-s 3.24+) to EApi.cxx
 
   * debian/rules:
     - strip librhino-java from java:Depends, we use the internal one still..
     - add pstoedit, imagemagick and ghostscript as (test) Build-Depends:
   * debian/control.in:
     - add ghostscript to the "EPS Suggests"
   * debian/rules. debian/control.in:
     - add libsane-suggests substvar to prepare for libsane1
 
   * merge from Ubuntu, thanks Rico Tzschichholz
     - don't recommend libreoffice-sdbc-firebird if firebird is disabled
 
   [ Rico Tzschichholz ]
   - fix get_libebook_dep.sh for libebook1.2-dev (>= 3.24)

libreoffice (1:5.4.0~rc2-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/patches/mediawiki-oor-replace.diff: back to ="fuse" for Paths.xcu
     as otherwise it overwrites Template paths and breaks the python wizards
     (closes: #867209)
 
   * debian/tests/control, debian/uitest: improve, we can only run the test
     now; remove build-needed
   * debian/tests/control, debian/tests/sdk-examples: move ...
   * debian/tests/control, debian/tests/odk-build-examples: ... here and use
     upstreams odk/build-examples check directly.
     (Needs zip, python3-uno and libreoffice-officbean as new test Depends:)
   * debian/tests/odk-build-examples: actually set -e...
   * debian/rules, debian/tests/control: remove extra hackery to add our
     Build-Depends(-Indep): to debian/tests/control.in; misses some packages
     (e.g. ant) and it should work at least since autopktest 3.16 from Jul 2015;
     use @builddeps@ instead
   * debian/tests/control, debian/tests/*uno-import.diff: split; make
     pyuno-import test import pyuno while uno-import does import uno
     (the uichecks do the former). Add python3 dependency for safety.
   * debian/test/control: sort by importance
   * debian/tests/: unapply patch after the make (or on error) so that the
     next test can patch it...
   * debian/tests/*: more cleanups for newer autopkgtests; use allow-stderr
     instead of manual 2>&1
 
   * debian/rules:
     - be consequent and set RUN_PYTESTS=n (and RUN_MAKE_UICHECK=n) where we set
       RUN_MAKE_CHECK=n
     - be consequent and add $(IGNORE_MAKE_CHECK_FAILURES) also to the "extra"
       test runs
     - disable the tests on bigendian archs: hang (failures non-fatal anyway.)
     - make i386 make check notfatal for now given the i386 Java Stack Clash
       regression
   * debian/control.in:
     - make -common Conflicts: older mediawikis to go sure
 
   * merge from Ubuntu, thanks Rico Tzschichholz
     - Bump soname in shlibs.override.orcus

libreoffice (1:5.4.0~rc1-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/tests/control.in, debian/tests/uicheck,
     debian/tests/patches/uicheck-standalone.diff: add initial version
     of autopgktest running uitest
 
   * debian/rules, debian/patches/system-xmlsec.diff: backport patch from
     master and add conditional for system-xmlsec. use it.
 
   * debian/rules, debian/control.lokit.in:
     - move /usr/share/gir-1.0/LOKDocView-0.1.gir to libreofficekit-dev and
       make libreofficekit-dev depend on gir1.2-lokdocview-0.1 as per gir
       policy
   * debian/rules:
     - clean up JRE Depends; we consider java6_architectures as Java arch, so
       let's remove the Java5 alternatives
   * debian/copyright, debian/source/include-binaries: remove xmlsec
   * debian/rules:
     - fix dh_missing call
   * debian/tests/sdk-examples: DevelopersGuide/OfficeDev/DesktopEnvironment
     needs -ljawt. Build this to check this and the JAVA_PROC_TYPE setting also.

libreoffice (1:5.4.0~beta2-4) experimental; urgency=medium

   * debian/patches/gb_SUPPRESS_TESTS.diff: add more tests to suppress
     (from master)
   * debian/patches/odk-settings-JAVA_PROC_TYPE.diff: set correct
     JAVA_PROC_TYPE for arm{el,hf}, mips* and ppc64el
   * debian/patches/gerrit_38597.diff: add from gerrit for master, fixes
     i386 tests
 
   * debian/rules, debian/scripts/locale-gen: upstream insists on using
     en_US.UTF-8 for the tests. "Steal" the locale-gen stuff from gcc
   * debian/control.in: make -core depend on ure (>= 5.4.0~beta2~)
     (closes: #864690)
   * debian/control.in:
     - make -gstreamer recommend gstreamer1.0-plugins-bad as we apparently
       want/need gtksink
 
   * merge from Ubuntu:
     - debian/tests/patches/java-subsequentcheck-standalone.diff: refreshed

libreoffice (1:5.4.0~beta2-3) experimental; urgency=medium

   *  debian/patches/series, also-suppress-odk-build-examples.diff: sigh.
      don't do that yet, not yet ready....

libreoffice (1:5.4.0~beta2-2) experimental; urgency=medium

   * debian/patches/disable-db-tests.diff: update
 
   * debian/rules:
     - try harder and also export LC_ALL=C.UTF-8 for uitest as the
       buildd/sbuild sets LC_ALL=POSIX already
     - fix icon installation in install-indep

libreoffice (1:5.4.0~beta2-1) experimental; urgency=medium

   * New upstream beta release
     - is now able to do "insert->image, choose pdf". Not insert->docunent
       but close enough, so this closes: #814598
       (unfortunately only using internal pdfium. sigh.)
 
   * debian/scripts/gid2pkgdirs.sh, debian/control{,.transitionals}.in:
     remove extra libreoffice-pdfimport, merge (even though the poppler
     dependency...) back to -common/-core since it has the above new feature and
     otherwise it may get confusing what is what.
 
   * debian/rules, debian/patches/cppunit-optional.diff: as name says;
     make cppunit build-dep optional and add <!nocheck> to the build-dep
   * debian/patches/disable-unneeded-test-programs.diff : micro-optimisation;
     as name says.
   * debian/gb_SUPPRESS_TESTS.diff: backport from master, allow checks build
     but not run them
 
   * tarballs/pdfium-3064.tar.bz2, debian/copyright,
     debian/source/include-binaries, debian/libreoffice-core.lintian-overrides:
     include pdfium; override embedded-library for lcms2
 
   * debian/rules:
     - adapt for (upcoming) usage of dh_missing
     - run build-nocheck with --without-junit --without-cppunit to configure
       and run check with them; build the checks with gb_SUPPRESS_TESTS first
       before running them
     - replace symlinks /usr/share/applications/*.desktop. move
       /usr/lib/libreoffice/share/xdg/*.desktop (except qstart.desktop) to
       them instead. Fixes e.g. appstream-generator for our appstream data
       (which cannot handle the symlinks...)
     - enable running make uicheck

libreoffice (1:5.3.3-2) experimental; urgency=medium

   * debian/patches/sensible-lomua.diff: sync upstreams
     "add xdg-email as the default email route" into here
 
   * debian/rules:
     - fix logic error; make -g1 etc work also with noddebs. Build with those
       flags also if building no -dbgsym
     - move DPKG_EXPORT_BUILDFLAGS and buildflags.mk include later to make it
       effective (worked before, but...)
     - fix /usr/share/libreoffice/program/classes/unoil.jar symlink
   * debian/control.in:
     - remove obsolete Pre-Depends
   * debian/rules, debian/control.in: remove now unneeded dejavu-depends
     substvar, simply use fonts-dejavu. Move from Depends: to Recommends: like
     the other fonts
   * debian/copyright: fix (add missing .'s)

libreoffice (1:5.3.3-1) experimental; urgency=medium

   * New upstream release
 
   * debian/control.in:
     - recommend new fonts-open-sans

libreoffice (1:5.3.3-0ubuntu1) artful; urgency=medium

   [ Olivier Tilloy ]
   * New upstream release: 5.3.3
   * debian/tests/patches/java-subsequentcheck-standalone.diff: refreshed
   * debian/control.in: move fonts-open-sans from recommends to suggests,
     as it is in universe
 
   [ Rene Engelhard ]
   * debian/patches/help-msg-add-package-info.diff,
     debian/patches/mention-java-common-package.diff,
     debian/patches/mediawiki-oor-replace.diff,
     debian/patches/series: actually update the patches and re-enable...
 
   * debian/control.in:
     - recommend new fonts-open-sans

libreoffice (1:5.3.2-1) experimental; urgency=medium

   * New upstream release
 
   * debian/patches/help-msg-add-package-info.diff,
     debian/patches/mention-java-common-package.diff,
     debian/patches/mediawiki-oor-replace.diff:
     debian/patches/series: actually update the patches and re-enable...
 
   * debian/rules:
     - move /usr/include/libreoffice/sal/typesizes.h symlink to -dev
       instead of -dev-common (closes: #858199)
   * debian/control.in:
     - add missing -java-common Depends: to -script-provider-{bsh,js}
   * debian/control.mediawiki.in:
     - add missing JRE depends
   (thanks to Daniel Richard G. for those two, see #858655)
   * debian/control.in:
    - make libreoffice meta-package only recommend libreoffice-java-common
      (closes: #858655)

libreoffice (1:5.3.1-1) experimental; urgency=medium

   * New upstream release
 
   * debian/rules, debian/libreoffice-dev-doc.links, debian/lo*.in:
     install SDK documentation into /usr/share/doc/libreoffice/sdk (and adapt
     dev-docs symlinks/doc-base stuff). Remove extra license file (thanks
     lintian) which otherwise would still install over the symlink.
   * debian/control.sdk.in: update -devs libreoffice-dev-doc Conflicts to
     (<< 1:5.2.5-2~) and add Conflicts: libreoffice (<< 1:5.2.5-2~) to both
     -dev*- for safety
   * debian/rules:
     - enable mergelibs only on 64bit archs (and i386), ld goes to OOM on
       mips(el) for example...
     - allow build with gold (maybe for LTO?)
     - ignore "libreoffice" for --link-doc
     - fix dh_installdocs calls to install copyright for "libreoffice"
     - symlink /usr/share/libreoffice/program/classes/unoil.jar to
       /usr/share/java/unoil.jar to "dedup" it
     - run rdfind to get duplicated /usr/share/icons/gnome symlinked to
       hicolor if identical (closes: #835515); add rdlink/symlinks B-D-I
     - fix generating lo-idl-ref doc-base file
   * debian/control.in, debian/rules, debian/scripts/cleandupes: remove unused
     fdupes B-D-I and commented-out usage
   * debian/rules, debian/control.in: recommend -sdbc-firebird only where it's
     built (LE) to prepare for it being a dependency when firebird will be the
     default embedded engine

libreoffice (1:5.3.1-0ubuntu3) UNRELEASED; urgency=medium

   * l10n: Use versioned Provides for -help as done for -l10n

libreoffice (1:5.3.1-0ubuntu2) zesty; urgency=medium

   [ Bjoern Michaelsen ]
   * cherry-picking fixes from Debian
   * l10n: depend >= instead of = from -lang to -common:
     - should still be enough to prevent premature promotion
     - but should allow skipping superfluous compatible -l10n rebuilds
 
   [ Rene Engelhard ]
   * debian/rules:
     - move /usr/include/libreoffice/sal/typesizes.h symlink to -dev
       instead of -dev-common (closes: #858199)

libreoffice (1:5.3.1-0ubuntu1) zesty; urgency=medium

   * new upstream release
   * dont modify generated files in SCM, also dont store generated files in SCM,
     do "readd ant" in source file instead of the generated one (which will get
     overwritten)
   * version lock -l10ns to -common to prevent premature promotion

libreoffice (1:5.3.0-1) experimental; urgency=medium

   * New upstream release
 
   * debian/rules:
     - add support for building with clang
     - move from hardcoded C(XX)FLAGS for -g -> -g1 to recommended
       DEB_C(XX)FLAGS_MAINT_*
   * debian/missing-sources:
     - add source of jquery 3.1.1 (from libjs-jquery package) for
       helpcontent2/source/jquery-3.1.1.min.js

libreoffice (1:5.3.0~rc3-0ubuntu2) zesty; urgency=medium

   * (re-)add ant and ant-optional dependency for autopkgtests
   * Dont have Recommends: on firebird when building w/o firebird

libreoffice (1:5.3.0~rc3-0ubuntu1) zesty; urgency=medium

   * remove spurious suggests from -common to -human
   * add (empty) -human transitional, remove -breeze dupe Suggest

libreoffice (1:5.3.0~rc3-0ubuntu1~zesty1) zesty; urgency=medium

   * new upstream rc

libreoffice (1:5.3.0~rc2-2ubuntu1~zesty4) zesty; urgency=medium

   * go full gtk3
   * remove remaining BUILD_DBG_PACKAGE parts
   * remove some more debhelper hackery which seems to mess up launchpad

libreoffice (1:5.3.0~rc2-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/patches/change-from-glew-to-epoxy.diff: update
   * debian/patches/m68k-use-mlong-jump-table-offsets.diff: add;
     as name says
 
   * debian/rules:
     - build-depend on gcc-7/g++-7 (>= 7-20170106) for m68k for
       -mlong-jump-table-offsets

libreoffice (1:5.3.0~rc1-2ubuntu1~zesty2) zesty; urgency=medium

   * allow root builds on lp

libreoffice (1:5.3.0~rc1-2ubuntu1~zesty1) zesty; urgency=medium

   * merge from Debian

2016

libreoffice (1:5.3.0~rc1-2) experimental; urgency=medium

   * debian/rules:
     - readd somehow lost libgl1-mesa-dev build-dependency...

libreoffice (1:5.3.0~rc1-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/patches/change-from-glew-to-epoxy.diff: backport from master;
     as name says
   * debian/patches/gtk3-opengl-slideshow.diff: backport from master to fix
     ogltrans generically with gtk3
   * debian/patches/disable-flaky-tests.diff: also disable svx.AccessibleShape
 
   * debian/control.ogltrans.in:
     - add Conflicts: libreoffice-gtk3 (<< 1:5.2.4~rc2)
 
   * debian/rules:
     - change glew conditionals/build-deps to epoxy
     - ENABLE_GDRIVE=y again on armhf and arm64

libreoffice (1:5.3.0~beta2-1) experimental; urgency=medium

   * New upstream beta release
 
   * debian/patches/m68k-alignment.diff: add patch from John Paul Adrian
     Glaubitz to fix m68k alignment
 
   * debian/libreoffice-sdbc-firebird.NEWS: add NEWS entry about the format
     incompatibility
   * debian/rules: revert ENABLE_GDRIVE=y on arm* as chromium got uploaded
     without it to sid and it's gone from experimental again on those

libreoffice (1:5.3.0~beta1-1) experimental; urgency=medium

   * New upstream beta release
 
   * try using just the used tarballs to avoid confusion and to shrink the
     .orig (they are downloaded anyway and not in the .orig)
     - remove unneeded tarballs from tarballs
     - include needed tarballs in include-binaries
     - update debian/copyright (remove many, add forgotten swingEx
       fix src -> tarballs; actually add MPL-2.0/ASF blurb)
     - update README.Debian-source
 
   * debian/patches/fix-system-lpsolve-build.diff: rename to ..
   * build-against-shared-lpsolve.diff: ... this to make the purpose more clear
   * debian/patches/fix-system-lpsolve-build.diff: add new one adding
     -llpsolve55_pic test/linkage (disabled)
   * debian/patches/no-openssl.diff: don't uselessly check for openssl and
     don't require openssl in postgresql-sdbc-impl, not (directly) used
 
   * debian/scripts/get_libvlc_dep.sh: fix to work again (also) with
     new multiarchified libvlc5
 
   * debian/rules:
     - don't install ChangeLog (now done automatically by dh compat >= 7) as
       it doubles -common/-core size and increases font-opensymbol *by 10*
     - ENABLE_GDRIVE=y also on armhf and arm64 as we've chromium there now, too
     - enable mysql-connector again now that libmysqlcppconn _and_
       mysql-workbench are built against mariadb.
       Bump Build-Dependency on libmysqlcppconn to >= 1.1.7-4 to go sure
       we're getting a >= 1.1.7 dependency
       Fix adding the libmysqlcppconn-dev Build-Dep in the default case
   * debian/control.in:
     - add Breaks: browser-plugin-libreoffice to libreoffice-core
       (closes: #843980)
   * debian/control.firebird.in: fix substvar: s/server/engine/
   * debian/libreoffice-common.maintscript: remove apparently unneeded quotes
     which now breaks at dpkg-maintscript-helper call... (closes: #844683)

libreoffice (1:5.3.0~alpha1-1) experimental; urgency=medium

   * New upstream alpha release
     - fixes typo in VCL.xcu; s/Tino/Tinos/ (closes: #834580)
     - fixes (experimental) Gtk print dialog crash (closes: #839701)
     - fixes copy paste cells between two tables of two documents with Gtk3
       (closes: #834622)
     - fixes tooltips when dragging/filling cells with Gtk3 (closes: #831977)
 
   * debian/control.{lang,help}.in: use ${help-l10n-virtual-version} as
     versioned Provides
   * debian/rules, debian/control.transitionals.in: remove jessie->stretch
     transitionals again
   * debian/rules, control.gcj.in: cleanup:
     - remove support for gcj (and thus building -gcj "native") completely;
       removed upstream; and also openjdk-9 apparently will drop support for
       source/target 1.5 (which gcj only supports) and gcc-7 apparently even
       will drop gcj, too
       (also the officeotron/odfvalidator stuff fails because due to the java-gcj
       in the path for safety reasons it picks up gcj..)
     - use java6_architectures for computing OOO_JAVA_ARCHS
   * debian/copyright: add schema/*/* to Files-Excluded: :/
   * debian/uno-libs3.symbols: update
   * debian/rules:
     - bump dh compat to 10
     - re-enable firebird (closes: #841253)

libreoffice (1:5.2.4~rc2-0ubuntu1~yakkety2) yakkety; urgency=medium

   * remove seek-1.wmf test doc, bad_alloc on i386 (in rules as it would be a
     binary diff)

libreoffice (1:5.2.4~rc2-0ubuntu1~yakkety1) yakkety; urgency=medium

   * new upstream rc
   * remove patches/gtk3-toolbar-styleclass.diff assuming it fixed by
     1439b3499ced0f1131af8e0de107e96d8aac4039 upstream
   * remove patches/lp-1527053.diff assume obsoleted by
     83dc2227f35795aee4e2ccaccbb7d67d4c50ba3f upstream

libreoffice (1:5.2.3~rc2-0ubuntu1~yakkety1) yakkety; urgency=medium

   * new upstream rc

libreoffice (1:5.2.2-0ubuntu3) yakkety; urgency=medium

   * use preferable upstream patch (LP: #1527053)

libreoffice (1:5.2.2-0ubuntu2) yakkety; urgency=medium

   * make notebook tab text readable w/ libreoffice-gtk3 (LP: #1527053)

libreoffice (1:5.2.2-0ubuntu1) yakkety; urgency=medium

   * new upstream release
   * fix gcj version (thanks Rico)

libreoffice (1:5.2.1~rc2-0ubuntu1) yakkety; urgency=medium

   * new upstream rc
   * disable cups for autopkgtests too
   * make libreoffice-gnome depend on -gtk3 by default
   * update gtk3 toolbar theming patch and re-enable it (LP: #1580537)
   * update gdrive auth details
   * kill packagekit var as did upstream and trigger on gio instead (as does upstream)
   * update C/R for liblosessioninstallerlo.so move

libreoffice (1:5.2.0-0ubuntu2) yakkety; urgency=medium

   * rules: remove spurious comment (thanks Rico)
   * scripts/joinctrl.py: explicitly use python3
   * disable cups when running tests

libreoffice (1:5.2.0-0ubuntu1) yakkety; urgency=medium

   * add transitional for -gtk -> gtk2
   * disable mergedlibs on BSD, thanks Joe Boden (LP: #1598492)
   * cherry-picked from Debian:
     - debian/patches/make-package-modules-not-suck.diff: move animcore into
       DRAW (closes: #833181)

libreoffice (1:5.2.3~rc1-3) unstable; urgency=medium

   * debian/patches/fix-system-lpsolve-build.diff: fix -L in configure.ac so
     that it actually checks (against) the shared lib

libreoffice (1:5.2.3~rc1-2) unstable; urgency=medium

   * debian/rules:
     - disable mysql connector given mysql-* will be removed for stretch and
       mysql-connector-c++ should probably stay mysql for mysql-workbench
     - if enabling mysql connector, use default (mariadb) as flavour and internal
       mysqlcppconn

libreoffice (1:5.2.3~rc1-1) unstable; urgency=medium

   * New upstream release candidate
 
   * debian/patches/startcenter-grey-out-not-installed.diff: backport from
     master, as name says (closes: #813430)
 
   * debian/rules:
     - add /usr/include/libreoffice/sal/typesizes.h symlink to multiarch
       include dir to fix SDK usage e.g in the SDK examples
     - disable firebird (as sid now got firebird-dev 3.0), and (internal)
       firebird2.5 doesn't build. But we probably should not switch to 3.0
       here (yet) before 5.3...
     - install LOKDocView-0.1.typelib into multiarch dir as recommended by
       the GI mini policy

libreoffice (1:5.2.2~rc2-2) unstable; urgency=medium

   * work around libcoinutils-dev pulling in -lbz2 without depending on it
     by Build-Depending on it here (temporarily)

libreoffice (1:5.2.2~rc2-1) unstable; urgency=medium

   * New upstream release candidate
 
   * debian/patches/gtk3-lot-of-style-updated-signals.diff: apply follow-up
     patch to don't throw away font settings every time (closes: #836531)

libreoffice (1:5.2.1-3) unstable; urgency=medium

   * debian/patches/gtk3-use-style-updated-signal.diff: backport from master;
     use style-updated instead of style-set signal. This closes: #837356.
   * debian/patches/xfce-fallback-list.diff: remove again, didn't help
 
   * debian/control.in: _really_ remove font depends from libreoffice, really
     closes: #836416
   * debian/rules: adapt SYSTEM_GCJ_VERSION detected for gcj-6 (>= 6.2.0-4)...

libreoffice (1:5.2.1-2) unstable; urgency=medium

   * debian/rules: install typesizes.h into
     usr/include/$(DEB_HOST_MULTIARCH)/libreoffice/sal/typesizes.h
   * debian/control.in:
     - remove libreoffice-report-builder-bin [kfreebsd-i386 kfreebsd-amd64]
       Conflicts: from -core, thanks Jon Boden (closes: #836887)
     - rework libreoffice metapackage "dependencies":
       + Recommend everything (except GNOME/KDE integration and similar) which
         the upstream .tar.gz contains:
          libreoffice-script-provider-bsh,
          libreoffice-script-provider-js,
          libreoffice-script-provider-python,
          libreoffice-ogltrans,
          libreoffice-librelogo,
          libreoffice-nlpsolver,
          libreoffice-pdfimport,
          libreoffice-report-builder,
          libreoffice-wiki-publisher
          libreoffice-sdbc-postgresql
       + make libreoffice only Recommend the fonts. Mention it recommends
         extra stuff like fonts to resemble a upstream install, thanks
         Fabian Greffrath (closes: #836416)
     - remove obsolete libreoffice-gtk conflicts which makes -core Break: it
       with bin-NMUs; add (intended) -gtk2/-gtk3 ones...
 
   * merge from Ubuntu:
     - uno-libs: Create the libuno_* symlinks in the multiarch libdir

libreoffice (1:5.2.1-1) unstable; urgency=medium

   * LibreOffice 5.2.1 final (identical to rc2)
 
   * debian/patches/xfce-fallback-list.diff: remove gtk3 from fallback list
     for xfce (closes: #836531)
 
   * upload to unstable
 
   * debian/bug-presubj: mention https://wiki.debian.org/AutomaticDebugPackages
   * debian/control.in: make the libreoffice meta-package depend also on
      fonts-crosextra-caladea, fonts-crosextra-carlito and fonts-linuxlibertine
   * debian/README.Debian-source: update (closes: #836186)

libreoffice (1:5.2.1~rc2-1) experimental; urgency=medium

   * new upstream release candidate
 
   * debian/rules:
     - oops, install libqstart_gtklo.so into /program, not /share

libreoffice (1:5.2.1~rc1-1) experimental; urgency=medium

   * new upstream release candidate
     - drop use of CAIRO_OPERATOR_DIFFERENCE, should fix performance
       regressions (closes: #832495)
 
   * debian/rules, debian/control.transitionals.in: readd -gtk as transitional
     package; depend on -gtk2 (closes: #833676) and -systray
   * debian/rules: re-enable systray (closes: #825642) now that we need
     NEW anyway and have a -gtk transitional package (which contained this
     before it was disabled)
   * debian/control.gtk2.in: stop providing libreoffice-gtk
   * debian/rules:
     - filter-out kfreebsd-i386 and kfreebsd-amd64 explicitly out of
       OOO_CHECK_ARCHS to save unneeded build-deps (again)
     - rework MySQL/MariaDB conditionals; allow default-libmysqlclient-dev
   * debian/libreoffice-gtk.maintscript: readd dir_to_symlink maintscript
   * debian/control.mysql.in: use default-mysql-server | virtual-mysql-server
     as MySQL Suggests

libreoffice (1:5.2.0-2) unstable; urgency=medium

   * debian/patches/make-package-modules-not-suck.diff: move animcore into
     DRAW (closes: #833181)
 
   * debian/control.nlpsolver.in: fix override disparity , use old values
     (math/extra)
   * debian/rules, debian/shlibs.override.libcmis: bump libcmis dependency
     to (>= 0.5.1+git20160603) to assure the advertised google 2-factor-auth
     stuff is present
   * debian/control.in:
     - update libroffice-gtk mentioning in libreoffice's
       description to say gtk(2|3) (closes: #833694) - thanks Vincent Levebre
     - remove mention of Quickstarter from libreoffice and libreoffice-gtk2
       descriptions; gone there since some time
     - add Replaces:/Breaks: for libanimcorelo.so move
   * debian/control.systray.in, debian/rules: install the systray stuff into a
     new -systray package (if enabled)
   * debian/control.lang.in: suggest libreoffice-hyphenation-fi at -l10n-fi
     (provided by libreoffice-voikko)
   * debian/rules:
     - clean up test disabling, disable on sparc64. Add missing <!nocheck>
       for junit4

libreoffice (1:5.2.0-1) unstable; urgency=medium

   * LibreOffice 5.2.0 final (identical to rc4)
 
   * debian/patches/curl-7.50.0.diff: add from master; fix build with
     curl 7.50.0
 
   * upload to unstable

libreoffice (1:5.2.0~rc4-1) experimental; urgency=medium

   * new upstream release candidate
 
   * debian/patches/jre-update-gt-99.diff: backport from libreoffice-5-2;
     allow java update version number > 99

libreoffice (1:5.2.0~rc3-1) experimental; urgency=medium

   * new upstream release candidate
 
   * debian/rules:
     - use (more) dh_* -a instead of deprecated -s
 
   * debian/rules, debian/scripts/joinctrl.py: use $(PYTHON) (so python3),
     "python" isn't pulled in (implicitely) anymore; update build-deps

libreoffice (1:5.2.0~rc2-1) experimental; urgency=medium

   * new upstream release candidate
 
   * debian/rules:
     - use dh_listpackages -a instead of deprecated -s

libreoffice (1:5.2.0~rc1-1) experimental; urgency=medium

   * new upstream release candidate
     - scales gtk3 smooth scaling events... (closes: #826654)
 
   * debian/patches/sparc64.diff: add sparc64 port, thanks James Clarke
 
   * debian/vars.sparc64: add
   * debian/rules: add sparc64 support again
 
   * debian/control.in:
     - move ttf-liberation-fonts recommends to -common (closes: #747132)
     - move libpaper-utils recommends to -core
 
   * debian/control.nlpsolver.in, debian/rules, debian/scripts/gid2pkgdirs.sh:
     package the NLPSolver from here (closes: #827474)

libreoffice (1:5.2.0~beta2-1) experimental; urgency=medium

   * New upstream beta release
     - only initalizes the OpenGL context if we need it (closes: #819153)

libreoffice (1:5.2.0~beta1-1) experimental; urgency=medium

   * New upstream beta release
     - fixes SVG t(ext s)pan import (closes: #665094)
     - fixes Impress slowing down with -gtk(3) and accessibility
        (closes: #824035)
     - fixes "LibreOffice RTF Stylesheet Code Execution Vulnerability"
       (TALOS-CAN-0126 / CVE-2016-4324)
 
   * debian/rules, debian/control.gtk3.in, debian/*.links: move
     liblibreofficekitgtk.so into an own package, as we have
     libreofficekit-{dev,data} anyway. Make liblibreofficekitgtk depend on
     libreofficekit-data
   * debian/rules, debian/control.in, debian/libreoffice-gtk.*: rename -gtk
     to -gtk2
   * debian/control.sdk.in, debian/rules: move arch-indep SDK stuff into new
     -dev-common. Move g++-mingw-w64-i686 to BUILD_DEPS_INDEP and only try to
     (re)build unowinreg.dll in build-indep. Remove arch-qualifiers.
   * debian/uno-libs3.symbols: update
   * debian/tests/control.in, debian/tests/sdk-examples: remove unowinreg.dll
     special-casing, we now have unowinreg.dll in a Arch: all. Depend on that.
 
   * debian/rules:
     - add initial build profile support: nodoc and nocheck
     - move GTK3_MINVER setting down in rules so the conditional gets honoured;
       gtk3 3.20 is available anywhere in stretch/sid so revert bump to >= 3.20
     - migrate from --ddeb-migration to --dbgsym-migration
 
   * debian/libreoffice-calc.lintian-overrides: (temporerily) readd
     libreoffice-calc: binary-or-shlib-defines-rpath override

libreoffice (1:5.1.3-0ubuntu4) yakkety; urgency=medium

   * use internal copy of mdds and orcus on yakkety for 5.1 series now

libreoffice (1:5.1.3-0ubuntu3) yakkety; urgency=medium

   * Fix libpng build dependency.

libreoffice (1:5.1.3-0ubuntu1) xenial; urgency=medium

   * new upstream bugfix release
   * fix crash with nullptr SdrObjList (LP: #1569500)
   * fix crash with ScCsvGrid living beyond VCL shutdown (LP: #1566050)
   * fix crash with non-empty BlendFrameCache in late VCL shutdown (LP: #1560328)

libreoffice (1:5.1.2-0ubuntu1) xenial; urgency=medium

   * new upstream bugfix release
   * remove xmloff patch again for better upstream fix

libreoffice (1:5.1.1-0ubuntu3) xenial; urgency=medium

   * Fix build failure in xmloff.

libreoffice (1:5.1.1-0ubuntu2) xenial; urgency=medium

   * libreoffice-subsequentcheckbase: Depend on default-jdk.

libreoffice (1:5.1.1-0ubuntu1) xenial; urgency=medium

   * upstream released an rc3 = final
   * allow libreoffice-style-elementary as alternative for -breeze in libreoffice-gtk (LP: #1483914)
   * fix File>Templates>Manage executes wrong action in unity (LP: #1559135)

libreoffice (1:5.1.1~rc2-0ubuntu1) xenial; urgency=medium

   * new upstream rc
   * update patches, remove upstreamed ones
   * reenable unity-default-breeze, which wasnt reenabled on 5.1 yet (LP: #1506544)
   * update Ubuntu palette, add main colors to standard palette (LP: #753627)

libreoffice (1:5.1.0-0ubuntu1) xenial; urgency=medium

   * finalize version, rc3 = 5.1.0
   * depend on libreoffice-sdbc-hsqldb from libreoffice-subsequentcheckbase for
     autopkgtests
   * add libreoffice-style-elementary from upstream (LP: #1483914)
   * continue building libreoffice-gtk3, but dont default-deploy (yet)
   * use system ucpp instead of bundling (LP: #1524638)
   * add google drive bits (LP: #1389936)
   * update indic fonts package names (LP: #958345)

libreoffice (1:5.1.0~rc3-0ubuntu2) xenial; urgency=medium

   * update autopkgtest runner patch, removing unhelpful build system deps for
     out-of-tree integration testing

libreoffice (1:5.1.0~rc3-0ubuntu1) xenial; urgency=medium

   * bump to rc3
   * backport fix for ppc64el ftbfs

libreoffice (1:5.1.0~rc2-0ubuntu2) xenial; urgency=medium

   * use system mwaw, libwp*, lpsolve

libreoffice (1:5.1.0~rc2-0ubuntu1) xenial; urgency=medium

   * bump to rc2 and enable l10n

libreoffice (1:5.1.3-1) unstable; urgency=medium

   * LibreOffice 5.1.3 final (identical to rc2)
 
   * debian/patches/kde4-cflags-no-usr-include.diff: don't set $kde_incdir
     to /usr/include since -isystem /usr/include makes the stuff FTBFS
     with gcc 6 (closes: #823145)
   * debian/patches/mdds-1.2.0.diff: backport patch to build with mdds 1.2
     from master
 
   * debian/*.lintian-overrides: remove obsolete
     binary-or-shlib-defines-rpath and no-debconf-config overrides
 
   * debian/rules:
     - bump libmdds-dev and liborcus-dev build-deps and update orcus handling
     - fix another warning for !gcj builds: only try to set GCJ_JAWT_DIR if
       GCJ_JAWT_DEPENDS is set

libreoffice (1:5.1.3~rc2-3) unstable; urgency=medium

   * debian/rules:
     - sigh. revert control changes for now, needs more work, apparently..

libreoffice (1:5.1.3~rc2-2) unstable; urgency=medium

   [ Mattia Rizzolo ]
   * debian/control.in: use nowdays canonical URIs in Vcs-*
 
   [ Rene Engelhard ]
   * debian/rules:
     - remove explicit $(MAKE) -f debian/rules control

libreoffice (1:5.1.3~rc2-1) unstable; urgency=medium

   * New upstream release candidate
 
   * debian/rules:
     - print error in control without gcj-jdk installed
     - don't try to run set GCJ_JAWT_DEPENDS if GCJ_VERSION is unset
     - disable the tests on kfreebsd-* (see #801865),
     - move hardcoded (!)kfreebsd-i386 (!)kfreebsd-amd64 to (!)kfreebsd-any.
       Use linux-any instead of just disabling it for kfreebsd for
       libbbluetooth-dev B-D; reflects the sense better

libreoffice (1:5.1.3~rc1-1) unstable; urgency=medium

   * New upstream release candidate
 
   * debian/patcches/GCC-6-PR69273-workaround.diff: remove; AFAICS gcc is
     fixed
 
   * debian/rules:
     - (temporarily) bump libgtk-3-dev build-dep to >= 3.20~ to ensure
       we build against 3.20

libreoffice (1:5.1.2-4) unstable; urgency=medium

   * debian/patches/fix-list-and-comboboxes-with-gtk3-3-20-2.diff:
     backport from libreoffice-5-1 branch, as name says

libreoffice (1:5.1.2-3) unstable; urgency=medium

   * debian/patches/don-t-install-qstart.desktop-if-it-s-disabled.diff:
     as name says (closes: #820657)
   * debian/libreoffice-gtk3.maintscript: bump version to also fix
     stretch updates

libreoffice (1:5.1.2-2) unstable; urgency=medium

   * debian/rules:
     - add boost-filesystem build-dependency...

libreoffice (1:5.1.2-1) unstable; urgency=medium

   * New upstream release
 
   * debian/patches/OPENCL_DLL_NAME.diff: backport from master, use .so.1,
     not .so
   * debian/patches/no-packagekit-per-default: disable losessioninstaller
     per default and make it conditional on --enable-packagekit.
   * debian/patches/setsdkenv-tripplet.diff: fix setsdkenv_unix.sh to work
     with *-linux-gnu* (as on e.g. armhf)
   * debian/patches/sdkname-lo.diff: fix OO_SDK_NAME;
     s/openoffice.org/libreoffice/
   * debian/patches/liborcus-0.11.diff: add from master; use liborcus 0.11
 
   * debian/control*in: add loads of ${misc:Pre-Depends} to packages having
     .maintscripts calling dir_to_symlink to get proper dpkg Pre-Dependency.
     Needed e.g. to fix wheezy+wheezy-backports -> jessie+jessie-backports
     upgrades.
   * debian/control[,.subsequentcheckbase}.in: remove hardcoded Java depends,
     use ${java:Depends}
   * debian/control.in: make -sdbc-hsqldb also depend on ${java-runtime-depends}
   * debian/libreoffice-{core,sdbc-firebird}.bug-script.in: fix; LO still uses
     /4 in the profile
   * debian/ure.bug-script.in: add, run javaldx
   * debian/libreoffice-report-builder.bug-script.in: remove, no extension
     anymore since long
   * debian/libreoffice-mysql-connector.bug-script.in: fix PLATFORMID
     substitution to actually work
   * debian/rules:
     - add conditional to choose mdds version and build with
       mdds 1.0/liborcus 0.11
     - move liblosessioninstallerlo.so into -gnome when enabled; better suited
       there
     - speed up check target: run $(MAKE) check in parallel and only if failing
       the second run without parallelism
     - remove artificial disabling of glTF for armel and mips(el). Probably
       still don't make sense but enable it for consistency (and because we
       enable other stuff there which don't make sense that much either)
     - disable the systray quickstarter (closes: #819878)
   * debian/tests/*: add "sdk-examples" test test-building some SDK examples
     to test the SDK itself
   * debian/control.in: remove recommend on xfonts-mathml (closes: #749979)
   * debian/control.sdk.in: fix Descriptions
   * debian/shlibs.override.orcus: 10 -> 11
   * debian/libreoffice-gtk3.maintscript.in: (re-)add dir_to_symlink also for
     libreoffice-gtk3 (closes: #820320)

libreoffice (1:5.1.2~rc1-1) unstable; urgency=medium

   * New upstream release candidate
     - -sdbc-postgresql: use proper schema name for type names
       (closes: #808125)
     - uses rtl::math::isNan() instead of isnan() (closes: #818829)
 
   * debian/rules:
     - decouple BUILD_TEST_PACKAGE and BUILD_DDEBS/BUILD_DBG_PACKAGE,
       as the tests con't depend on -dbg/-dbgsym anymore (and it fixes
       -dbg building for jessie-backports). Fix some order: add a if and
       remove --no-ddeb on jessie (not existing) to make -dbg package building
       actually work again
     - use internal libwps for jessie-backports
     - don't hardcode python3-six in -dbgsyms Recommends
   * debian/bug-presubj: point to TDF-bugzilla and LOs BT/strace instructions;
     minor wording fixes
   * debian/lo-{cpp,java}-ref.in, debian/rules, debian/libreoffice-dev-doc.links:
     fixups for new doc path since last upload...
   * debian/watch: add pgpversionmangle
   * debian/libreoffice-gtk3.links: add /usr/lib/liblibreofficekitgtk.so
     symlink (closes: #818433)

libreoffice (1:5.1.1-1) unstable; urgency=medium

   * LibreOffice 5.1.1 final (identical to rc3)
 
   * debian/patches/disable-flaky-tests.diff: (temporarily?) disable
     testFlipAndRotateCustomShape per upstreams advice (closes: #815292)
 
   * debian/rules:
     - unset DISPLAY before running make check; some test(s) might fail
       otherwise
   * debian/rules, debian/test/*:
     - stop adding -dbgsym to the test Depends:,
       ci.debian.net doesn't have the debug archive in sources.list -> fail
     - clean up: don't add %BUILD_DEPS_ARCH_ALL% to -subsequentcheckbases
       Depends: as it doesn't really need it; the tests do, add in in
       tests/control. Only depend on junit, ure, java-common in
       -subsequentcheckbase. Add libreoffice{,-sdbc-hsqldb} dependencies in
       tests/control.in
     - run with verbose=t as the "normal" build
 
   * merge from Ubuntu:
     - update autopkgtest runner patch, removing unhelpful build system deps for
       out-of-tree integration testing
     - depend on libreoffice-sdbc-hsqldb for autopkgtests
     - (re)add build version for "About LibreOffice"

libreoffice (1:5.1.1~rc3-1) unstable; urgency=medium

   * New upstream release candidate
 
   * debian/rules:
     - somewhen m68k vanished from OOO_ARCHS; readd ;)
     - actually we can use Chromiums Google API keys, so set
       --with-gdrive-client-{id,secret} properly (closes: #780253).
       Don't copy them but use chromiums ones directly, which makes this
       i386/amd64 only, but...
     - move install location of the SDK docs to
       /usr/share/doc/libreoffice-dev/sdk/docs as the old locations are
       "burned". Also sdk/docs matches the upstream structure anyway.
       (closes: #804317)
   * debian/scripts/get_libebook_dep.sh: fix to work with new multiarchified
     libebook
   * debian/control.sdk.in: remove broken and obsolete -dtd-officedocument1.0
     Suggests

libreoffice (1:5.1.1~rc1-1) unstable; urgency=medium

   * New upstream release candidate
     - fixes scrolling direction with trackpad in gtk3 (closes: #809363)
     - fixes distorted images in PDF export (closes: #813586)
 
   * upload to unstable
 
   * debian/patches/bash-completion-dir.diff: add from master;
     install bash completion to "new" /usr/share/bash-completion/completions
   * debian/patches/kfreebsd-openjdk8-JAVAINC.diff: add
     -I$JAVA_HOME/include/linux to JAVAINC for kFreeBSD to find jni_md.h
 
   * debian/rules:
     - remove sparc64 again, we're actually not ported
   * debian/libreoffice-common.maintscript:
     rm_conffile /etc/bash_completion.d/libreoffice.sh
   * debian/scripts/gid2pkgdirs.sh: adapt for bash_completion move and install
     without .sh
   * debian/libreoffice-common.{pre,post}{rm,inst}.in: remove long obsolete
     (3.4, OOo->LO) maintainer script snippets

libreoffice (1:5.1.0~rc3-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/patches/gcc-6.diff: backport gcc 6 compile/test fixes from master
     (closes: #811686)
   * debian/patches/GCC-6-PR69273-workaround.diff: add gcc 6 ICE workaround
     from Stephan Bergmann
 
   * debian/rules:
     - -officebean is a arch-dep package, move pom generation and mh_*
       calls for it to install-arch...
     - adapt for changed debhelper internals to make out -dbgsym hacks work
       again and build-depend on debhelper >= 9.20160115
     - update/clean up up JAVA_RUNTIME_DEPENDS: move gcj-jre after all the
       openjdks and add openjdk-8-jre

libreoffice (1:5.1.0~rc2-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/patches/disable-db-tests.diff,
     debian/patches/smoketest-disable-extension-tests.diff: make apply again...
 
   * debian/rules:
     - fix/update some ddeb conditionals and migrate -dbg to -dbgsym
     - "supplement" the -dbgsym packages also with the gdb helpers and
       the appropriate recommends (gdb, python3-six)
   * debian/tests/control{,in}, debian/rules: generate autopkgtest control
     with proper depends (-dbg or *-dbgsym) in rules' control target
   * debian/tests/control: depend on ure-dbg and uno-libs3-dbg, too
   * debian/tests/junit-subsequentcheck.diff: run
     ./debian/rules config_host.mk enable_report_builder=no to disable the SRB
     of which we don't have the (build-)deps in -subsequentcheckbases deps.
   * debian/control.debug.in: recommend gdb
   * debian/control.debug.in, debian/rules: move python(3)-six to recommends
     and recommend python3-six on sid as "gdb" uses python3.
   * debian/rules:
     - build-depend on libpng-dev instead of libpng12-dev (closes: #662411)

2015

libreoffice (1:5.1.0~rc1-1) experimental; urgency=medium

   * New upstream release candidate
     - doesn't link evoab2 to gtk2 anymore (closes: #807640)
     - fixes "LibreOffice Writer Lotus Word Pro TabRack Buffer Overflow
       Vulnerability"
     - fixes "LibreOffice Writer Lotus Word Pro 'ReadRootData' Buffer Overflow
       Vulnerability"
     - fixes "LibreOffice Writer Lotus Word Pro Bullet Buffer Overflow
       Vulnerability"
       (CVE-2016-0794)
     - fixes "LibreOffice Writer Lotus Word Pro 'TocSuperLayout' Buffer Overflow
       Vulnerability"
       (CVE-2016-0794)
 
   * debian/patches/disable-npapi-plugin-support.diff: as name says,
     the only serious usecase is the doomed Flash anyway and it's
     causes a link against gtk2 in -core (closes: #807601)

libreoffice (1:5.1.0~beta1-0ubuntu1) xenial; urgency=medium

   * new upstream prerelease

libreoffice (1:5.1.0~beta2-1) experimental; urgency=medium

   * New upstream beta release
     - fixes crash when selecting the border style in some window managers
       (closes: #801504)
 
   * debian/patches/disable-flaky-tests.diff:
     - disable also libreofficekit_tiledrendering as it SIGSEGVs after OK
       (but lloconv works) with merged libs
     - remove checkBookmarks disabling, should work now according to
       upstream
   * debian/patches/poms.diff: add "official" upstream poms
 
   * debian/rules:
     - fix up .desktop (closes: #804669), remove (D|d)ev and version from
       Icon= and Exec=
     - re-enable checks
     - add sparc64 to OOO_ARCHS
     - re-enable avahi
     - install the AppData files now that they are installed upstream and
       uptodate (closes: #734524)
 
   * debian/scripts/get_ttf_version.pl, debian/rules: drop fontforge B-D-I;
     use pure perl for determining the version; taken from upstreams win
     installer
 
   * debian/ure.poms, debian/rules: also install ures unoloader.jar into maven
   * debian/libreoffice-officebean.poms, debian/rules: also install
     officebean.jar into maven
   * debian/*.pom.in, debian/rules: remove own poms and create final poms
     with version from upstreams one

libreoffice (1:5.1.0~alpha1-4ubuntu4) xenial; urgency=medium

   * add all build deps for report builder

libreoffice (1:5.1.0~alpha1-4ubuntu3) xenial; urgency=medium

   * revert move of liblpsolve when --with-system-lpsolve, is already done
     upstream

libreoffice (1:5.1.0~alpha1-4) experimental; urgency=medium

   * debian/rules:
     - work around the experimental buildds' resolver bug installing
       experimental packages per default where they shouldn't and add
       firebird-dev (>= 3.0) Build-Conflicts:

libreoffice (1:5.1.0~alpha1-3) experimental; urgency=medium

   * debian/control{.sdk}.in, debian/rules, debian/libreoffice-dev-doc.links:
     - stop moving the SDK docs into libreoffice-devs /usr/share/doc (and move
       the stuff installed into /usr/share/doc/libreoffice/sdk in libreoffice-dev
       to /usr/share/doc/libreoffice-dev, too) and conflict against
       libreoffice-dev / libreoffice-dev-doc (<= 1:5.0.3~rc1-2) where needed
       (closes: #803272, #803306)
   * debian/control.ure.in:
     - also break libreoffice-common in ure in addition to Replaces:
       (closes: #801552, #803565) and make it << 1:4.5.0 which was meant...

libreoffice (1:5.1.0~alpha1-2) experimental; urgency=medium

   * debian/patches/fix-xmlparse-with-icu55.diff: backport fix from
     master fixing l10ntools' XML parsing with ICU 55
   * debian/patches/icu-56.diff: prepare for ICU 56; fix FTBFS with new
     charmaps; backported from master
 
   * debian/rules:
     - recommend -gtk3 again in gnome as (even in Alpha1)
       Save As.. works (at least for me...) - closes: #681180
     - remove l10ntools build hack again, now obsolete

libreoffice (1:5.1.0~alpha1-1) experimental; urgency=medium

   * New upstream alpha release
     - uses HttpURLConnection etc. of the JDK instead of commons httpclient
       in the Wiki Publisher (closes: #800992)
 
   * debian/patches/series, debian/patches/disable-tiledrendering-test.diff:
     remove again, we need the functionality for liblibreofficekitgtk.so
 
   * debian/rules, debian/vars.mips64*:
     - add mips64{el,} architecture stuff which is now added upstream
   * debian/uno-libs3.symbols: update
   * debian/control.lokit.in:
     - suggest libgtk-3-dev instead of libgtk2.0-dev
     - suggest gir-1.2-lokdocview-0.1
   * debian/control*in, debian/rules:
     - remove upstream gone kdeab and gnome-vfs, gconf options
   * debian/control*.in, debian/rules:
     - package the LOKDocView introspection stuff into gir1.2-lokdocview-0.1
     - move liblibreofficekitgtk.so into -gtk3 as it's for Gtk3 now
   * debian/rules:
     - gtk3 is on per default now (closes: #799399). Keep -gnome depending on
       -gtk as gtk3 crashes e.g. on "Save as..."
     - disable the tests for now
     - also disable the wiki publisher on gcj builds; uses Java 6+ stuff; make
       -wiki-publisher depend on >= Java 6
   * debian/rules: prepare for .ddebs: disable manual -dbg build if building
     ddebs; use dh_strip --ddeb-migration to create .ddebs
   * debian/libreoffice-core.bug-script.in: dpkg -l -gtk -gtk3 and -kde to list
     installed VCLplugs
 
   * merge from Ubuntu:
     - add am and gug locales

libreoffice (1:5.0.2-0ubuntu8) xenial; urgency=medium

   * uno-libs: Create the libuno_* symlinks in the multiarch libdir.

libreoffice (1:5.0.2-0ubuntu7) xenial; urgency=high

   * Rebuild against libpoppler57/s390x.

libreoffice (1:5.0.2-0ubuntu6) xenial; urgency=medium

   * No-change rebuild for new poppler

libreoffice (1:5.0.2-0ubuntu5) xenial; urgency=medium

   * No-change rebuild against libglew1.13.

libreoffice (1:5.0.2-0ubuntu4) xenial; urgency=medium

   * disable collada, gltf and coinmp on xenial
   * switch to breeze theme by default (lp: #1506544)

libreoffice (1:5.0.2-0ubuntu3) wily; urgency=medium

   * fall back to SYSTEM_GCC_VERSION, when SYSTEM_GCJ_VERSION is empty
   * substitute xfonts-mathml with fonts-stix (lp: #1487148)
   * cherry-pick from Debian:
     - readd conflicts against openoffice-unbundled to libreoffice-common.
       openoffice*-debian-menus contains /usr/bin/soffice
   * fix gug language description (thanks Rene)
   * add build version for "About LibreOffice"
   * create profile defaulting to human style on unity (lp: #1508177)
   * reenable Ubuntu palette
   * handle integral translations

libreoffice (1:5.0.2-0ubuntu2) xenial; urgency=medium

   * No-change rebuild for python3 defaults change.

libreoffice (1:5.0.2-0ubuntu1) wily; urgency=medium

   * new upstream release
   * removed upstreamed patches
   * cherry-picks from Debian:
     - update shlibs.override
     - bump gtk+ requirements
     - move liblibreofficekitgtk.so to -gtk

libreoffice (1:5.0.1-0ubuntu2) wily; urgency=medium

   * Build for arm64 and ppc64el.
   * Build using system libraries for libcppunit, libetonyek, liborcus,
     libpagemaker, libwps and libcmis.  The internal copies are not updated
     for at least ppc64el.

libreoffice (1:5.0.1-0ubuntu1) wily; urgency=medium

   * new final upstream release
   * changes vs. vivid:
     - use cpp-5 (thanks Rico)
     - use internal libwps, opencollada, collada2gltf, libcmis, cppunit

libreoffice (1:5.0.0-0ubuntu1~wily1) wily; urgency=medium

   * LibreOffice 5.0.0 final release (identical to rc5)
   * merge from Debian:
     - debian/patches/disable-tiledrendering-test.diff: temporarily disable test
     - rulees: bump build-depends on libgltf, collada, cppunit, liborcus, libcmis to
       build-depend on their gcc 5 rebuilds. Bump boost build-dep to >= 1.58
       (closes: #794717)
     - rules:fix SYSTEM_GCC_CHECK for gcc 5; remove obsolete >= 4.7 check for Qt to get
       correct build-dep
     - temporarily disable -evolution until libebook1.2-dev is installable again
     - debian/control.in: suggest breeze-icon-theme in -style-breeze (like the
       other ones do for oxygen/tango)
   * reduce diff to Debian: use Enhances in styles consistently
   * depend from leaf themes like -style-sifr on -style-galaxy for now

libreoffice (1:5.0.3~rc1-2) unstable; urgency=medium

   * debian/*.maintscript: add loads of dir_to_symlink calls to packages
     moving dir->symlink due to dh_installdocs --link-doc (closes: #801753)
   * debian/control.in:
     - make -gnome only recommend -gtk. it doesn't need -gtks libs

libreoffice (1:5.0.3~rc1-1) unstable; urgency=medium

   * New upstream release candidate
 
   * debian/rules:
     - use dh_installdocs --link-doc=libreoffice-{core,common}
     - update dh_shlibdeps calls for URE in /usr/lib/libreoffice/program and
       remove obsolete OOUREDIR
     - build-depend on default-jdk (>= 2:1.7-52.1) for OpenJDK 7 on kfreebsd-*
       again
   * debian/rules, debian/control.in:
     - readd conflicts against openoffice-unbundled to libreoffice-common.
       openoffice*-debian-menus contains /usr/bin/soffice
   * debian/control.in:
     - update -style-* dependencies based on the recommendation in
       https://lists.debian.org/debian-openoffice/2015/09/msg00343.html ff.
       + add various dependencies on fallback to the various -style-*
       + suggest -breeze instead of -crystal in common, crystal is disabled
       + depend on -style-default in libreoffice-core
   * debian/rules, debian/patches/fix-internal-hsqldb-build.diff: use servlet3.1
     and actually build-depend on it (again) if using internal hsqldb
   * debian/control.subsequentcheckbase.in:
     - remove hardcoded dependency openjdk-7-jdk; we get default-jdk in anyway

libreoffice (1:5.0.2-1) unstable; urgency=medium

   * New upstream release
     - fixes crash on gestureLongPress (closes: #798591)
 
   * debian/*.menu: remove, as per TC resolution
   * debian/control.in:
     - remove imagemagick from B-D-I:
     - mention liblibreofficekitgtk.so in -gtks description
     - various lintian fixes
       + add ${misc:Depends}, remove duplicated Priority:
       + make fonts-opensymbol Multi-Arch: foreign
       + don't add unneeded XS-Python3-Version:
   * debian/rules:
     - stop calling dh_installmenus and stop using convert to convert the icons
       to xpm
     - move liblibreofficekitgtk.so into -gtk
     - lintian fixes:
       + don't add XS-Testsuite; it defaults to autopkgtest anyway
         if idebian/tests/control exists
       + move dh_fixperms after gdb helper install to fix permissions of the
         gdb stuff
     - re-enable coinmp; build-dependencies now installable again; bump
       build-dependencies to the gcc 5 versions
   * debian/control.{,gtk3.in}, debian/rules: move disabled -gtk3 into extra
     file so tha it doesn't appear in control when disabled, makes dak think
     it's NEW.

libreoffice (1:5.0.1-2) unstable; urgency=medium

   * debian/patches/series, debian/patches/disable-mediaembedding-test.diff:
     remove, GTK3 is now disabled
 
   * debian/rules:
     - disable gtk3 for now again, too shaky
       (closes: #799251, #799049, #795131)
   * debian/control.in, debian/rules:
     - make -gnome depend on -gtk when gtk3 is disabled
       (reopens: #681180)
   * debian/control.in:
     - add Chris Halls <halls@debian.org> back to Uploaders:

libreoffice (1:5.0.1-1) unstable; urgency=medium

   * LibreOffice 5.0.1 final (identical to rc2)
 
   * debian/patches/mysqlcppconn-libmysqlclient-SONAME.diff: update; fix internal
     mysqlcppconn build
   * debian/patches/kde4-rtl.diff: KDE4: fix RTL scrollbar handling, from
     libreoffice-5-0
   * debian/patches/795131.diff: backport fix for crashes with clipboard managers
     in gtk3 backend from master (closes: #795131)
 
   * debian/rules:
     - two more s/src/tarballs/ I forgot
     - add explicit --without-system-libxml for a eventual internal-libxml2 case
     - add hack to build the just build-time-used l10ntools (and especially
       helpex)
       with internal icu,boost,expat so that we get working localized help...
     - use internal libgltf also for jessie-backports as otherwiese avmedia
       doesn't build with the needed internal glm
 
   * merge from Ubuntu:
     - move --with-help and $(CONFIGURE_FLAGS_LANG) into $(CONFIGURE_FLAGS_INDEP)
       and use it in build-indep

libreoffice (1:5.0.1~rc2-1) unstable; urgency=medium

   * New upstream release candidate
     - fixes 'LibreOffice Bookmark Status Memory Corruption Vulnerability'
       (CVE-2015-5214)
 
   * debian/patches/gtk3-rtl.diff: backport GTK3 RTL fixes (arrows, checkboxes,
     spin buttons) from libreoffice-5-0 and master
 
   * debian/rules:
     - bump libmysqlcppconn-dev and libclucene-dev build-deps to their
       gcc 5 versions
     - add explicit dh-python build-dependency
     - temporarily disable coinmp
     - fix autogen.sh for autopkgtests by exporting the needed env vars there,
       too
     - set TARFILE_LOCATION to tarballs instead of external/tarballs and keep
       external/ in the "main" orig wo we can just use it unchanged and keep
       the upstream signature
 
   * debian/tests/control, debian/tests/pyuno-import: add trivial import uno;
     test for python3-uno
 
   * merge from Ubuntu:
     - autopkgtest updates/fixes
     - add ENABLE_LTO conditional, off
     - get-orig-source fixes

libreoffice (1:5.0.1~rc1-2) unstable; urgency=medium

   * debian/patches/series: (re-)enable disable-tiledrendering-test.diff;
     still fails...

libreoffice (1:5.0.1~rc1-1) unstable; urgency=medium

   * New upstream release candidate
 
   * upload to unstable
 
   * debian/rules:
     - bump build-depends on libgltf, collada, cppunit, liborcus, libcmis to
       build-depend on their gcc 5 rebuilds. Bump boost build-dep to >= 1.58
       (closes: #794717)
     - rules:fix SYSTEM_GCC_CHECK for gcc 5; remove obsolete >= 4.7 check for Qt to get
       correct build-dep
     - temporarily disable -evolution until libebook1.2-dev is installable again
     - debian/control.in: suggest breeze-icon-theme in -style-breeze (like the
       other ones do for oxygen/tango)
   * debian/control.in: suggest breeze-icon-theme in -style-breeze (like the
     other ones do for oxygen/tango)

libreoffice (1:5.0.0~rc5-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/rules:
     - ENABLE_MERGELIBS=n on kfreebsd-* for now ("Argument list too long")
     - ENABLE_COLLADA=y (for i386/amd64) now that the libs finally are in
       Debian
     - KDE_ICONSET_DEP=libreoffice-style-breeze (closes: #794318)
   * debian/control.in:
      - update -l10n conflicts in -common, remove 3.5/3.6, add 4.3/4.4
        (closes: #794024)

libreoffice (1:5.0.0~rc4-1) experimental; urgency=medium

   * New upstream release candidate
     - fixes 'LibreOffice "PrinterSetup Length" Integer Underflow Vulnerability'
       (CVE-2015-5212)
     - fixes 'LibreOffice "Piece Table Counter" Invalid Check Design Error
       Vulnerability' (CVE-2015-5213)
 
   * debian/rules:
    - ENABLE_MERGELIBS=y as it's now upstream default

libreoffice (1:5.0.0~rc3-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/rules:
     - re-enable CVE tests on all platforms again now that the infinite loop with
       unsigned char-default is supposedly fixed

libreoffice (1:5.0.0~rc2-1) experimental; urgency=medium

   * New upstream release candidate
     - fixes "Arbritary file disclosure vulnerability" (CVE-2015-4551)
 
   * debian/control.in:
     - s/cliipart/clipart/ (closes: #787660 again)
   * debian/rules:
     - move libunoidllo.so from ure into uno-libs3, too, as
       libcppuhelpergcc3.so.3 is (now) linked to it
 
   * debian/rules:
     - move gnome-open-url (back) to -gnome

libreoffice (1:5.0.0~rc1-1) experimental; urgency=medium

   * New upstream release candidate
     - fixes "Can't use a hash as a reference" deprecation warning/error in
       lo-xlate-lang (closes: #788613)
 
   * debian/patches/liborcus.diff: backport build fixes for using liborcus
     0.9.1 from master
 
   * debian/rules:
     - readd lost move of sal.py/cppu.py and libuno*.so.3-gdb.py
       into uno-libs3-dbg (closes: #788848)
     - build-depend on liborcus >= 0.9.0
 
   * debian/control.in:
     - make -gnome depend on -gtk3 now that it's enabled upstream if desktop
       is gnome3 (closes: #681180)

libreoffice (1:5.0.0~beta3-1) experimental; urgency=medium

   * New upstream beta release
 
   * debian/patches/rsc-no-error-about-unknown-switch.diff: don't error out
     CPPFLAGS (e.g. -Wdate-time) to not FTBFS with the patched reproducible
     builds toolchain
 
   * debian/rules:
     - remove left-over dh_installxmlcatalogs call...
     - temporarily disable junit tests
 
   * debian/control{,.in}:
     - suggest openclipart2-libreoffice | openclipart-libreoffice
       (closes: #787660)
 
   * debian/copyright:
     - remove long gone dmake (closes: #788311)

libreoffice (1:5.0.0~beta1-1) experimental; urgency=medium

   * New upstream beta release
 
   * debian/control{,.lokit.in}, debian/rules, debian/libreofficekit-dev.*:
     initial LibreOfficeKit packaging
   * debian/control{,.in}, debian/rules, debian/*xmlcatalogs.in: drop packaging
     openoffice.org-dtd-officedocument1.0; we've kept this DTD for a obsolete
     format for too long already
 
   * debian/rules:
     - add conditional for system-collada2gltf
     - oops, also add old openoffice(.org) changelogs to fonts-opensymbol, it
       already existed in OOO 3.2.1 times (squeeze)
     - enable l10n again

libreoffice (1:5.0.0~alpha1-1) experimental; urgency=medium

   * new upstream snapshot
 
   * debian/rules:
     - adapt for ure folded into /usr/lib/libreoffice/program directly
     - build only en-US for now
   * debian/uno-libs3.symbols: update
   * debian/control.in, debian/rules: disable crystal icons (KDE3); enable
     breeze (KDE 5)

libreoffice (1:4.4.4~rc3-0ubuntu2) wily; urgency=medium

   * No-change rebuild, follow-up for the libstdc++6 ABI transition.

libreoffice (1:4.4.4~rc3-0ubuntu1) wily; urgency=medium

   * new upstream rc, includes hack to prevent crash on exit (LP: #1418551)
   * Fix mailmerge without libreoffice-base scenario

libreoffice (1:4.4.3~rc2-0ubuntu1~vivid5) vivid; urgency=medium

   * Fix mailmerge without libreoffice-base scenario

libreoffice (1:4.4.3~rc2-0ubuntu1~vivid3) vivid; urgency=medium

   * add upstream hack to prevent crash on exit (LP: #1418551)

libreoffice (1:4.4.3~rc2-0ubuntu1~vivid1) vivid; urgency=medium

   * new upstream rc

libreoffice (1:4.4.2-1) unstable; urgency=low

   * LibreOffice 4.4.2 final release (identical to rc2)
 
   * upload to unstable
 
   * debian/patches/icu-icudata-link-fix-armhf.diff: fix internal icu build
     on armhf ("stolen" from icu package)

libreoffice (1:4.4.2-0ubuntu3) wily; urgency=medium

    * Cherry-pick from Debian for wps 0.4
    * debian/patches/libwps-0.4.diff: backport from upstream; adapt for libwps
      0.4
    * debian/rules:
      - build-depend on libwps >= 0.4

libreoffice (1:4.4.2~rc2-1) experimental; urgency=medium

   * New upstream release candidate
     - fixes "out of bounds write in hwp file filter" (CVE-2015-1774)

libreoffice (1:4.4.2-0ubuntu2) vivid; urgency=medium

   * add missing Replaces: (LP: #1443667)

libreoffice (1:4.4.2-0ubuntu1) vivid; urgency=medium

   * new upstream release
   * Drop Recommends on obsolete ttf-punjabi-fonts package in favor of
     fonts-guru (thanks Steve Langasek)

libreoffice (1:4.4.1-0ubuntu2) vivid; urgency=medium

   [ Bjoern Michaelsen ]
   * merge from Debian:
     - debian/control.ogltrans.in: capitalize "impress" in description
       (closes: #779479)
     - debian/rules: fix logic to not install sound files (closes: #780497)
   * remove obsolete patches
   * update Ubuntu palette
 
   [ Jonathan Riddell ]
   * Add kubuntu_breeze-icons.diff and breeze.tar.xz with breeze icons
     for Plasma 5 taken from LibreOffice master (LP: #1435764)

libreoffice (1:4.4.1-0ubuntu1) vivid; urgency=medium

   * new upstream release, fixes printing bug (LP: #1419521)
   * adapt/kill ure-link for upstream changes (LP: #1419836)

libreoffice (1:4.4.0-1ubuntu1) vivid; urgency=medium

   * merge from Debian
   * use system mwaw, now that 0.3.4-1 is synced to main (LP: #1410883)
   * reenable MERGELIBS
   * reenable complex tests
   * use cpp-4.9 for urd preprocessing

libreoffice (1:4.4.1~rc2-1) experimental; urgency=medium

   * New upstream release candidate
 
   * merge from Ubuntu:
     - adapt/kill ure-link for upstream changes (LP: #1419836)
   * debian/patches/gcj-no-bitness-check.diff: fix gcj builds, --version
     doesn't return bitness so it fails on any gcj/64bit platform

libreoffice (1:4.4.1~rc1-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/patches/hppa-is-32bit.diff: as name says; don't assume hppa is
     64bit, as it isn't in Debian (closes: #776357)
   * debian/rules:
     - suggest gstreamer1.0-libav instead of gstreamer1.0-ffmpeg
       (closes: #776593)

libreoffice (1:4.4.0~rc3-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/rules:
     - move /var/spool/libreoffice into -core, not -common (closes: #775150)

libreoffice (1:4.4.0~rc2-0ubuntu3) vivid; urgency=medium

   * update autopkgtest patching

libreoffice (1:4.4.0~rc2-0ubuntu2) vivid; urgency=medium

   * temporary remove arm64 and ppc64el for first 4.4 upload

libreoffice (1:4.4.0~rc2-0ubuntu1) vivid; urgency=medium

   * new upstream rc
   * disable some broken tests
   * MIR and use system libabw, libe-book, libeot (LP: #1410966)
   * MIR and use system freehand, libodfgen (LP: #1410883)

libreoffice (1:4.4.0~rc2-1) experimental; urgency=medium

   * New upstream release candidate
 
   * debian/rules:
     - use internal libmwaw and libcmis for jessie-backports

2014

libreoffice (1:4.4.0~rc1-1) experimental; urgency=medium

   * New upstream release candidate

libreoffice (1:4.4.0~beta2-1) experimental; urgency=medium

   * New upstream beta release

libreoffice (1:4.4.0~beta1-2) experimental; urgency=medium

   * debian/patches/aarch64-bridges-add-missing-include-osl-mutex.hxx.diff: as
     name says
   * debian/patches/powerpc64-bridges-assert-static_assert-to-fix-build.diff: as
     name says

libreoffice (1:4.4.0~beta1-1) experimental; urgency=medium

   * new upstream beta release
     - fixes postgresql-sdbc-impl install (closes: #769156)
 
   * debian/rules:
     - remove --disable-opengl as it's gone upstream; keep OGLTrans.so in
       -ogltrans

libreoffice (1:4.4.0~alpha2-1) experimental; urgency=medium

   * new upstream alpha release
 
   * debian/rules:
     - add conditional/includes/libs for system-opencollada
     - use libmariadb-client-lgpl-dev instead of libmariadbclient-dev
       when USE_MARIADB=y
     - bump build-dependency on icu to >= 52 (see
       https://bugs.freedesktop.org/show_bug.cgi?id=82229#c38)
   * debian/shlibs.override.icu:
     - update to actual cuurent SOVERSION...
   * debian/rules, debian/shlibs.local.libc: revert libc 2.19 hack

libreoffice (1:4.4.0~alpha1-3) experimental; urgency=low

   * debian/patches/oox-fix-bigendian-build.diff: one more fix from master

libreoffice (1:4.4.0~alpha1-2) experimental; urgency=low

   * debian/patches/oox-fix-bigendian-build.diff: as name says
   * debian/patches/LibreOfficeKitInit-kfreebsd.diff: fix LibreOfficeKitInit.h
     on kFreeBSD

libreoffice (1:4.4.0~alpha1-1) experimental; urgency=low

   * new upstream alpha release
 
   * debian/rules, debian/patches/wheezy-backports-python.diff,
     debian/patches/series: remove wheezy-backports support (making loads
     of stuff easier/safer) and add (unused yet) jessie-backports support
   * debian/rules, debian/control.in: remove python2/python-uno support
   * debian/rules, debian/control.transitionals.in: remove wheezy->jessie
     transitional packages
   * debian/rules, debian/control.mozilla.in, patches/install-fixes.diff,
     debian/scripts/gid2pkgdirs.sh: remove nsplugin stuff; removed
     upstream...
 
   * debian/rules:
     - install tango_testing (if built, RELEASE_BUILD=n) into -tango
     - add new coinor-libcoinutils-dev build-dependency
     - bump boost build-dep to >= 1.55, build-depend on libpagemaker-dev
     - remove deprecated "default" from IMAGES

libreoffice (1:4.3.4~rc1-0ubuntu1) utopic; urgency=medium

   [ Bjoern Michaelsen ]
   * new upstream rc (and this one might be fasttracked and released from rc1)
 
   [ Dariusz Gadomski ]
   * Fix startcenter desktop file (LP: #1386170)

libreoffice (1:4.3.3-0ubuntu1) utopic; urgency=medium

   * new upstream release

libreoffice (1:4.3.2-0ubuntu1) utopic; urgency=medium

   * new upstream release
   * keep mergedlibs disabled (LP: #1373928)
   * adding build-essential to subsequentcheckbase should fix autopkgtest issues
   * we are at LTS+1, so clear the transitionals

libreoffice (1:4.3.1~rc2-0ubuntu1) utopic; urgency=medium

   * new upstream rc
   * no more special handling for default/galaxy

libreoffice (1:4.3.0-3ubuntu2) utopic; urgency=medium

   * MIR: Caladea and Carlito from Writer for metric compatibilty (LP: #1276252)
   * fix libreoffice-base postrm syntax
   * move db drivers back from -base to -base-drivers, even when not building firebird

libreoffice (1:4.3.0-3ubuntu1) utopic; urgency=low

   * merge from Debian 4.3.0-3 (LP: #1354557)

libreoffice (1:4.3.0-3) unstable; urgency=low

   * new upstream snapshot
     - disables sdremote per default (closes: #749770)
 
   * debian/rules:
     - enable coinmp, evoab2 and vlc also on arm64 now, now available
   * debian/shlibs.override.libc, debian/rules:
     - go sure and make the package depend on libc6/libc6.1/libc0.1 >= 2.19,
       see https://bugs.freedesktop.org/show_bug.cgi?id=82229

libreoffice (1:4.3.2-2) unstable; urgency=medium

   * debian/patches/sdk-use-sh-to-call-config-guess.diff: as name says;
     backported from master to cope with non-+x-config.guess after
     debian/patches/config-sub-guess-update.diff
 
   * debian/rules:
     - libnss3-1d-dbg -> libnss3-dbg in DBG_DBG_SUGGESTS
     - enable coinmp (except on arm64 where it's BD-Uninstallable right now)

libreoffice (1:4.3.2-1) unstable; urgency=medium

   * LibreOffice 4.3.2 final release (identical to rc2)
 
   * upload to unstable
 
   * debian/rules:
     - remove arm64 internal vigra workaround again; now built
     - remove obsolete libxml-parser-perl build-dep
     - fix technical.dic install for kmr-Latn and debian-presentation.otp
       install for kmr-Latn and ca-valencia so they end up in the correct
       package and don't survive clean
     - enable -kde on arm64; kde-runtime is now available
 
   * merge from Ubuntu:
     - adding build-essential to subsequentcheckbase should fix autopkgtest
       issues

libreoffice (1:4.3.2~rc2-1) experimental; urgency=low

   * new upstream release candidate
     - fixes crashes with e.g. "(1)(2)(3)aa" and brainfuck code
       (closes: #761226)
 
   * debian/rules:
     - bump libgltf build-dep to >= 0.0.1
   * debian/control*in, debian/rules:
     - improve kde,vlc,evo2 disabling on arm64, remove actually also
       from Architecture: of those packages

libreoffice (1:4.3.1-2) unstable; urgency=medium

   * debian/patches/ppc64el.diff: backport ppc64el port from upstream
     libreoffice-4-3 branch
   * debian/patches/config-sub-guess-update.diff, debian/patches/aarch64.diff:
     backport aarch64/arm64 port from Fedora/upstream master
   * debian/patches/ttranslation-merge-fix: add translation fix from upstream
     master fixing lower case greek letters in math and uppercase "enumeration"
     letters
 
   * debian/rules, debian/vars.ppc64el: add ppc64el support and enable
   * debian/rules, debian/vars.arm64: add arm64 support and enable
   * debian/rules:
     - help arm64 by working around (yet) BD-Uninstallable packages:
       - disabling kde, vlc and evolution
       - using internal vigra
     - fix duplicate BOOST_MINVER setting causing a too lax build-dep
       (>= 1.49.0-4 instead of >= 1.53) for gcc >= 4.8...
     - fix system-npapi-headers setting, npapi is also needed for the
       browser-plugins-inside-LO non-feature.

libreoffice (1:4.3.1-1) unstable; urgency=low

   * new upstream release
 
   * debian/patches/system-libgltf.diff: add patch to implement
     --with-system-libgltf
   * debian/patches/handle-collada-seperately.diff: as name says,
     from upstream master
 
   * debian/rules:
     - add conditional for system-libgltf and add ENABLE/DISABLE_COLLADA
     - enable gltf
   * debian/python-uno.NEWS: retroactively add a entry about python-unos
     removal in jessie+1 for 1:4.0.0-1

libreoffice (1:4.3.0-3) unstable; urgency=medium

   * debian/libreoffice-base.postrm.in: missing \ and broken if check...
   * debian/rules:
     - USE_UCPP=y (closes: #748004)
     - cleanup some OpenGL-related (build-)depends/compile options:
       + unconditionally build-depend on libgl1-mesa-dev, libgl1-mesa-dev -
         there is now more than OGLTrans needing it (and libglew-dev pulls it
         in anyway)
       + add OOO_GLTF_ARCHS as for OOO_OGLTRANS_ARCHS
     - stop trying to split libavmediaogl.so into -avmedia-backend-opengl.
       The (maybe) also used COLLADA libs get (statically) linked into
       libavmedialo.so (core) anyway and the file types for "Insert 3D Model"
       are handled in libsd (draw) anyway...
   * debian/control.ogltrans.in: clarify a bit: s/transitions/slide &/
 
   * merge from Ubuntu:
     - suggest Caladea and Carlito from Writer for metric compatibility
     - move ${java-common-depends} and ${java-runtime-depends} from Recommends
       to Suggests for -writer
     - move db drivers back from -base to -base-drivers, even when not building
       firebird

libreoffice (1:4.3.0-2) unstable; urgency=low

   * upload to unstable
 
   * debian/patches/system-coinmp.diff: add patch to implement
     --with-system-coinmp
 
   * debian/rules:
     - disable firebird on BE-archs as per upstream advice. Experimental
       feature anyway - and fails the dbacccess_firebird_test test
     - add conditional for system-coinmp, don't enable yet
   * debian/libreoffice-sdbc-firebird.bug-script.in: add, as for -gtk3

libreoffice (1:4.3.0-1) experimental; urgency=low

   * LibreOffice 4.3.0 release
 
   * debian/libreoffice-base.postrm.in: fix again..

libreoffice (1:4.3.0~rc3-2) experimental; urgency=low

   * Brown paper bag release
 
   * debian/patches/handle-symlinks-to-icon-themes-correctly.diff: as name says;
     from upstream
 
   * debian/rules:
     - fix typo so export DISABLE_CVE_TESTS=TRUE is actually set
     - add symlinks for images*.zip again
     - s/iceweasel-dev/npapi-sdk-dev/. Re-enable system-npapi-headers
     - ENABLE_AVAHI=n (closes: #749770, #755309)
   * debian/libreoffice-base.preinst.in: fix version check (closes: #755290)
   * debian/libreoffice-base.postrm.in: add more checks for the
     Access2Base diversions; add forgotten recommended abort-upgrade step
     from policy manual

libreoffice (1:4.3.0~rc3-1) experimental; urgency=low

   * new upstream release candidate
     - packages galaxy icon as the icon scanner expects
 
   * debian/rules, debian/control.in: revert images.zip Depends: workaround,
     symlink still seems to be broken somehow, keep that
   * debian/rules: remove unused (and buggy?) manual --with-images= when not
     building kde and/or gtk. Obsolete as upstream builds with all images
     per default anyway. Sync IMAGES with upstream configure.ac (split galaxy
     and default)
   * debian/rules: move new images_galaxy.zip into -galaxy
   * debian/rules: export DISABLE_CVE_TESTS=TRUE on arm*,powerpc*/ppc*,s390*
     to work around CppunitTest_filter_psd_test hang. Results are ignored
     anyway, and if it was a real issue it would fail on i386/amd64, too
     most probably
   * debian/control.ure.in: add Breaks: libreoffice-core (<< 1:4.3.0~) to
     uno-libs3 (closes: #754535)

libreoffice (1:4.3.0-0ubuntu1) utopic; urgency=medium

   * disable mergelibs for now for (lp: #1333073)
   *  use system cdr wpd wpg wps visio mspub revenge glew glm as they are now
      available
   * cherry-pick from Debian commit d4e4101a (thanks Rene):
     - debian/libreoffice-base.preinst.in: fix version check
     - debian/libreoffice-base.postrm.in: add more checks for the
       Access2Base diversions; add forgotten recommended abort-upgrade step
       from policy manual
   * tweak l10n major version (thanks Rico)

libreoffice (1:4.3.0~rc2-1) experimental; urgency=low

   * new upstream release candidate
 
   * debian/rules:
     - update webdav conditionals to specify --with-webdav=
   * debian/vars.alpha: re-add.. (closes: #752284)
   * debian/*.bug-script.in: remove
     {pdfimport,presentation-minimizer,presenter-console} bug-scripts
     as they are not extensions since long
   * debian/rules:
     - stop adding vars.$(DEB_HOST_ARCH) content into the maintscripts; unused
     - don't uselessly rebuild sdext - it's not a extension anymore and thus in
       "proper" langpacks
   * debian/control.debug.in: suggest python-six (used by the gdb helpers)
   * debian/scripts/gid2pkgdirs.sh:
     install gid_Module_Filters (oox-drawingml-{adj-names,cs-presets})
   * debian/control.in, debian/rules: specify -b in Vcs-Git:
   * debian/control.in, debian/rules:
     - stop moving images*zip to /usr/share and creating symlinks. hardlinks
       would work but cross-directory hardlinks are frowned upon...
     - WORKAROUND: make -common depend on all styles as otherwise right now
       the icon selection breaks badly
     (closes: #752531)

libreoffice (1:4.3.0~rc1-1) experimental; urgency=low

   * new upstream release candidate
 
   * debian/rules:
     - use internal np_sdk because the "NPAPI plugins inside LO" part doesn't
       build (uses a internal/external header mix even with
       --with-system-npapi-headers) with iceweasel 30.0...
     - actually add -Npython-uno if ENABLE_PYTHON2=n
     - install pyuno.rdb for python-uno...
     - rework python-uno build.
       Don't build py2uno.so etc but build pyuno.so etc. from the start (as on
       wheezy-backports where it works as python-only is the "default" build...)
       also for the python2 build...
     - remove liborbit2-dev build-dep, not needed since some time
   * debian/control.in: fix override disparity, add Priority: extra for python-uno

libreoffice (1:4.3.0~beta2-2) experimental; urgency=low

   * debian/rules:
     - re-enable system-libwpd?, -libcdr, -libmspub, -libvisio, -libodfgen

libreoffice (1:4.3.0~beta2-1) experimental; urgency=low

   * new upstream beta release
     - fixes recalculation of cells when deleting a row/column (closes: #749847)
     - fixes pyuno.so install in scp2 in system-python case (closes: #749998)
 
   * external/tarballs: fix orcus and zlib again
 
   * debian/patches/fix-system-glm.diff: backport patch to fix system-glm build
     from master
   * debian/patches/make-package-modules-not-suck.diff: fix Repository.mk
     to install libvclplug_kde* (and kdefilepicker for KDE3) into -kde
     (closes: #749751)
   * debian/patches/fix-mysqlc-remote-connections.diff: as name says; from
     upstream master (closes: #749592) and (hopefully) also closes:  #745101
   * debian/patches/javadoc-optional.diff: disable odk_javadoc tests when JAVADOC
     is empty
 
   * debian/rules:
     - remove | belocs-locales-data alternative from some -l10n-*, removed in
       2009
     - enable system-glm
     - use internal boost on wheezy-backports, libcmis' internal (not
       "standard",though) fails with wheezys boost
     - actually specify --without-doxygen if PACKAGE_SDK_DOCS=n, as on
       wheezy-backports
     - fix python dependencies: run dh_python(2|3) as described in the manpage as
       "Private libraries" to find the stuff in /usr/lib/libreoffice/program and
       consider it for the dependencies (thus tighten it). Build-depend on
       dh-python for wheezy-backports
       Remove (now) unneeded manual hack
     - cleanup python build-deps: PYTHON_FOR_BUILD is python3 in "standard"
       builds, so build-depend on that (and on python only when we build python2)
     - fix install targets for debuild -A:
       + move gengal and librpt* move to install-common
       + remove -wiki-publishers LICENSE in install-indep
     - micro-optimization: use --without-javadoc for build-arch and
       PACKAGE_SDK_DOCS=n
     - temporarily disable system-libwpd?, -libcdr, -libmspub, -libvisio,
       -libodfgen as the needed versions are only in NEW yet...
   * debian/control.*.in:
     - add Replaces: libreoffice-core (= 1:4.3.0~beta1-1) for above file move
       fixes
   * debian/shlibs.override.lib{wps,odfgen,mwaw}: fix dh_shlibdeps with those
     libs internal as they are .so.X's (add empty shlibs entry)

libreoffice (1:4.3.0~beta2-0ubuntu1) utopic; urgency=medium

   * merge from debian
   * ignore libreoffice-ogltrans deps for internal libGLEW for now
   * forward port to utopic
   * disable all tests for now: works in local pbuilder, but apparently not in
     the PPA one
   * update and bring back lp-1296715.diff, which is not yet upstreamed
   * bump to upstrean beta2

libreoffice (1:4.3.0~beta1-1) experimental; urgency=low

   * new upstream beta release
     - fixes unconditional execution of VBA macros (CVE-2014-0247)
 
   * debian/patches/odk-no-dot.diff: HAVE_DOT=NO in Doxyfiles to prevent loads
     of error: " Problems running dot: exit code=127, command='dot'"
   * debian/patches/disable-ftp-nohost-test.diff: remove, seems to work now
 
   * debian/rules:
     - move /usr/lib/libreoffice/share/basic/Access2Base from -common to -base,
       as it clearly is Base-specific
   * debian/control.in:
     - add Replaces: for the Access2Base move
   * debian/libreoffice-base.{preinst,postrm}.in: dpkg-divert dialog.xlc
     and script.xlc... FIXME: Better, scalable solution..
   * debian/control.help.in:
     - make -help-* depend on -style-default (closes: #748434)

libreoffice (1:4.2.4-3) unstable; urgency=low

   * debian/patches/i18npool-icu53.diff: add patches to work with ICU 53
   * debian/patches/javadoc-generated-dynamic-package.diff: backport fro
     master: don't use hardcoded filelist for SDK Javadocs (fixes build with
     OpenJDK8) (closes: #748046)
   * debian/patches/doxygen-1.8.7.diff: backport from upstream master, fix for
     build with doxygen 1.8.7 (explicitly specify HTML output...)
 
   * debian/rules:
     - add a rm -f $(PKGDIR)-core/$(OODIR)/program/librpt* if
       ENABLE_REPORTDESIGN=n. Looks hacky and probably is but this
       (closes: #748075)
     - enable the junit4 tests only on amd64/i386. slows down other builds and
       might hang (results ignored on !i386/amd64 anyways.)
   * debian/control.in:
      - make -core conflict against -report-builder-bin for
        kfreebsd-i386 kfreebsd-amd64

libreoffice (1:4.2.4-2) unstable; urgency=low

   * debian/patches/series: re-enable gcj-safe-jni-h-include.diff, now for sid
     it doesn't find jni.h (worked on falla. sigh.)
 
   * debian/rules:
     - actually add kfreebsd-* as GCJ_JDK_ARCHS again
     - use gcc 4.9 on GCJ_JDK_ARCHS
     - re-add ENABLE_TEST_PACKAGE=y
     - use new fonts-* packages for indic fonts where not already done
       (closes: #747692)

libreoffice (1:4.2.4-1) unstable; urgency=low

   * LibreOffice 4.2.4 release (identical to rc2)
 
   * upload to unstable
 
   * debian/patches/fix-wizards.diff: fix fax, letter etc. wizards. backported
     from libreoffice-4-2 branch...
   * debian/patches/series: disable gcj-safe-jni-h-include.diff as it adds a
     -I/usr/lib/gcc/$(DEB_HOST_ARCH)/4.9/include and that doesn't work at least
     on kfreebsd-* with the current gcc 4.8 + gcc libs 4.9 + gcj 4.9 combo

libreoffice (1:4.2.4-0ubuntu4) utopic; urgency=medium

   * Build with internal libwpd & friends, to decouple from the ongoing
     transitions.

libreoffice (1:4.2.4-0ubuntu3) utopic; urgency=medium

   * No-change rebuild of the trusty-security upload for utopic.

libreoffice (1:4.2.4-0ubuntu2) trusty; urgency=medium

   * bump upstream version
   * refresh patch queue
   * remove upstreamed patches:
     - fdo-74981.diff
     - fdo-50672.diff
   * bump help virtual version to 4.2
   * fix unity menu after insert formula (LP: #1296715)
   * avoid use of invalidated pointers (LP: #1219245)
   * add VBA macro patch
   * use internal npapi as this breaks with Firefox 30

libreoffice (1:4.2.4-0ubuntu1) trusty; urgency=medium

   * bump upstream version
   * refresh patch queue
   * remove upstreamed patches:
     - fdo-74981.diff
     - fdo-50672.diff
   * bump help virtual version to 4.2
   * fix unity menu after insert formula (LP: #1296715)
   * avoid use of invalidated pointers (LP: #1219245)
   * add VBA macro patch

libreoffice (1:4.2.3~rc3-0ubuntu2) trusty; urgency=medium

   * revert 7dba6e0a, to at least let LibreOffice start on KDE4 (LP: #1300283)

libreoffice (1:4.2.3~rc3-0ubuntu1) trusty; urgency=medium

   * apply fix for recent file menu (LP: #1008277)
   * bump version for new upstream rc
   * we dont care for stderr in the autopkgtest configure

libreoffice (1:4.2.3~rc2-0ubuntu1) trusty; urgency=medium

   [ Ritesh Khadgaray ]
   * fix symlink permissions (lp: #1200277)
 
   [ Bjoern Michaelsen ]
   * package libreoffice-help-en-us again (LP: #1288378)
   * make ConnectivityTools a normal target, so we can pack it
   * build libreoffice-subsequentcheckbase again
   * fix tests/junit-subsequentcheck
   * reenable junit
   * strip down -subsequentcheck deps
   * kill sensible-lomua.diff -- ExternalMailer should be good enough on all DEs
     now (LP: #1217191)
   * add jdk dep to -subsequentcheckbase
   * tweak java.library.path for autopkgtest
   * use gio when possible (LP: #1253620)
   * reenable Ubuntu palette
   * backport patch for fdo#74981 from 4.2.4

libreoffice (1:4.2.1-0ubuntu1) trusty; urgency=low

   * bump to new upstream release
   * update patch queue
   * remove adjust-PackageInfo-for-zip-files.diff - upstreamed
   * remove fix-ppc-build.diff - upstreamed
   * remove speedup-install-foo.diff - upstreamed
   * fix postprocess deps

libreoffice (1:4.2.0-0ubuntu1) trusty; urgency=low

   * fix localization issue
   * upstream final release, recreate tarballs
   * there is no --with-system-xmlsec anymore
   * suggest -style-sifr from -common
   * use system mdds and libcmis again

libreoffice (1:4.2.0~rc4-0ubuntu1) trusty; urgency=low

   * new upstream rc
   * merge from debian and fix subsequentcheckbase
   * update patch queue
   * updated make-package-modules-not-suck.diff to not move libs from
     PLAINLIBS_OOO to OOOLIBS when moving them to base (LP: #1272905)
     - this caused the hsqldb troubles
     - removing the hotfix patch for that, as it is now obsolete
   * tweak -ku transitional to match packages we produce
   * there is unfortunately evidence that PPA builders are still too small, so
     bring back the remove objects before install hack
   * also move the right file in install-common

libreoffice (1:4.2.0~rc2-0ubuntu2) trusty; urgency=low

   * backport upstream patches to fix endian issues on ppc

libreoffice (1:4.2.0~rc2-0ubuntu1) trusty; urgency=low

   * separate out -l10n source package
   * bump upstream release candidate
   * use system lpsolve again
   * fix presentation minimizer transitional to accept prereleases
   * remove discspace hack -- we should be ok now that we split out l10n
   * use the right arch of jdk and boost
   * skip branding on l10n packages
   * dont propagate BUILD_PATH and LD_LIBRARY_BUILD_PATH -- they leak the build
     env and seem to be unneeded in -l10n anyway

libreoffice (1:4.2.4~rc2-1) experimental; urgency=low

   * new upstream release candidate
 
   * debian/patches/kde4-fixes.diff: add patch to "prevent KDE/Qt from
     interfering with the session manager" from libreoffice-4-2. Remove obsolete
     rest which was never applied anyway
   * debian/patches/fix-kfileficker-crashes.diff: as name says, backported from
     libreoffice-4-2, really - or again? - closes: #743221)
 
   * debian/rules:
     - fix HELP_L10N_VIRTUAL_VERSION
     - re-enable system-libmwaw, -odfgen, -etonyek, -freehand, -libebook,
       -libabw, -libeot
   * debian/libreoffice-kde.NEWS:
     - adapt version, the de-facto disabling of the File Picker only happens
       now...

libreoffice (1:4.2.4~rc1-1) experimental; urgency=low

   * new upstream release candidate
 
   * debian/patches/hppa-call.diff: blind fix for hppa build
   * debian/patches/no-restart-on-empty-buildid.diff: Backport from master;
     Avoid soffice.bin restarting ad inf when version ini-file buildid is empty
     - as when we're using the source tarballs...
 
   * debian/rules, debian/vars.alpha: readd alpha, rumours say it works again
     (doesn't really matter anyway, but...) (closes: #738157)
   * debian/rules:
     - re-enable make check and junit checks (disable flaky checkBookmarks, though
       as per upstream advice)
   * debian/control.in: s/connectvity/connectivity/ (closes: #745138)

libreoffice (1:4.2.3~rc3-1) experimental; urgency=low

   * new upstream release candidate
 
   * debian/patches/debian/patches/kde4-fixes-from-libreoffice-4-2.diff: as name
     says. backport KDE4 fixes from libreoffice-4-2 branch:
     e.g. "Add a runtime check and configure warning to disable KDE4
     native file pickers, if the Qt4 glib dispatcher doesn't honor the
     QEventLoop::ExcludeSocketNotifiers flag." (closes: #743221)
     This effectively disables the KDE4 File Picker until Qt is fixed.
 
   * debian/rules, debian/patches/build-connectivitytools.diff: fix
     -subsequentcheckbase install
   * debian/tests/*: sync with Ubuntu
   * debian/rules, debian/lo-*ref.in: lo-common-ref -> lo-idl-ref...
   * debian/lo-idl-ref.in: .. and fix Index:
   * debian/control.in: break libreoffice-accessodf (<= 0.1-4) due to changed
     MessageBox API

libreoffice (1:4.2.2~rc1-1) experimental; urgency=low

   * new upstream release candidate
 
   * debian/patches/sparc-asm-syntax-fix.diff: fix syntax in sparc bridges'
     asm
 
   * debian/control.mysql.in:
     - suggest mariadb-server | mysql-server instead of just mysql-server

libreoffice (1:4.2.1-1) experimental; urgency=low

   * new upstream release
 
   * add src -> external/tarballs move already from 4.3 branch and create
     new .orig-external tarball
 
   * debian/rules:
     - autodoc got replaced by doxygen. bump doxygen build-dep to needed
       (>= 1.8.4-1) and disable packaging the SDK docs on wheezy-backports.
       Run dh_doxygen
     - build-depend on fonts-liberation when running the tests - the
       sc_macros_tests VBA tests need Arial etc.-similar fonts
     - add conditionals for new libs used: opencl, firebird, avahi-client,
       vlc, libetonyek, libfreehand, libe-book, libeot, libabw; add necessary
       updates/bumps
     - temporarily disable cppunit _and_ junit4 (and logically also
       autopkgtests) as it's flaky right now (hangs, ..)
     - enable gd (scottish_gaelic) l10n
     - temporarily use internal libmwaw, libodfgen, libetonyek, libfreehand,
       libe-book, libabw until we have them (in a correct version) in Debian
   * debian/control.in, debian/rules:
     - split avmediagst.so into new -avmedia-backend-gstreamer and put new vlc
       backend into a new -avmedia-backend-vcl. Recommend
       -gstreamer | -avmedia and make metapackage depend on that, too
   * debian/control*in, debian/rules, debian/libreoffice-base.NEWS:
     - create new libreoffice-base-drivers - as name says. Move hsqldb and
       firebird into own packages. Mention to people that they need
       to install the new -sdbc-hsqldb

libreoffice (1:4.1.5-1) unstable; urgency=low

   * new upstream release
 
   * debian/patches/kde-yield-fix.diff: backport patch from LO 4.2.0 which
     rewrites Qt4 based nested yield mutex locking (closes: #728987, #723087)
 
   * debian/control.ure.in:
     - add missing second a in "additional" (closes: #734512)
   * debian/pom.*.xml.in, debian/*.poms, debian/rules:
     - install maven stuff for juh,jurt,ridl and unoil (based on the poms from
       http://bertfrees.github.io/snapshots/org/libreoffice/), thanks Sebastian
       Humenda
   * debian/tests/junit-subsequentcheck:
     - temporarily disable the report builder here; Depends: generation for
       -subsequentcheckbase somehow misses the needed build-deps now...?!

2013

libreoffice (1:4.1.4-2) unstable; urgency=medium

   * debian/patches/disable-ftp-nohost-test.diff: temporarly disable test
     checking for connection to ftp://noname:nopasswd@nohost
 
   * debian/rules:
     - adapt dh_shlibdeps call for unordf to librdf0's multiarch usage
       and build-depend on librdf0-dev (>= 1.0.16-2) (closes: #732770)

libreoffice (1:4.1.4-1) unstable; urgency=low

   * new upstream release
 
   * debian/patches/unopkg-SHARED-quote.diff: properly quote $SHARED, thanks
     Anthony DeRobertis (closes: #731876)
 
   * debian/rules:
     - use new libbsh-java instead of bsh
   * debian/shlibs.override.libvisio, debian/rules:
     - bump libvisio dep to >= 0.0.18

libreoffice (1:4.1.3-1) unstable; urgency=low

   * new upstream release

libreoffice (1:4.1.3-0ubuntu3) trusty; urgency=medium

   * No change rebuild against libicu52

libreoffice (1:4.1.3-0ubuntu2) trusty; urgency=low

   * temporary use internal mdds for trusty

libreoffice (1:4.1.3-0ubuntu1) saucy; urgency=low

   [ Bjoern Michaelsen ]
   * new upstream release
   * add upstream patch for fdo#70201, review missed the tag
   * backport upsteam patch for fdo#70741 from libreoffice-4-1 branch
     (fixes RTL)
   * fix desktop files for unity quicklists (LP: #1231799)
   * no source change vs. the ~rc2 version in the PPA
     (but full l10n for the archive)
   * fix quicklist patch to add Actions too
   [ Rene Engelhard ]
   * debian/scripts/gid2pkgdirs.sh: use new gid for
     ScriptProviderFor{JavaScript,Beanshell}.jar install (fdo#71317)

libreoffice (1:4.1.2~rc3-0ubuntu1) saucy; urgency=low

   * new unscheduled upstream release candidate fixing fdo#69450, fdo#69220 and
     fdo#69440

libreoffice (1:4.1.2~rc2-0ubuntu1) saucy; urgency=low

   * merge from Debian
   * new upstream release candidate
     - fix fdo#68210, fdo#67602: trouble with mergedlibs and dynamic loading
       (LP: #1218890)
   * activate unity menus even earlier to reduce latency (LP: #1204592)
   * remove upstreamed and unused patch for lp#1085168
   * with mergedlibs, lp-solve is already needed by -core (LP: #1221014)

libreoffice (1:4.1.2-2) unstable; urgency=low

   * debian/patches/fdo70196-no-with_traceback-for-python2.diff: don't use
     .with_trackeback() in uno.py for python2 (closes: #725491)
   * debian/patches/fix-system-bluez.diff: don't hardcode
     -I$(SRCDIR)/bluez_bluetooth/inc in sd...
   * debian/scripts/gid2pkgdirs.sh: use new gid for
     ScriptProviderFor{JavaScript,Beanshell}.jar install
   * debian/control.in:
     - make -core depend on ure (>= 4.1.2~) (closes: #726909)

libreoffice (1:4.1.2-1) unstable; urgency=low

   * new upstream release
     - fixes debug logging for python3 in pythonscript.py (closes: #719941)
 
   * debian/rules:
     - fix curl conditional to really add libcurl4-<whatever>-dev builddep....
     - disable graphite2 for armel and sparc for wheezy-backports
     - build using gcj-jdk for kfreebsd-* on wheezy-backports
     - build galleries only in build-indep, specify --with-galleries=no for
       build-arch
   * debian/patches/javadoc-optional.diff: add missing -DJAVADOC for scp2
     to actually install java/refs...

libreoffice (1:4.1.1-1) unstable; urgency=low

   * LibreOffice 4.1.1 final (identical to rc2)
 
   * upload to unstable
 
   * debian/patches/translation-updates-and-bugfixes.diff: as name says
     from libreoffice-4-1-1 branch
 
   * debian/rules:
     - hardcode kfreebsd-* as openjdk arch until java-common setting it as
       default is uploaded
     - bump librdf0-dev build-dep to >= 1.0.16 to match reality; use
       internal one on wheezy
     - really build sysui with all languages again in build-arch so .desktop
       get the translations
 
   * merge from Ubuntu:
     - remove uuid build-dep again, just needed for crosscompile msi
       generation..

libreoffice (1:4.1.1-0ubuntu1) saucy; urgency=low

   * new upstream release
   * drop multiarch fix, now upstreamed to Debian, thanks Rico
     Tzschichholz

libreoffice (1:4.1.1~rc2-1ubuntu1~saucy1~ppa1) saucy; urgency=low

   * new upstream rc
   * merge from Debian

libreoffice (1:4.1.1~rc2-1) experimental; urgency=low

   * new upstream release candidate
     - fixes odg/odp font export (closes: #720192)
 
   * debian/patches/neon-0.30.diff: fix FTBFS with neon 0.30.0
   * debian/patches/qadevOOo-kfreebsd.diff: make qadevOOo not fail on
     "gnu/kfreebsd"
 
   * debian/rules:
     - don't try to package up -subsequentcheckbase on gcj-using archs
       as needed stuff isn't built there
     - build-depend on uuid when running make check
     - use openjdk also on kfreebsd-* (if not using default-jdk, otherwise that
       is taken)
     - "fix" to also ignore check failures on kfreebsd-{i386,amd64} (assuming
       openjdk use)
     - use default boost (1.54) again
     - fix build with a multiarched boost, thanks Bjoern Michaelsen
   * debian/libreoffice-dev-doc.links: add api -> docs symlink as Javadocs
     should be in api/
   * debian/libreoffice-script-provider-python.bug-script: remove, obsolete;
     it's not an extension anymore
 
   * merge from Ubuntu:
     - debian/control.debug.in: s/python-uno/python3-uno/

libreoffice (1:4.1.1~rc1-1ubuntu1~saucy1~ppa1) saucy; urgency=low

   * new upstream rc and merge from debian

libreoffice (1:4.1.1~rc1-1) experimental; urgency=low

   * new upstream release candidate
 
   * debian/rules:
     - remove PYTHONPATH setting in soffice again and add
       proper PYUNO_LOADER_PYTHONPATH=$ORIGIN to pythonloader.unorc,
       thanks Fedora for the hint
     - use default-jdk:
       + update for java-common (>= 0.49). use java_defaults.mk to populate
         OOO_JAVA_ARCHS/OOO_GCJ_(JDK_)ARCHS/OOO_OPENJDK_ARCHS
       + clean up jre depends:
         remove java-gcj-compat, prefer 7 over 6 except on ia64 (just 7)

libreoffice (1:4.1.0-4) unstable; urgency=low

   * debian/rules:
     - readd PYTHONPATH setting to soffice (as for unopkg)
       as it's apparently still needed for the python script provider
       to work (closes: #718403)

libreoffice (1:4.1.0-3) unstable; urgency=low

   * debian/rules:
     - use system-clucene again now that it's in sid
     - move liblpsolve55.so into -core if used internally, as otherwise
       -writer doesn't start without -calc installed..?!
   * debian/libreoffice-common.postrm.in:
     - add missed || true and use rm -f for javasettinsgunopkginstall.xml...
   * debian/control.librelogo.in:
     - apparently librelogo also needs -script-provider-python. Depend on
       that instead of ${pyuno-depends}, thanks Bjoern Michaelsen

libreoffice (1:4.1.0-2ubuntu1) saucy; urgency=low

   * unfuzz Ubuntu palette patch
   * remove sessioninstaller for wizards patch -- they are all python now
   * remove python-uno (Python 2 bridge)
   * trying to remove the workdir before installing on ppa builds to squeeze in
     size requirements
   * smaller src-tarballs
   * do not run subsequentchecks in build anymore, as we can run them as an
     autopkgtest, which is better, and eases distress caused by PPA buildds
     being storage contrained
   * use system orcus for real
   * remove double echo
   * merge with upstream
   * use system lpsolve and graphite
   * kill of csh stuff for good
   * clean up dupes in -core breaks against -evolution
   * remove dbghelp.dll binary from tarball creation
   * silence lintian on the copyright file
   * make -dbg use python3-uno proper
   * fix build against poppler 0.23/0.24

libreoffice (1:4.1.0-2) unstable; urgency=low

   * debian/rules:
     - fix uno.py, actually add starting / in LOs path (closes: #717930)
     - add -Nlibreoffice-report-builder to jh_depends call for arch-indep
       packages so it doesn't get added to -java-commons Depends
       (closes: #717903
   * debian/libreoffice-common.postrm.in:
     - don't create /var/lib/libreoffice/share/config/ anymore and
       remove it (and javaunopkginstall.xml if exists) on purge
       (closes: #707933)

libreoffice (1:4.1.0-1) unstable; urgency=low

   * new upstream release
 
   * upload to unstable
 
   * debian/rules:
     - use internal clucene again; still no action from the clucene
       maintainers...

libreoffice (1:4.1.0~rc3-1) experimental; urgency=low

   * new upstream release candidate

libreoffice (1:4.1.0~rc2-2) experimental; urgency=low

   * build with proper DEB_BUILD_OPTIONS so we actually get l10n
     (closes: #715353)
 
   * debian/rules:
     - also filter out binutils so that the mips(el)-only build-dep doesn't
       end up in -subsequentbases depends for everything
   * debian/rules, debian/control.in:
     - revert python3-uno -> python3.3-uno move now that python 3.3 is default
       and prefer python3-uno (>= 4.0~) in dependencies again

libreoffice (1:4.1.0~rc2-1) experimental; urgency=low

   * new upstream release candidate
 
   * debian/patches/hack-interlck_sparc.diff: hack around sparc build failure,
     #undef __sparcv8plus, __sparcv9 and __sparc_v9__ for interlck_sparc.o as
     we otherwise miss osl_InterlockedCountSetV9...
 
   * debian/rules:
     - revert gcc 4.6 hack; armel built fine with g++-4.8, including checks,
       so let's try with it everywhere.

libreoffice (1:4.1.0~rc1-1) experimental; urgency=low

   * new upstream release candidate
 
   * debian/patches/gcj-safe-jni-h-include.diff: fix -I placement...
 
   * debian/control.sdk.in:
     - also replace libreoffice-common (<< 4.1.0~beta1) (closes: #710767)
   * debian/rules:
     - enable kk (kazakh) l10n (closes: #700835)
     - fix JAVA_MAINVER setting to actually set 6 for mips(el) and not
       for ia64.
     - also build-depend on libc6 (>= 2.17-6) on mips(el)
   * debian/control:
     - fix -dbg suggests: s/python/$(PYTHON)/. to suggest python3.3-dbg
     - temporarily force gcc-4.6(!) (instead of build-conflicting
       against gcc (>< 4:4.7~) on all archs except *i386/*amd64 until
       all bridges are ported to the new gcc 4.7+ behaviour
     - remove last buildd special-casing: build --enable-verbose everyhwere,
       also on the buildds
   * debian/patches/make-pyuno-work-for-system-wide-module-install.diff,
     debian/patches/didable-sw-python.diff, debian/rules:
     remove patch(es), add the lines to uno.oy during install ("stolen" from
     Fedora)
     Otherwise the python-based unit tests fail miserably (sw_python).

libreoffice (1:4.1.0~beta2-2) experimental; urgency=low

   * debian/rules:
     - revert back to using gcj on kfreebsd-*, OpenJDK7 doesn't work (hangs) or
       still isn't available... (kfreebsd-i386)
     - fix librpt* move, install path differs between binary-only and full
       builds, sigh.

libreoffice (1:4.1.0~beta2-1) experimental; urgency=low

   * debian/patches/show-the-startcenter.diff: as name says, remove
     NoDisplay=true from startcenter.desktop
 
   * new upstream beta release
     - make distro-pack-install installs .desktop again (closes: #710591)
 
   * rebuild against libharfbuzz0a/libharfbuzz-icu0 (closes: #710847)
 
   * debian/control.sdk.in:
     - update Replaces: for gengal move to -dev (closes: #710767)
   * debian/rules:
     - enable graphite2 on all archs now that it's fixed on armel/sparc

libreoffice (1:4.1.0~beta1-2) experimental; urgency=low

   * debian/patches/javadoc-optional.diff: make javadoc optional and disable
     it on gjdoc builds, they miss files we expect.
 
   * debian/rules:
     - use OpenJDK 7 on everything including kfreebsd-* - except on
       mips(el). Stay with 6 there.
   * debian/control:
     - regenerate; uses libservlet3.0-java instead of libservlet2.5-java now

libreoffice (1:4.1.0~beta1-1) experimental; urgency=low

   * new upstream beta release
 
   * debian/rules, control.sdk.in:
     - dmake finally gone
   * debian/rules:
     - add new conditionals: libmwaw, libodfgen, harfbuzz, mariadb
       (use MySQL instead of MariaDB, though as long as we need mysqlcppconn
       anyway)
     - build with explicit --enable-python=system
     - enable the tightended binutils build-dep, we're in experimental anyway
       and need orcus and mdds from experimental, too
     - enable system-clucene again
     - temporarily disable cleandupes for -l10n-* as it's broken right nwo
   * debian/uno-libs3.symbols: update

libreoffice (1:4.0.3-3) unstable; urgency=low

   * debian/patches/uno-executables-link-to-xmlreader.diff: fix
     sp2bv/regcomp/regsingleton/uno-skeletonmaker build on
     mips(el) by linking explicitly with libxmlreader.so with sids gcc without
     experimentals binutils.
 
   * debian/control.in, debian/rules:
     - depend on fonts-dejavu instead of ttf-dejavu (closes: #708062)
     - prepare build-depending on experimentals binutils on mips(el), thanks
       Aurelien Jarno for the hint
   * debian/copyright:
     - mention swext/mediawiki/src/filter/odt2mediawiki.xsl copyright/license

libreoffice (1:4.0.3-2) unstable; urgency=low

   * debian/control.in:
     - add Breaks: libjaxe-java (<= 3.5-2) for saxon9.jar disappearing from
       -java-common
     - remove -core Depends: for -style and add Enhances: libreoffice-core
       for them. Apps should depend on their data files but data files not on
       the apps
   * debian/rules:
     - build with libboost1.53-dev to work around mdds-using sc unit tests
       failing to build with sids new gcc-4.7
     - move libxmlreader.so (although not versioned...) and libreg.so.3 (although
       private...) and it's dependency libstore.so.3 into uno-libs3 as
       libuno_cppuhelpergcc3.so.3 now links to it (breaks ure->uno-libs3->ure
       dependency loop)
 
    (hopefully breaking those two dependency loops closes: #705158, thanks
     David Kalnischkies - see also #707578)

libreoffice (1:4.0.3-1) unstable; urgency=low

   * LibreOffice 4.0.3 final (identical to rc3)
 
   * upload to unstable

libreoffice (1:4.0.3~rc3-1) experimental; urgency=low

   * new upstream release candidate
 
   * debian/control.in:
     - break zotero-libreoffice-integration (<= 3.0.11.1-26-g08fb709-1), see
       #705998)
     - add (commented out for now - as long we are python3.3-uno anyways) the
       missing Provides: ${python3:Provides}
   * debian/uno-libs3.symbols: update and cleanup - use (symver) instead
     of *@...
   * debian/copyright: mention gbuild (and its makefiles) are MPL-2.0

libreoffice (1:4.0.3~rc1-3) experimental; urgency=low

   * The "the third time is a charm" release
   * fix check rule again: move - where it actually works; also ignore
     test failures on s390 and powerpc and simplify logic

libreoffice (1:4.0.3~rc1-2) experimental; urgency=low

   * brown paper bag release
   * fix make -k check || make check rule

libreoffice (1:4.0.3~rc1-1) experimental; urgency=low

   * new upstream release candidate
 
   * debian/control.librelogo.in:
     - actually use ${pyuno-depends}...
   * debian/rules:
     - enable liblangtag on arm*, too now that it's available there
     - Use internal clucene until clucene 2.x is in unstable. Remove
       arm* hack for internal clucene as it seems to work in the
       meanwhile
     - explicitly set JDK=openjdk again until default-jdk (>= 1:1.7-48)
       is in unstable (needed for ia64 defaulting to java7)
     - run make -k check || make check (try to work around spurious failures) and
       ignore test suite failures (on the second run) on armhf, ia64, sparc,
       mips(el)

libreoffice (1:4.0.2-0ubuntu5) saucy; urgency=low

   * Add libcommons-logging-java BD, to work around brokenness when doing an
     arch build.

libreoffice (1:4.0.2-0ubuntu4) saucy; urgency=low

   * cherry-pick from Debian to fix FTBFS:
     - actually set --with-hsqldb-jar=$(HSQLDB_JAR)

libreoffice (1:4.0.2-0ubuntu3) saucy; urgency=low

   * cherry-pick from Debian:
     - build against "new" libhsqldb1.8.0-java

libreoffice (1:4.0.2-0ubuntu2) saucy; urgency=low

   [ Dmitrijs Ledkovs ]
   * Build against boost1.53
 
   [ Bjoern Michaelsen ]
   * disable test broken by toolchain update (LP: #1182170)

libreoffice (1:4.0.2-0ubuntu1) raring; urgency=low

   * new upstream release
   * merge from Debian
   * add junit subsequentcheck as autopkgtest
   * revert ppa specialcasing removal -- the ppa builders are still too small
   * limit jobs for subsequent checks to 1 and re-enable heisenbugged tests
   * make -common break old -emailmerge (LP: #1160533)
   * make -emailmerge B/R consistent
   * we have libservlet-3.0 already
   * revert temp. python3-uno->python3.3-move that we don't need, while trying to
     keep the diff low
   * some lintian tweaks
   * remove self-conflicts
   * build against system liblangtag (requested by Benjamin Drung)

libreoffice (1:4.0.2~rc2-2) experimental; urgency=low

   * debian/patches/boost-1.53.diff: backport buildfixes for boost 1.53
     from master
 
   * debian/rules:
     - build-depend on libboost-dev 1.53 when building with gcc 4.8,
       see 701310/695826 (closes: #701310)
     - always build -dbg package if we build -subsequentcheckbase, as the
       test depends on -dbg
     - build against "new" libhsqldb1.8.0-java
     - we need to build-depend on python3 even when building python3.3-uno
       as it contains dh_python3...
   * debian/control.in:
     - add Breaks: on libreoffice-writer2latex/libreoffice-writer2xhtml
       (<< 1.0.2-9) due to LO 4.0 API change

libreoffice (1:4.0.2~rc2-1) experimental; urgency=low

   * new upstream release candidate
     - keeps migrating more user extensions after one failed (closes: #703486)
 
   [ Rene Engelhard ]
   * src/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.zip: remove
     lib/servlet.jar..
   * debian/patches/fix-internal-hsqldb-build.diff: ... and fix internal
     hsqldb build to use /usr/share/java/servlet-api-2.5.jar
 
   * merge from Ubuntu:
     - reverting l10n conflicts as they create an unfortunate mess in image and
       installer creation (related: lp#957589)
   * debian/rules, debian/control.in:
     - temporarily rename python3-uno to python3.3-uno to be able to upload
       this to unstable without waiting for a python3-defaults transition.
   * debian/control.in:
     - mention that python-uno is for old python2 compatibility and move to
       oldlibs
     - make -base recommend -writer (because forms in base need it), thanks#
       Lionel Elie Mamane
     - make -common break all pre-3.6 extensions (closes: #686666)
     - revert make -help-en-us break "the others" to work around 682838
       as it breaks the installer (reopens: #682838)
   * debian/control.libreloho.in:
     - librelogo needs -writer (see
       http://lists.freedesktop.org/archives/libreoffice/2013-March/048222.html)
 
   [ Bjoern Michaelsen ]
   * squash and cherry-pick junit autopkgtests from Ubuntu

libreoffice (1:4.0.2~rc1-1) experimental; urgency=low

   * new upstream release candidate
 
   * merge from Ubuntu:
     - add transitional for -presenter-console
     - silent some lintian noise for unversioned breaks:
       + promote Breaks to Conflicts against -binfilter as it will never return
       + remove Breaks against -style-industrial which is long gone
       + promote Breaks to Conflicts from langpacks against en-US
     - remove all traces of -so52
   * add patches from Benjamin Drung:
     - Apply fonts package renames from ttf-foo to fonts-foo.
     - Update machine-readable copyright Format to 1.0
     - Standards-Version to 3.9.4 (no changes needed).
   * debian/control.help.in:
     - remove obsolete ${java-common-depends} Recommends
   * debian/control*.in, debian/rules:
     - stop building extra -emailmerge as stuff in -common (wizards) now
       need pyuno anyway.

libreoffice (1:4.0.1-0ubuntu2) raring; urgency=low

   * reverting l10n conflicts as they create an unfortunate mess in image and
     installer creation (related: lp#957589)

libreoffice (1:4.0.1-0ubuntu1) raring; urgency=low

   [ Bjoern Michaelsen ]
   * new upstream release
     - fixes CRASH in action after Undo (LP: #785518)
     - fixes fontconfig warning (LP: #1034928)
     - fixes desktop file translations (LP: #1131470)
   * add transitionals for -presenter-console and -binfilter
   * add sessioninstaller for remaining wizards (LP: #780399)
   * merge from debian at 1:4.0.1~rc1-2
   * remaining delta on debian/control:
     - drop ${java-common-depends} from Recommends to Suggests on
       libreoffice-help-*
     - add libreoffice-gnome | libreoffice-kde Recommends on libreoffice
     - add libreoffice-style-human Suggests to libreoffice-common
     - add libreoffice-common self Conflicts with << 3.5.0
     - drop java-common-depends and java-runtime-depends from Recommends to
       Suggests on libreoffice-writer
     - add libreoffice-pdfimport Recommends on libreoffice-draw
     - drop libreoffice-core from Depends to Recommends on libreoffice-style-*
     - add libreoffice-style-human
     - add C/P/R against lo-menubar from libreoffice-gtk
     - alternatively Recommends libreoffice-style-human from libreoffice-gtk3
     - add C/R against libreoffice-core (<< 1:3.9999) from libreoffice-gnome
     - add Conflicts against libreoffice-common (<< 1:3.5.0) from python3-uno
     - add libreoffice-subsequentcheckbase
     - add libreoffice-presenter-console transitional
   * remaining delta on debian/patches:
     - add Ubuntu brand palette
     - add session-installer for Java Wizards
   * remaining delta on rules:
     - fix configure switch for human theme
     - use internal jfreereport because of huge component mismatch otherwise
     - white progressbar instead of Debian Purple (or Ubuntu orange)
     - adjust bug reporting destination for ppa builds
     - disable tests on armel, armhf, powerpc
     - enable parallel build and mergelibs
     - disable evolution
     - use internal liblangtag for now
     - disable help building on armel/armhf
     - Ubuntu backport fixes
     - reduced l10n for ppa builds
     - alternatively allow firefox-dev to xulrunner-dev as build-dep
     - warn early on GVFS and GIO in same build
     - generate transitionals
     - generate subsequentcheckbase
     - fix missing closing para wrt slide remote
     - move sessioninstaller from -gtk to -gnome for gio deps
     - move subsequentcheckbase jars to package
     - use --with-all-tarballs in addition to our flags for getting the source
       - this is so that ./configure doesnt stumble over other checks
         (e.g. still needing gnomevfs)
   * removed delta:
     - drop libreoffice-filter-mobiledev and ttf-sil-gentium-basic from Depends
       to Suggests on libreoffice
     - remove libreoffice-core postinst
     - fixed gnu make version
     - remove hotfixes get-orig-sources hack
     - some whitespace
   * silent some lintian noise for unversioned breaks:
     - promote Breaks to Conflicts against -binfilter as it will never return
     - promote Breaks to Conflicts from langpacks against en-US
     - remove Breaks against -style-industrial which is long gone
   * libreoffice-core already conflicts with -evolution, so no need to break in
       addition
   * remove all traces of -so52
   * conflict help language packages in both ways
 
   [ Rico Tzschichholz ]
   * disable two more flaky tests for now:
     - fdo#35663
     - fdo#61896

libreoffice (1:4.0.1~rc1-2) experimental; urgency=low

   * debian/rules:
     - add correct build-dep on cpp-4.7...

libreoffice (1:4.0.1~rc1-1) experimental; urgency=low

   * new upstream release candidate
     - removes "Impress Remote" menu option unless in experimental mode.
       (closes: #700728)
 
   * debian/patches/debian-hardened-buildflags.diff: only set CPPFLAGS here now
 
   * debian/rules:
     - use /usr/share/dpkg/buildflags.mk for C(XX)FLAGS, LDFLAGS now that LO
       honours those from the env in configure. Remove manual passing to make.
     - conditionalize pyuno build/install more so that we can build only
       python-uno on wheezy-backports. Bit obscure, but...
     - explicitly use cpp-4.7 as cpp 4.8 would fail
     - use $(OOVER) instead of hardcoded 3.6 for the README...

libreoffice (1:4.0.0-1) experimental; urgency=low

   * new upstream release
     - contains new driver for mozab (mork). Automatically enabled thus
       this closes: #321099
     - now has a basic(!) gnumeric import in experimental mode
       (closes: #595708)
     - fixes LibreOffice Calc unshows comments importing MS Office xlsx (LP: #990868)
     - supports IFERROR (closes: #662798)
 
   * debian/control.in:
     - make -impress suggest bluez (for impress remote control)
     - make libreoffice depend on / -common recommend python(3)-uno for the
       new python-based wizards
   * debian/rules:
     - add new conditionals for new dependencies: liblangtag, liborcus,
       libmspub, (u)cpp; remove them for gone saxon, librsvg, db
     - enable sdrmeote on all archs; b-d on libbluetooth-dev on where we
       enable bluetooth (!kfreebsd-*)
     - use gstreamer1.0
     - use --disable-dependency-tracking instead of gb_FULLDEPS= and
       --enable-hardlink-deliver instead of gb_Deliver_HARDLINK=T
     - python3 is default now; reverse logic (use python3 per default and
       and build python2 in a extra step)
     - add option to build with --enable-mergelibs, not yet enabled.
     - remove stlport hacks for i386 - not used/needed anymore upstream
   * debian/uno-libs3.symbols: update
   * debian/control*.in, debian/rules, debian/scripts/gid2pkgdirs.sh: binfilter
     is gone. yay.
   * debian/*.mime:
     - don't use obsolete -no-oosplash anymore, thanks Matthijs Kooijman
       for the patch (closes: #698845)
   * debian/copyright: update
   * debian/control.mozilla.in: OOo -> "old OOo and OpenDocument"
     (closes: #699708)

libreoffice (1:4.0.0~beta2-0ubuntu2) raring; urgency=low

   * Build using the internal libmspub for a first build.

libreoffice (1:4.0.0~beta2-0ubuntu1) raring; urgency=low

   * new upstream prerelease 4.0 beta2:
     - fixes Cross-references and TOC links broken in XHTML export (LP: #122383)
     - fixes Print orientation won't change (LP: #201642)
     - fixes Writer AutoSpellcheck flags capitalized words as misspelled despite
       being added lowercase in the custom dictionary (LP: #220703)
     - fixes Impress mis-rotates text saving to .pptx (LP: #505188)
     - fixes Custom Animation not repeating (LP: #778293)
     - fixes Text not black in LibreOffice (LP: #628105)
     - fixes soffice.bin crashed with SIGABRT in
       __gnu_cxx::__verbose_terminate_handler() (LP: #875583)
     - fixes Add keywords to .desktop files (LP: #950834)
     - fixes Can't open XML files larger than 1.1 MB (LP: #951153)
     - fixes LibreOffice Calc unshows comments importing MS Office xlsx
       (LP: #990868)
     - fixes soffice.bin crashed with SIGSEGV in
       SwAnchoredObject::FindPageFrmOfAnchor() (LP: #1063535)
     - fixes Calc mis-sorts left to right (sort columns) (LP: #1082449)
     - fixes Cannot open xls file in 3.6.3.2, but works in 3.5.4 (LP: #1083947)
     - fixes FILEOPEN Word 97-2003 DOC structure as exported by apple pages is
       not recognized (LP: #1086566)
     - fixes LibreOffice Mailmerge Label generated incorrectly (LP: #1090745)
     - fixes FORMATTING: Objects anchored to cell wrongly positionned to A1
       (LP: #1097433)
     - fixes torn off popups trigger keyboard focus problems (LP: #1097718)
     - fixes default hori/vert frame anchor during RTF import (LP: #1097735)
     - fixes Load Java scripts with class loaders (LP: #1097744)
     - fixes Do not consider timestamp differences as corruption (LP: #1097748)
     - fixes sw: better fix for DOCX table import crash (LP: #1097760)
     - fixes STG_FREE sector locations rejected (LP: #1097811)
     - fixes restrict page sanity check to non-storage chunks (LP: #1097966)
     - fixes German OK and Cancel buttons show ~ (LP: #1103495)
   * re-enable report-builder (LP: #992232)
   * sync unopkg wrapper from Debian (LP: #1022382)
   * enable mergedlibs
   * merge from Debian, adjust mergedlibs-foo, remove debianized patches
   * generate control file that makes ppa prerelease bugs reported to packaging
     mailing list
   * build full l10n for testing
   * add libreoffice-gnome C/R for upstreamed 3.6/quantal vendor-patches

libreoffice (1:3.6.5-1) experimental; urgency=low

   * LibreOffice 3.6.5 release (idential to rc2)
 
   * debian/rules:
     - stop using lsb_release -cs, parse dpkg-parsechangelog instead.
       avoids the base-files issue.
   * debian/libreoffice-common.triggers.in, debian/rules:
     - fix trigger to actually be in effect
     - enable tr,vi help, fully translated according to
       https://gerrit.libreoffice.org/1895

libreoffice (1:3.6.5~rc2-1) experimental; urgency=low

   * new upstream release candidate
      - fixes --view (closes: #697723)
 
   * debian/rules:
     - make -help-en-us break "the others" to work around 682838
       (closes: #682838)
     - temporarily remove wheezy backport conditionals as base-files would make
       us think we should build for wheezy right now
     - fix gdb helper installation; use upstreams install-gdb-printers
   * debian/rules, debian/*.triggers.in, debian/libreoffice-common.postinst.in:
     - re-introduce @OODIR@/share/extensions trigger as we still need to tell
       LO to sync if a subdir inside share/extension changes, but "touch" is
       enough now

2012

libreoffice (1:3.6.4-1) experimental; urgency=low

   * LibreOffice 3.6.4 release (identical to rc3)

libreoffice (1:3.6.4~rc3-1) experimental; urgency=low

   * new upstream release candidate
 
   * debian/patches/poppler_0_21_x.diff: moove from poppler_0_21_0.diff; fix
     build with 0.21.1 again
   * debian/patches/bigendian-utext-mixup.diff: backport from libreoffice-3-6
     branch to fix ooxml regression test failure
 
   * debian/rules:
     - don't rely on dictionaries submodule. unused.
   * debian/control.in:
     - remove obsolete Pre-Depends on ure  (>= 1.5.1+OOo3.1.1-15)
       (by the way closes: #693626)
   * debian/control.mozilla.in, debian/rules: rename
     mozilla-libreoffice -> browser-plugin-libreoffice

libreoffice (1:3.6.4~rc1-1) experimental; urgency=low

   * new upstream release candidate
 
   * debian/patches/poppler_0_21_0.diff: fix build of sdext with poppler
     0.21.0
 
   * merge from Ubuntu:
     - fix quoting of PYTHON_{CFLAGS,LIBS} (Matthias Klose)
   * debian/rules:
     - mention CVE-2012-4233 in 1:3.6.1~rc2-1's changelog
     - re-enable mozilla plugin
     - actually make python version-switching work
   * debian/control.in:
     - recommend fonts-liberation instead of ttf-liberation
       (closes: #691949)
   * debian/libreoffice-core.bug-control:
     - report-with: fonts-opensymbol instead of transitional ttf-opensymbol
   * debian/libreoffice-{core,gtk3}.bug-script.in:
     - find out whether we have Experimental features enabled

libreoffice (1:3.6.3~rc2-1) experimental; urgency=low

   * new upstream release candidate
 
   * debian/patches/soffice-bashisms.diff: fix bashism in soffice for
     valgrinding (closes: #690717)
   * debian/patches/he-lucida-sans-unicode.diff: Update default Hebrew font
     from Lucida Sans to Lucida Sans Unicode, thanks Lior Kaplan
   * debian/patches/ure-no-etc-opt-ure.diff: exclude /etc/opt/ure from ure
     search paths (closes: #677601)
 
   * debian/rules:
     - fix upstream README(_en-US) install for binary-indep packages
     - fix typo in finding gcj dir detection, thanks Rico Tzschichholz
     - don't add version from librsvg*.shlibs (as for libebook) as we
       dlopen() it anyway.

libreoffice (1:3.6.3~rc1-1) experimental; urgency=low

   * new upstream release candidate
 
   [ Rene Engelhard ]
   * debian/patches/sensible-lomua.diff: add patch from Dave Steele to
     make senddoc.sh default to standard mailto handler (closes: #687228)
 
   * debian/rules:
     - try again with gcc 4.6 for mips* since apparently testtools/smoketest
       now work..
     - document truth and remove alpha from supported architectures
     - exclude .desktop from dh_link call to get absolute symlinks
       (closes: #690336)
 
   [ Bjoern Michaelsen ]
   * make metapackage explicit in short description

libreoffice (1:3.6.2~rc1-1) experimental; urgency=low

   * new upstream release candidate
     - waits for InternalIPC::ProcessingDone in oosplash (closes: #681185)
 
   * debian/patches/disable-flaky-unoapi-tests.diff: disable flaky
     toolkit and sc.ScAccessible* unoapi tests
   * debian/patches/gcj-safe-jni-h-include.diff: add missing -I...
   * debian/control.in:
     - make -core break libreoffice-common (<< 1:3.6.1~rc1) as "unopkg sync"
       ran in the triggers is gone (closes: #686666)
   * debian/rules:
     - fix native-jars dependeny to depend on install-common ...
     - ... but as this doesn't build then disable it for now...
     - hack around broken "*" directory in debian/tmp/pkg on kfreebsd-*
       extremely slowing down the install target...
     - use xz compression for all binary packages (closes: #687041)

libreoffice (1:3.6.1-1) experimental; urgency=low

   * LibreOffice 3.6.1 final release (identical to rc2)
 
   * debian/rules:
     - work around possible failure install-common target with missing
       ca-XV .dirs/.install...

libreoffice (1:3.6.2~rc2-0ubuntu6) raring; urgency=low

   * cherry pick from upstream 3.6 branch Change-Id
     I2e02156ffc30629476b80134ffb0b50e793f7ead (LP: #585910)
     - improve rendering of the "faux bold" font on Impress
       presentation

libreoffice (1:3.6.2~rc2-0ubuntu5) raring; urgency=low

   * debian/rules: Fix quoting.

libreoffice (1:3.6.2~rc2-0ubuntu3) quantal-proposed; urgency=high

   * packaging shouldnt try to move stuff it doesnt build on armel/armhf

libreoffice (1:3.6.2~rc2-0ubuntu2) quantal-proposed; urgency=high

   * do not build extensions on armel, armhf for bug 1062448
   * update to unitymenus patch Change-Id
     Ia8f82024e56ad83c8979d60df3c94e8209fe2552 (LP: #1062757) (LP: #1062812)

libreoffice (1:3.6.2~rc2-0ubuntu1) quantal-proposed; urgency=low

   * update to unitymenus patch to 7ffc24eb76325afef89c25e8a7fe13124ed5a041
   * lo-menubar is obsolete with this (C/P/R needs to stay there until 14.04 LTS)

libreoffice (1:3.6.2~rc2-0ubuntu1~ppa2) quantal; urgency=low

   * update to Antonios fixes for today

libreoffice (1:3.6.2~rc2-0ubuntu1~ppa1) quantal; urgency=low

   * ttf-sil-gentium-basic has been renamed to fonts-sil-gentium
   * new upstream release 3.6.2.2
   * update unitymenus patch to 767bae2cefd4cfcaa852c2c39e651bab81e4e134

libreoffice (1:3.6.1~rc2-1ubuntu6~ppa1) quantal; urgency=low

   * update unitymenus to commit 22774aff3f1d4b2a09d713555e0180a3eded3155
   * make metapackage explicit in short description (LP: #1045165)
   * drop ttf-sil-gentium-basic and filter-mobiledev to suggests on
     metapackage (LP: #1045165)

libreoffice (1:3.6.1~rc2-1ubuntu5) quantal; urgency=low

   * update unitymenus to commit a12a4a6befd8688495b966fb4741f61242740389
   * Menus should now correctly show/hide when (not) needed (LP: #1044657)

libreoffice (1:3.6.1~rc2-1ubuntu4) quantal; urgency=low

   * No-change rebuild for libpoppler27 -> libpoppler28 transition.

libreoffice (1:3.6.1~rc2-1ubuntu3) quantal-proposed; urgency=low

   * Fix i386 FTBFS with s/VX/XV/ and adding a missing cat in debian/rules.

libreoffice (1:3.6.1~rc2-1ubuntu2) quantal-proposed; urgency=low

   * test for ca-XV files before trying to use them
     - ca-XV l10n files are special-cased in that they are merged in the ca l10n
       packaged
     - the libreoffice-l10n-* files are generated by gid2pkgdirs.sh
     - for an binary-only, arch dep-only build ca-XV might be set in
       LANGPACKISOS and HELPISOS, even though we do not pass such parameters to
       ./autogen.sh and thus neither scp2 nor gid2pkgdirs.sh generate any l10n
       package files
     - this wasnt discovered on the ppa builds because of ppa filesystem
       limitations, we can only building with a subset of l10n (not ca-XV) there,
       thus shadowing the issue, even though we do binary-only, arch dep-only builds.

libreoffice (1:3.6.1~rc2-1ubuntu1) quantal-proposed; urgency=low

   * version bump for quantal main including upstream, debian and unitymenu
     fixes
   * update unitymenus to commit 91f332524f3b632b3e96d69921e2593c161f0ea5

libreoffice (1:3.6.1~rc2-1ubuntu1~ppa1) quantal; urgency=low

   * merge from debian 3.6.1~rc2-1
   * waiting for clucene FFE (lp#1042192)
   * make libreoffice-draw recommend libreoffice-pdfimport (LP: #966498)
   * update unitymenus to commit e9db2efab56f37b59fc10da18af73d9cf09846d8

libreoffice (1:3.6.1~rc2-1) experimental; urgency=low

   * new upstream release candidate
     - fixes CVE-2012-4233 / HTB23106
 
   * debian/patches/debian-debug.diff: patch new gb_SYMBOLS in unxgcc.mk to
     make ENABLE_SYMBOLS=SMALL (-g1) working again..
   * debian/patches/debian/patches/kfrebsd-add-missing-P_SEP.diff: fix Java build
     on kfreebsd (non-broken CLASSPATH)
 
   * src/2ab442d169156f34c379c968f3f482dd-zlib-1.2.7.tar.bz2: remove
     zlib-1.2.7/doc/rfc195{0,1,2}.txt (closes: #685133)
 
   * debian/rules:
     - save some space/build time: build only with en-US in build-arch first
       and build sdext/mysqlc (localized help/descriptions) manually with all
       languages after make check; remove buildd special-casing for
       languages
   * debian/control.fonts.in: remove ttf-opensymbol transitional package
   * debian/control.in:
     - remove obsolete sharutils, po-debconf and wget | curl build-deps

libreoffice (1:3.6.0~rc4-0ubuntu3) quantal-proposed; urgency=low

   * backport patch to evade fdo#51324 (LP: #1017125)
   * pure white progress bar is better for now (LP: #1026059)
   * reenable subsequentcheck
   * update patch queue:
     - readd split-binfilters-and-evo.diff from debian
     - add backported dont-let-autoextension-interfere-with-kfiledialog.diff
       from debian
     - remove obsolete force C++ ABI patch
     - remove obsolete lp-904212-add-missing-mimetypes-to-impress.desktop.diff
     - remove obsolete remove-broken-mysqlcon-version-check.diff
     - remove unoapi-test disabling patch, now that we seem to evade lp#1017125
   * reenable reportbuilder for universe ppa builds only (LP: #992232)
   * add packagekit patch
   * add unitymenus patch

libreoffice (1:3.6.0~rc4-0ubuntu1) quantal-proposed; urgency=low

   * update to upstream rc4

libreoffice (1:3.6.0~rc2-0ubuntu3) quantal-proposed; urgency=low

   * remove reportbuilder dep as long as we still have it disabled
   * disable help on armel,armhf for now because of build breaker in
     helpcontent2/util/sdatabase

libreoffice (1:3.6.0~rc2-0ubuntu2) quantal; urgency=low

   * remove build-conflict against gcc-4.7
   * disable subsequentcheck for this (first) upload

libreoffice (1:3.6.0~rc2-0ubuntu1) quantal; urgency=low

   * new upstream rc
   * switch to libservlet 3.0 API (LP: #1023405)
   * revert 78c2f91bd0ba744ddacb908457a18ca6537c8017
   * temp. disable reportbuilder for it needs 17 MIRs still

libreoffice (1:3.6.0~beta3-0ubuntu1~ppa1) quantal; urgency=low

   * new upstream beta
   * merge from debian
   * revert gconfbe temporary hack

libreoffice (1:3.6.0~beta2-0ubuntu1~ppa3) quantal; urgency=low

   * force disable HAVE_CXX0X for ABI incompatibilty
   * keep xmloff unoapi disabled on gcc-4.7 builds for now, even though we
     ourselves should be good

libreoffice (1:3.6.0~beta2-0ubuntu1~ppa2) quantal; urgency=low

   * rebase on debian

libreoffice (1:3.6.0~beta2-0ubuntu1~ppa1) quantal; urgency=low

   * new upstream beta
   * fix gcc versioning
   * disable broken pdfimport test for now

libreoffice (1:3.6.0~beta1-0ubuntu5) quantal; urgency=low

   * new upstream beta, rebasing on debian
   * build against gcc 4.6 (related: lp#1007616)

libreoffice (1:3.6.1~rc1-2) experimental; urgency=low

   * debian/rules:
     - revert "build-depend against libpng-dev instead of libpng12-dev"
       as it breaks on the buildds which install the libpng from experimental
       (fails GTK3 pkg-config test) (reopens: #662411)
     - fix build and install targets to prevent build-arch be called under
       fakeroot, thanks rleigh for the hints

libreoffice (1:3.6.1~rc1-1) experimental; urgency=low

   * new upstream release candidate
     - fixes splashscreen location in multi-monitor setups
       (closes: #657444, #431473)
     - caches fontconfig font substitutions (closes: #631308)
     - fixes dot handling in KDE File Picker (closes: #645946)
 
   * debian/patches/build-dont-run-checks.diff: as name says
 
   * debian/rules:
     - new conditionals for: doxygen, libcdr, liblcms2
     - remove liblucene2-java stuff; now clucene is used
     - build-depend on libxml2-utils, xmllint now needed
     - build-depend on liboost-date-time-date, we now link to boost...
     - build-depend against libpng-dev instead of libpng12-dev
       (closes: #662411)
     - remove squeeze-backports stuff, add wheezy-backports
     - install upstreams README(_en-US) (closes: #676340)
     - clean up some warnings:
       + readd /usr/lib/`dpkg-architecture -qDEB_HOST_MULTIARCH`/libfakeroot
         to LD_LIBRARY_PATH for dh_shlibdeps
       + don't run jh_depends -i/-a, use -p for each package, otherwise it
         gets confused by help.jar/s*.jar which is just zips, no "real" jar
     - switch to default-jdk, b-d on default-jdk (>= 1:1.7-48) on ia64 and
       check for "OpenJDK" in tests yes/no clause for JDK=default
     - add ENABLE_HELP conditional now that we have --without-help; also
       add the new --disable-extensions and --disable-database-connectivity to
       their respective places
     - split build into build-{arch,indep}
     - use generic python3.pc instead of pythonX.Y(mu).pc
   * debian/uno-libs3.symbols: update
   * debian/libreoffice-common.links.in:
     - s/libreofficeoasis/libreoffice-oasis/, thanks Jakub Wilk
       (closes: #683784)
   * debian/shell-lib-extensions.sh, debian/rules,
     debian/libreoffice-common.lintian.overrides.in: unopkg sync not
     necessary anymore; remove. javasettingsunopkginstall.xml also gone
   * debian/*.p*.in, debian/*.triggers.in: remove obsolete triggers and
     sync_extensions calls (closes: #677146)

libreoffice (1:3.5.4-7) unstable; urgency=high

   * debian/patches/CVE-2012-2665*.diff: fix CVE-2012-2665
     ("Multiple heap-based buffer overflows in the XML manifest
      encryption handling code")
 
   * debian/control.in: drop "| ttf-opensymbol" from -core and -math depends
     (closes: #682462)

libreoffice (1:3.5.4-6) unstable; urgency=medium

   * debian/patches/CVE-2012-2334-clip-max-entries.diff: add additional
     fix for CVE-2012-2334 from Florian Weimer which we missed to apply
     so far..
 
   * debian/templates/soffice-template.desktop.in: fix Icon= (remove
     obsolete 3), thanks Miros◈aw Zalewski (closes: #678313)
   * debian/control.in: make -filter-mobiledev Break libreoffice-core
     (<< 1:3.5~) (closes: #633929)
   * debian/control.mediawiki.in: add missing epoch to -core dependency
   * debian/rules: re-enable -gcj

libreoffice (1:3.5.4-5) unstable; urgency=low

   * debian/patches/evolution-3.4.diff: as name says,
     add libebook-1.2.so.13
 
   * debian/python{,3}-uno.NEWS: add missing )
   * debian/*.bug-script: add -draw to libreoffice report-with:;
     report libreoffice-script-provider-python with python(3)-uno

libreoffice (1:3.5.4-4) unstable; urgency=high

   * debian/patches/make-shortcuts-in-menus-localized-again.diff:
     backport from libreoffice-3-5; as name says, regression from 3.5.3
   * debian/patches/fix-legacy-report-opening.diff: backport fixes from
     libreoffice-3-5; as name says
   * debian/patches/s390-remove-fsigned-char.diff: move ...
   * debian/patches/fix-signed-char-mess.diff: ... here and add same
     fixes for gbuild modules - and m68k ;)
 
   * debian/rules:
     - re-enable Base on armel/armhf; apparently also fixed by
       yyinput-fix-for-unsigned-char.diff
     - remove i386/amd64 special-casing, run junit checks on all archs
     - remove obsolete rm -rf preventing -report-builders contents getting
       packaged, thanks Björn Michaelsen for pointing out the empty package
   * debian/changelog:
     - mention recent security fixes in respective changelog entries

libreoffice (1:3.5.4-3) unstable; urgency=medium

   * debian/patches/ppc-readd-fsigned-char.diff: sigh. actually breaks.
     revert.
   * debian/patches/s390-remove-fsigned-char.diff: remove -fsigned-char
     to fix smoketest
 
   * debian/rules:
     - re-enable extensions on s390(x)
     - actually enable evolution on s390x - and don't ship an empty package
       if -evolution is disabled

libreoffice (1:3.6.0~alpha1-0ubuntu1) quantal; urgency=low

   * first upstream alpha

libreoffice (1:3.5.4-2) unstable; urgency=medium

   * debian/patches/ppc-readd-fsigned-char.diff: backport
     7ef203d2bf72f7d96fd10d1297af06e82550a1c4 from master, as name says
 
   * debian/rules:
     - sigh. fix $(error clause in gcj builds

libreoffice (1:3.5.4-1) unstable; urgency=medium

   * LibreOffice 3.5.4 final (identical to rc2)
 
   * upload to unstable
 
   * debian/patches/tests-fix-build-with-jdk7.diff: backport root fix
     7e6a58014864ddafe534ed7a08ecca75fa4e4860 from libreoffice-3-5;
     remove other parts ...
   * debian/patches/jdk7.diff: ... and move here. Also add internal hsqldb
     buildfix.
   * debian/patches/fix-Test-BigPtrArray-on-64bit-bigendian.diff: backport test
     fix from Fedora, should fix s390x (closes: #666746), thanks Aurelien
     Jarno
   * debian/patches/yyinput-fix-for-unsigned-char.diff: add from Fedora;
     Fixes database opening tables on ppc if -fsigned-char is removed
 
   * debian/rules:
     - exclude s390(x) from OOO_REPORTDESIGN_ARCH to not make "libreoffice"
       depend on -report-builder-bin there as extensions (and also
       -report-builder-bin) are disabled there.
     - re-enable Base on powerpc et al. (closes: #667047)
 
   * merge from Ubuntu:
     - add control tags as per 'firefox distro add-on support'-spec

libreoffice (1:3.5.3-0ubuntu1) precise-proposed; urgency=low

   * bump version to final, use debian tarballs

libreoffice (1:3.5.3~rc2-0ubuntu1~ppa2) precise; urgency=low

   * reduce l10n set for ppa builds

libreoffice (1:3.5.3~rc2-0ubuntu1~ppa1) precise; urgency=low

   * cherry-pick 496346c9e692b7ba8ec0aa78c78cac7b71d830a5 from
     debian (LP: #986205)
     - guard libdbalo.so mv with feq PACKAGE_BASE=y...
   * upstream bugfix release 3.5.3:
     - fix colorspace conversion for greyscale bitmaps fdo#34324 [Michael Meeks]
     - cache calls to mdds:mixed_type_matrix::size, related fdo#47299 [Markus Mohrhard]
     - clrContourCache for SwAnchoredDrawObjects fdo#45376 [Andreas Schierl]
     - copy column privileges into table privileges fdo#47937 [Lionel Elie Mamane]
     - cppcanvas: processEMFPlus: fix valgrind warning: fdo#42252 [Michael Stahl]
     - disable cairo canvas on Windows fdo#46532, fdo#46901, fdo#45584 [Michael Meeks]
     - do not increase height of checkboxes fdo#47963 [David Tardon]
     - do not play sound in presenter console fdo#33914 [David Tardon]
     - docx, no mso-fit-shape-to-text means the textbox size is fixed bnc#751573 [Cédric Bosdonnat]
     - export all style information to xls/xlsx, fdo#46738 [Markus Mohrhard]
     - fdo43752: PPTX import fix affected odp imports. bnc#719989, bnc#719997 [Muthu Subramanian]
     - find install location during help pack install fdo#48411 [Andras Timar]
     - fix - edge-case trans gradients came out empty fdo#33591 [Thorsten Behrens]
     - fix - use older ODF encryption by default fdo#47484 [Thorsten Behrens]
     - fix RTF import of \page in inner groups fdo#48104 [Miklos Vajna]
     - fix RTF import of all capitals char prop fdo#46955 [Miklos Vajna]
     - fix RTF import of character encoding in footnotes fdo#45182 [Miklos Vajna]
     - fix RTF import of custom fonts in substreams fdo#45394 [Miklos Vajna]
     - fix RTF import of mixed super/nonsuper text fdo#47326 [Miklos Vajna]
     - fix RTF import of multi-paragraph exact height textboxes fdo#47036 [Miklos Vajna]
     - fix RTF import of shapes inside text frames at the start of the doc fdo#47036 [Miklos Vajna]
     - fix RTF import of tables with empty first row fdo#45394 [Miklos Vajna]
     - fix RTL menu rendering on Windows fdo#42537 [Ivan Timofeev]
     - fix border printing: fdo#38635 [Michael Stahl]
     - fix crash on RTF import of shapes inside tables fdo#47802 [Miklos Vajna]
     - fix the fix so it doesn't crash lp#905355, fdo#43895 [Michael Stahl]
     - fix vcl alpha blending bnc#714787 [Thorsten Behrens]
     - fix vertical align when switching mode in multibar fdo#44140 [Noel Power]
     - fixed pdf export (of images). bnc#717947 [Muthu Subramanian]
     - handle various busted rtf docs without hanging fdo#48640 [Caolán McNamara]
     - improved label/BC wizard - set paper size fdo#44516 [Winfried Donkers]
     - increase nCol before next iteratation to prevent loop, fdo#46220 [Markus Mohrhard]
     - macros: Macro to set filter in Calc does not work with .StringValue fdo#46983 [Takeshi Abe]
     - make "Replace All" work with REs fdo#44861 [David Tardon]
     - match version in about dialog and file properties fdo#47840 [Petr Mladek]
     - more reliable way to check for RTL text. fdo#48431, fdo#32530 [Kohei Yoshida]
     - never let users save in /tmp by default lp#905355, fdo#43895 [Andrzej J. R. Hunt]
     - RTF/DOCX import: fixed the import of consecutive frames fdo#47036, bnc#703032 [Cédric Bosdonnat]
     - removed strange non-wrapping condition bnc#750258, i#40155 [Cédric Bosdonnat]
     - resolved CSV import got confused by erroneous HTML detection fdo#40021 [Eike Rathke]
     - resolved the current document is not always the first in list rhbz#813280 [Eike Rathke]
     - revert "make text wrapping work in headers/footers too " fdo#39155 [Cédric Bosdonnat]
     - rtftok: initial PN (legacy numbering syntax) support fdo#47107 [Miklos Vajna]
     - rtftok: support bullet points in paragraph numberings fdo#47107 [Miklos Vajna]
     - shift+F3 should be the shourtcut for Edit > Duplicate in Draw fdo#48584, fdo#32559 [Andras Timar]
     - show synchronized checked only if all margins are the same, related fdo#44337 [Markus Mohrhard]
     - sw: fix border corner gaps: fdo#38635 [Michael Stahl]
     - swNodes: fix inconsistent outline check: rhbz#789022 [Michael Stahl]
     - TOC dialog, Entries tab: the right arrow button does not work fdo#40948 [Ivan Timofeev]
     - this hack in no longer needed, fdo#44337 [Markus Mohrhard]
     - use fabs for double values, not abs, fdo#47632 [Markus Mohrhard]
     - use of pointer to deleted object fdo#47068 [Caolán McNamara]
     - use same border width information for xls import and export, fdo#44742 [Markus Mohrhard]
     - use x.y.z version also for desktop integration packages fdo#47840 [Petr Mladek]
     - fix find toolbar X error handling fdo#46687 [Michael Meeks]
     - add unit test for Converter::convertDouble fdo#48969 [Michael Stahl]
     - border paint ordering: fdo#45562, fdo#47717, fdo#42750 [Michael Stahl]
     - default to Office 2007/2010 filter for ooxml export, fdo#48941 [Markus Mohrhard]
     - duplicated characters in PDF import fdo#45848 [Korrawit Pruegsanusak]
     - fix RTF import of special unicode characters fdo#48356 [Miklos Vajna]
     - getConversionFactor: add inch as source unit fdo#48969 [Michael Stahl]
     - ignore corrupted items in Recent Documents fdo#46074 [Stephan Bergmann]
     - paint borders in SwFlyFrm::Paint: fdo#45562 [Michael Stahl]
     - resolved update sheet-local named expressions correctly fdo#48856 [Eike Rathke]
     - switch units in Converter::convertDouble fdo#48969 [Michael Stahl]

libreoffice (1:3.5.4~rc2-1) experimental; urgency=low

   * new upstream release candidate
 
   * debian/rules:
     - really disable -gcj package completely (not just empty package)
     - surrender and disable mozilla plugin. broken again for whatever
       non-LO reason.

libreoffice (1:3.5.4~rc1-1) experimental; urgency=low

   * new upstream release candidate

libreoffice (1:3.5.3-3) unstable; urgency=low

   [ Rene Engelhard ]
   * debian/patches/ignore-sc_cellrangesbase-fails.diff:
     make .IGNORE actually work
   * debian/patches/wiki-publisher-add-missing-xsls.diff:
     add missing .xsls for -wiki-publisher
   * debian/rules:
     - (temporarily) stop building -gcj even on kfreebsd-* to be able to get into
       testing (otherwise gcc-defaults is blocking...)
   * debian/mysqlcppconn-mysqlclient-SONAME.diff: move ...
   * debian/mysqlcppconn-libmysqlclient-SONAME.diff: ... and dynamically determine
     libmysqlclient_r.so.XX in internal mysqlcppconn
 
   [ Andreas Beckmann ]
   * debian/shell-lib-extension.sh: set HOME to $INSTDIR also for
     unopkg list --bundled  (Closes: #669271). Most probably also
     closes: #619263 as $HOME isn't touched anymore.

libreoffice (1:3.5.3-2) unstable; urgency=low

   * upload to unstable
 
   * debian/patches/mozilla-profile-absolute-paths.diff: add patch from
     libreoffice-3-5 branch to respect absolute paths for mozilla profile
     (closes: #659733)
   * debian/patches/more-robust-nss-initialization.diff: add patch from
     master to fall back to without profile if path is invalid or profile
     does not exist
   * debian/patches/fix-bean.diff: add patch from master to fix bean after
     switching to gbuild

libreoffice (1:3.5.3-1) experimental; urgency=low

   * LibreOffice 3.5.3 final (identical to rc2)
 
   [ Rene Engelhard ]
   * debian/patches/ignore-sc_cellrangesbase-fails.diff: as it says; gives
     OK but (sometimes!) segfaults after it.
   * debian/patches/smoketest-disable-db-insert-delete-seek-tests.diff: move ...
   * debian/patches/disable-db-tests.diff: ... here and also disable dbaccess
     complex patch if Base disabled
 
   * debian/rules:
     - guard libdbalo.so mv with feq PACKAGE_BASE=y...
     - use make -k check
 
   [ Björn Michaelsen ]
   * add missing mimetypes to impress.desktop (LP: #904212)

libreoffice (1:3.5.3~rc2-1) experimental; urgency=low

   * new upstream release candidate
 
   * debian/patches/gcc-4.4.dif: fix gtk3 build with gcc 4.4
 
   * debian/rules:
     - only ship (and build) unowinreg.dll for i386/amd64. Probably not used
       on other archs and it saves us the g++-mingw-w64-i686 build-dep there
     - use gcc 4.4 on mips a) for consistency b) as 3.5.3~rc1-1 bus errord on
       ball, too
     - readd move of libdbalo.so to -base-core (closes: #670350)
   * debian/shell-lib-extension.sh: also set HOME to $INSTDIR for unopkg
     (as -env=UserInstallation doesn't work (anymore) - closes: #669271
   * debian/libreoffice-common.postrm.in: fix typo to actually try to rm -rf
     /var/lib/libreoffice/share/prereg

libreoffice (1:3.5.3~rc1-1) experimental; urgency=low

   * new upstream release candidate
     - additional fixes for png for SA47244/CVE-2012-1149
 
   [ Rene Engelhard ]
   * debian/rules:
     - build-depend on new g++-mingw-w64-i686 instead of the whole thing
     - use gcc 4.4 on mipsel
   * debian/libreoffice-common.links: move ...
   * debian/libreoffice-common.links.in: ... here again as we need to
     subsitute @OODIR@ (closes: #669138)
 
   [ Björn Michaelsen ]
   * add visio mimetype to libreoffice draw desktop file

libreoffice (1:3.5.2-4) unstable; urgency=medium

   * debian/patches/icu-4.9.diff: backport fix from libreoffice-3-5
     for ICU >= 4.9 support
   * debian/patches/fix-system-lpsolve-build.diff: use -Wl$(COMMA)-rpath as
     otherwise gbuild strips everything after the , away;
     makes it actually set the rpath and fixes gcc 4.7 build
   * debian/patches/tests-fix-build-with-jdk7.diff: fix tests (connecticity
     and dbaccess) build with OpenJDK7 for some modules, thanks Douglas Mencken
     for the hint. Not complete yet so this disables sfx2,sw,unoxml tests for
     jdk7
   * debian/patches/gcc-4.7.diff: add also fix for sal/qa/osl/osl_Mutex.cxx
   * debian/patches/disable-sc-sw-unoapi-subsequentcheck-for-now.diff: move ..
   * debian/patches/disable-unoapi-subsequentcheck-for-now.diff: ... here and
     disable all unoapi tests, still too flaky (should be better in master...)
 
   * debian/rules:
     - readd gcc-$(GCC_VERSION), g++-$(GCC_VERSION) build-deps if
       GCC_VERSION != ""....
     - actually add epoch to libqt4-dev builddeps...
     - revert JDK7 test workaround from last upload again
     - build-depend on make >= 3.81-8.2 instead of 3.82 now that sid is also fixed;
       PARALLEL_BUILD=y again
   * debian/python{,3}-uno.preinst.in: only run extension stuff when upgrading
     from version where the extension was here ...
   * debian/libreoffice-script-provider-python.preinst.in: ... and copy
     (old version) here
   * debian/control.in:
     - readd libreoffice-core (<< 1:3.5~), libreoffice-common (<< 1:3.5~)
       conflicts again (lost when moved to -script-provider-python) to help
       upgrades (closes: #666523)
     - make libreoffice-core Pre-Depend on ure
   * debian/debian/shell-lib-extensions.sh: run unopkg list before trying
     to sync; hopefully catches cases where unopkg doesn't (yet) work
     (closes: #668193)

libreoffice (1:3.5.2-3) unstable; urgency=low

   * brown paper bag release;
     rebuild .dsc/.debian.tar.gz with correct gcc epoch in
     Build-Conflicts: and with proper arch-qualifiers...
 
   * debian/rules:
     - use gnutls for neon again
     - disable junit tests on OpenJDK7-using archs, building
       fails
     - add ulimit -c unlimited before make check call to catch
       backtraces on sporatic soffice.bin crashes "failing" the build;
       build-depend on gdb if RUN_MAKE_CHECK=y

libreoffice (1:3.5.2-2) unstable; urgency=low

   * debian/patches/gcc-4.7{,-i386.-amd64}.diff: backport gcc 4.7 build and
     runtime(!) fixes for i386/amd64 from master
   * debian/patches/odk-jni-include.diff: remove ...
   * debian/patches/safe-jni-h-include.diff: ... in favour of this using
     gcj --print-file-name include/jni.h. thanks doko
 
   * debian/shell-lib-extensions.sh, debian/*bug-script.in:
     use --bundled instead of --shared; that's what we do and without bundled
     we don't get the info with unopkg list
   * debian/rules:
     - strip ure from uno-libs3.substvars again after the .symbols change
       (closes: #667465)
     - remove hack to use same gcc version as gcj version again
     - build-depends on libqt4-dev (>= 4.8) if SYSTEM_GCC_VERSION is 4.7...
   * debian/libreoffice-core.preinst.in: silence rmdir
   * debian/rules, debian/control.in, debian/*.triggers.in,
     debian/scripts/gid2pkgdirs.sh: split script-provider-for-python out of
     python(3)-uno out to libreoffice-script-provider-python where it belongs
   * debian/control.in:
     - build-conflict against
       gcc (>= 4:4.7~) [!i386 !amd64 !kfreebsd-i386 !kfreebsd-amd64],
       g++ (>= 4:4.7~) [!i386 !amd64 !kfreebsd-i386 !kfreebsd-amd64]

libreoffice (1:3.5.2-2ubuntu3) precise-proposed; urgency=low

   * add missing mimetypes to impress.desktop (LP: #904212)
   * Remove SalDisplay::GetKeyboardName (LP: #818761)
   * cherry-pick c6e83cc1711e5d4f1025316e0824640e73c1da2d from debian:
     - debian/libreoffice-common.postrm.in: fix typo to actually try to rm -rf
       /var/lib/libreoffice/share/prereg
   * cherry-pick 01fbc48a560cdc32a32b044c7fa290462a034479 from debian: (LP: #986205)
     - readd move of libdbalo.so to -base-core (closes: #670350)

libreoffice (1:3.5.2-2ubuntu2) precise-proposed; urgency=low

   * remove presentation templates for install media size (LP: #958384)
   * fix quicklist patch (LP: #950825)
   * add visio mimetype to libreoffice draw desktop file
   * add recommend to -gnome|-kde from libreoffice metapackage
     (LP: #841696)
   * fix typo in unity quicklist for zh_CN/Base (LP: #984893)
   * backport fix for findbar crash by Michael Meeks (LP: #975430)
   * readd updated Ubuntu brand palette colors (LP: #753627)
   * default to ~/Documents for saving, find templates in ~/Templates
     (LP: #973134)
   * tweak bibliography patch again (LP: #527938)
   * cherry-pick 0a20b5e181a4317ee838064ea122e753ab935430 from debian:
     - add ulimit -c unlimited before make check call to catch
       backtraces on sporatic soffice.bin crashes "failing" the build;
       build-depend on gdb if RUN_MAKE_CHECK=y
   * cherry-pick 1fbcf3815d89f87909e9003292d27fcf37249830 from debian:
     - debian/patches/fix-system-lpsolve-build.diff: use -Wl$(COMMA)-rpath as
       otherwise gbuild strips everything after the , away;
       makes it actually set the rpath

libreoffice (1:3.5.2-2ubuntu1) precise; urgency=low

   * Reverting 4bf0323053b4e21778f4244d111316760db008fb as we do not yet
     have synced the problematic neon-0.29.6-2 from debian to precise
     (LP: related 974103)
   * Reverting 39bf4c059665c168cf1582d7d45cd80df0a7700a as we do not
     deliver lightproof in precise
   * remove upstreamed patches
   * update lp#905355 fix
   * reenable debian hardened patch

libreoffice (1:3.5.2-1) unstable; urgency=low

   * LibreOffice 3.5.2 final (same as rc2)
 
   * debian/patches/gtk3-hack-explicit-gmodule.diff: explicitly link to
     gmodule, as we otherwise get undefined references to g_mdoule_ in the
     gtk3 VCLplug...
   * debian/patches/debian-hardened-buildflags.diff: remove extraneous ""'s
     breaking the build on ia64 as the hardened LDFLAGS is empty there
 
   * debian/rules:
     - enable Base stuff on s390x again, libebook1.2-dev available now
     - (temporarily?) build with libneon-dev (openssl) to work around #667043
   * debian/uno-libs3.lintian-overrides:
     - override shlibs-declares-dependency-on-other-package and
       symbols-declares-dependency-on-other-package
   * debian/control*.in:
     - make extensions conflicts against libreoffice-core (<< 1:3.5~),
       libreoffice-common (<< 1:3.5~) to (hopefully) help unopkg be working
       when called on upgrades 3.4 -> 3.5 (closes: #666523)
   * debian/control{,.lang}.in:
     - suggest libreoffice-grammarcheck{,-@LCODE@} (e.g. provided by
       lightproof)

libreoffice (1:3.5.2~rc2-1) unstable; urgency=low

   * new upstream release candidate
     - fixes gvfs build for glib (closes: #665574)
     - avoids looping on busted escher records e.g. ppt (CVE-2012-2334)
 
   * upload to unstable
 
   * debian/rules:
     - make make check failure abort again
     - readd apparently lost explicit --with-num-cpus=1 when PARALLEL_BUILD=n,
       the configure check apparently doesn't prevent us from failing (anymore)
   * debian/rules, debian/uno-libs3.symbols:
     - add ure dependency for stuff linked to uno-libs3, too

libreoffice (1:3.5.1-1ubuntu5) precise; urgency=low

   * do not use libreoffice-cores unopkg in preinst (LP: #969707)
   * backport dtardons fix for single job collation (LP: #925836)
   * actually install the Ubuntu presentation templates
   * cherry-picked a163c978 from master:
     - make extensions conflicts against libreoffice-core (<< 1:3.5~),
       libreoffice-common (<< 1:3.5~) to (hopefully) help unopkg be working
       when called on upgrades 3.4 -> 3.5 (closes: #666523)

libreoffice (1:3.5.1-1ubuntu4) precise; urgency=low

   * version bump for bug 930217

libreoffice (1:3.5.1-1ubuntu3) precise-proposed; urgency=low

   * fix typo in control.in

libreoffice (1:3.5.1-1ubuntu2) precise-proposed; urgency=low

   * call fsync on write (LP: #817326)
   * add a few conflicts for defusing the old -common dpkg-trigger
     around interfering (LP: #916291)
   * its com.sun.star.sdb.RowSet, not sdbc neither sbd
   * never let users save in /tmp by default (LP: #905355)

libreoffice (1:3.5.1-1ubuntu1) precise; urgency=low

   * new upstream release
     - fixes crash in QCoreApplication::notifyInternal() (LP: #925049)
     - fixes Writer crashes on Tools->Bibliography without libreoffice-base
       (LP: #527938)
     - fixes crash in SwTxtFrm::HideAndShowObjects() (LP: #872716)
     - fixes recent documents list is always empty (LP: #950071)
   * merge from debian-experimental-3.5
   * fail gracefully in -common postinst (LP: #916291)
   * kde4libs update breaks LibreOffice (LP: #958781)
   * exchange firefox-dev and xulrunner-dev order in rules rules

libreoffice (1:3.5.1-1) experimental; urgency=low

   [ Rene Engelhard ]
   * new upstream release
     - fixes up excessive numbers of "JRE is defective" messages
       (closes: #602127)
     - fixes populating "Recent Documents" after a profile upgrade
       (closes: #660185)
     - fixes nsplugin to create a correct
       com.sun.star.ucb.SimpleFileAccess instance (closes: #661747)
     - disables problematic reading of external entities in internal
       raptor copy (CVE-2012-0037)
 
   * debian/patches/armhf-bridges-doubles.diff: some more armhf fixes
     (+ testcase) from master
   * debian/patches/debian-hardened-buildflags.diff: use hardened
     buildflags from dpkg-buildflags (closes: #656643)
   * debian/patches/debian-opt.diff: fix to actually make test and grep
     work
   * debian/patches/bibliography-no-crash-if-no-base.diff: backport fix
     from libreoffice-3-5 to not crash Tools -> Bibliography if -base isn't
     installed (closes: #602953, #598809)
   * debian/patches/pyuno_fix_python2.diff: backport from libreoffice-3-5.
     As name says, fix breakages in python2 after python3 fixes
 
   * debian/rules: rename ext-sources to src, as done upstream
   * debian/control.fonts.in: make ttf-opensymbol Priority: extra, thanks
     lintian
   * debian/rules:
     - --with-mingw -> --with-mingw-cross-compiler; remove obsolete
       "export MINGWSTRIP" hack
     - don't set ENABLE_SDBC_POSTGRESQL=n when building no extensions, as
       this isn't an extension anymore
     - remove obsolete "export MINGWSTRIP" hack
     - fix (>= 1.1.9) for libcommons-logging-java to actually work, thanks
       Rico Tzschichholz
     - chmod 755 setsdkenv_unix
     - also disable graphite on alpha (closes: #661294)
     - actually filter-out also armhf and powerpc powerpcspe ppc64 s390x for
       OOO_REPORTDESIGN_ARCHS
     - remove -O0 setting via ARCH_FLAGS, already handled by debian-opt.diff
   * debian/control.in: build-conflict against
     libc0.1-dev (= 2.13-26) [kfreebsd-i386 kfreebsd-amd64]
   * debian/control.mozilla.in: stricten dependencies to 3.5, thanks
     Mario Holbe for the observation
   * debian/rules, debian/control.mozilla.in: update nsplugin conditional
     to actually disable nsplugin build (and get rid of xulrunner-dev build-dep)
     if disabled
   * debian/*.triggers, debian/*.prerm.in:
    - add activate triggers for /usr/lib/libreoffice/share/extensions to
      the respetive extensions. Run sync_extensions after rm -rf'ing the
      dir already in preinst (upgrade) (closes: #658646)
 
   [ Bjoern Michaelsen ]
   * debian/patches/fix-quickstart-shutdown.diff: fix logout with
     quickstarter (closes: #632920, #605268)

libreoffice (1:3.5.0-2ubuntu2) oneiric; urgency=low

   * reenable libexttextcat

libreoffice (1:3.5.0-2ubuntu1) precise; urgency=low

   * merge from debian-experimental-3.5 at
     a9613a0cfaf22d4fa91652cbd135787cbf61e790
   * backport a6d65732f14e49be8ec61aac53a2a8b909d810f7 by Rene
     (LP: #882588)
   * actually give the quickstarter suppressor instance a scope
   * remove failing parts of -common postinst script, they in -core
     anyway (LP: #916291)

libreoffice (1:3.5.0-2) experimental; urgency=low

   [ Rene Engelhard ]
   * debian/patches/armhf-bridges*.diff: add armhf bridges fixes from
     Jani Monoses (LP: #900636)
   * debian/patches/revert-468fe685e3c58c84bce6d9a48b931dcc21682679.diff:
     remove, obsolete
   * debian/patches/icu-arm.diff: fix internal icu build on arm.
   * debian/patches/move-binfilter-mimetypes-in-extra-desktop-file.diff:
     as name says; imported from Fedora
   * debian/patches/passwordTest-test-old-password-algorith-too.diff: as name
     says (see fdo#45171 and #659733/#659720)
   * debian/patches/getMIMEDescription-mismatch.diff: update with proper
     ./configure check, thanks Lubok Lunak...; also update internal header
 
   * debian/rules:
     - remove obsolete (and buggy) conditional icu-on-arm-fails breaking
       the build
     - apply patch from Rico Tzschichholz to update some configure flags
       to new names in 3.5.x; remove some obsolete ones
     - don't try to mv libvclplug_gtk3.so if not built, thanks Rico
       Tzschichholz again
     - disable base (libebook1.2-dev missing and nsplugin (xulrunner-dev
       missing) on s390x
     - disable all extensions on s390*, extension mechanism broken
   * debian/source/components: remove, unused and causes lintian error
 
   [ Bjoern Michaelsen ]
   * debian/libreoffice-common.postrm.in: remove mismerged superfluous fi
     (closes: #660580)

libreoffice (1:3.5.0-1ubuntu4) precise; urgency=low

   * disable reportbuilder again, java deps are just too heavy
   * drop reportbuilder deps
   * using partial internal lucene copy (again because deps)

libreoffice (1:3.5.0-1ubuntu3) precise; urgency=low

   * MIR lucene2 (LP related: #938708)
   * MIR libcmis (LP related: #938709)
   * MIR libexttextcat (LP related: #938582)
   * MIR sampleicc (LP related: #938712)
   * reenable reportdesigner

libreoffice (1:3.5.0-1ubuntu2) precise; urgency=low

   * replaces/breaks for the unopkg move
   * make gbuild use hardlinks and use linkoo in smoketest to save some
     space
   * do not run checks on powerpc armel armhf for now as they fail with
     debug output level 11 is too high rules

libreoffice (1:3.5.0-1ubuntu1) precise; urgency=low

   * Ubuntufy splash progress
   * merge from debian-experimental-3.5

libreoffice (1:3.5.0-3) UNRELEASED; urgency=low

   * debian/patches/armhf-bridges-doubles.diff: some more armhf fixes
     (+ testcase) from master
 
   * debian/control.fonts.in: make ttf-opensymbol Priority: extra, thanks
     lintian

libreoffice (1:3.5.0-1ubuntu1~ppa2) precise; urgency=low

   * remove failing smoketest cleanup code for now

libreoffice (1:3.5.0-1ubuntu1~ppa1) precise; urgency=low

   * reenable EVO2 and MEDIAWIKI extensions (reduces delta to debian)
   * move unopkg wrapper from -common to -core to allow extension
     registration
   * do extension registration from -common to -core because we actually
     have the binaries (unopkg.bin etc.) to do it there (LP: #917153)
   * cherry-picked from debian-experimental-3.5:
     debian/libreoffice-common.postrm.in: remove mismerged superfluous fi
   * use source tarballs from debian

libreoffice (1:3.5.0-1) experimental; urgency=low

   * LibreOffice 3.5.0 final release (identical to rc3)
 
   * debian/patches/no-rcX-in-final.diff: don't show rc3, it's not a rc
     amymore...
   * debian/patches/patches/make-gengal-work-again.diff: register gengal.bin
     executable to get proper rpath and remove gengalrc
   * debian/patches/odk-fix-rdb-paths.diff: backport fix to fix rdb path
     in settings/std.mk in the SDK
 
   * debian/rules:
     - install found .gdb-py files into respective -dbg packages
     - add additional libpoppler-private-dev build-dep for new popplers
   * debian/control.in, debian/libreofice-common.p*:
     apply patch from Colin Watson to use Pre-Depends rather than
     'dpkg-maintscript-helper supports' guards (closes: #659867)
   * debian/watch: point to download.documentfoundation.org/libreoffice/src
     instead of dev-builds

libreoffice (1:3.5.0~rc3-1) experimental; urgency=low

   * new upstream release candidate
 
   * debian/patches/SwTblBoxFormula-destructor.diff: work around link error
     on armel by specifying explicit SwTblBoxFormula destructor, thanks
     Michael Meeks
   * debian/patches/ia64-oox-size.diff: build oox on ia64 with -Os
     as otherwise it gets too big to link
   * debian/patches/mediwiki-oor-replace.diff: replace oor:fuse by oor:replace
     for -wiki-publishers config (hopefully closes: #616011)
 
   * debian/rules:
     - give gb_FULLDEPS= to actual make check call, not debian/rules
       check
     - simplify -dbg/--enable-symbols conditionals
     - build with default boost again but add build-dep on g++-4.6 (>= 4.6.2-12)

libreoffice (1:3.5.0~rc2-2) experimental; urgency=low

   * debian/rules:
     - fix another merge error to really fix patch rule in check
     - enable ca-XV, put into -{l10n,help}-ca

libreoffice (1:3.5.0~rc2-1) experimental; urgency=low

   * new upstream release candidate
 
   * debian/rules:
     - fix patch rule in check
     - fix merge errors: $(ARCH) -> $(DEB_HOST_ARCH)
     - install full changelog only for packages with the same name in OOo
       times; strip pre-libreoffice entries otherwise.
     - (re-)enable -script-provider-js
   * debian/libreoffice-common.postrm.in: fix merge:
     @OOBRANDDIR@/@OOBASISDIR@ -> @OODIR@

libreoffice (1:3.5.0~rc1-1) experimental; urgency=low

   * new upstream release candidate
 
   * debian/patches/gbuild-JavaClassSet-honour-JAVAFLAGS.diff: honour
     JAVAFLAGS (-source 1.5 -target 1.5)
 
   * debian/rules:
     - fix Java stuff in SDK install (don't remove /usr/share/libreoffice/sdk)
     - work around smoketest failure; disable base for powerpc(spe)/ppc64 as
       for armel
     - switch to .xz tarballs, upstream will only provide those...
 
   * merge from ubuntu-precise-3.5:
     - re-enable junit tests

libreoffice (1:3.5.0~beta2-2ubuntu4) precise; urgency=low

   * demote lucene and java-common recommends to suggests for help
     packages again (LP: #916726)

libreoffice (1:3.5.0~beta3-1) experimental; urgency=low

   * new upstream beta release
 
   * debian/patches/fix-ARM-detection-in-set-soenv.diff: fix for armhf...
   * debian/patches/revert-468fe685e3c58c84bce6d9a48b931dcc21682679.diff:
     fix armhf build in bridges...
   * debian/patches/ppc-fix-soffice.sh.diff: make soffice.sh on ppc correct
   * debian/patches/jdbc-driver-threading.diff: backport fix for
     Attach/Detach-CurrentThread slowness from libreoffice-3-5
     (closes: #644957)
 
   * debian/libreoffice-core.preinst.in:
     - rm -f /var/lib/libreoffice/basis3.4/program/services.rdb on upgrade
       (and for safety on install, too) (closes: #650341)
   * debian/libreoffice-{common,core}.postrm.in:
     - on remove, remove all /var/lib content on remove (prereg/bundled
       basisX.Y)
   * debian/rules:
     - stop creating a dependency on ure for uno-libs3 in .shlibs, use
       uno-libs3 instead
     - specify correct --with-servlet-api= after recent libcommons-logging-java
       changes
   * debian/uno-libs3.symbols:
     - use uno-libs3, not ure as dependency
   * debian/control.ure.in:
     - remove obsolete cli-uno-bridge Suggests
 
   * merge from ubuntu-precise-3.5:
     - add debian multiarch support for Qt4
     - no dependencies needed for full builds
       + propagate gb_FULLDEPS
     - get rid of obsolete BrOffice specialcasing (LP: #884786)
     - enable l10n
   * merge from libreoffice_3.5.0_beta2-2ubuntu2
     - enable gio, disable gvfs

libreoffice (1:3.5.0~beta2-2ubuntu3) precise; urgency=low

   * enable l10n
   * get rid of obsolete BrOffice specialcasing (LP: #884786)
   * add control tags as per 'firefox distro add-on support'-spec (picked
     from oneiric-3.4)
   * enable human theme and make it the default for gtk desktops
   * cherry-pick Replaces commit from 3.4 (LP: #705343)
   * cherry-pick demotion of java-Recommends for -writer to Suggests
   * make preinst cleanup a bit more robust (LP: #915271)

libreoffice (1:3.5.0~beta2-2ubuntu2) precise; urgency=low

   * enable gio, disable gvfs
   * backport fpicker kde4 workaround by Lubos Lunak

libreoffice (1:3.5.0~beta2-2ubuntu1) precise; urgency=low

   * reenable junit tests
     - however, disable sc unoapi tests for now
     - unset DISPLAY for subsequenttests
   * no dependencies needed for full builds
     - propagate gb_FULLDEPS
   * SOURCE_TREE still needed as root path
   * also look for mozilla-plugin with pkg-config
   * allow firefox-dev as alternative to xulrunner-dev
   * for now, use internal:
     - libcmis
     - lpsolve
     - libvisio
     - lucene
     - libexttextcat
     - graphite
     - sampleicc
   * for now, disable:
     - reportdesign
     - smoketest on powerpc and armel

2011

libreoffice (1:3.5.0~beta2-2) experimental; urgency=low

   * debian/patches/fix-ARM-detetcion-in-set-soenv.diff: as name says
   * debian/patches/make-package-modules-not-suck.diff: add missing , so
     that kde4be1.uno.so correctly ends up in -kde
 
   * debian/smoketest/patches/smoketest-disable-db-insert-delete-seek-tests.diff,
     debian/rules: make patch apply again
 
   * debian/rules:
     - force boost to 1.46 due to ICE with 1.48
     - prevent creating bogus gcc- build-dependency on gcj archs

libreoffice (1:3.5.0~beta2-1) experimental; urgency=low

   [ Rene Engelhard ]
   * new upstream beta release
     - fixes SA47244/CVE-2012-CVE-2012-1149
     ("LibreOffice Integer Overflow" when allocation memory for images)
 
   * debian/*:
     - use "core" sources, no libreoffice-build anymore. Loads of updates.
 
   * debian/patches/*: move from patches/hotfixes to patch the code
     directly without libreoffice-build
 
   * debian/rules, debian/vars.*, debian/*.links.in:
     - loads of updates for new envfile name and gone LIBSUFFIX
   * debian/rules:
     - enable new build against Gtk3
     - bump python b-d to >= 2.6 as we don't work with earlier anymore.
       Also build python3-uno
     - add new conditionals and build-deps for new (libvisio,librsvg,gettext,
       libcmis) libraries and libexttextcat switch - and those we needed to move
       from libreoffice-builds' distro-configs. Adapt for changed configure
       options
     - add new conditionals and build-deps for new libvisio,librsvg,gettext,
       libcmis usage and libexttextcat switch - and those we needed to move
       from libreoffice-builds' distro-configs
     - run new "make check" instead of solenv/bin/subsequenttests and
       manual smoketest
     - remove fakeroot hackaround
   * debian/rules, debian/make-package-modules-not-suck.diff: migrate loads of
     mv's in debian/rules to proper scp2 patches
   * debian/rules, debian/control.in:
     - move from self-defined UPSTREAM_VERSION/ARCH etc. to use
       /usr/share/dpkg/*.mk
   * debian/control.in:
      - update descriptions for new Gtk(3) print dialog
     - move libreoffice, libreoffice-l10n-{in,za} to new metapackages
       section
   * debian/control.fonts.in: ttf-opensymbol should be in oldlibs, thanks
     lintian
   * debian/patches:
      - migrate reportdesign-mention-package.diff from libreoffice/build
      - migrate jdbc-driver-classpaths.diff from libreoffice/build
      - migrate mysqlcppconn-mysqlclient-SONAME.diff from libreoffice/build
      - migrate system-python-{ure-bootstrap,uno-path}.diff and
        pyuno-ooodir.diff from libreoffice/build
      - migrate split-icons-search-usr-share.diff from libreoffice/build
   * debian/vars.armhf: add
 
   [ Bjoern Michaelsen ]
   * debian/rules:
     - set CURDIR before first use and use safe method to set it
     - update GIT_ vars, add GIT_BASEURL for local mirrors
     - update get-orig-source
     - build needs the ext-sources
   * debian/README:
     - update most outdated README sections
   * debian/patches:
     - migrate mention-java-common-package.diff from libreoffice/build
     - migrate help-msg-add-package-info.diff from libreoffice/build
     - update help-msg-add-package-info.diff, replace openoffice.org with
       libreoffice
     - migrate sensible-ooomua.diff from libreoffice/build and rename to
       sensible-lomua; add icedove and thunderbird as fallbacks
     - migrate sensible-browser.diff from libreoffice/build

libreoffice (1:3.4.4-2) unstable; urgency=medium

   * debian/patches/libebook-1.2.so.11.diff: remove ...
   * debian/patches/libebook-1.2.so.12.diff: ... for this and update
     accordingly (evolution 3.2)
   * debian/patches/wordml2ooo_draw.xsl-add-missing-include.diff: backport
     patch from master to add missing include (closes: #648250)
 
   * debian/rules:
     - recommend fonts-thai-tlwg instead of ttf-thai-tlwg (closes: #648785)
     - disable mono in prepartion for mono transition
   * debian/control.in, debian/rules:
     - correctly disable SRB on gcj-archs
   * debian/rules, debian/control.fonts.in:
     - rename ttf-opensymbol to fonts-opensymbol

libreoffice (1:3.4.4-1) unstable; urgency=low

   * New upstream release
     - repackage liblayout and seamonkey in ext-sources to remove
       RFC/I-Ds (closes: #645753)
 
   * debian/patches/update-sdbc-postgresql.diff: update to 0.8.1
   * debian/patches/update-libreoffice.1.diff: update libreoffice.1 for
     new long parameters (closes: #646800)
 
   * debian/rules:
     - don't try to use internal jfreereport on ia64; disable the SRB
       instead.
     - fix USE_SYSTEM_TEXTCAT_DATA for squeeze
     - change debug in DEB_BUILD_OPTIONS not to do -g only but also
       --enable-debug
   * debian/watch:
     - point to libreoffice-bootstrap-(\d.\d.\d).\d.tar.bz2 in debian/watch;
       does not suffice but we should reference the source and not binaries
   * debian/rules, debian/*.menu.in:
     - also add icon version to debian menus (closes: #645953)
   * debian/control.in:
     - remove suggests on menu (closes: #647371)

libreoffice (1:3.4.3-4) unstable; urgency=low

   * debian/patches/poppler-0.17.x.diff: backport patches from master to
     make pdfimport build with poppler 0.17.x
   * debian/patches/update-sdbc-postgresql.diff: add check for
     PQconnectdbParams in -lpq
 
   * debian/rules:
     - use jh_classpath instead of manual MANIFEST.MF hacking for jurt.jar
     - build-depend on libpoppler-cpp-dev
     - fix libsslX.Y.Z in -dbgs suggests for multiarch
     - use internal jfreereport on squeeze-backports
     - keep -g1 on squeeze-backports
     - use mingw-w64 for unowinreg.dll build (closes: #642954)
     - build-dep on libpq-dev (>= 9.0~) for PQconnectdbParams
     - add libhunspell-1.3-0-dbg to DBG_DBG_SUGGESTS
     - remove PYTHON_HELPER conditional, we use dh_python2 anywhere and
       lintian just spits out false positives...
 
   * merge from ubuntu-oneiric-3.4:
     - hard hack to make upload happy: Pre-Depends on xz-capable dpkg
       for -dbg

libreoffice (1:3.4.3-3) unstable; urgency=low

   * debian/patches/jdk-1.7.0-vendorname.diff: backport from master; allow
     "Oracle Corporation" JDK >= 1.7.0 (closes: #642425)
   * debian/patches/s390x.diff: add patch from aurel32 to fix build on s390x
     (closes: #642951)
 
   * debian/rules:
     - build against "normal" pentaho libraries again, in new upstream versions
       (closes: #641594)
     - build with -g on {,kfreebsd}{i386,amd64} (similar to linux-2.6's -dbgs)
       as policy says. Compress with xz
     - allow openjdk 7; build against it on ia64 even when the rest is at 6
     - stop building -gcj on all openjdk-archs, keep it on gcj-using archs
     - build with gcc 4.6 again, add build-conflicts on g++ 4.6.1-10 and -11
 
   * merge from ubuntu-oneiric-3.4:
     - fixing crash on closing document with footnotes (LP: #854626)
     - fixing crash on screen resolution change (LP: #852819)

libreoffice (1:3.4.3-2) unstable; urgency=medium

   [ Rene Engelhard ]
   * debian/patches/no-deprecated-options-in-qstart-wrappers.diff: use --writer
     instead of -writer (closes: #638868)
   * debian/patches/fix-sample-icc-1.3.2-patch.diff: backport from master:
     re-enable patch hunk to fix PDF A/1-a export on 64bit archs, thanks lmamane
     for the patch (closes: #633480)
   * debian/patches/update-sdbc-postgresql.diff: update SDBC PostgreSQL
     driver to Lionels new LibreOffice version.
   * debian/patches/handle-NULL-display-gracefully.diff: backport from
     libreoffice-3-4
 
   * debian/control.in:
     - remove obsolete Pre-Depends on debconf in ure
     - add Breaks: on incompatible -cores on -common (basis-link symlink)
       (closes: #641357)
   * debian/control.postgresql.in: add (>= 8,4) to postgresql suggests to make
     more visible that we need >= 8.4 of PostgreSQL. Update Homepage for new
     LibreOffice location
   * debian/control.reportdesign.in: make -report-builder depend on
     -report-builder-bin (>= ${base-version}) (closes: #640900)
   * debian/rules:
     - re-enable -sdbc-postgresql
     - fix adding PYTHONPATH to unopkg (closes: #625878)
     - temporarily build with gcc 4.5 as gcc 4.6.1-10 breaks the vcl build
   * debian/libreoffice-common.links, debian/rules:
     - fix mimetype icon links for hicolor (closes: #641860)
 
   [ Lionel Elie Mamane ]
   * debian/rules: we need translate-toolkit (>= 1.9.0)

libreoffice (1:3.4.3-1) unstable; urgency=low

   * New upstream release
     - fixes Out-of-bounds read in DOC sprm (CVE-2011-2713)
 
   * debian/patches/fdo35784.diff: add patch from fdo35784, thanks lmamane
   * debian/patches/mipsel-jfw-plugin-arch.diff: fix JFW_PLUGIN_ARCH
     (s/mips32/mipsel/) in jvmfwk for mipsel, thanks Aurelien Jarno
   * debian/patches/oosplash-javaldx-path.diff: fix javaldx path in oosplash
     (closes: #637829)
 
   * debian/rules:
     - try build with openjdk on mipsel again now that jvmfwk knows the
       correct arch
     - fix SYSTEM_STUFF for ENABLE_JAVA=n
     - don't try to run dh_nativejava if ENABLE_JAVA=n
     - adapt for /usr/lib/jvm/java-6-openjdk -> /usr/lib/jvm/java-6-openjdk-$ARCH
       move in OpenJDK

libreoffice (1:3.4.2-2) experimental; urgency=low

   * debian/patches/make-gengal-work-again.diff: as name says
   * debian/patches/fix-distro-config.diff: really use system sane.h
 
   * debian/rules:
     - fix syntax of graphite removal from SYSTEM_STUFF (forgot s/+=/:=/)
     - install gengal again
     - on sid (and when building with debug), compress -dbg with xz; make bzip2
       compression unconditional

libreoffice (1:3.4.2-1) experimental; urgency=low

   * new upstream release
 
   * debian/patches/*: migrate to libreoffice-build/hotfixes where possible
   * debian/rules:
     - try gcj again on mipsel, stay with OpenJDK for mips
     - use system-graphite again, disable graphite on armel and sparc for
       the time being as we don't have a graphite2 which doesn't fail its tests
       there yet

libreoffice (1:3.4.1-4) experimental; urgency=low

   * debian/rules:
     - don't statically check for /build/buildd- but use grep, which will
       catch also /build/buildd2- as on lucatelli2...
     - reverse conditional to not build reportbuilder to really disable
       its build on gcj archs (apparently ant and envvars still broken due
       to multiarch)
     - add libstlport4.6-dev builddep only when something is in
       OOO_STLPORT_ARCHS, don't rely on LINK_TO_STLPORT. Not set on !i386...

libreoffice (1:3.4.1-3) experimental; urgency=low

   * debian/patches/fix-bridges-cpp-uno-depends.diff: fix mising depends in
     bridges' build.lst which can cause FTBFS on s390(x), arm, ia64, hppa, alpha
   * debian/patches/no-prctl-on-kfreebsd.diff: don't try to #include <sys/prctl.h>,
     it doesn't exist for FreeBSD
 
   * debian/rules:
     - also set ON_BUILDD=y if $(CURDIR) begins with /build/buildd-
     - build-depend on javahelper >= 0.37~ instead of >= 0.37 to help
       squeeze-backpors

libreoffice (1:3.4.1-2) experimental; urgency=low

   [ Rene Engelhard ]
   * debian/patches/vbaobj-visibility-fix.diff: fix sc build on i386, imported
     from Fedora
 
   * debian/libreoffice-common.postinst.in, libreoffice-core.postinst.in,
     debian/shell-lib-components.sh:
     check for /@OOBASISDIR@/program/.services.rdb before using it
     (closes: #633396) and replace manual call of the function by
     dpkg-trigger. Also run the trigger in -cores postinst
     (thanks Jonathan Nieder)
   * debian/control.in:
     - make new -common break old -evolution/-filter-binfilter
   * debian/rules:
     - also -Xlibreoffice-dbg on jh_depends... (closes: #633540)
     - update ENABLE_OPENGL configure flags, now --enable-opengl is default
       upstream
     - fix build with make 3.82: remove space after, in $(call; build-depend
       on make >= 3.82 if PARALLEL_BUILD=y
     - fix -javafilter.destop Exec=
     - remove obsolete libstlport4.6-dev build-conflict, thanks Björn
       Michaelsen
     - fix conditional for translate-toolkit
     - explicitly specify --without-stlport
     - temporarily build with internal graphite2 until the system graphite2
       package is ready for use
   * debian/copyright: s/Specificatin/Specification/, thanks Jakub Wilk
   * merge from ubuntu-oneiric-3.4:
     - gconf also needs liborbit2-dev
     - bump libebook so name to allow for libebook-1.2.so-11 too
     - disable --dynamic-list-cpp-new/--dynamic-list-cpp-typeino
       as they SIGSEGV ld from binutils-2.21.52.20110707
 
   [ Nelson A. de Oliveira ]
   * debian/*menu.in, debian/*mime:
     - Fix deprecated options when calling soffice and libreoffice
       (closes: #634001)

libreoffice (1:3.4.1-1) experimental; urgency=low

   * new upstream release
     - handles various table columns differing in case correct
       (closes: #617596)
     - should fix embedding of (some) fonts in PDFs (closes: #616117)
     - (still) use libreoffice-build for now; not tagged,
       use 069b0a4b4f052255c97ece23f0e37be85921fe27
 
   * debian/patches/debian-debug.diff: readd option to build with small
     symbols (removed upstream), otherwise we get a too big -dbg (760M, 2G I-S)
   * debian/patches/update-debian-opt.diff: call dpkg-buildflags correctly
 
   * debian/rules:
     - bump build-dep on libmdds-dev to >= 0.5.0
     - build-depend on libgraphite2-dev instead of libgraphite-dev
     - update for new extension and mingw configure switches
     - temprarily don't install gengal, not built anymore since the switch to
       GNU Make...
     - install .component files to registered-components
     - build-dep on translate-toolkit, now needed for translations module
   * debian/control.sdk.in, debian/rules:
     - stop building with STLport on i386, just create a symlink in ure.
       Should suffice for compat with binary-only OOo extensions
   * debian/control.in, debian/rules:
      - the script providers are now extensions. split js and bsh out into
        extra packages (also closes: #603595)
   * debian/uno-libs3.symbols: update
   * debian/rules, debian/patches/packcomponents-remove-split-components.diff:
     remove evoab, binfilter and kdeab deregistering into patch patching
     the new packcomponents
   * debian/shell-lib-components.sh: add new update_services_rdb() merging
     "default" services.rdb and the .component files from registered-components
   * debian/libreoffice-common.triggers.in, libreoffice-*.p*.in:
     new trigger running update_services_rdb, remove obsolete maintainer scripts
   * debian/changelog: mention VU#953183/CVE-2011-2685 in 1:3.3.3-1
   * debian/control.in:
     - fix description: s/libreoffice-hyphenation/hyphen/,
       s/libreoffice-thesaurus/mythes/
   * debian/rules:
     - don't try to change libreoffice-base when we don't built it
     - build-depend on javahelper (>= 0.37) and use -s
   * debian/source.lintian-overrides:
     - override new libreoffice source: dh_pycentral-is-obsolete line 3214
       and libreoffice source: dh_python-is-obsolete line 3223

libreoffice (1:3.3.3-4) unstable; urgency=low

   * The "Don't trust, test-install even libreoffice-officebean" release.
 
   * debian/rules:
     - bump javahelper build-dep to (>= 0.35)
     - exclude ure for jh_depends. Readd it manually for -officebean. jh_depends
       would add a ure (>= ${source:Version}) which doesn't match the ure
       versioning scheme.

libreoffice (1:3.3.3-3) unstable; urgency=low

   * brown paper pag release.
 
   * debian/patches/mips-openjdk-jre-paths.diff: oops, forgot JRELIBIR when
     porting the patch from gabrielli..

libreoffice (1:3.3.3-2) unstable; urgency=low

   * debian/patches/bsh-hardcode-path.diff,
     debian/patches/disable-rhino.diff: add hacks to fix build
     with the still broken gcj multiarch/ant combo. Disable rhino completely
     as we can't patch the envvar usage out in a sane way
   * debian/patches/disable-sdbc-postgresql.diff: also disable the build
   * debian/patches/mips-openjdk-jre-paths.diff: add missing jre/ to
     set_soenv for MIPS
 
   * debian/rules:
     - make multiarch changes conditional and skip them for squeeze
       (Daniel Baumann)
     - move evolocal.odb into -evolution proper
     - use OpenJDK on mips(el), seems to work. (ia64 still SIGSEGVs)
   * debian/libreoffice-filter-binfilter.links.in: actually create symlink
     for libbindet*so in registered-components
   * debian/control.in:
     - move libpaper-utils from Suggests to Recommends
     - fix libreoffice Description: - -filter-binfilter is not installed
       per default since longer (only suggested)
   * debian/control.in, debian/rules: move libpq-dev builddep to a
     conditional
   * debian/rules, debian/control*in:
     - run jh_depends and add ${java:Depends} where we have Java

libreoffice (1:3.3.3-1) unstable; urgency=medium

   * new upstream release
     - fixes VU#953183: 'Lotus Word Pro' document import filter
       multiple vulnerabilities (CVE-2011-2685)
 
   [ Rene Engelhard ]
   * debian/patches/disable-optional-outplace-ole.diff: as name says; makes
     toolbars work in e.g. Base edit forms (closes: #617319)
 
   * debian/rules:
     - disable -sdbc-postgresql until fixed (closes: #620100)
     - stop moving vbaevents*.uno.so to -calc. Move libvbaswobj*uno.so
       to -writer
     - make -l10n-sw (if enabled) depend on locales (>= 2.13-5)
     - adapt GCJ_JAWT_DIR handling for new multiarch dirs and explicitly
       give -l to the libgcj_bc.so.1 multiarch dir to dh_shlibdeps...
   * debian/control.in:
     - build-conflict against libmdds-dev (>= 0.4.0)
   * debian/rules, debian/*lintian-overrides:
     fix/override (some) new Java related lintian warnings
   * debian/rules, debian/libreoffice-filter-binfilter*.in:
     oops, we forgot to do (de-)registering for libbindet*.so
 
   [ Björn Michaelsen ]
   * debian/patches/jurt-soffice-location.diff: add the fallback
     /usr/lib/libreoffice/program/soffice to jurts NativeLibraryLoader;
     we know where it is

libreoffice (1:3.3.2-4) unstable; urgency=low

   * debian/patches/gcc4.6.0.diff: fix build with gcc 4.6, imported from
     Fedora
   * debian/patches/odk-jni-include.diff: add hack to also include e.g.
     /usr/lib/gcc/x86_64-linux-gnu/4.6.1/include explicitly to work around gcj
     mismatches
 
   * debian/rules:
     - disable smoketest on sparc, flaky

libreoffice (1:3.3.2-3) unstable; urgency=low

   * debian/rules, debian/control.in:
     - readd recommends for libtextcat-data though libtextcat0 depends on it.
       Makes more clear what we need now (see #620568)
   * debian/rules:
      - run dpkg -s gcj-jdk on openjdk-using archs only when we build -gcj,
        as otherwise it's not installed on the buildds (and we end up with a
        eventually "wrong" gcc).
      - restrict parallel=x to 2, at least 6 breaks, and don't experiment :)
      - don't reference -ctl-he anymore and fix CTLSequenceChecking setting
        in ctl_he.xcd (closes: #622301)
      - enable is (icelandic) l10n
   * debian/control.in:
     - build-conflict against at3-dev-tools, it installs a moc-qt3 alternative
       for moc, which might hose the KDE VCLplug build - and configure insists
       on ../bin/moc relative to libQt.so (thus /usr/bin/moc) now
   * debian/control.gcj.in: move -gcj into Section: java
   * debian/*.lintian-overrides*: update for new lintian 2.5.0 (s#/usr#usr#g)

libreoffice (1:3.3.2-2) unstable; urgency=medium

   * debian/patches/fix-evolution-local.diff: backport from libreoffice-3-3
     branch
 
   * debian/rules:
     - really use internal libtextcat on squeeze (thanks dba)
     - re-enable -evolution
     - hack around gcc vs. libgcj mismatch for jni.h, explicitly build against
       (and use) gcc x.y matching the gcj-x.y-jdk version
     - remove obsolete s390 and armel gcc builddeps
   * debian/libreoffice-common.postinst.in:
     - try to remove /etc/openoffice if it's empty
   * debian/*.mime:
     - s/LibreOffice/OpenOffice.org/, it's OOo 1.0 file format after all
     - add print= for OpenDocument mimetypes (closes: #619569)
   * debian/rules, debian/*.mime:
     - remove obsolete KDE 3 stuff
   * debian/shlibs.override.kde: remove, obsolete
   * debian/rules, debian/libreoffice-common.links.in:
     - remove fingerprint link, create on the fly in rules; we don't want
       this if we use the internal data

libreoffice (1:3.3.2-1) unstable; urgency=low

   * LibreOffice 3.3.2 final (identical to rc2)
 
   * debian/patches/update-debian-opt.diff: update debian-opt.diff:
     + don't hardcode -Os for m68k, mips, ARM
     + use dpkg-buildflags when available to honour noopt and to make support
       generic
 
   * debian/rules:
     - don't add shell-lib-conffiles.sh to maintscripts anymore
     - remove lenny-backport support; lenny hasn't a dpkg-maintscript-helper
     - make base-files build-conflict also work after 6.0.1
     - build with system libtextcat now that that is patched
     - call dh_python2 with -ppython-uno to work around #619005
   * debian/libreoffice-common.p*.in:
     - remove hardcoded rm_conffile. use dpkg-maintscript-helper
     - move psprint.conf, sofficerc and soffice.sh (closes: #619113)
   * debian/shell-lib-conffiles.sh: remove
   * debian/control.in:
     - Standards-Version: 3.9.1 (no changes needed)
     - make conflicts on libtextcat-data versioned

libreoffice (1:3.3.2~rc2-1) unstable; urgency=low

   * new upstream release candidate
 
   * debian/patches/arm-optimization.diff, debian/rules:
     - remove ARM fixes introduced in last revision again,
       better solution upstream
 
   * debian/control.mediawiki.in:
     - make -wiki-publisher depend on -java-common
   * debian/rules:
     - use dh_python2 (closes: #616871)
   * debian/control.in:
     - add replaces and (versioned) conflicts against mozilla-openoffice.org
       (closes: #618550)
 
   * merge from Ubuntu:
     - added ppc fixes (LP: #727118)

libreoffice (1:3.3.1-1) unstable; urgency=low

   * LibreOffice 3.3.1 final (identical to rc2)
 
   * debian/patches/arm-optimization.diff: add explicit support for
     optimization for armv4t/6/7, based on i117017
   * debian/patches/javaldx-LibreOffice.diff: s/openoffice.org/libreoffice/
     for javaldx (closes: #614103)
   * debian/patches/alpha-no-relax.diff: use -Wl,--no-relax on alpha
     (https://bugs.freedesktop.org/show_bug.cgi?id=32224)
   * debian/patches/disable-impress-media-embedding.diff: temp fix from
     upstream; disable impress media embedding patches so that avmedia gets
     file urls passed correct again (closes: #612940)
 
   * debian/rules:
     - --with-arm-target=7 on armhf, explicit --with-arm-target=4
       (armv4t) for armel
   * debian/libreoffice-common.links: s/openofficeorg3/libreoffice/
     (closes: #614100)

libreoffice (1:3.3.1~rc2-1) unstable; urgency=low

   * new upstream release candidate
 
   * debian/control.in:
     - update for new git
   * debian/rules, debian/soffice.sh, debian/README.Debian:
     - more s/OOo/LibreOffice/ (closes: #613215)
   * debian/rules:
     - disable evolution2 support for now as it doesn't work with
       evolution 2.32
     - build -ogltrans for armhf
   * debian/control.in, debian/control.{kab,evolution}.in, debian/rules:
     - move -evolution and -kab into own files so they get automatically
       be removed from control when disabled

libreoffice (1:3.3.1~rc1-2) unstable; urgency=low

   * debian/libreoffice-preinst.in: remove files in /user and /share one
     by one (closes: #613083)

libreoffice (1:3.3.1~rc1-1) unstable; urgency=low

   * new upstream release candidate
 
   * debian/patches/odk-settings-fix-STLPORTLIB.diff: fix STLPORTLIB setting
     (aka make it empty) on kfreebsd-*,powerpc,sparc
 
   * debian/rules:
     - allow squeeze backports
     - explicitly set export HOME=$(CURDIR)/debian/smoketest for the
       smoketest, as it otherwise fails if $HOME is not there/broken (as on
       buildds)
     - fixup PRODUCTNAME_BR also in javafilter.desktop and startcenter.desktop
       (closes: #612598)
   * debian/control.sdk.in:
     - conflict against openoffice.org-dev-doc (closes: #612494)
   * debian/shell-lib-extensions.sh: properly set INSTDIR and d also in
     sync_extensions() (closes: #612572)
   * libreoffice-common.preinst.in: rm -rf /share and /user when upgrading from
     versions before 3.3.0-3
   * libreoffice-common.postinst.in: run sync_extensions() in postinst when
     upgrading from versions before 3.3.0-3 explicitly

libreoffice (1:3.3.0-2) unstable; urgency=low

   * upload to unstable
 
   * debian/patches/fixed-close-parentheses-with-icu-4.4.diff: add fix for
     closing parantheses with icu >= 4.4 from fdo#32171 (closes: #601078)
   * debian/patches/nsplugin-LibreOffice.diff:
     s/OpenOffice.org Plug-in/LibreOffice Plug-in/g
 
   * debian/rules:
     - fix parallel=n handling to also work if parallel=N is not the first or
       only option, thanks Kees Cook
     - install jar.sos in /usr/lib/gcj/libreoffice instead of /openoffice
       (closes: #611276)
     - don't hardcode TMP=/tmp for make install, thanks Jani Monoses for the
       pointer
     - build-depend on default-jdk in the JDK=default case only. Add
       gcj-native-helper/default-jdk-builddep build-dep when building the
       jars native
   * debian/control.gcj.in:
     - depend on gcj-jre instead of (the virtual) java-gcj-compat
       (closes: #609657)
   * debian/control.in:
      - make -core conflict against libreoffice-style-* (<< 1:3.3.0-1)
        (closes: #611279)
   * debian/watch:
     - update to look after the binaries in stable/, not src, as that
       version is different
   * debian/README.Debian, debian/control.in, control.lang.in:
     update for new names of hyphenation patterns and thesauri
     (hyphen-*/mythes-*). Actually make -l10n-* suggest mythes-*

libreoffice (1:3.3.0-1) experimental; urgency=low

   * LibreOffice 3.3.0 final (identical to rc4)
 
   * debian/patches/bridges-mkstemp-error-better-message.diff: make failure to
     create temp file because /tmp vanished more clear; backported from master
   * debian/patches/pyuno-demo-fix-PYTHONPATH.diff: fix insecure PYTHONPATH
     usage in pyuno demos (closes: #605178)
 
   * debian/rules:
     - remove obsolete (commented-out) FIXME section as /usr/share for icons
       works again since longer. Fixes actual splitout of the images to the
       various -style-* packages, thanks Matthias Klose for the pointer
     - really substitute ${PRODUCTNAME_BR} ${PRODUCTVERSION} in Name[pt_BR]
       (closes: #610345)
     - error-out on control target if /usr/include/ldap_features.h is not
       existing
     - stop renaming libreoffice.sh to ooffice.sh now that have transitional
       packages cleaning up office.sh from openoffice.org-common
   * debian/control.in
     - readd versioned ttf-opensymbol depends bogusly removed by
       "Remove obsolete OOo versions in dependencies." (closes: #610917)
     - some more s/OOo/LibreOffice/
     - make libreoffice-common conflict against
       openoffice.org-common (<< 1:3.3.0~)
   * debian/libreoffice-common.preinst.in: rm_conffile
     /etc/bash_completion.d/ooffice.sh if upgrading from older libreoffice-common
   * debian/changelog: mention fixed security issues in previous changelog
     entries

libreoffice (1:3.3.0~rc4-1) experimental; urgency=low

   * LibreOffice 3.3.0 rc4
     - fixes right/left margin settings in report builder on 64bit
       archs (closes: #607715)
 
   * debian/copyright: update Upstream-{Maintainer,Source}
   * libreoffice-emailmerge.preinst.in: remove (closes: #610205)
   * debian/rules:
     - also substitute ${PRODUCTNAME_BR} ${PRODUCTVERSION} correctly
       (closes: #610345)
     - fix to not install {intro,about}-pt_BR.png into -common if not
       building pt-BR (file conflict common/-l10n-pt-br)
   * debian/control.in:
     - add Vcs-Browser:, thanks Nelson A. de Oliveira

libreoffice (1:3.3.0~rc3-2) experimental; urgency=low

   * debian/patches/fix-mesa-headers-check.diff: readd, still needed;
     forgot to actually push this upstream

libreoffice (1:3.3.0~rc3-1) experimental; urgency=low

   * LibreOffice 3.3.0 rc3
     - includes OpenOffice.org 3.3.0 release branch milestone 19, so:
       + fixes CVE-2010-3702 and CVE-2010-3704 for the (unused) internal
         xpdf copy
       + fixes CVE-2010-4494 for the (unused) internal libxml2 copy
       + fixes possible heap overflow when reading manipulated TGA images
         (CVE-2010-4643)
 
   * debian/patches/java-common-message-LibreOffice.diff: fix patched-in
     java-common message to say libreoffice-java-common (closes: #609660)
   * debian/patches/presenter-screen-fix-description.diff: fix for correctly
     generating -presenter-consoles description.xml
 
   * debian/rules
     - bump SPI (c) upto 2011
     - remove debian source package 1.0 format support, we don't
       support stuff older than lenny anyways and lenny is able to
       handle 3.0 (quilt)
     - stop creating libreoffice -> ooffice symlink
     - install LibreOffices new technical.dic (closes: #425791),
       obsoletes Debian.dic
     - lintian fixes (permissions, really remove some of the LICENSE files)
   * debian/control.in, debian/rules, *.xmlcatalogs.in: rename
     libreoffice-dtd-officedocument1.0 back to
     openoffice.org-dtd-officedocument1.0. It's OpenOffice.org 1.x' dtd,
     so... Fix description to say OpenOffice.org 1.x instead of
     LibreOffice 1.x and .xmlcatalogs.in itself
     ("/OpenOffice.org//DTD OfficeDocument 1.0"). Make package properly
     versioned.
   * debian/source/local-options: abort-on-upstream-changes
   * debian/rules, debian/*.manpages, debian/README.Debian: update for
     oo* -> lo*/libreoffice
   * debian/control.in:
     - remove openoffice.org-{base,math,draw,impress,calc}
       Replaces: again, as we don't ship oo* wrappers/manpages anymore
       but lo*.
     - actually add Replaces: on openoffice.org-common (closes: #602867)
     - change Homepage: to point to www.libreoffice.org

libreoffice (1:3.3.0~rc2-3) experimental; urgency=low

   [ Rene Engelhard ]
   * debian/patches/fix-mesa-headers-check.diff: backport fix from
     master: check for mesaa headers only when OpenGL enabled.
 
   * debian/rules
     - merge OOo lenny-backport fixes
       + keep 3.0 (quilt) for lenny-backports now that it supports it
       + really use internal mythes
       + disable gconf as gconftool-2 -g /desktop/gnome/interface/accessibility
         hangs in the smoketest in a lenny chroot
     - add explicit --with-system-mesa-headers
     - update hsqldb conditionals for new SYSTEM_STUFF variable.
     - fix report-builder install to actually install the files
     - remove unneeded LICENSE files in the extensions
 
   [ Matthias Klose ]
   * debian/rules:
     - Cleanup architecture specific configuration handling.
     - Move architecture specific config before distro specific config.
     - Add build support for dh_python2.
     - Do not re-introduce arm (old ARM ABI).
     - Add a helper macro gen_no_archs to generate macros OOO_NO_<foo>_ARCHS
       from OOO_<foo>_ARCHS.  Use these macros in build dependencies.
     - Factor out SYSTEM_GCC_VERSION macro.
     - Don't special case CC_PREFIX on sparc, not needed.
     - Eliminate the explicit macros for the configuration of system
       components.
   * debian/control.in:
     - Remove packages and versions in build dependencies,
       which are present in the last old stable release.
     - Avoid empty filed in build dependencies.
     - Adjust for slightly changed OOO_NO_BASE_ARCHS macro.
   * debian/scripts/joinctrl.py:
     - Normalize whitespace in dependencies and similar fields.

2010

libreoffice (1:3.3.0~rc2-2) experimental; urgency=low

   [ Rene Engelhard ]
   * debian/rules:
     - use dpkg -s instead of apt-cache show (closes: #607873)
     - install modes.sxd into /usr/share/doc/python-uno directly, not a
       extra doc/
     - fix mingw32/gcc-mingw32 conditional to not break with gcc 4.5,
       thanks Matthias Klose
 
   [ Matthias Klose ]
   * debian/rules:
     - Remove leading whitespaces.
     - Avoid some duplicate shell calls.
   * debian/control*.in:
     - Remove obsolete OOo conflicts, replaces and provides.
     - Remove obsolete OOo versions in dependencies.

libreoffice (1:3.3.0~rc2-1) experimental; urgency=low

   * LibreOffice 3.3.0 rc2
     - fixes CVE-2010-4008 for the (unused) internal libxml2 copy
     - fix config path in soffice (closes: #606432)
     - includes OpenOffice.org 3.3.0 release branch milestone 18, so:
       + fixes export of group shapes to ppt (closes: #607377)
 
   * stop versioning libreoffice-build and ext-sources-libreoffice-build
     as releases of them now match LibO releases, makes building from git
     easier, thanks Chris Halls
 
   * stop building a broffice package. Most BrOffice things is now at
     runtime (LANG=pt-BR), which is apparently what the BrOffice people
     wanz. Put intro and about for pt-BR into -l10n-pt-br. fix .desktop files
     (closes: #593123)
 
   * debian/patches/do-not-switch-workspaces-of-wm.diff: backport fix from
     OOo 3.4 to not switch workspaces of wm when using awesome
     (closes: #607051) and set it to "false" so it's never done on any wm
     (closes: #380748)
 
   * debian/rules:
     - re-enable sdbc-postgresql
     - add conditional for squeeze-backports (Daniel Baumann)
       (closes: #606368) - disabled for now as lsb_release returns squeeze
       on sid right now...
     - apparently we need -with-extension-integration explicitly now; install
       the extensions from debian/tmp instead of -common/-core
     - use new --with-helppack-integration as we otherwise don't get the help
       installed
     - follow "universial" builds with "tag libreoffice x.y.z" in
       --with-build-version
   * debian/control.in:
     - remove libreoffice-core conflicts against itself, thanks Julian
       Andres Klode (closes: #606480)
   * debian/README.Debian-source: update to reflect current source package
     format and document building form vcs (Chris Halls)
   * debian/README.qa, debian/control*in, debian/rules: fix various URLs and
     Homepage: fields

libreoffice (1:3.3.0~rc1-1) experimental; urgency=low

   * LibreOffice 3.3.0 rc1
     - includes OpenOffice.org 3.3.0 release branch milestone 17, so:
       + fixes CVE-2010-4253: Heap based buffer overflow, PPT files.
 
   * debian/patches/splash-progressbarcolor.diff: update for new artwork
   * debian/patches/buildfix-patches.diff: remove
     reportdesogn-mention-package-l10n.diff patch, upstream
 
   * debian/broffice.lintian-overrides: oops forgot s/broffice.org/broffice/
     here...
   * debian/libreoffice-{filter-mobiledev,dev}.lintian-overrides,
     libreoffice-{base,calc,draw,impress,math,writer}.lintian-overrides.in,
     more lintian fixes
   * debian/uno-libs3.symbols: tighten depends to (>= 1.7.0+LibO3.3.0~beta3)
     for osl_{set,clear}Environment@UDK_3.11 (closes: #604201, #605897)
   * debian/patches/smoketest-disable-db-insert-delete-seek-tests.diff:
     rediff again - seems it got broken last time (closes: #603008)
   * debian/rules:
     - don't try to add application/vnd.openofficeorg.extension to
       startcenter.desktop, it's already there, thanks Axel Beckert
     - adapt for new .oxt packaging of postgresql-sdbc
     - remove libwpd 0.9 conditional, now 0.9 is needed as 0.8 support is gone
     - add explicit --prefix=/usr
   * debian/control.postgresql.in: bump depends to 3.3
   * debian/control.in: remove Breaks on -sdbc-postgresql again

libreoffice (1:3.3.0~beta3-2) experimental; urgency=low

   * debian/patches/postgresql-sdbc-0-7-6-b.diff: update PostgreSQL driver
     to 0.7.6b, needing for OOo/LibO 3.3 support
 
   * debian/rules:
     - actually install debian-presentation.odp to -common...
       (really closes: #602043)
     - create fake -help-sk package with symlink and depening on -help-cs
       (closes: #600335)
   * debian/rules: add support to build with libwpd 0.9.x(libwp{s,g} 0.2.0.
     Will be the only option from next version on anyway...
   * debian/control.ure.in: Breaks: openoffice.org-core (<< 1:3.3~) due to
     upstream (private library) symbol breakage (closes: #603549)
   * debian/control.in:
     - as LibO is independent from Sun and doesn't need to obey
       what Sun thinks is "integral part of the office", stop libreoffice
       depending on the officebean (closes: #459332)
     - readd imagemagick to B-D-I, we actually use it in install-indep, thanks
       Kai Wasserbäch
   * debian/uno-libs3.symbols: update
   * debian/*.lintian-overrides.in: update for libreoffice
   * debian/*.menu: update icon= and use libreoffice -xy

libreoffice (1:3.3.0~beta3-1) experimental; urgency=low

   * LibreOffice 3.3 beta3
     - Set correct default formula syntax value in case it's not
       explicitly set (closes: #527535)
     - includes OpenOffice.org 3.3.0 release branch milestone 10, so:
       + fixes several vulerabilities:
         . soffice script does not treat empty LD_LIBRARY_PATH like unset one
           (CVE-2010-3689)
         . Crash in WW8DopTypography::ReadFromMem (CVE-2010-3454)
         . Crash in SwRTFParser::ReadNumSecLevel (CVE-2010-3452)
         . Out of bounds write in WW8ListManager::WW8ListManager()
           (CVE-2010-3453)
         . Loading certain RTF document leads to corrupt table model
           (CVE-2010-3451)
 
   * debian/patches/buildfix-patches.diff:
     openoffice.org-report-builder -> libreoffice-report-builder
   * debian/patches/hack-no-rm-fr-of-smoketest-userconfig.diff: don't try
     to remove user dir on smokest, rm -f -r mysteriously fails
 
   * debian/control.in:
     - make -math depend on ttf-opensymbol (>> 2:2.4.3~) (closes: #603203)
     - remove build-dep on imagemagick
     - replace old openoffice.org-{base,math,draw,impress,common,kde,writer,calc}
       (closes: #602866)
     - stop build-depending on libpam0g-dev, pam-needing stuff gone
   * debian/copyright:
     - update again, it's actually supposed to be "Copyright (c) 2000, 2010
       LibreOffice contributors and/or their affiliates."
     - add dmake/dbug/*, thanks Alexander Schmehl
   * debian/rules:
     - revert system-{graphite,cppunit,stlport} changes in 1:3.3.0~beta2-2
     - stop building with --enable-hids per default again, slows down  the build
       and we don't use the VCL Testtool anyway
     - use new --enable-broffice
     - remove manual installing of LibO splash (LibO now also supports intro.png)
     - update .desktop file/icon installation to actually give sensible results
       (Exec= and Icon=; fix up broffice.org changes) (closes: #602883)
     - stop trying to change the product name in ooo*.res and versionrc;
       apparently it is not needed anymore (and doing so breaks BrOffice.org
       About) (closes: #602868)
     - we need to explicitly add --enable-build-unowinreg now
     - also disable the "subsequent tests" on non-openjdk builds
   * debian/broffice.org.p*.in: adapt diversions for new intro.png;
     remove ooo*.res/versionrc diversions
   * debian/soffice-template.desktop.in: update for LibreOffice and ..
   * debian/templates/soffice-template.desktop.in: ... move here
   * debian/templates/debian-presentation*: add Debian presentation template,
     thanks Raphael Hertzog (closes: #602043)
   * debian/rules, debian/control.in: add Bugs: header to divert reports on
     backports to debian-backports@l.d.o
   * debian/rules, debian/control.in: hi-IN -> hi
   * debian/watch: update to look for libreoffice-build
   * debian/smoketest/smoketest-disable-db-insert-delete-seek-tests.diff:
     rediff (closes: #603008)
   * debian/control.in, debian/rules: remove .org from BrOffice stuff
   * debian/broffice.org.*: move ...
   * debian/broffice.* ... here

libreoffice (1:3.3.0~beta2-2) experimental; urgency=low

   * debian/patches/buildfix-patches.diff: don't apply fields-table-formula.diff
 
   * debian/control.in:
     - add missing build-depends on automake
   * debian/rules, control.lenny_squeeze_transitional.in:
     - remove lenny->squeeze transitional packages, obsolete and not
       needed here anyways with the OOo -> LibO move
   * debian/rules:
     - temporarily disable system-{graphite,cppunit,stlport} on i386,
       will be reeenabled when beta3 included the necessary patches to
       make this work
     - fix clean to remove some generated localize-related files
   * debian/copyright: update

libreoffice (1:3.3.0~beta2-1) experimental; urgency=low

   * welcome, LibreOffice 3.3 beta 2 (aka 3.2.99.2)
     - includes OpenOffice.org 3.3.0 release branch milestone 9, so:
       + fixes hebrew text in sheet tabs when using system fonts
         (closes: #433231)
       + fixes directory traversal vulnerability in OOo (CVE-2010-3450)
 
   * switch to new LibreOffice build infrastructure (more or less ooo-build,
     though), update Homepage:.
     LO uses own splash, so this indirectly closes: #529709
 
   * debian/*: loads of OpenOffice.org -> LibreOffice changes
 
   * debian/rules:
     - add and rework target(s) for new external sources handling upstream
     - updates for (OOo) 3.3 and its various configuration changes
     - move oo-*ldap.xcd.sample to /usr/share/openoffice.org-common/examples
     - unpack extensions to /usr/lib/openoffice/share/extensions instead of
       shipping the oxt
     - adapt jar locations to actually match Java policy: public jars
       inside /usr/share/java (and /usr/lib/ure/...) and "internal" ones
       to /usr/share/java/basisX.Y/program/classes. Keep the symlinks there
     - remove WITH_SPLIT option, upstream vanilla tarballs not supported by
       new ooo-build build anymore
     - temporarily disable -sdbc-postgresql as unopkg apparently has problems
       with .zips now...
     - use convert directly for copnverting to 24bpp bmp instead of using fix_bmp_rgb
     - opens___.ttf has an own version number; reflect this in the package version
   * debian/control.in, debian/rules: adapt for "Test Cleanup". Build-depend
     on libcppunit-dev and junit4. Remove xvfb.
   * debian/*.{pre,post},{inst,rm}.in, debian/shell-lib-{components,extensions}:
     cleanup. remove unused THIS_SCRIPT. Use dpkgs DPKG_MAINTSCRIPT_PACKAGE
     instead of THIS_SCRIPT
   * debian/shell-lib-extensions.sh: remove add_extension(), not needed anymore;
     add new validate_extensions() and sync_extensions()
   * debian/*.postinst.in, debian/*.prerm.in: Remove unopkg calls for
     extensions in prerm and postinst, as we don't need them anymore
   * debian/control*in: remove Pre-Depends: on openoffice.orgVER-common
   * debian/*.preinst.in: when upgrading from a m84 or newer, don't run unopkg
     remove anymore
   * debian/control.in:
     - move binfilter to suggests (and remove from openoffice.orgs
       Description), it is not in the default install anymore
     - generalize -style-* Breaks: in common to always break -style-*
       (<< ${basis-version}) and add a Breaks on (>= 1:{next-basis-version})
       so that we don't "loose" icons because of not-matching basis. Thanks
       Michael Tokarev for pointing this out.
   * debian/uno-libs3.symbols: update
   * debian/icons: remove again
   * debian/broffice.org*: update diversions
   * debian/Recovery.xcu: remove, we now need to to this in main.xcd
   * debian/rules, debian/scripts/vars.powerpcspe: add powerpcspe support
     (Sebastian Andrzej Siewior)  - closes: #594038
   * debian/openoffice.org-common.triggers, debian/shell-lib-extensions.sh:
     add trigger for openoffice.org-common to run unopkg sync after all
     extensions in /usr/lib/openoffice/share/extensions have been
     installed/updated
   * debian/control.in, debian/rules: stop building industrial package
   * debian/scripts/fix_bmp_rgb: remove
   * debian/catalog.xml: move ...
   * debian/catalog.xml.in: ... here and fix path to dtd
   * debian/udk*in, debian/xmerge-javadoc.in: Sun Microsystems, Inc -> Oracle

openoffice.org (1:3.2.1-7) unstable; urgency=low

   * debian/patches/add-some-missing-german-translations.diff: as named,
     thanks Andre Schnabel
   * debian/patches/pdf-link-export-fix.diff: import from ooo-build master;
     don't export PDFs with damaged xref table (closes: #594275)
 
   * debian/control.in:
     - we use bc in debian/rules control, we probably should build-dep on it
   * debian/rules:
     - change Class-Path: of jurt.jar to contain /usr/lib/ure/lib hardcoded
       as otherwise libjpipe.so (needed in the Java bridge) is not found...
   * debian/scripts/fix_image_rgb: -resize to 548x364 to work around
     i#95472 (closes: #513746)

openoffice.org (1:3.2.1-6) unstable; urgency=high

   * debian/patches/reduce-height-on-dialogs-for-netbooks.diff: add
     patch from ooo-build-3-2-1 branch to reduce the PDF export and Recovery
     dialogs to fit on Netbooks (closes: #531930)
   * debian/patches/regcomp-fix-spelling.diff: succesful -> successful
     (closes: #593440)
   * debian/patches/shift-translations.diff: some translations must be shifted
     in the itemlist; backported from ooo-build-3-2-1 branch (closes: #593234)
   * debian/patches/SA40775.diff: fix CVE-2010-2935 and CVE-2010-2936
     aka SA40775: two buffer-overflow vulnerabilities in OpenOffice.org Impress
 
   * merge from Ubuntu (thanks Loic Minier):
     - Pass the same -v to "dh_makeshlibs --" (for dpkg-gensymbols) as to
       "dh_gencontrol --" (for dpkg-gencontrol); some symbols are missing from
       the symbols files and hence ure symbols have bogus dep on ure >=
       source-version which can't be satisfied as ure uses another versioning
       scheme

openoffice.org (1:3.2.1-5) unstable; urgency=medium

   * debian/patches/odk-configure-honour-ure-link.diff: fix the (unneeded)
     configure.pl of the SDK to honour ure-link (closes: #588495)
   * debian/patches/fix-i113084.diff; fix easy to trigger crash in macro
     recorder (from upstream)
   * debian/patches/fix-i113461.diff: do not freeze after erasing non-breaking
     space inserted by French AutoCorrection (from upstream)
 
   * debian/rules:
     - for safety, add a build-conflicts against libhsqldb-java (>> 1.8.1~)
     - move startcenter.png install to the rest of hicolor icons install;
       don't install ooo-build desktop icons when using sysui desktops
     - move LDAP.xcu.sample to /usr/share/openoffice.org-common/examples
   * debian/control.in:
     - make new -common Breaks: older openoffice.org-core (closes: #587750)
   * debian/control.kde.in:
     - remove obsolete Pre-Depends:

openoffice.org (1:3.2.1-4) unstable; urgency=medium

   * debian/patches/fix-smoketest-without-java.diff: complete fix,
     I missed some parts and had the conditional wrong...
   * debian/patches/fix-system-saxon.diff: fix configure check/makefile
     for system saxon; doesn't work at runtime yet, though
 
   * debian/rules:
     - fix builds without Java
     - update smoketest conditional, enable smoketest uncoditionally when
       building without Java
     - build without the layout dialogs again, broken in various ways
       (closes: #587171, #575908)
     - use the vanilla app icons when USE_OOO_BUILD_DESKTOPS=n (closes: #512731);
       install fixed startcenter.png
   * debian/control.in, debian/rules:
     - build for only the default python again (closes: #587402)
   * debian/icons/sysui: add fixed startcenter.png to match the rest from
     3.3

openoffice.org (1:3.2.1-3) unstable; urgency=low

   * ooo-build:
     - update (3.2.1.4)
 
   * debian/rules:
     - make smoketest install into debian/smoketest/tmp as some buildds
       only have a 128m /tmp...
     - don't run smoketest on gcj archs when on the buildds

openoffice.org (1:3.2.1-2) unstable; urgency=low

   * debian/patches/powerpc-fixes.diff: add powerpc fix and powerpcspe
     support, thanks Sebastian Andrzej Siewior
   * debian/patches/fix-smoketest-without-java.diff: disable tests which
     need Java if Java is disabled
   * debian/patches/fix-nodep-check.diff: fix ooo-builds check whether
     we can enable nodep=true to actually work with system dmake. Big effect
     on build time
   * debian/patches/installer-globals-max-1-regcomp.diff: only try to register
     one component at a time
   * debian/patches/kde4-statusbar-redrawing-border-width.diff: backport; add
     better border width (closes: #584322)
 
   * debian/control.in:
     - update Vcs-Bzr:
   * debian/rules:
     - run smoketest for armel again (the logic was flawed anyway and
       disabled smok)etest for all archs)
   * debian/smoketest/*, debian/rules: disable Database{Insert,Delete,Seek}
     tests on armel. No regression. Base (still) unusable, though :/
   * debian/rules, debian/control*in: disable Base and associated stuff for
     armel (As Base is now gone this closes: #585829)

openoffice.org (1:3.2.1-1) unstable; urgency=medium

   * OpenOffice.org 3.2.1 final (OOO320_m19)
 
   * translation-updates-20100529: oops, this has to be ....
   * translation-updates-20100526: ... this
 
   * ooo-build:
     - update (3.2.1.3)
 
   * debian/patches/hu-translation-fixes.diff: add hu translation fixes
     from ooo-build-3-2-1 branch
   * debian/patches/backport-ftruncate-check.diff: add from ooo-build-3-2-1
     branch - check for success of ftruncate(). Fixes OOo start when $HOME is
     on cifs
   * debian/patches/fix-incorrect-automatic-print-area-assignment.diff: as
     the name says, also from ooo-build-3-2-1 branch
   * debian/patches/fix-save-performance-with-hidden-rows.diff: add patch
     from ooo-build-3-2-1 branch to fix performance when saving with hidden
     rows (closes: #582785)
 
   * debian/rules:
     - use Oracles tarballs again
     - actually remove $(STAMP_DIR) in clean
   * debian/changelog: mention security fix in rc1s changelog

openoffice.org (1:3.2.1~rc2-2) experimental; urgency=low

   * debian/patches/extensions-mozilla-plugin-pc-if-libxul.diff: remove
     again ..
   * debian/patches/fix-bashisms-in-configure.diff: in favour of the
     correct fix (== vs. = breaking with dash)
 
   * debian/rules:
     - use system mdds
     - fix variable to not add kfreebsd-i386 to OOO_MONO_ARCHS twice but
       to actually add it to OOO_MOZILLA_ARCHS
     - OpenJDK crashes on runtime on armel, run the tests using gcj, still
       breaks though so disable smoketest on armel for now

openoffice.org (1:3.2.1~rc2-1) experimental; urgency=low

   * OpenOffice.org 3.2.1rc2 (OOO320_m18)
 
   * ooo-build:
     - update (3.2.1.2)
       - also add cifs to the locking conditionals in soffice.sh
       - redraw the status bar when needed in KDE4 (closes: #570570)
 
   * translation-updates-20100529: update GSIs from ftp.linux.cz
 
   * debian/control.lenny_squeeze_transitional.in: move packages to
     localization, where they belong
   * debian/control.in:
     - add Breaks: -style-* as with new -common and old -style the newly branded
       startcenter is broken, thanks Mechtilde Stehmann
   * debian/rules,
     debian/openoffice.org-{filter-binfilter,evolution,kab}.bug-script.in:
     fix component bug scripts and add the kab one
   * debian/rules:
     - start a next try to run the smoketest after the build. move the tests in
       the non-fakeroot part of the build (call test in build)
     - explicitly set LD_PRELOAD so that we don't get loads of
       libfakeroot-sysv.so preloading errors during make install anymore
     - temporarily use "split" tarballs again
   * debian/rules, debian/po/*, debian/control*in, debian/*.lintian*:
     remove debconf error when OOo is running again (closes: #565692)
   * debian/broffice.org.postinst.in: guard against $2 being empty

openoffice.org (1:3.2.1~rc1-2) experimental; urgency=low

   * ooo-build:
     - update (3.2.1.1)
       - cws-kfreebsdport01v2.diff: update to fix SDK for kfreebsd-*
       - fix-arm-eabi-bridge.diff: update with newest patch also fixing
         extensions
       - reportbuilder-mention-package-l10n.diff: don't remove translation we
         should keep (dbuimiscres.src)
 
   * debian/rules, debian/control.in: stop building libmythes-dev (now built
     again by mythes)
   * debian/rules:
     - re-enable extensions on armel
     - make grep -v for RID_STR_EXTENSION_NOT_PRESENT stricter so that
       we don't catch dbumiscres.src
   * debian/copyright: mention mdds

openoffice.org (1:3.2.1~rc1-1) experimental; urgency=low

   * OpenOffice.org 3.2.1 rc1 (aka OOO320_m17)
     - avoids execution of python code when browsing macros (CVE-2010-0395)
     - fixes crash when copying text to clipart and then exporting with RTF.
       Although not being RTF upstream says this also closes: #575109
 
   * ooo-build:
     - update (3.2.0.99.3)
 
   * translation-updates-20100506: update GSIs from ftp.linux.cz
 
   * debian/patches/fix-system-mythes-for-mythes-1.2.diff: adapt build
     for mythes 1.2
 
   * debian/rules,
     debian/openoffice.org-{report-builder,presentation-minimizer}.*:
     adapt for new .oxt filenames for -report-builder and
     -presentation-minimizer
   * debian/copyright: update for (C) Oracle
   * debian/rules:
     - get intro.bmp (still needed due to oosplash) from intro.png, remove
       unused intro.png again
     - update get-orig-source target for 3.0 (quilt)
     - fix/update get-orig-source to current state wrt hyphenation patterns
   * debian/broffice.org.*: update diversions for new about.png

openoffice.org (1:3.2.0-9) unstable; urgency=low

   * debian/patches/cws-kfreebsdport01v2.diff: add kFreeBSD port patches,
     thanks Petr Salinger (closes: #578023)
   * patches/fix-localized-filenames.diff: backport fix from upstream to
     fix the "localized" names of the extras when the en-US version is used
   * debian/patches/debian/patches/fix-arm-eabi-bridge.diff: updated patch
     from caolan from cws armeabi02 to fix the ARM EABI bridges
   * debian/patches/fix-calc-formula-option-tree.sdf.diff: fix ooo-build patch
     for xx-IN -> xx move
 
   * debian/control*.in:
     - Build-Depends: libc0.1 (>= 2.10.2-7) [kfreebsd-i386 kfreebsd-amd64]
   * debian/rules:
     - fix langpacks target to actually remove extra LICENSE* and README*
       files again
     - fix build with new dpkg 1.15.7
     - fix es translation for SC_OPCODE_SUBSTITUTE, thanks Margarita Manterola
       (closes: #578767)
     - enable kfreebsd-{i386,amd64}
     - actually add subsitution for java-runtime-depends to dh_gencontrol -i call
   * debian/scripts/vars.kfreebsd-*: add PLATFORMID
   * debian/shlibs.override.libc: force libc0.1 dependency to (>= 2.10.2-7)
   * debian/control.in, debian/rules: use textcat data from
     libtextcat-data-utf8 if the same with "ours". B-D-I on libtextcat-data-utf8
     to find that out
   * merge from Ubuntu:
     - add ENABLE_SDBC_POSTGRESQL variable and disable the build of the
       arch-dep extensions when we don't package them anyways
     - change the way components like -evolution or -filter-binfilter are
       registered so that we do not need to pre-depends on
       openoffice.org-core anymore (thanks Michael Vogt)
   * debian/rules, debian/control.sdk.in: stop suggesting/recommending
     java2-compiler, add the JAVA_RUNTIME_DEPENDS we already use instead.
   * debian/control.in, debian/rules: move netpbm, fdupes and xml-core to
     Build-Depends-Indep

openoffice.org (1:3.2.0-8) unstable; urgency=low

   * Brown paper bag release.
 
   * debian/rules:
     - fix OOO_BINFILTER_ARCHS setting so that we don't build it for arm(el)
       again
     - fix builds without arch-dep extensions to not fail at dh_genchanges
     - add Replaces: to l10n-xx for l10n-xx-in (for safety, seems to work
       otherwise as the filenames change)
   * debian/control.mysqlc.in: s/OOO_ARCHS/OOO_ARCH_DEP_EXTENSIONS_ARCHS/
   * debian/changelog: remove bogus changelog entry

openoffice.org (1:3.2.0-7) unstable; urgency=low

   * ooo-build:
     - update (3.2.0.10)
 
   * debian/patches/branch-update-bc571534c9b7435429003010d733e9c3a34df32d.diff:
     remove
   * debian/patches/es-fix-buleano.diff: fix spanish "boolean value" translation
     (closes: #576842)
   * debian/patches/nsplugin-path-handle-relative-symlinks.diff: add patch
     from upstream to handle relative symlinks (closes: #570452)
   * debian/patches/nsplugin-long.diff: add patch from issue 110747 to fix
     the plugin on 64bit archs
 
   * debian/rules, debian/shlibs.*: fix shlib-dependencies to not depend
     on the kdelibs5 transitional package anymore when built with KDE 4.4
   * debian/rules:
     - remove trailing ), breaking the libmysqlcppconn-dev build-dep on sparc
     - disable binfilter building on mips(el) like we do on arm(el) to save
       build time
     - remove libnpsoplugin.so symlinks in dirs except /usr/lib/mozilla
       (which is the canonical location)
   * debian/scripts/vars.s390x: add, we have S390X conditionals in rules
     after all
   * debian/rules, debian/control*in: GAH, I missed that armel has broken
     arch-dep extensions, Reintroduce %OOO_ARCH_DEP_EXTENSIONS_ARCHS%
   * debian/control.in: add also Pre-Depends on -common for -evolution to
     work around APT bug (thanks Ubuntu..).
     Do the same for -filter-binfilter to make it have orrect Pre-Depends:
     again
   * debian/rules, debian/control.lenny_squeeze_transitional.in: add
     transitional packages for xx-IN -> xx move as Conflicts/Provides/Replaces
     alone doesn't seem to work

openoffice.org (1:3.2.0-6) unstable; urgency=low

   * debian/patches/cws-linuxaxp01.diff: update
   * debian/patches/branch-update-f7b99eb375dea6024a48ca1b41f8bc76c220a38e.diff:
     move ...
   * debian/patches/branch-update-bc571534c9b7435429003010d733e9c3a34df32d.diff:
     ... here and update to current git
     - removes (bogus) last hunk in last interator usage fix (closes: #576665)
 
   * debian/rules:
     - remove obsolete filter-out for libmysqlcppconn-dev builddep so it
       actually gets added for i386...
     - add -F0 to QUILT_OPTIONS
     - re-enable arch-dep extensions for m68k
     - fix rule for replacing the old -in packages to not add it in
       uppercase (closes: #576721)
     - fix python-uno install for 2.6. $(shell is bad here
   * debian/rules, debian/control*in: remove %OOO_ARCH_DEP_EXTENSIONS_ARCHS%
     again

openoffice.org (1:3.2.0-5) unstable; urgency=low

   * ooo-build:
     - update (3.2.0.9)
       - branch_directly_to_cpp_vtable_call_on_arm.diff: adds
         ARM bridges fix from issue 105359
 
   * debian/patches/update-mysqlc.diff: "update" MySQL Connector to the
     version which (unnannounced) went in to 3.2.1
   * debian/patches/cws-linuxaxp01.diff: add alpha port from issue 110145
   * debian/patches/fix-system-redland.diff: remove redland patches
     allowing to use system-redland and reset security preferences (from issues
     108911 and 110523)
   * debian/patches/branch-update-f7b99eb375dea6024a48ca1b41f8bc76c220a38e.diff:
     update ooo-build-3-2 branch
     - Fix invalid iterator usage in X11SalGraphics::drawPolyPolygon
       (closes: #575758)
 
   * debian/shell-lib-extensions.sh: handle non-existant basis-link
     (closes: #561498)
   * debian/rules:
     - re-enable system-mysqlcppconn (also in the STLport case)
     - re-enable armel, disable arch-dep extensions for it now, though
     - fix build with 1.0 source format. Add missing uuencode for the extra
       "3.0 (quilt)" components. Use "normal" quilt for patching, add build-dep
     - disable system-boost on lenny
     - remove ant1.7 workaround, add build-conflicts against ant 1.8.0-{1,2,3}
     - update get-ooo-build and get-orig-source tergets to create
       .orig-ooo-build-X.Y.z.tar.gz, too and remove obsolete vcsupdate target
     - fix libservlet2.x-java package/jar name detection, thanks calc for the
       info
     - enable alpha
     - enable system-redland
     - due to the reland change: switch to libcurl4-gnutls-dev (closes: #391671)
     - sort arch lists, patch from Chris Cheney
     - install uno.py and unohelper.py for all supported python versions
       (closes: #476213)
   * debian/README.Debian-source: update for 3.2, mention new extra compnents
   * debian/scripts/vars.alpha: add
   * debian/control*.in:
     - remove full-featured from short description to accommodate longer
       language names (closes: #566606)
     - Standards-Version: 3.8.4 (no changes)
     - fix python-unos description
     - fix Breaks: on -sdbc-postgresql for lenny-backports (allow -4~...)
     - hack: "lower" Pre-Depends: on -java-common to -common for -report-builder.
       Add -java-common to Depends: instead (closes: #571771)
   * debian/po:
     - add nb.po, thanks Bjørn Steensrud
     - add vi.po, thanks Clytie Siddall (closes: #576122)

openoffice.org (1:3.2.0-4) unstable; urgency=low

   * debian/patches/update-postgresql-sdbc-to-0.7.6a.diff:
     update PostgreSQL driver to 0.7.6a (closes: #572590).
     Hack around 0.7.6+... > 0.7.6a+... by keeping 0.7.6 as version.
   * debian/control.in:
     - add Breaks: openoffice.org-sdbc-postgresql (<< 1:0.7.6+OOo3.2.0-4)
       for -base
   * debian/copyright: update

openoffice.org (1:3.2.0-3) unstable; urgency=low

   * debian/control.in: update Vcs-Bzr:
   * debian/rules:
     - build-depend on ant1.7 on gij-using archs (see #571532)
     - conditionalize armel build; re-enable on lenny-backport - that still
       should work
     - change build version to omit openoffice.org-core but mention ooo-build
       release instead

openoffice.org (1:3.2.0-2) unstable; urgency=low

   * ooo-build:
     - update (3.2.0.7)
       - really localize the layout dialogs (closes: #570378)
       - gcc-HelpLinker.diff: work around HelpLinker miscompile with gcc 4.3
         by using -O0, thanks Phillip Matthias Hahn (see #555026)
 
   * debian/control.in:
     - make -base depend on -java-common (>= 1:3.2.0~) (closes: #570335). Also
       fix conflicts against -help for 2.4 and 3.1. Thanks Tim Richardson
     - stop -filter-binfilter pre-depending on new(er) core to unbreak
       upgrades (closes: #570361) though stricly it'd be needed...
     - remove obsolete X-Vcs-Git: - we use ooo-builds release tarballs now
 
   * debian/rules, debian/source/*: migrate to "3.0 (quilt)" with bzip2
     compression
   * debian/po: add sk.po, thanks Ivan Masár (closes: #571225)

openoffice.org (1:3.2.0-1) experimental; urgency=low

   * OpenOffice.org 3.2.0 final (same as RC5)
 
   * ooo-build:
     - update (023b7794da1e7eda6857466b839562177b13c903)
       - fix logic for nfs/smb detection to actually work; also export
         STAR_PROFILE_LOCKING_DISABLED=1 when on nfs|smb/FILE_LOCKING=no
         (closes: #568672) and also copy it over to unopkg (closes: #568036).
         Also split home on nfs and file on nfs tests, thanks Alex Bodnaru
       - actually apply mysqlcppconn-mysqlclient-SONAME.diff (closes: #560788)
       - desktop-initial-preference-5.diff: add InitialPreference=5 to make
         OOo have a priority over koffice or even okular for ODF documents
         (closes: #549940)
 
   * debian/control.in:
     - build-conflict against graphicsmagick-imagemagick-compat (<< 1.3.9¨),
       suggest imagemagick | graphicsmagick-imagemagick-compat instead of
       vice-versa (closes: #569124)
     - build-depend on libjpeg-dev instead of libjpeg62-dev
   * debian/rules:
     - wrap KDELIBS_MINVER for KDE4 into ifneq "$(LENNY_BACKPORT)" "y" as it
       for some reason also gets used for lenny-backports which has KDE3..
   * debian/control.ure.in: fix uno-libs3*'s ure replaces
   * debian/changelog: mention security fixes in last uploads
   * debian/po:
     - add ro.po, thanks Ionel Mugurel Ciobica
     - add updated ar.po, fr.po (closes: #568596), ja.po (closes: #568605), ru.po
   * debian/ure.preinst, debian/shell-lib-{extensions,components}:
     - add a || true to db_input/db_go where missing (closes: #569840)

openoffice.org (1:3.2.0~rc5-2) experimental; urgency=low

   * ooo-build:
     - update (f390aa944ea0330c26a983408766293df1cc4c3f)
 
   * debian/rules:
     - re-enable -gcj again as gcc-defaults migrated
     - add explicit build-dep on mingw32-runtime when using gcc-mingw32,
       see #567698
   * debian/control.in:
     - update Java packages in openoffice.orgs description

openoffice.org (1:3.2.0~rc5-1) experimental; urgency=low

   * OpenOffice.org 3.2.0 release candidate 5 (OOO320_m12)
 
   * ooo-build:
     - update (d1c34f500fba2e2bd02377587e8c3d0414d8f23c)
       - fix-es-accelerators.diff: fix "accelarators" for es (closes: #567384)
 
   * debian/rules:
     - move from manual installing of the bug files to dh_bugfiles, bump
       debhelper builddep
   * debian/*.control.bug, debian/*.script.bug.in, debian/presubj: move ...
   * debian/*.bug-control, debian/*.bug-script.in, debian/bug-presubj: ... here
   * debian/control.in:
     - make -base conflict against openoffice.org-report-builder (<< 1.2.0~) and
       openoffice.org-report-builder-bin (<< 1:3.2.0~)
   * debian/control*in:
     - make -core depends on ure (>= 1.5.1+OOo3.1.1-15) to get
       above fix and make all extensions/conflicts conflict against older ures.
       (closes: #566832, #566829, #566189)
     - make -core conflict against ure (>= 1.6.0~), thanks Alex Bodnaru
       (closes: #566062)
   * debian/ure.templates.in, debian/po/*: Add debconf note for the "broken
     rdbs" problem.
   * debian/po: add updated de,po it.po, cs.po, es.po, zh_CN.po,
     sv.po (closes: #568017), pt.po (closes: #568026), eu.po (closes: #568077)

openoffice.org (1:3.2.0~rc4-1) experimental; urgency=low

   * OpenOffice.org 3.2.0 release candidate 4 (OOO320_m11)
 
   * ooo-build:
     - update (88ffff08f56f252264b491d0022e05d0d7639747)
     - src: add fixed es GSI from issue 108563
 
   * debian/rules:
     - re-enable system-stlport as a updated patch works with STLport 4.6
     - also exclude /var/lib/openoffice/basisX.Y/program/services.rdb at
       dh_md5sums
     - build without VERBOSE=true (normal) mode on all buildds now in a try
       to mitigate buildd log size
   * debian/shell-lib-{extensions,components}.sh: add echos instead of debconf
     message on DEBIAN_FRONTEND = noninteractive so that people in that case also
     know what goes on
   * debian/openoffice.org-common.tenplates,in, debian/rules, debian/po*: Move
     debconf template to shared/openofficeorg-running (see #566644); Unfuzzy.
   * debian/control.presenter.in: depend on (our) OOo 3.2
   * debian/control.in: Breaks: openoffice.org-presenter-console (<< 1.0.3~)

openoffice.org (1:3.2.0~rc3-1) experimental; urgency=low

   * OpenOffice.org 3.2.0 release candidate 3 (OOO320_m10)
 
   * ooo-build:
     - update (86bf4b50ea8d350ecaed08451b32f86710d611c0)
 
   * merge 1:3.1.1-14

openoffice.org (1:3.1.1-14) unstable; urgency=medium

   * ooo-build:
     - update (2953d9ac150d05f8774712294a792302bc15ade1)
 
   * debian/rules
     - fix conditionals to also add gcj-jdk builddep in non--gcj-build cases
       as we have archs needing it also for "normal" builds
     - add -Xjavasettingsunopkginstall.xml so that it doesn't end up in
       .md5sums, thanks Loic Minier

openoffice.org (1:3.2.0~rc2-1) experimental; urgency=low

   * OpenOffice.org 3.2.0 release candidate 2 (OOO320_m9)
       - fixes table wizard problem; get data source correctly (closes: #553612)
 
   * ooo-build:
     - switch to ooo-build-3-2 branch
     - update (fd8a89475d134bb24f8082e94f3bf0fefbea3bd5)
 
   * debian/control.in:
     - actually fix Vcs-Bzr:
 
   * debian/rules:
     - use internal STLport and use system-graphite also on i386 (4.6 won't
       work)
     - work around weird crash in the build by build-conflicting against
       libstlport4.6-dev when building with internal STLport
     - remove explicit GCC_VERSION := 4.4 setting
 
   * merge 1:3.1.1-12 and -13

openoffice.org (1:3.1.1-13) unstable; urgency=medium

   * ooo-build:
     - switch to own debian-3-1-1 branch
     - update (6feb90398c1e18eb4951af3c1be4f4d4c8e6861a)
 
   * debian/rules:
     - actually also remove armel from OOO_JAVA_ARCHS and OOO_MOZILLA_ARCHS;
       remobe stray arm from OOO_MOZILLA_ARCHS
     - temporarily disable -gcj to get a chance to get into testing
       (gcc-defaults is blocked)
     - per request from the security team: use internal mysqlcppconn for
       all archs (consistency), instead of only for i386
   * debian/shell-lib-{extensions,components}.sh: add missing .lock to actually
     check for the extistence of the lockfile and not for the profile dir, thanks
     Chris Cheney

2009

openoffice.org (1:3.1.1-12) unstable; urgency=medium

   * ooo-build:
     - update (bfe183f5f669daea3dd91d13fea47b2ddc8e370)
       - odk-unowinreg-osdir.diff: add missing -I.../include/linux also for
         gcj
 
     - surrender and disable armel until the bug in the bridges is fixed...
     - disable mono on sparc

openoffice.org (1:3.2.0~rc1-1) experimental; urgency=low

   * OpenOffice.org 3.2.0 release candidate 1 (OOO320_m8)
 
   * ooo-build
     - update (26ed7c54320e44e0d31005c7db78194257ec80c8)
       - fixes vba macros not honouring macro security settings (CVE-2010-0136)
       - makes "Always allow saving of document" configurable (closes: #478130)
       - src: add OOO320 GSIs from ftp.linux.cz
 
   * debian/rules:
     - re-enable eo; enable ast (asturian)
     - enable hppa, use gcj-jdk
     - --enable-layout
     - install Recovery.xcu (see below)
 
   * debian/Recovery.xcu: add Recovery.xcu to make OOo handle
     GNOME session close (see issue 105172)
 
   * merge 1:3.1.1-9 to 1:3.1.1-11

openoffice.org (1:3.1.1-11) unstable; urgency=low

   * ooo-build:
     - update (89b6191f14b42664b9c46395722ccecd562418c4)
       - fixes vba macros not honouring security settings (CVE-2010-0136)
       - debian-opt.diff: build with -O2 instead of -Os. Fixes FTBFS on ppc
 
   * debian/control.in:
     - bump ttf-opensymbol dep to (>= 1:3.0), we need it for some bullets
       (closes: #561182)
     - make -common depend on ure (hopefully closes: #544621)
   * debian/rules:
     - build-depend on g++-4.4 (>= 4.4.2-5) on armel because of various
       wrong code generation fixes. Thanks Matthias Klose.
     - bump build-dep for mono to >= 2.4.2.3 and adapt for csc -> mono-csc
       change
     - don't add LIBSUFFIX/PLATFORMID to the arch-indep packages' maintainer
       scripts, as it will "only" be the system where the upload was built
       on anyway, thanks Kurt Roeckx
     - move libcalc??.so into -base as it actually is a db driver, not a
       calc component. Makes Base start up without -calc installed now...

openoffice.org (1:3.1.1-10) unstable; urgency=low

   * ooo-build:
     - update (6929a9d4285be22b2e6d682bab6d0c5bca2e8fa5)
       - mysqlcppconn-mysqlclient-SONAME.diff: use libmysqlcppconn.so.16 instead
         of libmysqlcppconn.so also in the internal mysqlcppconn copy...
 
   * debian/rules:
     - only build-depend on (gcc-)mingw32 when we actually enable the SDK
     - build-depend on kdelibs5-dev (>= 4:4.3.4) when building against KDE4
     - when building with internal mysqlcppconn, add explicit dep on
       libmysqlclient. Together with the new patch above this closes: #560788
   * debian/shlibs.local.in: force a kdebase-runtime >= 4:4.3.4 dependency

openoffice.org (1:3.1.1-9) unstable; urgency=low

   * ooo-build
     - update (3bb313baf6ad6669913cee47884a438c75bf88be)
       - open-url-support-iceanimals.diff: support ice{ape,dove,weasel}
         in open-url (closes: #543652)
       - add support for building with internal mysql-connector-cpp (as
         upstream does) to ooo-build infrastructure; disable
         debian-mysqlc-build-against-stlport-hack.diff for now
 
   * debian/rules:
     - re-enable sparc
     - fix install on no-Java builds
     - build-depend on libmysqlcppconn*-dev (>= 1.1.0~r791) to build against
       version with fixed visibility of (e.g.) SQLException
       This closes: #558240 for !i386 at least.
       Build with internal libmysqlcppconn on i386 for now...
     - don't build-depend on openjdk on archs using gcj-jdk...
     - remove cacao-oj6-jre support, gone

openoffice.org (1:3.2.0~ooo320m6-1) experimental; urgency=low

   * OpenOffice.org 3.2.0 release branch milestone 6
     - fixes "OpenOffice.org XPM Import Integer Overflow" (CVE-2009-2949)
       and "OpenOffice.org GIF Import Heap Overflow" (CVE-2009-2950
     - fixes "OOO sprmTDefTable issue" (CVE-2009-3301) and
       "OOO sprmTSetBrc issue" (CVE-2009-3302)
 
   * ooo-build
     - update (405cdcba2ee1f14ddac18095cff2e2c3df907719)
       - cws-linuxhppa1.diff: backport hppa port (closes: #484116)
 
   * debian/rules:
     - enable l10n again (closes: #558030)
     - enable new languages:
       om (Oromo) including help, is (Icelandic), ug (Uighur),
       si (Sinhala), id (Indonesian) and as now fixed: oc (occitan)
     - remove removed languages: lo
     - fix install on no-Java builds
     - add BUILD_HPPA conditional, don't enable it yet
     - add symlink /usr/lib/openoffice/basisX.Y/help -> /usr/share/... to work
       around regression.... (see i107283)
     - remove beta splash workaround and fix regex to also catch one-digit
       milestones...
     - HELP_L10N_VIRTUAL_VERSION:=3.2
   * debian/control.in, debian/rules: adapt for upstream xx-IN -> xx rename
     (except hi-IN and pa-IN)
   * debian/scripts/vars.hppa: add

openoffice.org (1:3.2.0~beta-2) experimental; urgency=low

   * ooo-build:
     - update (752257c78e21cb4702b80ab4be02f5677c37ffe7 - 3.1.99.2)
 
   * debian/control.in:
     - make -core conflict against -style-* (<< 1:3.2.0~beta)
     - make all styles depends on -core (>= 1:3.2.0~beta)
     Thanks Mechtilde Stehmann for pointing this out.
   * debian/rules:
     - add conditional to disable the layout dialogues. Disable it as it
       still has some bugs (closes: #554274)
     - if ooo-build/ChangeLog exist, install it as upstream changelog
     - build with g{cc,++} 4.4
   * debian/uno-libs3.symbols: add symbol file
 
   * merge 1:3.1.1-7 and 1:3.1.1-8

openoffice.org (1:3.1.1-8) unstable; urgency=low

   * debian/changelog:
     - fix typo: s/endianess/endianness/
   * debian/rules:
     - just build-depend on libgcj-common (>= 1:4.4.1)
     - fix usr/lib/openoffice/ure removal to not fail if the dir does
       not exist anymore (e.g. on the non-mono archs)
   * debian/control.in:
     - fix Vcs-Bzr:
   * debian/openoffice.org-common.lintian-overrides.in: move ...
   * debian/openoffice.org-common.lintian-overrides: ... here

openoffice.org (1:3.1.1-7) unstable; urgency=low

   * ooo-build
     - update (06bcdf6420e39ef6aff6f313bc9626b9fdac6b06)
       - icc-use-sal-endianness-and-types.diff: use correct endianness
         in icc (closes: #536348)
       - xulrunner-1.9.1.diff: fix build with xulrunner 1.9.1
 
   * debian/po:
     - add
       - fi.po (thanks Esko Arajärvi, closes: #554031)
       - fr.po (thanks L.F.Templeton, closes: #554374)
       - es.po (thanks Francisco Javier Cuadrado, closes: #554713)
       - gl.po (thanks Marce Villarino, closes: #554988)
       - it.po (thanks Vincenzo Campanella, closes: #556111)
   * debian/rules:
     - revert build-dep bump for armel, as it does not help as of latest
       findings and the bug probably is in OOo...
     - remove useless empty dir /usr/lib/openoffice/ure in -core
     - bump libgcj-common build-dep to 1:4.4.1-1 to fix lintian warnings
       (command-with-path-in-maintainer-script)
     - install /usr/share/openoffice/shell-lib-extensions.sh only with 644;
       thanks lintian
     - MOZILLA=libxul (closes: #555912)
   * debian/openoffice.org-common.lintian-overrides.in: override
     E: openoffice.org-common: no-debconf-config

openoffice.org (1:3.2.0~beta-1) experimental; urgency=low

   * OpenOffice.org 3.2.0 beta (OOO320_m2)
     - fixes internal libxmlsec copy for CVE-2009-0217
     - paste into memo field doesn't replace existing content anymore
       (closes: #482473)
     - has many performance improvements for Base (closes: #488202)
     - unifies paper handling between modules, fixes for paper handling
       (closes: #488667)
     - supports opening of encrypted OOXML files (closes: #540442)
     - now you can add notes even when there are more document windows.
       Note that they are not updated on-the-fly when typing (closes: #538109)
     - now has ooo-builds patch integrated so we have synced behaviours e.g.
       with text in cells and SUM (closes: #504604)
     - now honours ACLs (closes: #216596, #548881)
     - no duplicate shortcut in Insert Menu anymore (closes: #550510)
 
   * ooo-build:
     - update (07111fca568ecb76a941c231af94a4f29f5f2a75)
 
   * debian/rules:
     - revert back to internal redland libs because odfmetadata2 now is in.
       As we don't have conflicting build-deps anymore revert to building
       using libcurl4-openssl-dev
     - build with --enable-hids to get a hid.lst build we can use later
       for the testtool
     - enable graphite; it's now upstream; don't use system-graphite on i386
       for now
     - bump libnss3-dev build-deps to >= 3.12.3
     - fix --with-lang= passing to configure. Don't do it when we build only
       en-US
     - update get-orig-source target for new way of downloading the tarballs
       from cgit.freedesktop.org
     - bump libboost-dev build-dep to >= 1.38
     - for now, only build with en-US
     - work around the fact that this is a beta version but has no beta splash
       but we're supposed to use the "Developer Snapshot" splash
     - move help and images*.zip into /usr/share (see #218067)
   * debian/control.mediawiki.in:
     - we don't need a strict depends on lucene anymore, remove it again.
       Bump dependencies to >= 1:3.0.0~ matching description.xml
   * debian/control.reportdesign.in, debian/control.mysql.in:
     - bump depends on >= 3.2 (for mysql for safety)
   * debian/control.in:
     - make openoffice.org depend on ttf-sil-gentium-basic as those fonts
       are included in OOos source now (for graphite support)
   * debian/control.in, debian/rules:
     - remove hardcoded libldap2-dev builddep and add ENABLE_LDAP conditional.
       Only suggest it because it's now dlopen()'ed anyway.

openoffice.org (1:3.1.1-6) unstable; urgency=low

   [ Rene Engelhard ]
   * ooo-build:
     - update (8a4d08ec440c3c5eaf664b5732eb79d2c6ed9896)
       - fixes wrong filter texts in KDE4 fpicker (closes: #551774)
       - Correct fix for the mirrored range selection bug in RTL mode.
         (closes: #548767)
 
   * debian/templates: apply changes from debian-l10n-english review
     (closes: #552370)
   * debian/po:
     - debconf-updatepo; update de.po
     - add
       - zh_CN.po (thanks Aron Xu)
       - cs.po (thanks Michal Simunek, closes: #552327)
       - ar.po (thanks Ossama Khayat, closes: #552381)
       - ja.po (thanks Hideki Yamane, closes: #552460)
       - eu.po (thanks Piarres Beobide, closes: #552703)
       - sv.po (thanks Martin Bagge, closes: #552740)
       - pt.po (thanks Pedro Ribeiro, closes: #553284)
   * debian/rules:
     - add conflict against (<< <minor version of lucene OOo was built with)
       for -help-en-us as newer versions necessarily don't create indexes a old
       version can read...
     - actually add lucene-depends to -wiki-publishers dh_gencontrol call
       (closes: #553370)
   * debian/control.in:
     - conflict against libhsqldb-java (>= 1.8.1~)
   * debian/templates, debian/openoffice.org-common.templates.in
     debian/rules: move templates to openoffice.org-common so that they get
     installed into openoffice.org-common per default, not openoffice.org...
 
   [ Rail Aliev ]
   * debian/po:
     - update ru.po, tr.po

openoffice.org (1:3.1.1-5) unstable; urgency=low

   * ooo-build:
     - update (01bbcda85cb32be9eb5334430fb208ec5ca60041)
       - fixes german translation (s/Verwerfen/Abbrechen/) (closes: #550453)
       - kde4_fpicker_fixes2.diff
         - fixes text for checkboxes (closes: #544691)
         - makes filters work (closes: #550467)
     - src:/: update GSIs from ftp.linux.cz: ga nb nn sl
 
   * debian/control.in:
     - move -style-* recommends at -common to suggests (closes: #550126)
     - build-depend on po-debconf
     - build-depend on binutils (>= 2.20) and g{cc,++}-4.4 (>= 4.4.1-6) for
       armel when building with gcc 4.4, see http://gcc.gnu.org/PR40521
     - make -core provide openoffice.org-headless
   * debian/shell-lib.sh, debian/shell-lib*.sh, debian/*.lintian-overrides*,
     debian/rules: only add the functions needed to the respective maintainer
     scripts to prevent some bad side-effects, thanks Steve Langasek...
   * debian/shell-lib-{components,extensions}.sh: check for known OOo-using
     services (docvert-openoffice.org) and stop/start them
   * debian/rules:
     - install extension shell lib for use by extensions not from here
     - enable el help (thanks Fotis Tsamis for telling it is enough translated)
     - move one missed place from bc to expr and fix expr statement, thanks
       Chris Cheney again

openoffice.org (1:3.1.1-4) unstable; urgency=low

   * ooo-build:
     - update (db285975a659e1b3cd36bc16e5add7a0c427ac58)
       -  fix typo to make with-STLport build build

openoffice.org (1:3.1.1-3) unstable; urgency=low

   * The "Goodbye sparc!" release. :-(
 
   * ooo-build:
     - update (4d4be60ad4dfc84b85b0ea1d4b21b8d74212673d)
       - Fixed range selection for RTL languages. (closes: #548767)
       - fix some Extended Tips abbreviations for Italian (closes: #478761)
       - apply optional-icon-themes.diff so that OOo doesn't list not-installed
         icons anymore (closes: #416877)
 
   * merge from Ubuntu:
     - Add support to turn off building on sparc.
   * debian/rules:
     - don't build sparc. Too many random(!) build failures
     - add ENABLE_S390X conditionals. enable. forgotten so far although OOo
       claims to support s390x
     - enable mysql-connector
     - use expr instead of bc so we get a proper kdelibsX-dev also with bc
       not installed
     - remove bogus (.*på engelsk) from GSI_da to fix some functions
       (closes: #548608)
     - fix lang= handling for DEB_BUILD_OPTIONS
     - point --with-external-{dict,hyph,thes}-dir to the new locations
     - build against libneon27-gnutls-dev (closes: #534243)
   * debian/control.in:
     - break dict/hyphen patterns/thesauri packages with the old location
     - stop making -common have a hard depends on the default iconset; make
       it depend on openoffice.orgVER-style-default | openoffice.orgVER-style
       and make -gtk/-kde only recommend -style-tango/-style-{crystal,oxgen}.
       Provide openoffice.orgVER-style on all -style-* (closes: #423021)
       Stop -style-* depending on -common (closes: #406778)
   * debian/control.mysql.in: remove bogus conflicts, add Homepage:
   * debian/shell-lib.sh:
     - check whether OOo is running before (de-)registering extensions or
       components (closes: #548721, #546723)
     - run unopkg with -v to have more info and to see where it breaks when
       it breaks. Removing "Adding extension XY .. done" echos
   * debian/templates, debian/po: add debconf error shown when OOo is running

openoffice.org (1:3.1.1-2) unstable; urgency=low

   [ Rene Engelhard ]
   * ooo-build:
     - update (1f44d9a5c0c024cba36a904b0b04dd09aca9e205)
   * debian/rules:
     - bump libmysqlcppconn-dev builddep for new snapshot of mysqlnative and
       adapt for STLport flavour
     - fix parallel=X handling to actually works, thanks to Wouter Verhelst for
       pointing it out
     - add export PYTHONPATH into /usr/lib/openoffice/program/unopkg, too.
       Thanks Frederic Peters (closes: #545482)
   * debian/control.in:
     - s/msttcorefonts/ttf-mscorefonts-installer/. Former is a transitional
       package even in lenny
     - conflict against mozilla-plugin-vlc (<< 1.0)
     - actually add Pre-Depends: for -filter-binfiler, thanks Chris Cheney
       for the pointer
   * debian/control.mysql.in:
     - remove conflicts against OOo >= 3.3
   * debian/changelog:
     - mention fixed security issues in ~ooo310m15-1 and rc2-1 uploads
 
   [ Rail Aliev ]
   * debian/rules:
     - use the official tarballs in get-orig-source when WITH_SPLIT=n is set
     - prevent empty GCJ_JAWT_DIR when libgcj10-awt is installed
     - remove ooo-build directory before "git clone"
     - remove download.list file produced by download target
   * debian/control.in, debian/control.mediawiki.in,
     debian/control.minimizer.in, debian/control.mysql.in,
     debian/control.postgresql.in, debian/control.presenter.in:
     - drop the fields inherited from source package

openoffice.org (1:3.1.1-1) unstable; urgency=low

   * OpenOffice.org 3.1.1 final release.
   * upload to unstable
 
   * ooo-build:
     - update (e73e72f999097ca3ab08ec48cddec798d6128075 - 3.1.1.1)
       - new-SQLLEN.diff: fix ODBC libs for "new" SQLLEN (closes: #539642)
       - prevent-multiple-window-resize-calls-when-maximised.diff: add;
         fixes window resize behavior when using Gtk plugin under KDE,
         thanks Chris Halls (closes: #542387)
       - fixes save to UTF8 paths in KDE4 filefpicker (closes: #536664)
 
   * debian/rules:
     - use upstreams tarballs
 
   * debian/control.mysql.in, debian/rules,
     debian/openoffice.org-mysql-connector.*: add support for "mysqlnative"
     driver 1.0.0 alongside the already packages sdbc_postgresql one. Use
     internal libmysqlcppconn on i386 for now... Don't enable it yet.
   * debian/control.mediawiki.in: don't depend on liblucene2-java but on
     ${lucene-depends}, so that we don't pick up a liblucene2-java depends
     when we use internal lucene...

openoffice.org (1:3.1.1~rc2-1) experimental; urgency=low

   * OpenOffice.org 3.1.1 rc2 (OOO310_m19)
     - fixes CVE-2009-2414 / CVE-2009-2416 for the (unused) inernal libxml2
       copy
 
   * ooo-build:
     - update (28051d9210b60491d4de238a41f03d96035b0f29)
     - src: update GSIs from ftp.linux.cz: bg bn el ga mk nb nn sk sl uz
 
   * debian/control.in:
     - Standards-Version: 3.8.3 (no changes needed)
   * debian/rules:
     - make sure debian/scripts/get_libebook_dep.sh is executable
     - move libsdfilt* to -draw
     - remove result/ and test/ from OOos own copy of libxml2, too...
       (see #331534)
     - use gcc-mingw32 instead of mingw32 when we build with gcc 4.4
     - use gcj-jdk/java-gcj-compat-dev on kfreebsd-*
     - make -l10n-tr suggest openoffice.org-spellcheck-tr to catch
       openoffice.org-zemberek analogous to openoffice.org-voikko
   * debian/rules, debian/openoffice.org-filter-binfilter-*:
     Move libbf_migratefilter* back to -filter-binfilter as it's linked to
     libs there. Add the regcomp (un)registering.
   * debian/source.lintian-overrides:
     - remove, lintian is fixed to not complain about these anymore

openoffice.org (1:3.1.1~rc1-1) experimental; urgency=low

   * OpenOffice.org 3.1.1 release candidate 1 (aka OOO310_m18)
     - imports tables in RTL context with (almost) correct alignment
       (closes: #528836)
 
   * ooo-build:
     - switch to ooo-build-3-1-1
     - update (00d9bf9f96938abe869a36085e72b3fe360b9e95)
       - fixes hyperlink opening in calc (closes: #533874)
 
   * debian/rules, debian/control.kde.in, debian/openoffice.org-kab*:
     also add/revoke libkab1.so to fix similar bug as with -evolution in -2
   * debian/control.in, debian/rules, debian/scripts/get_libebook_dep.sh:
     don't hardcode libebook1.2-9 as depends. Get libebook version on the fly.
     Add Build-Dependency on libebook1.2-dev.
   * debian/control.pdfimport.in:
     - mention that -pdfimport is for opening PDFs in Draw (closes: #538062)
   * debian/rules:
     - remove debian/*.install and debian/*.dirs in clean
   * merge from Ubuntu:
     - don't depend on openoffice.org at -l10n-{in,za}, as it would install also
       not-wanted stuff
     - add conditional to disable gnome-vfs; add a confitional for gconf as
       we need a diect libgconf2-dev builddep anyway when we enable GConf
     - remove locolor, don't include gnome. Switch everything to use hicolor
     - rename ooo-*desktop to openoffice.org*desktop to use standard name
       for .desktop files (gnome-shell)

openoffice.org (1:3.1.1~ooo310m15-1) experimental; urgency=high

   * OpenOffice.org 3.1.1 development milestone 15 (OOO310_m15)
     - fixes import of (non-RTL) ww8 tables (closes: #535971)
     - fixes CVE-2009-0200 ("OpenOffice.org sprmTDelete integer underflow")
       and CVE-2009-0201 ("OpenOffice.org sprmTInsert buffer overflow")
 
   * ooo-build:
     - update (ccbde7123a771221cf05adccf8ab86a1e01cf583)
     - src: update GSIs from ftp.linux.cz (bg cs el fi ga km uz)
 
   * debian/rules:
     - update graphite conditionals

openoffice.org (1:3.1.1~ooo310m14-1) experimental; urgency=low

   * OpenOffice.org 3.1.1 development milestone 14 (OOO310_m14)
     - fixes some (random) crashes in "uno" (closes: #472461)
 
   * ooo-build:
     - update (f3f544d7348651fc9b84d8038bf20b4d208a9c3d aka
               ooo-build 3.1.0.98.2)
       - "Slightly better way to prevent progress bar instantiation."
         (closes: #534658)
 
   * debian/rules:
     - fix typo in kde-icons-oxygen Suggests (closes: #534261)
     - stop running dh_desktop on sid, thanks lintian

openoffice.org (1:3.1.1~ooo310m13-1) experimental; urgency=low

   * OpenOffice.org 3.1.1 development milestone 13 (OOO310_m13)
     - fixes sort when involving formulas (closes: #529430)
 
   * ooo-build:
     - use 'master' again (9bb64f6fa29ac3c7db1ad54a222010c6f9d4a115)
       + adds "a JVM and" to javaldx' message if no Java is found
         (closes: #532549)
 
   * debian/rules:
     - WITH_SPLIT=n, enable milestone detection again, use ooo-build tarballs
     - add conditionals for KDE4, enable -kde for KDE4 again (closes: #528487)
     - don't set VERBOSE=true on ia64/buildd now that the quiet-buildd.diff
       is more complete.
     - remove explicit gcj-4.3 builddep again
   * debian/control.in:
     - build-conflict against libmono-dev 2.4+dfsg-2 on sparc - -3 is fixed
   * debian/README.Debian: mention kde4 for OOO_FORCE_DESKTOP
   * debian/control*in, debian/rules: add -style-oxygen package and synchroniize
     style handling in rules by just relying on $(IMAGES)
   * debian/ttf-opensymbol.*.in: remove; removes fc-cache calls (see
     debian-devel)

openoffice.org (1:3.1.0-5) unstable; urgency=low

   * ooo-build:
     - update (5947487f5c17fc66f1e11d4eec055c0df95f64c1 - 3.1.0.6)
       - Fix build with glibc-2.10.1 and above/ICU 4.2
   * debian/rules:
     - BOOST_VERSION=default (closes: #531118)
     - remove mono-jit (>= 1.9+dfsg-2) B-D as it's apparently gone
       in mono 2.4 and lenny has -6 anyway.
     - bump LPSOLVE_MIN_VERSION and SUITESPARSE_MIN_VERSION for
       suitesparse 3.4.0
     - add explicit gcj-4.3 builddep to work around #532065
   * debian/shell-lib.sh:
     - don't rely on
       /u/l/openoffice/basis-link/share/config/javasettingsunopkginstall.xml
       - find out the basis and specify /var/lib/openoffice/basisX.Y directly
       (hopefully closes: #530694, #531116, #531750)
   * debian/control.in:
     - add Pre-Depends: openoffice.org-comon to the various extension
       Add -java-common and ${java-runtime-depends} for the Java extensions.
       (hopefully closes: #529521)
     - add Pre-Depends: openoffice.org-core (>= 3.1.0-2) to -evolution
       (hopefully closes: #529519)

openoffice.org (1:3.1.0-4) unstable; urgency=low

   * ooo-build:
     - update (3f777bce5cbe0665fb840eee9cfe08fd9e1c710e)
 
   * debian/rules:
     - use gcj-jdk instead of java-gcj-compat-dev (closes: #526292)
     - add | java5-runtime | jre to JAVA_RUNTIME_DEPENDS (closes: #509690)
     - use /usr/lib/gcc/aotcompile.py instead of (gone)
       /usr/share/pyshared/aotcompile.py
   * debian/control.in:
    - make -evolution depend on libebook1.2-9 (which is dlopen()ed)
   * debian/openoffice.org-common.preinst.in, debian/rules:
    - again move javasettingsunopkginstall.xml to
      /var/lib/openoffice/basisX.Y/share/config to match what $OOO_BASE_DIR
      would do...
   * debian/shell-lib.sh:
    - adapt to rely on /usr/lib/openoffice/basis-link instead of
      hardcoding the path

openoffice.org (1:3.1.0-3) unstable; urgency=low

   * ooo-build:
     - update (c1a864706b14df89477cbafffdaba519fbc6c4e9 - 3.1.0.2)
 
   * debian/openoffice.org-common.preinst.in: use mkdir -p, not mkdir
     (closes: #529518)
   * debian/rules:
     - add explicit build-dep on gcj when building native jars, now needed
       due to java-gcj-compat changes....
   * debian/shell-lib.sh:
     - check whether $rdb exists in revoke_from_services_rdb() before running
       regview on it as it doesn't when the new -evolution is first unpacked in
       a upgrade run before the new -core.

openoffice.org (1:3.1.0-2) unstable; urgency=low

   * ooo-build:
     - switch to ooo-build-3-1 branch
       (cda7535b832b1b354eedf6aacd0260d628ff9884)
       - odk-use-correct-L.diff: specify correct -L in settings.mk
         (closes: #529020)
 
   * debian/rules:
     - add support for boost-defaults
     - more fixes for GCC_VERSION setting
     - introduce new BASIS_VERSION variable
     - HSQLDB_MINVER= (>> 1.8.0.9) for lenny, thanks Tim Retout
     - move services.rdb to /var/lib/openoffice/basisX.Y/program
     - deregister libevoabl?.so from services.rdb in install-arch as Base
       now fails when its not present (closes: #527910)
   * debian/control.in, debian/rules:
     - allow flex again, bump build-dep for flex if we use gcc 4.4 for safety
   * debian/control.in:
     - update openclipart-openoffice.org conflicts to (<= 0.18+dfsg-7)
     - make -emailmerge Pre-Depend on ${python:Depends}, python-uno
       (closes: #522022, #527558)
     - make -common conflict against -core having another basisX.Y than -common
       (closes: #528854)
   * debian/copyright:
    - actually add Files: section matching the upstream tarballs
   * debian/rules, debian/broffice.org.{preinst,postrm}.in,
     soffice-template.desktop.in: add extra .desktop files and soffice.* from
     extras/source/shellnew to /usr/share/templates for KDE (closes: #512737)
   * debian/rules, debian/shell-lib.sh, openoffice.org-common.preinst.in:
    - move javasettingsunopkginstall.xml once again to keep the path structure
      (now in /var/lib/openoffice/share/config)
   * debian/shell-lib.sh
    - add functions revoke_from_services_rdb() and register_to_services_rdb()
   * debian/openoffice.org-evolution.*.in:
    - add maintainer scripts for registering/revoking libevoabl?.so

openoffice.org (1:3.1.0-1) unstable; urgency=low

   * OpenOffice.org 3.1.0 final (no source changes to rc2)
   * upload to unstable
 
   * ooo-build:
     - update (ed83f8ef25c224f80ded79eb91c845064b407421)
       - forces OpenJDK javadoc even on gcj builds, fixes odk build breakage
       - use 3.1s new feature of setting JDBC CLASSPATHs in DataAcess.xcu
         directly
 
   * debian/rules:
     - move python version setting before the python conditionals deciding
       thanks Chris Cheney)
     - remove arch specifier from openjdk build-dep
     - fix GCC_VERSION handling to work again with OOo build calling
       e.g. i486-linux-gnu-gcc
     - remove changing jvmfwk3rc for adding JDBC CLASSPATHs
     - keep -kde/-kab enabled on lenny-backports
     - build with -openssl flavour of curl on lenny-backports
   * debian/watch: move from ftp.stardiv.de (not master anymore) to
     ftp.gwdg.de
   * debian/control.in:
     - also suggest libjtds-java
   * debian/control.reportdesign.in, control.presenter.in:
     - update depends/conflicts to match description.xml

openoffice.org (1:3.1.0~rc2-1) experimental; urgency=low

   * OpenOffice.org 3.1.0 rc2 (OOO310_m11)
   * ooo-build
     - update (43f5c40737796e18d399275bd6f65237e98f66c8)
       - moves default-system-fpicker.diff into the common set
         (closes: #523314)
 
   * debian/control.in, debian/control.kde.in, debian/rules:
     - disable -kde and -kab as they're for KDE3 (closes: #523899). Improve
       BUILD_KDE conditional
   * debian/control.in, debian/broffice.org.postrm.in, debian/rules:
     - Standards-Version: 3.8.1. Fix DEB_BUILD_OPTIONS lang= parsing to actually
       work with DEB_BUILD_OPTIONS being separated by spaces as introduced
       in 3.8.0. (ccache,lang=en-US de -> ccache lang=en-US,de)
   * debian/rules, debian/control.debug.in:
     - fix lintians dbg-package-missing-depends
   * debian/rules, debian/control.in:
     - remove writer2latex remains as it a) is not a "bundled extension"
       anymore and b) is not in the code anymore either. Still available
       externally.
   * debian/rules debian/openoffice.org-gcj.post:
     - remove postinst/postrm of -gcj, let dh_nativejava -o do the job
   * debian/rules:
     - remove Python26 special-casing, we now have a generic patch for 2.4 and
       2.6
     - remove scsolver stuff, scsolver is gone from ooo-build
   * debian/control.in:
     - make openoffice.org-common recommends xfonts-mathml (closes: #525245)

openoffice.org (1:3.1.0~rc1-2) experimental; urgency=low

   * ooo-build:
     - update (9c5c8322f541550ca0bd605169aa40d9fd654d98)
 
   * debian/shell-lib.sh: export PYTHONPATH="/@OOBASISDIR/program" as
     regstering mailmerge.py aparently calls "import pythonloader" which
     does not work anymore without (closes: #522536)
   * debian/control.in:
     - fix override dispariry (-l10n-in/-l10n-za -> localization)
   * debian/rules, debian/shell-lib.sh:
     - move javasettingsunopkginstall.xml to /var/lib/openoffice and adapt
       unopkg calls (closes: #523044)
   * debian/control.in, debian/control.ogltrans.in, debian/rules:
     OOo is fixed to not crash when OGLTrans.uno.so is not there anymore,
     re-enable splitout to -ogltrans

openoffice.org (1:3.1.0~rc1-1) experimental; urgency=low

   * OpenOffice.org 3.1.0 rc1 (OOO310_m9)
 
   * ooo-build:
     - update (b6c58e692ac4fa15ec666a3fbd79c98eed78c46e)
     - src: add GSI_ro.sdf.bz2 from ftp.linux.cz (DEV300), closes: #522180
   * debian/rules:
     - add conditional to use python-support
   * debian/control.in, debian/control.ogltrans.in, debian/rules:
     - don't put OGLTrans into -ogltrans, services.rdb references it and
       Impress crashes horribly if it's not there (closes: #521035). Add
       Conflict/Replaces/Provides.
   * debian/rules, ooo-build/*: switch to Fedoras solution for PyUNO. Replace
     RPATH with os.path.append in uno.py and just install uno*.py into
     site-packages (closes: #520944)
   * debian/control{,sdk,reportdesign}.in:
     - add last three ${misc:Depends}, even where we have no Depends: line
       otherwise

openoffice.org (1:3.0.1-9) unstable; urgency=high

   [ Rene Engelhard ]
   * debian/rules:
     - use libcurl4-gnutls-dev (closes: #521741, #391671)
 
   [ Ben Finney ]
   * debian/control*.in:
     + Re-work each package synopsis to avoid self-reference.
       (Closes: Bug#520611)

openoffice.org (1:3.0.1-8) unstable; urgency=high

   [ Rene Engelhard ]
   * ooo-build:
     - update (81a9da548b0e400b574bfe4e78b06b16982cd270), now in git
       without ChangeLog...
   * debian/rules:
     - fix saxon conditional. use internal saxon because system-saxon
       breaks various filters....
     - add arm to OOO_MOZILLA_ARCHS again as it FTBFSes on the lenny backport
       otherwise because iceape-dev is not installed.
     - remove "openoffice" symlink, add "openoffice.org$(VER)" (closes: #511232),
       upstream has openoffice.org3 launcher in /usr/bin, too
     - build with java-gcj-compat on mipsel (and mips, too as IMHO it doesn't
       make sense to build mips and mipsel with different JDKs) so that it
       builds...
   * debian/rules, debian/control.qa.in, debian/openoffice.org-qa-tools-*:
     - remove -qa-*, broken and unused anyway
 
   [ Ben Finney ]
   * debian/control*.in:
     + Replace deprecated ‘${Source-Version}’ with ‘${binary:Version}’ for
       architecture-dependent packages.
     + Replace deprecated ‘${Source-Version}’ with ‘${source:Version}’ for
       architecture-independent packages.
       (Closes: Bug#520475)
     + more ${misc:Depends}
       (Closes: Bug#519644)
     + Follow Lintian's recommendation to avoid dependency on a Debian ‘-1’
       revision.
       (Closes: Bug#520604)

openoffice.org (1:3.1.0~ooo310m6-1) experimental; urgency=low

   * OpenOffice.org 3.1.0 development snapshot OOO310_m6
     - build without -march=armv5te for arm (closes: #501957)
     - lbnames.h supports gcc 4.4 (closes: #505669)
     - now has overline supports for word (closes: #228392)
     - About box now fixes en-US tense and adds missing comma (closes: #470521)
     - fixes bridges for SELinux (hopefully closes: #440105)
     - doesn't decrement date on input to 1 day past on some $TZ anymore
       (closes: #512644)
     - new orig without rfc314.txt (closes: #516784)
     - removes bogus /rs in some localized dialogs (closes: #514398)
     - fixes actions in the edit area after slideshow (closes: #520161)
   * ooo-build:
     - back on trunk (r15564)
       - updates openoffice.1 to remove --version (closes: #505768)
       - mentions ; vs , change in the help (closes: #519828)
     - src: add OOO310 GSIs from ftp.linux.cz
   * debian/shlibs.override.icu: update for new icu
   * debian/shlibs.override.xmlsec: remove, xmlsec went static
   * debian/rules:
     - bump minimal ICU version for sid to >= 4.0.0
     - various 3.1-related updates
     - remove option for internal writer2latex as it's now a (bundled) extension
       upstream too and we have it packaged already.
       Hardcode --without-writer2latex
     - add conditional for enabling graphite, now that ooo-build has a surrected
       --enable-graphite again (and upstream a cws for it)
     - temporarily disable the Report Builder extension until rptfix04
     - move install of make install-installed file from cp -a to dh_install;
       this also moves hid.lst to -qa-tools
     - explicitly specify --with-stlport in USE_STLPORT=y case as
       ./configure now only defaults to STLport on i386. Add note
       about STLport and some upcoming system stuff
     - remove build-conflict on libxul-dev for MOZILLA != libxul again;
       configure fixed
     - remove -unbundled conflict when VER = "" because upstreams packages
       now are called openoffice.orgX-*.
     - tighten hsqldb depends to 1.8.0.10 with the lock fix
     - only specify --with-lang= when we don't only build en-US. en-US is
       default anyway and not specifying --with-lang=en-US afais speeds up the
       en-US only build even more
     - OGLTrans seems to work now in sid (even for amd64), so re-enable
       (closes: #517335)r
     - update pentaho libs (build-)depends to the -OOo31 versions
     - enable ca and fi help
   * debian/control*in:
     - update for new sections:
       - -dbg -> debug, -l10n-* -> localization, -officebean -> java,
         -base -> database, ttf-opensymbol -> fonts, cli -> cli-mono
   * debian/rules, debian/startcenter.desktop: remove own startcenter.desktop;
     OOo now has one upstream
   * debian/control.ure.in: suggest java5-runtime instead of java2-runtime as
     jvmfwk stopped displaying JVMs < 1.5.0 and conflict against Java
     extensions using the (wrong for OOo 3) $ORIGIN in their maintainer
     scripts to not break upgrades as the old Java config is invalidated....
   * debian/control.mediawiki.in: depend on liblucene2-java until i#98680 is
     fixed
   * debian/rules, debian/scripts/openoffice-xlate-lang:
     - add openoffice-xlate-lang symlink in debian/scripts, use
       debian/scripts/openoffice-xlate-lang
   * debian/rules, debian/control.in: add support for building against an other
     python than the "current" (default) one
   * debian/copyright:
     - update
     - migrate to http://wiki.debian.org/Proposals/CopyrightFormat format

openoffice.org (1:3.0.1-7) unstable; urgency=high

   * brown papaer bag release
   * debian/openoffice.org-emailmerge.postinst.in:
     - add missing @ (closes: #520146)

openoffice.org (1:3.0.1-6) unstable; urgency=low

   [ Rene Engelhard ]
   * ooo-build:
     - update (15544)
   * debian/rules:
     - remove ure (>= ...) from uno-libs3s Depends: (closes: #519138)
   * debian/control.in:
     - s/experimental/unstable/ in Vcs-Bzr
   * debian/openoffice.org-qa-tools.{postrm,preinst},
     openoffice.org-emailmerge.postinst.in, debian/rules: don't hardcode the
     dir, use @OOBASISDIR@
 
   [ Ben Finney ]
   * debian/control.in:
     + add nosmart+ to Vcs-Bzr:
     + ‘Depends: ${misc:Depends}’ as recommended by Lintian for
       debhelper(7).
       (Closes: Bug#519644)

openoffice.org (1:3.0.1-5) unstable; urgency=high

   * ooo-build:
     - update (r15496)
   * debian/shell-lib.sh:
     - $ORIGIN -> $OOO_BASE_DIR
   * debian/presubj:
     - directly point to http://wiki.debian.org/OpenOffice#debug in IV
      (closes: #517987)
   * debian/README.Debian:
     - remove openoffice.debian.net (closes: #517978)
   * debian/control.in:
     - remove http://udk.openoffice.org/python/python-bridge.html from
       python-unos description, we already have it in Homepage:
   * merge from Ubuntu:
     - fix PYTHON_SITE for python2.6 (print(sysconfig.get_python_lib())
     - Update rebuild-gcj-db snippet.

openoffice.org (1:3.0.1-4) unstable; urgency=low

   * ooo-build:
     - update (r15428)
   * debian/rules
     - MONO2=y (closes: #517738)
     - re-enable lsb_release -cs call and build-conflict against base-files = 5
       for sid
   * debian/control.in:
     - make -core conflict against < OOo3 -java-common (closes: #517001)

openoffice.org (1:3.0.1-3) unstable; urgency=low

   * ooo-build:
     - update (r15395)
   * debian/rules:
     - build with boost 1.37
     - add libdbX.Y-dbg to DBG_DBG_SUGGESTS
     - @ICONVERSION@ is 3 and not 30 (closes: #516257)
   * debian/control.in:
     - add Conflicts: openoffice.org-core  (<< ${Source-Version}) for
       openoffice.org-common (closes: #516090)
     - readd build-dep changing for suitesparse 3.2.0, bump to 1:3.2.0-2
       and make lenny backport compatible..

openoffice.org (1:3.0.1-2) unstable; urgency=low

   [ Rene Engelhard ]
   * upload to unstable
   * ooo-build:
     - update (r15324)
   * debian/openoffice.org-common.links: add symlinks to the mimetype icons so
     that they adhere to the Icon Naming Specification, thanks Guido Günther
     (closes: #512792)
   * debian/rules:
     - add Recommends openoffice.org-math to openoffice.org-writer
     - specify ARCH_FLAGS as -O0 when DEB_BULD_OPTIONS contains noopt
       (closes: #514166)
     - only build-dep on mono 2.0.1 when MONO2=y
     - MONO2=n and revert lp-solve build-dep on the one built against
       suitesparse 3.2.0/suitesparse builddep so that we build in sid right
       now.
     - build against default db (4.7) now (as librd0-dev depends on libdb-dev
       which depends on libdb-dev...)
   * debian/openoffice.org-{base,calc}.overrides.lintian: override
     desktop-command-not-in-package here, too (like in all the other modules)
 
   [ Chris Halls ]
   * ooo-build/patches/dev300/sfx2-recent-files.diff:
     Update recent files list after save as and open (closes: #505879)

openoffice.org (1:3.0.1-1) experimental; urgency=low

   * OpenOffice.org 3.0.1 final (except for Windows identical with rc2)
   * ooo-build
     - update (r15151)
   * debian/rules:
     - add build-conflicts against xulrunner-dev is MOZILLA != libxul
     - build-depend on libsuitesparse (>= 3.2.0) and a lp-solve also built
       against it to prepare the transition
   * debian/control.in:
     - allow imagemagick for build again, as it seem to create the splash
       correctly now
   * debian/scripts/fix_image_rgb, debian/rules: use convert instead of
     gm convert
   * debian/openoffice.org-common.preinst.in: fix typo to actually also remove
     dictionary.lst.old

openoffice.org (1:3.0.1~rc2-2) experimental; urgency=low

   * ooo-build:
     - update (r15097)
   * debian/rules:
     - update xulrunner build-dep in MOZILLA=libxul case for current reality
     - use UREPACKAGEVERSION for determining ures version, more correct and
       also includes the micro. Remove +OOo3.0.0~ suffix as ure now is at 1.4.1
       and we bump .shlibs anyway
     - create .so symlinks in UREs dir in -dev so that we have some even if
       the SDK mechanism which creates a dir in $HOME fails.
     - stop adding a extra text/rtf as writer.desktop now already contains
       it upstream (closes: #512417)
   * debian/control.in:
     - make -common conflict against dictionaries-common (<< 0.98.14)
     - move from Breaks: to Conflicts: as otherwise the experimental buildds
       fail to install -common...
   * merge from Ubuntu:
     - make ure only Suggest a JRE

openoffice.org (1:3.0.1~rc2-1) experimental; urgency=low

   * OpenOffice.org 3.0.1 rc2 (OOO300_m15)
   * ooo-build:
     - update (r15061):
       - remove workaround for #i97491 again (closes: #511459)
   * build without stray ure.links (closes: #509793)
   * debian/startcenter.desktop.in: use ooo-gulls.png as Icon
   * debian/rules:
     - apply Python26 patchset if building with python 2.6
     - install libsalalloc_malloc.so.3 into -qa-tools
     - remove rest of if(n)eq ETCH_BACKPORT conditionals
     - fix extra license/readme file removal
     - remove empty .../ure/lib dir in -common
     - fix OOSDKDIR setting and move all $(OODIR)/sdk to $(OOSDKDIR)
     - install ooo-build/NEWS
   * debian/control.reportdesign.in:
     - add missing Depends: on ${java-runtime-depends}
   * debian/control.in:
     - only recommend ttf-liberation and change it to
       ttf-liberation | msttcorefonts (closes: #509193)
     - fix -kdes description: remove KDE adressbook mentioning, it's in -kab
     - -common Breaks: openclipart-openoffice.org (<= 0.18+dfsg-5)
   * debian/rules, control.gcj.in: disable ppc for -gcj as gij doesn't work
     there anyway (#478760). Fix Architecture: of -gcj to not include
     non-Java archs.
   * debian/rules, debian/broffice.org.{preinst,postrm}.in: also change
     UI-brand.xcu for BrOffice.org
   * debian/presubj: point to OpenOffice.orgs README sections
     ("Problems During Program Startup" and "File Locking").

2008

openoffice.org (1:3.0.1~rc1-2) experimental; urgency=low

   * ooo-build:
     - update (r14911):
       - work around #i97491: do not move soffice into
         openoffice.org-common (closes: #509435)
   * debian/rules: (temporarily?) comment out soffice changing in -common.
   * debian/control{,in}: fix Vcs-Bzr:

openoffice.org (1:3.0.1~rc1-1) experimental; urgency=low

   * OpenOffice.org 3.0.1 rc1 (OOO300_m14)
     - fixes usage of flash v9 plugin (closes: #434510)
   * ooo-build
     - switch to ooo-build-3-0-1 branch (r14903)
   * debian/source.lintian-overrides: override bogus (lintian bug #511859)
     missing-build-dependency-for-dh_-command
   * debian/rules:
     - update .so -> -dev merging to the fact that 3.0s SDK does not have
       the .so symlinks for libuno_* anymore but only for the internal xmlsec.
     - install vnd.openofficeorg.extension.desktop and /openoffice.applications
       directly from sysui and make install-*/broffice use the directories
       for the respective flavour directly
     - also install /usr/share/mime-info/openoffice.keys for broffice.org
     - remove "Lohit Hindi" addition for hi-INs help, obsolete since (at least)
       3.0.0
   * debian/README, debian/rules: remove obsolete targets, explain
     make patch.apply
   * debian/control.in:
     - openoffice.org-base-core needs to depend on openoffice.org-core....
   * debian/openoffice.org-common.postinst.in: remove; call to
     update-openoffice-dicts is obsolete because OOo does not honour
     dictionary.lst anymore
   * debian//openoffice.org-common.preinst: remove
     /etc/openoffice/dictionary.lst*
   * debian/shell-lib.sh: remove long obsolete "trap {...}". bashism anyway.
     Thanks lintian.

openoffice.org (1:3.0.0-6) experimental; urgency=low

   * ooo-build:
     - update (r14697)
       - mailmerge-ssl-ehlo.diff: fix SMTP dialog for SSL (closes: #507448)
   * debian/rules:
     - changes for mono 2.0 transition (thanks Jo Shields):
       - build-depend on mono-devel (>= 2.0.1), bump MONO_MINVER to >= 2.0.1
       - add overrides for MCS, GMCS to /usr/bin/csc and MKBUNDLE2 (mkbundle)
     - if we enable gio, install ucpgio1.uno.so properly into -gnome and fix
       -gnomes description ((GNOME) VFS -> GIO)
     - add hackaround to use ENABLE_QA_TOOLS=n on ia64 as "jar" segfaults
       there (and only there) (closes: #507135)

openoffice.org (1:3.0.0-5) experimental; urgency=low

   * ooo-build:
     - update (r14608)
       - sensible-browser.diff: fix "typo" (sic!) (closes: #505429)
       - i95118.diff: add patch from i#i95118 to make user scripts found again
         and python extensions deployable again (closes: #504140)
       - pythonloader-no-DEBUG.diff: don't set DEBUG=1 in pythonloader.py
         (closes: #491922)
     - src: update GSIs from ftp.linux.cz
   * debian/rules:
     - update ENABLE_GIO conditional, either we want gio or gnome-vfs
     - install the extension.desktop with Type=MimeType (to
       /usr/share/mimelnk/application/vnd.openofficeorg.extension.desktop) and
       install icons for it from ooo-build. Also actually install
       openoffice.org.xml for shared-mime-info (closes: #502737)
     - don't add | java5-runtime to JAVA_RUNTIME_DEPENDS as we don't work
       with cacao-oj6
     - add lucene-depends substitution also to binary-arch since openoffice.org
       is not Arch: all and it doesn't get the liblucene2-java dep otherwise.
   * debian/startcenter.desktop.in:
     - MimeType=application/vnd.openofficeorg.extension
   * debian/control.postgresql.in:
     - only suggest postgresql
   * debian/control.in:
     - conflict against cacao-oj6-jre (closes: #495694)
   * debian/broffice.org.{preinst,postrm}.in: add
     /usr/share/mimelnk/application/vnd.openofficeorg.extension.desktop

openoffice.org (1:3.0.0-4) experimental; urgency=low

   * ooo-build:
     - update (r14425)
       - no-latex-filter-without-writer2latex.diff: don't include LaTeX stuff
         in Writers filter list with --without-writer2latex (closes: #502549)
       - sensible-browser.diff: run kde-open on mailto: URLs in kde-open-url.sh
         instead of removed sensible-ooomua (closes: #502852)
   * debian/rules:
     - update libstlport_gcc.so symlink to be in ure/lib (closes: #502812)
     - add option to run the API tests (cwscheckapi)
     - build with java-gcj-compat on ia64 again, at least temporarily
       (closes: #502422)
   * debian/rules, debian/broffice.org.{preinst,postrm}.in: fix Setup.xcu
     diversion
   * debian/control.in:
     - make -common conflict against older broffice.orgs

openoffice.org (1:3.0.0-3) experimental; urgency=low

   * ooo-build:
     - update (r14320)
   * debian/copyright, debian/README.Debian-source: fix
   * debian/rules:
     - don't run the smoketest again as it still causes weird build/install
       failures on the buildds
     - remove etch-backport conditionals, add lenny-backport conditionla -
       use internal lucene there.
     - update LD_LIBRARY_PATH setting in the SDK wrapper scripts for the
       URE

openoffice.org (1:3.0.0-2) experimental; urgency=low

   * ooo-build:
     - update (r14305)
       - xmlhelp-system-lucene-fix.diff/extensions-system-java.diff: don't
         hardcode unxlngx6.pro...
   * debian/rules:
     - make ootestapi find OOoRunnerLight.jar by setting the necessary symlink
   * debian/control.qa.in:
     - make -qa-api-tests depend on Java as it needs OOoRunnerLight.jar to be
       run to be used. Make -qa-tools suggest it.

openoffice.org (1:3.0.0-1) experimental; urgency=low

   * OpenOffice.org 3.0.0 final (identical to rc4)
   * ooo-build
     - update (r14292)
       - system-python-ure-bootstrap.diff: set URE_BOOTSTRAP variable if not
         there with system-python, thanks Daniel Watkins (closes: #501028)
   * debin/rules:
     - remove now obsolete ADDITIONAL_SECTIONS="DebianBaseSystem*"
     - build against KDE3 again. In contrast to building against KDE4 it works
       in runtime (and also works with KDE4)
     - run smoketest during build again to prevent e.g. #501664 happening again.
       Put it into a mktemp -q -d generated dir instead of in the build tree
       so that it doesn't break the install after it....
   * debian/control.in:
     - make openoffice.org metapackage depend on liblucene2-java.

openoffice.org (1:3.0.0~rc4-1) experimental; urgency=low

   * OpenOffice.org 3.0 release candidate 4 (OOO300_m9)
   * ooo-build:
     - update (r14207)
       - unxsplash-rework.diff: don't run the external oosplash with -nologo
         (no splash anyway) and with the (new) -no-oosplash
     - src: update GSIs (et ro sk)
   * debian/*.mime: run with -no-oosplash (closes: #396276)
   * debian/control.in:
     - make the openoffice.org metapackage depend on
       openoffice.org-report-builder-bin as the libs contained there are
       in the standard OOo install and the SRB needs it (even more when
       installed not from the deb)
   * debian/rules:
     - create symlinks cli_xyz.config -> cli_xyz.dll.config as policy*dll
       apparently references the former

openoffice.org (1:3.0.0~rc3-1) experimental; urgency=high

   * OpenOffice.org 3.0 release candidate 3 (OOO300_m8)
     - fixes CVE-2008-2238 (multiple EMF parser flaws)
   * ooo-build:
     - update (r14129)
       - soffice-detect-mozilla-certificates.diff: only do a full find for
         cert8.db when we don't find it with just maxdepth 2 (closes: #499062)
     - src: update GSIs (et ga ku sk)
   * debian/rules:
     - remove extraneous LICENSE file again
     - re-enable Mono packages
     - oops, remove $TMPD in get-orig-source
   * debian/openoffice.org-report-builder-bin.overrides.lintian: fix
   * debian/control.in:
     - conflict against non-matching versions of -qa-ui-tools now that
       the new "testautomation" module follows cwses

openoffice.org (1:3.0.0~rc2-1) experimental; urgency=high

   * OpenOffice.org 3.0 release candidate 2 (OOO300_m7)
     - fixes CVE-2008-2237 (WMF META_ESCAPE Integer Overflow Vulnerability
     - catches exception on (malformed) ODGs referencing not existing
       images (closes: #494644)
     - makes -report-builder depend on 3.0 exactly.
   * ooo-build:
     - use ooo-build-3-0 branch
     - update (r14043)
       - really fixes ppc/openjdk build
       - math-draw-generic-name.diff: add GenericName for
         Draw (closes: #498922) and Math (closes: #498924)
       - sc-skip-overlapped-cells.diff: check the vadility of row numbers
         (closes: #499374)
       - src: update GSIs
   * debian/rules:
     - fix USE_SCSOLVER conditional
     - re-enable hu
     - HELP_L10N_VIRTUAL_VERSION:=3.0
     - various conditional updates for new extension configure defaults
     - --with-java-target-version=1.5 for builds with openjdk/cacao-oj6
     - also complain in binary-indep when Mono is disabled
   * debian/control.reportdesign.in:
     - depend on OOo base and java-common with >= ${base-version} and conflict
       against them with >= ${base-version}.1. According to the bug this
       closes: #497204
   * debian/shlibs.override.icu: update for OOo 3.0s icu 3.6
   * debian/openoffice.org-presentation-minimizer.preinst.in: oops, fix version
     comparison

openoffice.org (1:3.0.0~ooo300m3-3) experimental; urgency=low

   * ooo-build:
     - update (r13694)
       + config_office-openjdk-paths.diff: add missing paths or fix
         client/server mismatch for builds with OpenJDKon !i386/amd64
         (closes: #496479)
   * debian/rules:
     - update lucene2 version; enable system-lucene now that it's in main
     - add conditonal for cacao-oj6-jdk (which doesn't work, though,
       testtool fails with the same error as seen in #495694)
     - gcj-dbtool (which we use since we build with OpenJDK) is in gij, not
       gij-X.Y and only the latter is pulled in by java-gcj-compat-dev. Add
       builddep (closes: #496480)
     - create debian/usr/bin/moc during the build, pointing to the right moc.
       moc is an alternative and can point to the wrong Qts moc.
   * debian/control.ure.in:
     - Section: libdevel for uno-libs3-dbg to fix override disparity
   * debian/control.reportdesign.in:
     - -report-builder-bin contains librpt* which is linked against libraries
       from -base so that one should depend on -base, not -report-builder

openoffice.org (1:3.0.0~ooo300m3-2) experimental; urgency=low

   * ooo-build:
     - update (r13660)
       + bin/package-ooo: add OFFICE_BASE_HOME and OO_SDK_URE_HOME with
         correct contents to setsdkenv (closes: #496219)
     - src: update GSIs (bg et ga nb nn ro sk)
   * debian/rules:
     - make bin/piece/* also executable

openoffice.org (1:3.0.0~ooo300m3-1) experimental; urgency=low

   * OpenOffice.org 3.0 release branch milestone 3 (OOO300_m3)
     - deleting cell contents while spellchecking window is open does now
       not crash in calc anymore in some circumstances (but the text is not
       editable) (closes: #490549)
     - package-ooo: fix install to make help land properly in -help-xx.
   * merge 1:2.4.1-7
   * ooo-build:
     - update (r13651)
     - src: get OOO300 GSIs from ftp.linux.cz
   * debian/rules:
     - Add SYSTEM_LUCENE conditional, disable it yet as liblucene2-java is
       in contrib
     - Add SYSTEM_REDLAND conditional
     - re-enable the SDK
     - enable mn (Mongolian); build all languages again (except hu which is
       broken and just contains Swedish right now)
     - build against kde4
     - update JAVA_RUNTIME_DEPENDS; add cacao-oj6-jre as alternative, bump
       java2-runtime to java5-runtime as we now stricly need a 1.5-capable
       JRE
     - don't run ldconfig in ure package, thanks lintian
     - add Replaces: for above help fix, ended up in -common in beta2-1
     - update get-orig-source
     - adapt for new source split
     - remove xalan/xerces conditionals, add saxon ones
     - build with OpenJDK
     - add conditional to decide whether to build with Suns Solver or Koheis
       as ooo-build supports it. Use Suns solver for now
     - add build-dep on libpoppler-dev (>= 0.8.0) as there's now a patch
       making "xpdfwrapper" build against poppler. yay.
   * debian/rules, debian/control.help.in: recommend
     liblucene2-java/openoffice.org-java-common. We don't depend on it as we
     don't want to make the help depend on Java (lucene is needed for "search"
     now)
   * debian/rules, debian/control.etch_lenny_transitional.diff: remove
     etch->lenny transitional package
   * debian/rules, debian/scripts/vars.m68k: yes, we do have a m68k port now...
   * debian/rules, debian/control.in:
     - -style-andromeda is back (contains the "Classic" theme)
     - split kab support into -kab to not make -kde depend on kdepimlibs5
   * debian/rules, debian/control.mono.in:
     - update for cli_types.dll split due to the three layer OOo and other
       restructuring inside OOo. Don't make ure contain/depend on cli*dll as
       that would make all OOo packages depend on mono and people might not
       want/need it
     - Install more (upstream-generated) .config and policy* files for the mono
       bridge
     - make cli-uno-bridge conflict against the old libuno-cli-types1.1-cil
   * debian/control.in:
     - fix -andromedas Replaces:
     - Homepage: http://www.go-oo.org, thanks Renato Yamane
     - move bsh from Depends to Suggests at -java-common
   * debian/control.ure.in:
     - uno-libs3-dbg is Priority: extra
   * openoffice.org-presentation-minimizer.prerm.in: fix removal
   * debian/rules, debian/control.in,
     openoffice.org-headless.lintian-overrides: libvclplug_svp is now in
     -coreXY upstream. Follow.

openoffice.org (1:2.4.1-7) unstable; urgency=medium

   * ooo-build:
     - update to debian-2-4-1 branch
   * debian/control.mono.in:
     - Section: libs to fix override disparity
   * merge from experimental/3.0:
     - debian/control.in:
       + remove xutils build-dep, nas was using xmkmf and it's long gone here
   * debian/control.in:
     - Standards-Version: 3.8.0 (already following it)
     - For upgrades from bpo packages add a Replaces on
       openoffice.org-java-common to -base because of hsqldb, see below.
       (closes: #494512)
   * debian/copyright:
     - wrap "Debian package authors:" line to please lintian
   * debian/rules:
     - remove obsolete [$(OOO_ARCHS)] qualifier from python-dev builddep
       (closes: #491623)
     - put hsqldb.jar also to -base  with internal hsqldb so that we don't
       get file differences between sids package and backports.
   * debian/rules, debian/control.reportdesign.in:
     - split librpt* out into a -report-builder-bin package. Newer versions of
       the SRB also often work with older librpt*/OOo, but that would not work
       with the current packaging due to shlibdeps.

openoffice.org (1:3.0.0~beta2-1) experimental; urgency=low

   * OpenOffice 3.0.0 beta2 (BEB300_m3)
     - Base now doesn't quit anymore on "recently used files" in the wizard
       when those got deleted/moved (closes: #452810)
     - now properly complains about missing permissions when trying to write
       to a read-only location (closes: #238906)
     - fixes printing of handouts in grayscale mode (closes: #416309)
   * ooo-build:
     - update (r13171)
   * debian/template.desktop.in: move to ..
   * debian/startcenter.desktop.in: .. this and run ooffice now, which
     will bring us to the new StartCenter. Reuse writers icon.
   * debian/*.overrides.lintian*: move ..
   * debian/*.lintian-overrides*: here.
   * debian/scripts/installoverrides: remove
   * debian/rules:
     - run dh_lintian
     - lots of updates for removed $UPD, removed files and changed locations
       and the "three-layer OOo" (of which we merge the layers in ooo-build)
     - bump ant builddep to ant (>= 1.7.0) and additonally build-dep on
       ant-optional when we build the mediawiki extension
     - remove scsolver conditionals, not disableabe in Suns version.
       Remove obsolete mvs
     - support default-jdk-builddep, begin support of openjdk-6-jdk for
       building, still default to java-gcj-compat-dev
     - move ure Java stuff to /usr/share/java (as before in -java-common)
     - temporarily disable SDK package (until jsc21)
     - update get-orig-source target
     - add --enable-gio conditional, disable it for now since it breaks OOo
     - start of KDE4 support
     - add BUILD_GTK conditional
     - BUILD_ONLY_EN_US=y
     - remove spellchecking symlink and specify the new configure options for
       specifying dictionary/hyphenation/thesauri paths.
     - disable mono, known-broken right now, will be fixed with m22 onwards
   * debian/rules, debian/control.in:
     - make openoffice.org-core Pre-Depend on ure (>= 1.4+OOo3.0.0~)
       (unfortunately ure didn't update it's version although 3.0.0 needs new
       symbols) and update dh_makeshlibs to add a corresponding shlibs
   * debian/control.ure.in:
     - remove unneeded ${shlibs:Depends} for ure-dbg
   * debian/openoffice.org-core.shlibs.local, debian/rules:
     - don't use a .shlibs.local for the URE libs anymore. Get the URE
       dependency via the normal .shlibs mechanism
   * debian/rules, debian/control.in,
     debian/control.{minimizer,presenter,mediawiki}.in,
     debian/openoffice.org*.{preinst,prerm,postinst}.in,
     debian/openoffice.org*.{script.bug}:
     - package the new Presenter Console, Wiki Publisher and PDF Import
       extensions
     - update/add Presentation Minimizer conditionals
   * debian/broffice.org.{preinst,postrm}.in,
     debian/openoffice.org-dtd-officedocument1.0.xmlcatalogs,
     - update
   * debian/rules, debian/control.in: URE is now a part of the "three-layer
     office". Remove PACKAGE_URE conditionals and make -core depend on ure.
   * debian/copyright: LGPL v3; update
   * debian/scripts/vars.*: add PLATFORMID (not kfreebsd-* yet...)
   * debian/control.in:
     - s/cupsys/cups/
     - remove xutils build-dep, nas was using xmkmf and it's long gone here
   * debian/openoffice.org-presentation-minmizer*: update for new ID
   * debian/rules, debian/control.ure.in: package the public UNO libs
     into a specific uno-libs3 package

openoffice.org (1:2.4.1-6) unstable; urgency=low

   * ooo-build
     - update (r13167)
   * debian/rules:
     - only try to copy debian/tmp/pkg/openoffice.org-{help,l10n}-xx when
       it's there
   * debian/control.mono.in, debian/rules:
     - hrm, we probably shouldn't make binary-arch depend on binary-indep.
       Hardcode cli-uno-bridges dependencies instead of relying on
       dh_clideps

openoffice.org (1:2.4.1-5) unstable; urgency=medium

   * ooo-build:
     - update (13085)
   * debian/rules:
     - re-enable Java for armel, gcj-4.3 OOM reportedly fixed. Add build-dep
       on gcj-4,3 (>= 4.3.1-2) for armel
   * debian/rules, debian/control.mono.in, debian/*.installcligac: split
     cli_*dll in various subpackages to make the packages CLI policy compliant.
     Rename libuno-cil to cli-uno-bridge. Move the files in libuno*-cil to
     /usr/lib/cli/uno-1.x
   * debian/rules, debian/control.in:
     - split emailmerge out into an own package. Don't make -writer depend on
       python-uno anymore so that -writer (and openoffice.org) still can be
       installed when python-uno is not installable (like at python-defaults
       changes)
   * debian/openoffice.org-emailmerge*: unopkg add --shared mailmerge.py
     to register mailmerge.py as it otherwise doesn't seem to work
     (closes: #488875)

openoffice.org (1:2.4.1-4) unstable; urgency=medium

   * ooo-build
     + update (r12994)
       + sw-field-patch-fix-competing-protection.diff: for the competing
         protection problem from n#400884 (really closes: #477653)
       + distro-configs/Common.conf.in: randr re-enabled per default
   * debian/rules:
     - re-enable randr
     - re-enable mono, mono seems to be fixed on amd64
   * debian/control.in:
     - make openoffice.org metapackage depend on ttf-liberation. Remove
       msttcorefonts suggestion.
   * debian/openoffice.org-core.postrm.in:
     - fix. rm -rf /var/spool/openoffice, not /var/spool/openoffice2

openoffice.org (1:2.4.1-3) unstable; urgency=medium

   * ooo-build:
     - update (r12885)
       + cws-cmcfixes47-sw.diff: backport fix from 3.0 to not open Word
         documents read-only (closes: #477653)
       + cws-cmcfixes47-extensions.diff: fix mozilla plugin for 64-bit mozilla
         API
       + distro-configs/Common.conf.in: --disable-randr (closes: #485833)
   * debian/rules:
     + re-enable mozilla plugin for 64bit archs
     + add ENABLE_RANDR conditional, remove libxrandr2 Recommends:

openoffice.org (1:2.4.1-2) unstable; urgency=low

   * ooo-build:
     - update (r12856)
       + ooo86080.unopkg.bodge.diff: fix bashism: s/==/=/ (closes: #485706)

openoffice.org (1:2.4.1-1) unstable; urgency=low

   * OpenOffice.org 2.4.1 final
   * upload to unstable
   * ooo-build:
     - update (r12837)
   * debian/control.in:
     - only recommend -fitler-binfilter. (closes: #484287)
     - conflict against libgtk2.0-0 = 2.12.10-1 on amd64 because of
       #484580 and #484758.
   * debian/rules:
     - install also other resolutions than 48x48 for the ooo-build/desktop
       icons, thanks Chris Cheney
   * debian/rules, debian/broffice.org.*.in:
     - fixup openoffice.applications (closes: #485437) and stop specifying
       unopkg with full paths (we don't do it for ooffice either and
       /usr/bin/unopkg does it)
   * debian/copyright:
     - update

openoffice.org (1:2.4.1~rc2-1) experimental; urgency=low

   * OpenOffice.org 2.4.1 rc2 (OOH680_m17)
   * ooo-build:
     - update (r12720)
   * debian/control.in:
     - s/meta package/metapackage/
   * debian/rules:
     - fix typo in installing bug scripts/presubj for arch-indep packages

openoffice.org (1:2.4.1~rc1-1) experimental; urgency=low

   * OpenOffice.org 2.4.1 rc1 (OOH680_m16)
     - now doesn't need a patched icu (public SetBreakType) anymore for
       building
   * ooo-build:
     - use ooo-build-2-4-1 branch
     - update (r12682)
       + allows to change broken java configuration
         This closes: #451928, #452925
         Most probably also closes: #454996
   * debian/rules:
     - we also need to build-depend on libnss3-dev (closes: #481996)
     - re-enable system-icu for etch backports
     - add get-orig-source target
     - remove overseen $(OOO_ARCHS); make control/maintscripts depend on all
       .ins for it (removes duplicate contro.gcj.in). Thanks Chris Cheney
     - disable mono on amd64 and OGLtrans on 64-bit archs
     - improve USE_STLPORT/ENABLE_MONO/ENABLE_OGLTRANS/MOZILLA conditionals to
       add the right build-deps even when the arch we generate it doesn't build
       e.g. with STLport
   * debian/control.in:
    - remove libicu build-conflicts
   * debian/control.in, debian/rules:
     - libsapdbc-java was removed, stop suggesting it and adding it to OOos
       CLASSPATH

openoffice.org (1:2.4.1~ooh680m14-1) experimental; urgency=low

   * OpenOffice.org 2.4.1 snapshot OHO680_m14
   * ooo-build:
    - update (r12554)
   * debian/rules:
     - update for new xulrunner 1.9 packaging using iceape-dev.
       Use MOZILLA=iceape (closes: #480813)
     - specify -Nopenoffice.org-gcj when building without Java
     - remove extra dependency changing for libhyphen0, we now get a
       dependeny on 2.4 "for free"; build-dep on libhyphen-dev (>= 2.4)
   * debian/control.qa.in:
     - fix -qa-tools' depends
   * debian/copyright: fix "Obtained from", mention go-oo.org. Remove obsolete
     section about odk/sdk_oo

openoffice.org (1:2.4.0-6) unstable; urgency=low

   * ooo-build:
     - update (r12409)
   * debian/rules:
     - fix debian/rules to add archs to OOO_SCSOLVER_ARCHS when they build OOo
       to not get useless build-deps there
     - support xulrunner 1.9
     - fix java-gcj-compat-dev build-depends conditional logic to set the
       right versioned build-dep for !etch
     - correct control.mono.in inclusion regardless of host architecture
     - explicitly set ENABLE_REPORTDESIGN=n in arch conditonals for
       disabling java (-> arm(el)). Only depend on openoffice.org-writer2latex
       when Java is enabled
     - also install pythonscript.py into $(SITE_PACKAGES)
   * debian/control.in:
     - make the openoffice.org metapackage depend on ttf-dejavu, since upstream
       OOo ships it
   * debian/scripts/vars.ppc64: actually add
   * debian/control.in, debian/rules:
     - remove the "build libmythes-dev only" option as OOo is now enabled
       on all important archs. Remove the now unndeeded arch specifiers
       on builddeps. Hopefully makes mips(el) parse the builddep line
       again without segfault...
   * debian/control.in:
     - make impress recommend libxrandr2 as OOo now can detect size
       changes through it
     - build-depend against libxrandr-dev

openoffice.org (1:2.4.0-5) unstable; urgency=low

   * rebuild with python-central 0.6.4 (closes: #476678)
   * ooo-build
     - use ooo-build-2-4 branch
     - update (r12270)
       + patches/src680/configures-explicit-arch.diff: fix up for
         the internal icu build
       + patches/src680/sc-openformula-frequency.diff: fixed a silly regression
         that prevents the built-in FREQUENCY function from working properly
         (closes: #477104)
       + patches/src680/sdk-settings-honour-linux.diff: honour also linux
         as in s390-ibm-linux instead of only linux-gnu (closes: #477153)
   * debian/rules:
     - revert libstlport4.6-dev builddep bump. Will break our builddeps
       for etch-backports and testing now has already -ldbl
     - set PACKAGE_NPSOPLUGIN=n when MOZILLA= (--disable-mozilla)
     - enable scsolver for armel (lp-solve now available)
   * debian/control.in, debian/rules:
     - only add a dependency on openoffice.org-officebean to openoffice.org
       when openoffice.org-officebean is actually built (i.e. we build with
       Java), thaks Chris Cheney
   * debian/changelog: mention the various security fixes in OOH680_m5 and
     OOH680_m6
   * merge from Ubuntu:
     - debian/rules:
       + Correct control.mozilla.in inclusion regardless of host architecture

openoffice.org (1:2.4.0-4) unstable; urgency=medium

   * rebuild against python 2.5 (closes: #476220)
   * ooo-build:
     - update (r12156)
       + disables cjk-character-units-*.diff as they cause some problems
         (closes: #474028)
       + emf+-canvas-vcl-non-closed-polygon.diff: fixed invalid access
         (closes: #465423)
       + sw-hindi-numbers.diff: revert change for i#81577 to fix number
         displaying in hebrew docs
       + fixes uninitialized memory in manual spellchecking (closes: #469894)
     - src: update GSIs from ftp.linux.cz: bg da et fi ga mk nb nn
   * debian/rules:
     - handle new aotcompile.py location in java-gcj-compat-dev due to
       python-central >= 0.6 (closes: #475987)
     - bump libstlport4.6-dev builddep to ensure building against
       libstlport4.6ldbl
     - re-enable system-hunspell
     - bump libhyphen0 dep to 2.3-1-3
     - set MOZILLA= when arch not in OOO_MOZILLA_ARCHS
     - fix OOO_OGLTRANS_ARCHS conditional
     - disable Java (OOM) and mozilla (no xulrunner/nss/nspr available yet)
       on armel
   * debian/rules, ooo-build/patches/src680/configures-explicit-arch.diff:
     explicitly specify --host and --build (closes: #475037)
   * debian/control.in, debian/control.reportdesign.in: Fix long
     description, thanks Gerfried Fuchs (closes: #475992)
   * merge from Ubuntu:
     - debian/*.mime:
       + Update and sort mime-types.
     - debian/rules:
       + Use openjdk-6-jre instead of icedtea-java7-jre.
     - debian/control.reportdesign.in:
       + change %OOO_ARCHS% to %OOO_JAVA_ARCHS%

openoffice.org (1:2.4.0-3) unstable; urgency=low

   * The "Third time is a charm?" release.
 
   * ooo-build:
     - update (r12025 - ooo-build 2.4.0.5)
       + now installs a /usr/bin/unopkg wrapper (closes: #319548)
     - src: update GSIs from ftp.linux.cz: et ga
   * debian/shell-lib.sh, debian/openoffice.org{,-common}.preinst.in:
     - don't query docbook-xmls conffiles but ours....
   * debian/rules:
     - actually add text/rtf to ooo-writer.desktop (closes: #472952)
   * debian/openoffice.org-common.manpages: install unopkg.1

openoffice.org (1:2.4.0-2) unstable; urgency=low

   * Brown paper bag release.
   * build with a correct control to get the needed libstlport4.6-dev builddep
     on i386
   * debian/rules:
     - remove arm also from OOO_MOZILLA_ARCHS and OOO_NPSOLPLUGIN_ARCHS. Fix
       "build-only-mythes" conditional to actually be on effect for arm

openoffice.org (1:2.4.0-1) unstable; urgency=low

   * OpenOffice.org 2.4.0 final
   * ooo-build:
     - update (r11988)
       + buildfix-oox-depends-on-unotools.diff: make oox
         depend on unotools (closes: #471633)
       + sc-fix-value-iterator.diff; fixes e.g MIN function
         (closes: #471416)
   * debian/control.in:
     - remove obsolete libsndfile1-dev builddep
     - also build-conflict against nvidia-glx-legacy-dev
     - fix Vcs-Bzr:
   * debian/*.lintian-overrides*: remove "unused-override"s
   * debian/openoffice.org-{core,ogltrans}.control.bug:
     Report-With: infos about fglrx and nvidia drivers
   * debian/rules:
     - disable binfilter builds for arm(el)
     - disable arm builds completely as it's "an obsolete arch". Still keep
       armel (won't block testing migration)
     - don't build-depend on g{cc,++}-4.3 on s390 anymore as it's the default
       now anyway. Build-depend on gcc (>> 4.3.0) and g++ (>> 4.3.0)
       instead
     - fix l10n-sr up to not conflict against -sr-cs as that's our
       etch->lenny transitional package.

openoffice.org (1:2.4.0~rc6-1) unstable; urgency=low

   * OpenOffice.org 2.4.0 rc6 (aka OOH680_m12)
   * ooo-build:
     - update (r11918)

openoffice.org (1:2.4.0~rc5-1) unstable; urgency=low

   * OpenOffice.org 2.4.0 rc5 (aka OOH680_m11)
   * ooo-build:
     - update (r11890)

openoffice.org (1:2.4.0~rc4-1) unstable; urgency=low

   * OpenOffice.org 2.4.0 rc4 (aka OOH680_m10)
   * ooo-build:
     - update (r11862)
       - ubuntu-soffice-config.diff: set $HOME from getent if not set
         (closes: #431976)
       - src:
         - update GSIs from ftp.linux.cz:  bg da et fi ga mk ro uz
   * debian/rules:
     - suggest libnss-1d-dbg instead of libnss3-0d-dbg (closes: #469872)
   * debian/control.in:
     - GTk -> GTK+, thanks lintian
   * debian/udk*ref.in
     - Apps/Programming -> Programming, thanks lintian

openoffice.org (1:2.4.0~rc3-1) unstable; urgency=low

   * OpenOffice.org 2.4.0 rc3 (aka OOH680_m9)
   * ooo-build
     - update (r11840)
   * debian/rules:
     - enable s390 build (don't enable mono); force gcc 4.3 to workaround
       ICE(s)
   * debian/control.in:
     - build-depend on libxtst-dev

openoffice.org (1:2.4.0~rc2-1) unstable; urgency=low

   * OpenOffice.org 2.4.0 rc2 (aka OOH680_m8)
     - fixes printing of control elements (closes: #467168)
   * ooo-build:
     - update (r11750)
   * debian/rules, debian/control.ure.in:
     - introduce ure:Version variable (closes: #466932)
   * debian/rules:
     - fix self-reference of GCJ_JAWT_DEPENDS on etch-backports
       (closes: #466932)
   * debian/control.in:
     - remove obsolete libstartup-notification0-dev builddep

openoffice.org (1:2.4.0~rc1-3) unstable; urgency=low

   * ooo-build:
     - update (r11700)
       + cws-ia64port01.diff: backport ia64 port
       + ubuntu-soffice-config.diff: remove disabling of thai autohinting,
         thanks Theppitak Karoonboonyana (closes: #467180)
   * debian/rules:
     - use readlink -f for determining libstlport_gcc.so.4.6s location
       (closes: #466040)
     - BUILD_IA64=y
     - --disable-mono for arm(el)
     - add GCJ_JAWT_DIR to LD_LIBRARY_PATH for a try to fix FTBFS on mips
     - install pythonloader.py into $(PYTHON_SITE) (closes: #466412)
     - temporarily build with internal hunspell (closes: #459943)
     - build with libdb4.6 (closes: #464754)
     - add symlink /usr/share/doc/openoffice.org-dev/index.html ->
       /usr/lib/openoffice/sdk/index.html. Is the other way around like
       the submitter suggested but still closes: #420804 AFAIS.
       Replace non-working link to license.html with link to
       http://www.gnu.org/licenses/lgpl.html
     - openoffice$(VER) -> $(OODIRNAME)
     - build against libsuitesparse-3.1.0; adapt build-depends to require
       the new version (and the lp-solve built against libsuitesparse-3.1.0)
     - add ttf-thai-tlwg FONT_SUGGESTS
   * debian/control.in:
     - only recommend openoffice.org-writer2latex at -writer. Add it
       to the "openoffice.org" metapackage as Depends (closes: #466170)
     - only suggest -style-{hicontrast,industrial} (closes: #466494)

openoffice.org (1:2.4.0~rc1-2) unstable; urgency=low

   * upload to unstable
   * ooo-build:
     - update (r11592)
   * debian/rules:
     - build-depend on debhelper >= 5.0.51~ for dh_icons, thanks lintian
     - make arm build really use --without-java for the build
   * debian/libuno-cil.installcligac.in:
     - also register cli_uno_bridge.dll (although versioned 0.0.0.0) into the
       GAC
   * debian/openoffice.org-core.control.bug:
     - s/openoffice.org-filter-so52/openoffice.org-filter-binfilter/
   * debian/openoffice.org-{report-builder,ogltrans}.control.bug:
     - add report-with: openoffice.org-base / openoffice.org-impress
   * debian/*.script.bug:
     - new bug scripts listing all extensions (-core) or the extension infos
       (-report-builder, -sdbc-postgresql, -presentation-minimizer)

openoffice.org (1:2.4.0~rc1-1) experimental; urgency=low

   * OpenOffice.org 2.4.0 rc1 (aka OOH680_m7)
   * ooo-build:
     - update (r11558)
     - src: update GSIs from frp.linux.cz (mk, ro, uz, vi)
   * debian/control.in:
     - fix logic error, we of course should conflict against old
       openoffice.org-calcs in the new common, not the other way around
       (really closes: #464544).
       Go safe for the future; make -common Conflicts: against all the modules
       (<< ${base-version})
     - build-conflict against flex (= 2.5.34-1) on amd64
     - s/python/Python/, thanks lintian. Add Homepage: field for python-uno
   * debian/control.qa.in:
     - add ${shlibs:Depends}, thanks lintian
   * debian/control.ure.in:
     - make ure-dbg depend on ure, thanks lintian
   * debian/control.postgresql.in:
     - s/postgresql/PostgreSQL/, thanks linttian

openoffice.org (1:2.4.0~ooh680m6-3) experimental; urgency=low

   * ooo-build:
     - update (r11531)
   * debian/control.in:
     - make -calc conflict against openoffice.org-common (<< 1:2.3.0)
       (closes: #464544)

openoffice.org (1:2.4.0~ooh680m6-2) experimental; urgency=low

   * ooo-build:
     - update (r11513)
   * debian/rules:
     - add some missing/fix arch qualifiers to libsuitesparse-dev/libgcj-bc
       builddeps
     - fix typos in specifying the libxml.jar and libfonts.jar
     - reinstate Common-math.xcu moving (somewhen got lost(?)) to prevent
       file conflicts on upgrade
   * debian/control.ogltrans.in:
     - bump depends to force fixed openoffice.org-common containing the correct
       Impress.xcs

openoffice.org (1:2.4.0~ooh680m6-1) experimental; urgency=low

   * new upstream snapshot (OOH680_m6)
     - fixes CVE-2007-4770 and CVE-2007-4771 for the (unused) internal icu
       copy
   * ooo-build:
     - update (r11494)
   * debian/rules:
     - stop adding libgcj9-0-awt to java-runtime-depends. Make
       java-gcj-compat depends of officebean versioned to force 1.0.77-4 which
       already depends on the -awt package now
     - specify --with-XXXX-jar for the report-builder jars explcitely

openoffice.org (1:2.4.0~ooh680m5-1) experimental; urgency=high

   * new upstream snapshot (OOH680_m5)
     - adds https support for WebDAV (closes: #244280)
     - officially adds possibility to input formulas starting with -/+
       (closes: #433360)
     - now queries CUPS for printers again when opening the print dialogue;
       not only on startup (closes: #290016)
     - doesn't link libofficebean.so with -lgcj anymore (closes: #441202)
     - fixes CVE-2007-5745, CVE-2007-5746, CVE-2007-5747 and
       CVE-2008-0320
   * ooo-build:
     - use trunk again (r11432)
     - src:
       + use (new) OOH680 GSIs from ftp.linux.cz
         . new: ro, gd
       + add eu GSI from Issue 85486
   * debian/rules, debian/scripts/vars.mips{,el}, debian/scripts/vars.arm{,el}:
     (re)add conditionals and vars for new mips(el)/armel and revived arm
     support; enable
   * debian/rules, debian/scripts/vars.ia64: first preparations for the
     (upcoming) ia64 port
   * debian/rules:
     - fix configure flags for "no mozilla" case, we need to specify
       --without-system-mozilla explicitly
   * debian/control.in, debian/rules,
     debian/openoffice.org-presentation-minimizer*:
     - package the new "Presentation Minimizer" extension as
       openoffice.org-presentation-minimizer
   * debian/control.ure.in, debian/rules, debian/ure.overrides.lintian.in:
     - package the URE
   * debian/rules:
     - build against OpenSSL versions of curl and (especially) neon again
       as the webdav ucp now directly links against openssl...
       (reopens: #391671). Use system-openssl.
     - ENABLE_OPENGL=y
     - bump dmake builddep
     - fix BUILD_BINFILTERS conditional to work
     - add PACKAGE_WRITER2LATEX / USE_EXTERNAL_WRITER2LATEX conditionals
     - s/stlport4/stlport/
     - fix ENABLE_JAVA=n build, build the help as it doesn't need Java anymore,
       don't build report-builder
     - enable the report-builder using the internally-built jars for the etch
       backport now that this is possible
     - temporarily build the report-builder using the internally-built jars
     - fix SYSTEM_XALAN conditional to not reset SYSTEM_XML_APIS
       bogusly
     - enable eu and ro langpacks, enable eu help
     - s/libjfreereport-java/libpentaho-reporting-flow-engine-java/
     - update for gcj 4.3; detect libgcj package name/libjawt dir automatically
     - add icedtea-java7-jre to JVM alternatives for JVM recommends/depends.
       Place it before sun-java?-jre
     - don't try to create a libstlport_gcc.so symlink if we don't build
       with stlport and the readlink will fail :)
   * debian/control.in:
     - remove Provides: writer2latex from -writer, bogus (we only provide
       libwriter2latex-java at all, and that with an old version). Depend
       on openoffice.org-writer2latex.
     - build-depend on graphicsmagick-imagemagick-compat instead of simply
       graphicsmagick as ooo-builds Makefile.shared now uses "convert".
       Suggest graphicsmagick-imagemagick-compat | imagemagick.
     - suggest only ttf-dejavu instead of ttf-dejavu | ttf-bitstream-vera;
       OOo now contains the DejaVu fonts. Closes: #461279
     - add USE_SYSTEM_JFREEREPORT conditional
     - build-depend on flex-old instead of flex, see Issue 85508
     - another Replaces: (-core) missed the epoch, thanks Chris Cheney
     - make openoffice.org-writer conflict against -java-common (<< 1:2.3.1)
       (closes: #462477)
   * debian/control.ogltrans.in:
     - depend on openoffice.orgVER-core and openoffice.orgVER-impress
       >> 2.4.0~m237
   * debian/openoffice.org-ogltrans.*.in:
     - remove, ooo-build makes this pre-registered
   * debian/openoffice.org-{ogltrans,base-core}.overrides.lintian:
     - override RPATH warning
   * merge from Ubuntu:
     - debian/rules:
       + Use java-runtime-depends variable for java dependencies.
       + make -gcj depend on libhsqldb-java-gcj
       + some minor parallel build conditional improvements

2007

openoffice.org (1:2.3.1-3) unstable; urgency=low

   * debian/control.in:
     - update VCS headers...
     - add build-conflicts on broken libmono-devs
   * debian/rules:
     - add build-dep on mono-{1,2}.0-devel for new mono packages
       (closes: #458541)
     - mono is now also building sparc packages; enable it

openoffice.org (1:2.3.1-2) unstable; urgency=low

   * ooo-build:
     - update (r11083)
       + buildfix-sal-system.h-no-asm-sigcontext.h.diff: don't include
         <asm/sigcontext.h>, thanks Aurelien Jarno
       + disables SVGImport
   * debian/rules:
     - fix PYTHONPATH setting and remove aotcompile.pyc in clean, too...
     - we also need -l$(PKGDIR)-base/$(OODIR)/program for dh_shlibdeps
       as report-builder links against libdbu
     - remove libsvg conditional; SVGImport is incomplete and now disabled
       in ooo-build
     - etch backport fixes
       - use db4.4
       - use internal icu
       - use STLport on all archs
   * debian/rules, debian/control*.in:
     - add ENABLE_REPORTDESIGN conditional; disable it for etch backports
     - verbosize -report-builders description
   * debian/control.in:
     - add missing epoch to -base-core's Replaces: (closes: #454625)
     - add Replaces: openoffice.org-common (<< 1:2.3.1) to
       openoffice.org-writer as the MediaWiki things moved into -writer
       upstream (closes: #455961)
   * debian/copyright:
     - UTF-8'ize, thanks lintian

openoffice.org (1:2.3.1-1) unstable; urgency=low

   * OpenOffice.org 2.3.1 final (identical to rc1);
     mention CVE-2007-4575 in rc1s changelog
   * merge 2.3.0.dfsg-3 (closes: #453130)
   * upload to unstable
   * ooo-build
     - use ooo-build-2-3 branch
     - update (r11041)
       + patches/src680/fpicker-kde-dialog.diff: keeps filename between 2
         directories now (closes: #427908)
       + fixes right() function in StarBasic (closes: #452267)
       + disables GnomeVFS section for !Novell (closes: #451849)
     - src: update mk GSI from ftp.linux.cz
   * debian/control.gcj.in:
     - "fix" override disparity of -gcj
   * debian/control.in:
     - make -l10n-in depend on -mr-in, too
   * debian/control.ogltrans.in, debian/rules,
     debian/openoffice.org-ogltrans*:
     - package the new "OpenGL rendered transitions" UNO package as
       openoffice.org-ogltrans when ENABLE_OPENGL=y.
   * debian/rules:
     - add $(OOO_ARCHS) to the mesa builddeps
     - fix build with new dpkg-dev
     - re-enable cy langpack
     - build against libhyphen-dev which contains a shared lib for ATLinuxhyph
       now
   * debian/rules, debian/aotcompile-256M-default.diff: work around
     java-gcj-compat-devs defaults causing (at least) the i386 buildd
     to OOMing while building the native jars
   * debian/control.in, debian/rules:
     - put libdba680l?.so into a -base-core package. Make -base, -writer and
       -calc depend on it (closes: #381083)
   * debian/README.Debian-source
     - update
   * debian/shell-lib.sh:
     - run unopkg with -env:JFW_PLUGIN_DO_NOT_CHECK_ACCESSIBILITY=1 because
       otherwise the first run with gcj won't find a JRE (and might fail the
       install then). Flush the cache after removing as unopkg doesn't remove
       files on uninstall but marks them as "to-be-removed-on-next-start".
       Thanks Caolan McNamara.
   * debian/README.Debian:
     - update

openoffice.org (1:2.3.0.dfsg-3) unstable; urgency=low

   * ooo-build:
     - update (r10855)
       + patches/emf+/emf+-cppcanvas-emfplus.diff: fix big endian builds

openoffice.org (1:2.3.1~rc1-1) experimental; urgency=high

   * OpenOffice.org 2.3.1 rc1 (OOG680_m9)
     - fixes CVE-2007-4575
   * ooo-build:
     - src: remove vi and ar again (integrated)
   * debian/rules:
     - bump (build-)dep for external hsqldb to >= 1.8.0.9-1
     - fix milestone detection...
   * debian/control.in:
     - build-conflict against libicu36-dev (<= 3.6-7), libicu-dev (<= 3.8-1)
       because we need a function which was private in those versions...
   * debian/README.Debian-source
     - update

openoffice.org (1:2.3.0.dfsg-2) unstable; urgency=low

   * ooo-build:
     - update (r10834)
       + pyuno-rpath-ooodir.diff: fix (closes: #316030)
   * debian/README.Debian-source:
     - update

openoffice.org (1:2.3.0.dfsg-1) unstable; urgency=low

   * clean jfreereport sources included in OOo from binary-only jars
   * upload to unstable
   * ooo-build
     - update (r10794)
       - jvmfwk-detect-removed-java.diff: try autodetection if it is allowed
         and the current JRE has been removed (hopefully closes: #416242,
         please reopen if not)
     - src:
       - update GSIs from ftp.linux.cz: da km mk sl vi
       - add ar GSI from from i#83301
   * debian/rules:
     - since 2.3.0 final we need --enable-dbus explicitly
     - remove obsolete glitz build-dep
     - re-enable -gcj (closes: #449201) and bump build-dep on
       java-gcj-compat-dev for this
     - fix logic error preventing mozilla-openoffice.org having
       real content, oops (closes: #449528)
     - use system jfreereport libs
     - re-enable ar langpack
     - add libfontconfig1-dbg to DBG_DBG_SUGGESTS
     - Adapt for STLport5 patchset not applied anymore. Remove STLport5
       support.
     - Build --without-stlport4 (closes: #294105). Keep STLport4 for i386
       now due to compatibility with upstream OOo and binary-only stuff
     - fix -dbg suggests on libstdc++6 (we want libstdc++6-4.x-dbg)
   * debian/control.in:
     - XS-Vcs-* -> Vcs-*
     - add a conflict against libicu38 (= 3.8~d01-1)
   * debian/control.{,gcj}.in:
     - depend/recommend (on) java-gcj-compat instead of gij | java-gcj-compat
       as "gij" alone doesn't seem to be sufficient to make OOo know there's
       a "Free Software Foundation" JDK (closes: #440899)
     - s/j2re1.4/sun-java5-jre/
   * debian/shell-lib.sh: fix again to match what a plain upstream build
     creates when embedding the extension in the installset...

openoffice.org (1:2.3.0-4) experimental; urgency=medium

   * ooo-build:
     - update (r10582)
   * debian/control.mozilla.in:
     - recommend konqueror-nsplugins (closes: #446911)
   * debian/control.in:
     - build-conflict against libicu-dev (= 3.8~d01-1) and rebuild against
       libicu-dev 3.8-1 (closes: #447735)
     - stop recommending nfs-common because people now need to install
       nfs-common anyway when they want to use NFS (closes: #424761)
   * deian/rules:
     - fix qstart.desktop installation. Yes, it's not obsolete (why did I thnk
       that?) and ended up in the wrong package (closes: #447732)

openoffice.org (1:2.3.0-3) experimental; urgency=medium

   * ooo-build:
     - update (r10550)
       + ooo82608.vcl.gtkbadfree.diff: backport fix from i#82608 to fix
         bad free on theme resources (closes: #444741)
     - src/: (re)add biblio.tar.bz2
   * debian/rules:
     - readd $(OOO_ARCHS) at neon builddep which got lost
     - add a libstlport_gcc.so symlink in /usr/lib/openoffice/program when
       using STLport4 to not rely on libstlport4.6-dev where binary-only
       components would expect a libstlport_gcc.so
     - look for Autodoc_DiagnosticMessages.txt in the correct path...
     - add conditional for --enable-opengl (cws transogl1)
   * debian/control.in:
     - build-conflict against nvidia-glx-dev for safety
     - build-conflict against broken libicu36-devs on amd64, see #447275
   * debian/control.in, debian/rules:
     - adapt for new qstart implementation in ooo-build, which apparently
       makes ooqstart and qstart.desktop obsolete

openoffice.org (1:2.3.0-2) experimental; urgency=low

   * ooo-build:
     - update (r10478)
 
   [ Rene Engelhard ]
   * debian/rules:
     - remove bogus curl conditional which was temporary but slipped in...
     - fix Developer Snapshot detection to match on x.y.z~mX
     - migrate from num-cpus= to parallel= in DEB_BUILD_OPTIONS, the latter
       is the quasi standard and will also be used by -j of the new
       dpkg-buildpackage
     - fix ooo-extension.desktop fixing and actually install it in the right
       target...
     - we build against libcurl3-gnutls, so build against -gnutls for neon, too
     - default to -P<number of cores> for PARALLEL_BUILD=y
     - build against neon 0.27.x
     - get rid of Autodoc_DiagnosticMessages.txt completely
   * debian/control.in:
     - make -report-builder depend on -java-common (>= 1:2.3.0~oog680m1) as
       that apparently is needed
     - remove long obsolete debconf depends; we don't use debconf anymore
   * debian/copyright:
     - point to /usr/share/common-licenses/LGPL-2.1 instead of just LGPL
       as OOo is LGPL 2.1 only
   * debian/control.mozilla.in, debian/rules:
     - don't build mozilla-openoffice.org on amd64/ppc64, broken
   * debian/*.overrides.lintian.in: adapt for new lintian
   * merge from Ubuntu:
     - debian/control.in: Build openoffice.org-officebean only on architectures
       with java support
 
   [ Mirco Bauer ]
   * debian/rules:
     - use LC_ALL=C instead of LANG=C for date call, else LC_ALL or LC_TIME
       might override it.
     - added mono-jit-dbg and mono-dbg to suggest list for debug packages
   * debian/control.mono.in:
     - enhanced package description

openoffice.org (1:2.3.0-1) experimental; urgency=low

   * OpenOffice.org 2.3.0 final (identical to 2.3.0rc3)
   * ooo-build:
     - update (r10301)
       + sc-preserve-imp-opts.diff: fix order (closes: #403128), thanks
         Nagy Elemer Karoly
       + ucb-no-CURL_NO_OLDIES.diff: don't build with -DCURL_NO_OLDIES
         (closes: #442338)
   * debian/changelog:
     - mention fix for the tiff bug in 2.3.0~src680m224-1s changelog
   * debian/rules:
     - honour nocheck at test:
   * debian/control.in: Build-Conflict against libc6-dev (= 2.6.1-3) and
     libc6-dev (= 2.6.1-3) on i386/amd64 as sigcontext.h is broken
     there.

openoffice.org (1:2.3.0~rc3-1) experimental; urgency=low

   * OpenOffice.org 2.3.0rc3 (OOG680_m5)
   * ooo-build:
     - update (r10271)
       + build with hash-style=both
       + (temporarily) disables SELinux patch again (closes: #441380)
     - src: update GSIs: da mk; remove *.log
   * debian/rules:
     - add support to build/run unit tests. For now, ignore all errors
       (bugs in the build); disable per default
   * debian/README.Debian-source: update
   * debian/watch: add
   * debian/openoffice.org-impress.mime: run Impress with -show for .pps

openoffice.org (1:2.3.0~rc2-1) experimental; urgency=low

   * OpenOffice.org 2.3.0rc2 (OOG680_m4)
   * ooo-build:
     - update (r10223)
     - src: update GSIs: bg cs da et vi
   * debian/rules:
     - build against db4.5 on sid (closes: #431786)
     - build with system-boost again
     - remove apparently obsolete OOO_LICENSE change to the GSIs (except
       lv and sr-CS/sh-YU which apparently still need it)
     - do not corrupt the ku GSI
   * debian/control.*.in:
     - migrate to new Homepage: field instead of adding it to the package
       description
   * debian/README.Debian-source: s/2.2.0/2.3.0/

openoffice.org (1:2.3.0~rc1-1) experimental; urgency=low

   * OpenOffice.org 2.3.0rc1 (OOG680_m3)
   * ooo-build:
     - update (r10187)
       + jvmfwk-gij-paths.diff: update for new gcj-4.2 packages
       + jawt-check-cleanup.diff: clenup jawt check to not expect -lgcj
         (only needed with long obsolete libgcjawt). As we now only
         have a dependency on libjawt.so which all supported JDKs have,
         and don't have a dependency on a specific gcj lib anymore we
         can just depend (or-ed) on all supported JDKs.
         Indirectly closes: #439287
       + ooo80816.selinux.bridges.diff: add patch from Fedora to make OOo
         work under SELinux (closes: #440105)
       + src/: update GSIs from ftp.linux.cz: bg cs eo et fi mk vi
   * debian/README.Debian: mention myspell-hy, myspell-fa, hunspell-ar
   * debian/rules:
     - BUILD_JARS_NATIVE=n until gcj-4.2 is unbroken
     - actually install the binfilters...
     - don't specify --with-java=gij anymore to use javac -> ecj from
       java-gcj-compat on sid
     - (build-)depend on libhsqldb-java (>= 1.8.0.8-1)
     - don't run dh_icons on etch backports
     - remove PATH setting for icu tools, now handled by configure
     - remove $(PATCHSET)64 handling, obsolete
     - temporarily disable cy, as it breaks building sbasics help

openoffice.org (1:2.3.0~oog680m2-1) experimental; urgency=medium

   * new upstream snapshot (OOG680_m2)
     - doesn't "translate" function names into german in hebrew calc anymore
       (closes: #365964)
   * ooo-build:
     - update (r10111)
       - ooo59127.vcl.honourcairofont.diff: fix for gdk hang. [CC]
         (closes: #433870)
       - cairo-canvas-ppc-fix.diff: fix endianness to fix yellow color in
         presentation mode under cairo (closes: #339439)
     - src: update GSIs from ftp.linux.cz: bg cs et fi gl sl vi
   * debian/control.in:
     - fix libpq-dev builddep, thanks calc
     - make the openoffice.org metapackage depend on openoffice.org-officebean as
       the officebean is a "standard part of the office"
   * debian/control.qa.in:
     - make -qa-tools conflict against openoffice.org-core (<< 1:2.3.0~oog680m2) as m1 breaks
       the testtool and it's already uploaded..
   * debian/rules:
     - remove some more occurances of conditionals I missed to remove
       in 2.3.0~src680m225-1
     - remove RID_STR_EXTENSION_NOT_PRESENT translation from the GSIs so that
       it is not merged (we changed the string)
     - bump HELP_L10N_VIRTUAL_VERSION to 2.3
   * merge from Ubuntu:
     - fix JAWT_DEPENDS for new gcj-4.2

openoffice.org (1:2.3.0~oog680m1-1) experimental; urgency=low

   * new upstream snapshot (OOG680_m1)
     - makes unopkg being able to handle bundled Java extensions
   * ooo-build:
     - update (r10077)
       + cws-dba23e.diff: fix system-hsqldb
     - src/: Get fixed be-BY GSI from Issue 79966
   * debian/shell-lib.sh, debian/openoffice.org-report-builder.{pre,post}*.in:
     impove maintainer scripts (based on cws jl68). Check whether the extension
     is registered before trying to remove it (it's not in case unopkg fails,
     and we should be able to recover)
   * debian/control.in:
     - make -report-builder depend on -core >> 1:2.3.0~oog680m1 as we need the
       fixes from cws jl68
     - add Homepage: for the report-builder extension
   * debian/control.in:
     - fix -devs description; Xmerge Javadoc is not there for now, mention
       gsicheck instead
   * debian/rules:
     - fix control target dependencies
     - remove hack for #340468; seems to be not needed anymore
     - readd MySQL, MaxDB and PostgreSQL JDBC drivers to
       UNO_JAVA_JFW_CLASSPATH_URLS (removed in m224-1 due to the hsqldb
       problems fixed in dba23e)
     - one more lintian/.desktop fix
     - build-depend on libicu-dev; 3.8 changed the -dev name (and 3.4 and 3.6
       provide libicu-dev)
     - update for OOG680
     - handle epochs in $(BINARY_VERSION)
     - fix X-KDE-Protocols addition to not add it a second, third etc. time on
       incremental builds
     - ooo-extension.desktop also needs Application; removed
   * debian/control.{postgresql,}.in, debian/rules,
     debian/openoffice.org-sdbc-postgresql.*: package PostgreSQL SDBC Driver
     from http://dba.openoffice.org/drivers/postgresql/ (closes: #346475)
   * debian/copyright: update from readlicense_oo/html/THIRDPARTYLICENSE.html
     (removing stuff which is not (anymore) in OOos source...) and
     reportdesign/util/THIRDPARTYLICENSE.html

openoffice.org (2.3.0~src680m225-1) experimental; urgency=low

   * new upstream snapshot (SRC680_m225)
   * ooo-build:
     - update (r10029)
     - src: update GSIs from ftp.linux.cz: bg cs dz et fi mk sk
   * debian/control.in:
     - build-conflict against gjdoc (= 0.7.8-2) [RE]
     - make -base suggest -report-builder and -report-builder enchance
       Base [RE]
   * debian/rules:
     - clean up multi-threaded build support [CC, RE]
     - remove share/xdgs .desktop files (except qstart.desktop), not
       needed [RE]
     - enable system-libwpg on sid [RE]
       (it's on p.d.o/~rene/libwpg while in NEW)
     - fix PRUNE_OOOBUILD conditional [RE]
     - remove removal of the Sun logo from the BrOffice.org splashs again,
       upstream now also has nologo versions for them [RE]
   * debian/*:
     - remove Ubuntu conditionals added in -1 again, it makes
       the rules for Debian even harder to read/understand than
       it's even now... [RE]
   * debian/soffice.sh, debian/rules:
     - install /etc/openoffice/soffice.sh, merged from Ubuntu. [CC, RE]
   * debian/rules, debian/overrides.lintian:
     - fix or override (package depends on package containing the file)
       lintians new desktop warnings [RE]
   * debian/rules, debian/control.in, debian/openoffice.org-report*:
     component got renamed to sun-report-builder. sigh. adapt [RE]

openoffice.org (2.3.0~src680m224-1) experimental; urgency=high

   * new upstream snapshot (SRC680_m224)
     - fixes joining cells in writer tables (closes: #218281)
     - fixes text width in PDF export (closes: #408209)
     - adds fy_NL localedata (closes: #413205)
     - adds option to ignore printer settings from documents (closes: #428646)
     - fixes sheet printing in calc (what to print now choosable easily)
       (closes: #386250)
     - fixes tiff heap overflow (CVE-2007-2834)
   * ooo-build:
     - use trunk again
     - update (r10006)
       + apply Split section. Fixes the binfilter split so that StarWriter
         3.0-5.0 etc. do not appear anymore when -filter-binfilter is not
         installed (indirectly closes: #421274)
     - src/:
       + add updated GSIs from ftp.linux.cz:
         af be-BY bg cs cy da dz eo et fi ga ka ku lt mk nb ne nn sl tg vi
       + add uz GSI from cwx localisation21 [RE]
   * debian/rules, debian/Adobe-Core35_AFMs-314.tar.gz.uu: remove, unneeded
     [RE]
   * debian/rules:
     - update for 2.3 [RE]
     - add ppc64 test-wise [RE]
     - re-enable mr-IN since now fixed [RE]
     - build-depend on libneon26 again, got fixed and is the only supported
       version since m219 anyway [RE]
     - add conditional for system-libsvg, enable it for sid/experimental [RE]
     - install headless vcl plugin into -headless [RE]
     - remove debian/libuno-cil.installcligac in clean [RE]
     - set HELP_L10N_VIRTUAL_VERSION to $(shell $(UPSTREAM_VERSION) | tr [~]
       [\\-]) [CC]
     - suggest libc*-dbg [RE]
     - build with --enable-openxml to get the OOXML extensions for the bash
       completion [RE]
     - don't manually split binfilters anymore [RE]
     - build-depend on gperf for OOXML patchset [RE]
     - fix some stuff for etch backports [RE]
     - install splash screens directly from OOos source tree after fixing
       their RGBness and removing the Sun logo from the BrOffice.org splash
       while we don't have a nologo variant upstream yet (thanks Martin Hasch
       for the conversion hint and André Schnabel for the needed (gm) convert
       statement for the "Sun removal") [RE]
     - migrate to graphicsmagick as convert from imagemagick (at least etchs)
       does create a broken BMP out of the Sun logo removal step.. [RE]
     - re-enable km again due to demand of the Khmer people... [RE]
     - uuencode all ooo-build/desktop icons [CC]
     - add USE_SYSTEM_VIGRA conditional, enable it [RE]
     - install updchk again, as the extension manager UI now apparently
       needs this one, too... [RE]
     - wrap various java code with ENABLE_JAVA [CC]
     - wrap ooo-build pruning with PRUNE_OOOBUILD [CC]
     - simplify uuencode/uudecode code [CC]
     - add DBVER substition [CC]
     - fix testtoolrc (non)installation [RE]
     - enable uz langpack [RE]
   * debian/control.in:
     - build-depend on libxml-parser-perl [RE]
     - Add XS-Vcs-{Bzr,Svn} fields [RE]
     - we need to build-depend on dmake (>= 1:4.7) [RE]
     - build-depend on netpbm [RE]
     - remove imagemagick; add graphicsmagick [RE]
     - remove version from java-common-depends since it is substituted [CC]
   * debian/*.menu, debian/*.overrides.lintian:
     - update for 2.3 [RE]
   * debian/README.Debian-source: update [RE]
   * merge from Ubuntu:
     - make system-dmake conditional [RE]
     - add Ubuntu conditonals [CC]
   * debian/br{intro,about}.bmp.uu: remove, obsolete [RE]
   * debian/scripts/fix_image_rgb: add [RE]
   * debian/openoffice.org-core.shlibs.local: add
     libuno_purpenvhelpergcc3 [RE]
   * debian/rules, debian/openoffice.org-reportdesigner*: properly
     install/package the reportdesigner extension [RE]
   * debian/rules, debian/*.menu.in, debian/*.overrides.lintian.in:
     add version number to the icon= entry dynamically [RE]
   * debian/NEWS: remove, obsolete [CC]
 
    (CC = Chris Cheney)

openoffice.org (2.2.1-7) unstable; urgency=low

   * ooo-build:
     + update (r9936)
     + src:
       - add he GSI from Issue 79651
         . fixes hardcoded 2.0.3 in recovery dialog (closes: #432770)
         . removes bogus 2.0.3 from Help->About ttle (closes: #432771)
   * merge from 2.3/experimental branch:
     - debian/rules:
       + fix some stuff for etch backports
       + suggest libc*-dbg
       + re-enable km again due to demand of the Khmer people...
     - debian/*.mime: move Star* into a -filter-binfilter.mime [RE]
   * debian/control.in:
     - add build-conflicts against
       libxul-dev (= 1.8.0.13~pre070720-0etch1) - broken security update, see
       #434844
   * debian/README.Debian: update for myspell-af and
     openoffice.org-hyphenation-it
   * debian/rules:
     - suggest openoffice.org-ctl-he at -l10n-he

openoffice.org (2.2.1-6) unstable; urgency=low

   * ooo-build:
     - update (r9849)
   * debian/*.menu:
     - adapt to the new menu sections
     - fix icon=
   * debian/openoffice.org-*.overrides.lintian:
     - update overrides for menu icons
   * debian/rules:
     - fix order in USE_LIBCURL4
     - fix setting of path for the ICU utils, thanks calc
     - (temporarily) stop install xmerge javadoc as its build broke with ant
       1.7.0. Fixes FTBFS because files were tried to be installed which aren't
       there (the ant step doesn't fail...)
     - build against lp-solve (>= 5.5.0.10-4) and libsuitesparse
       (closes: #433486)

openoffice.org (2.2.1-5) unstable; urgency=low

   * ooo-build:
     - update (r9703)
       + libpaper-support.diff: backport suppressing of
         "paperconf: command not found" from cws vcl79 (closes: #430141)
   * debian/control.mozilla.in:
     - stop recommending mozilla-browser (closes: #431269)
   * debian/rules:
     - remove FontOOo from /usr/lib/openoffice/share/basic/launcher/script.xlb,
       see issue 79153
     - stop running the smoketest again...
     - revert to using libstlport4.6, sorry Torsten...

openoffice.org (2.2.1-4) unstable; urgency=low

   * debian/rules: fix lp-solve builddeps, oops

openoffice.org (2.2.1-3) unstable; urgency=low

   * debian/shell-lib.sh: do not parse /var/lib/dpkg/status diretcly, use
     dpkg-query -W -f='${Conffiles}'
   * ooo-build:
     - update (r9666)
       + distro-configs: --disable-access, broken, thanks Mechtilde Stehmann
         for the reminder
       + fix smoketestoo_native
   * debian/rules:
     - --disable-access; remove BUILD_MDBTOOLS conditionals, see above
     - improve test target; make it honour nocheck for DEB_BUILD_OPTIONS,
       run smoketest per default
     - remove some ifeq "$(ETCH_BACKPORT)" "y" conditionals, one to go...
     - make -gcj depend on bsh-gcj
     - add (Build-)Conflicts against libcairo2 (= 1.4.8-1) (closes: #430135),
       cairo 1.4.10 is fixed
     - install xmerge javadoc into -dev-doc
     - change ooo-template.desktop also for BrOffice.org
   * debian/broffice.org*.in: add diversion for ooo-template.desktop
   * debian/openoffice.org-impress.mime: add pps
   * debian/openoffice.org.control.bug: fix thinko (s/base/core/)
   * debian/control.mozilla.in: remove unneeded ${misc:Depends} at
     mozilla-openoffice.org

openoffice.org (2.2.1-2) unstable; urgency=low

   * ooo-build:
     - update (r9584)
       + canvas_x64.diff: fixes vanvas build with internal boost on amd64
   * debian/rules:
     - adapt libmythes-dev build for canonical upstream tarball name
       (closes: #428850)
     - do not add the internal libxmlsec to openoffice.org-cores .shlibs
     - add SYSTEM_LIBWPG conditional, not enabled anywhere yet
     - use internal boost on amd64, too (closes: #425528 again)
     - fix typos (s/oooqstart/ooqstart/)

openoffice.org (2.2.1-1) unstable; urgency=low

   * OOo 2.2.1 final release without source changes
     (with new, fixed orig.tar.gz removing some non-free stuff which
     were left in to the scripts' bug and a overseen upstream change)
   * mention CVE-2007-0245 fix in 2.2.1~rc1-1's changelog
   * ooo-build:
     - update (r9562)

openoffice.org (2.2.1~rc3-3) unstable; urgency=low

   * ooo-build
     - update (r9534)
       + wpgimporter.diff: wpgimport moved intro -draw
   * debian/control.in:
     - update Replaces:
   * debian/rules:
     - fix debian/rules typo at adding libmono0-dbg to -dbgs Suggests
       which made OOo FTBFS on archs where mono is enabled

openoffice.org (2.2.1~rc3-2) unstable; urgency=low

   * ooo-build:
     - update (r9520)
   * debian/rules:
     - use internal boost (closes: #425528)
     - add libmono0-dbg to -dbgs Suggests:
     - handle libgcj8-0-awt of gcj-4.2
   * build in a clean env without DEB_BUILD_OPTIONS="lang=en-US de" to
     actually build with all languages... sigh, again (closes: #427547)

openoffice.org (2.2.1~rc3-1) unstable; urgency=low

   * OOo 2.2.1rc3 (aka OOF680_m18)
     - fixes CVE-2007-2754 for the (unused) internal freetype copy
   * ooo-build:
     - update (9495)
       + distro-configs/Debian*conf.in: --without-nas
   * debian/rules:
     - stop symlinking simpress' help files as that breaks searching
       in it. ship them again instead of hardlinking them as hardlinks
       are not allowed/discouraged (closes: #411693)
     - build-depend on libcurl{3,4}-gnutls-dev (closes: #391671)
     - remove unneeded diriso setting at help copying. confusing and not
       needed anymore.
     - fix qstart.desktop - again (closes: #415180)
   * debian/control.in:
     - remove libaudio-dev builddep
     - add Replaces: broffice.org (<< 2.2.1~rc1) to openoffice.org-common
       to fix upgrades from etch with broffice.org installed.  Thanks
       Otavio Salvador for the report

openoffice.org (2.2.1~rc1-1) unstable; urgency=high

   * OOo 2.2.1rc1 (aka OOF680_m16)
     - fixes RTF parser heap overflow (CVE-2007-0245)
   * build in a clean env without DEB_BUILD_OPTIONS="lang=en-US" to
     actually build with all languages, oops
   * ooo-build:
     - update (r9418)
     - distro-configs/Debian*.conf.in: remove --with-libpaper-link
       libpaper is GPL. (closes: #423906)
     - libpaper-support.diff: update to version in cws vcl78 using the
       paperconf command.
   * merge 2.2.0-7 (closes: #422492, #422530)
   * debian/rules:
     - don't remove updatefeed.uno.so, the extension manager needs it
       (closes: #422870)
     - fix some files in the udk-common-ref doc-base file
     - updates for 2.2.1
     - remove generated udk-common-* doc-base files in clean
     - don't add Autodoc_DiagnosticMessages.txt into udk-{cpp,common}-refs
       doc-base.
   * debian/broffice.org.*.in:
    - add about.bmp to the diversions
   * debian/control.in:
     - Stop build-depending on libpaper-dev; suggest libpaper-utils (see above)
     - (again) only suggest the packages from -style-*. Somehow got lost.
       (closes: #423950)

openoffice.org (2.2.1~oof680m15-1) experimental; urgency=low

   * new upstream milestone (OOF680_m15)
   * ooo-build:
     - update (r9359)

openoffice.org (2.2.0-7) unstable; urgency=low

   * ooo-build:
     - update (r9364)
       + default to OPENGL_SUPPORT=no (closes: #422492)
       + prefer /gcj-4.1-71/libjvm.so over /gcj-4.1/libjvm.so
   * debian/rules:
     - use tail -n 1 instead of grep ^ii in the gcj-4.1 dpkg -l check
       as it apparently isn't always ii after installed (like in sbuild/on the
       buildds)... Same change at the libc6 check for consistency although
       libc6 probaby should be ii always even on the buildds :)
     - move oovbaapi.rdb back into -core (closes: #422530)
   * debian/rules, debian/control.in:
     - build against libcurl4 on sid

openoffice.org (2.2.0-6) unstable; urgency=low

   * ooo-build:
     - update (r9346)
       + jvmfwk-gij-paths.diff: add /gcj-4.1-71/libjvm.so to fix FTBFS with
         new libgcj7-1
   * debian/rules:
     - stop creating a xt.jar symlink (closes: #412671)

openoffice.org (2.2.0-5) unstable; urgency=low

   * ooo-build:
     - switch to ooo-build-2-2 branch
     - update (r9331)
       + adds crashfix for impress crashing with STLport5.1 on exit
         (closes: #421297)
   * debian/control.in:
     - add forgotten Conflicts to -common against older -writer etc due to the
       wrapper scripts/ooqstart changes
     - make new -base,-writer,-mobiledev,-officebean pre-depend on new
       -java-common, make java-common conflict against old versions of above
       packages.
   * debian/rules:
     - move oovbaapi.rdb into -calc as the rest of VBA stuff is there
     - remove unneeded updatefeed.uno.so
     - make classes a normal dir again (and add symlinks in it) instead of it
       being a symlink itself since it breaks the UNO bootstrap mechanism
       some stuff (including extensions) seem to rely on...
     - add ice* to senddoc again, got lost with the upgrade to 2.2.0
       (closes: #411387)
     - install tenmplate.desktop as ooo-template.desktop
     - handle new libgcj7-1-awt...
     - fix links to the DevelopersGuide (closes: #420803)
     - fix "openoffice" command, symlink to ooffice instead of gone ooo-wrapper
       (closes: #421030)
     - fix acor_*.dat fixing (closes: #401651)
     - cleanup:
       - split binary-* targets, remove binary-common
       - remove makebinariestar, we now have a -dbg
     - fix some links in the UDK Java docs
   * debian/libuno-cil.installcligac.in:
     - remove cli_uno_bridge.dll
   * debian/openoffice.org-{base,writer,officebean,filter-mobiledev,java-common,dev}.preinst.in:
     - add; remove classes symlink if found since dpkg doesn't replace a
       symlink with a dir
   * debian/template.desktop.in:
     - add from Ubuntu (changed in Debian to read "OpenOffice.org"
       instead of a "OpenOffice.org From Template" and remove now obsolete
       translation; and to show it) per user requests...
   * debian/rules, debian/udk-{java,common,cpp}.ref.in:
     - register UDK documentation with doc-base (closes: #420805)
   * debian/control.in, debian/rules:
     - don't depend on libxerces2-java-gcj, libxalan2-java-gcj on etch
       backports

openoffice.org (2.2.0-4) unstable; urgency=low

   * Upload to unstable
   * ooo-build:
     - update (r9238)
       + apply CairoFonts patchset
   * debian/rules:
     - build-depend on libgtk2.0-dev (>= 2.10) as CairoFonts needs it
     - build against libportaudio2 (portaudio v19)
     - work around loads of fakeroot warnings by adding /usr/lib/libfakeroot
       to LD_LIBRARY_PATH ourself.
     - remove version number from qstart.desktop
     - remove temporarily added mono-build-deps again

openoffice.org (2.2.0-3) experimental; urgency=low

   * ooo-build:
     - update (r9218)
   * debian/control.in:
     - lower Recommends added in last revision to Suggests since
       aptitude users otherwise would get the whole kde/gnome chain installed
       although they just want crystal/industrial icons.
     - make mozilla-openoffice.org depend on openoffice.org-core. remove
       conflicts; also remove unneeded ${perl:Depends}
   * debian/rules:
     - add missing mkdir -p at mono-openoffice.pc install, doh..

openoffice.org (2.2.0-2) experimental; urgency=low

   * ooo-build:
     - update (r9212)
       + merge ubuntu-soffice-config.diff from Ubuntu. Makes variables residing
         in soffice configurable (and disables autohinting for thai)
   * debian/rules:
     - etch backport fixes (no mono, system-lpsolve fixes)
     - fix standalone libmythes build for new upstream archive type
     - revert to build with libneon25
       (closes: #406926, #396094, #401286, #410917)
     - run dh_installcligac, thanks Mirco Bauer
     - install mozilla plugin as it now apparently seems to work. (closes: #418270)
       Conflict against openoffice.org-core (<< 2.2.0-2)
   * debian/libuno-cil.installcligac.in: add
   * debian/control.in:
     - make -style-crystal recommend kde-icons-crystal;
       make -style-industrial recommend gtk2-engines, gnome-themes,
       industrial-icon-theme; make -style-hicontrast recommend
       gtk2-engines; make -style-tango suggest tango-icon-theme
     - make -dtd-officedocument1.0's description say what DTD is
       (closes: #417068)
     - make -writer Suggest -base (see #381083)
     - remove "instructions for using the package" from the descriptions
       (closes: #392629)
   * debian/control.mozilla.in: update
   * debian/copyright, debian/README.Debian-source: minor updates
   * debian/libuno-cil.{prerm,postinst}.in: remove
   * merge from openoffice.org_2.2.0-1ubuntu2.diff.gz:
     - build pt help
     - recommend nfs-common at -core

openoffice.org (2.2.0-1) experimental; urgency=low

   * 2.2.0 final release.
   * ooo-build:
     - update (r9112)
       + libpaper-support.diff, libpaper-link.diff: add (closes: #412067)
   * debian/rules:
     - follow upstreams mono pkg-config rename to mono-openoffice.pc
     - fix glibc 2.5 check
   * debian/control.in:
     - build-depend on libpaper-dev
     - fix duplicate Replaces: at -style-andromeda, thanks lintian
   * debian/ttf-opensymbol.post{inst,rm}.in: use fc-cache -fs
   * debian/libuno-cil.{prerm,postinst}.in: fix typo

openoffice.org (2.2.0~rc4-1) experimental; urgency=low

   * new upstream release candidate
   * ooo-build:
     - update (r9064)
   * debian/rules, debian/control.in:
     - rename -style-default to -style-andromeda
   * debian/libuno-cil.prerm.in: fix, doh
   * debian/libuno-cil.*.in, debian/broffice.org.*.in:
     - remove hardcoded usr/lib/openoffice, use @OODIR@
     - add @VER@ for desktop files
   * debian/rules:
     - temporary increase mono build-deps (all packages which differ in
       experimental to sid when we install mono-gmcs mono-mcs libmono-dev
       cli-common-dev) as autobuilding otherwise fails in experimental...
     - install tango icons
     - fix dh_shlibdeps call for glibc 2.5
   * debian/control.in:
     - add -style-tango package; make -gtk depend on -tango instead of
       -industrial as tango now is default on GNOME

openoffice.org (2.2.0~rc4~oof680m13-1) experimental; urgency=low

   * new upstream milestone
   * ooo-build:
     - update (r9022)
       + added senddoc-add-mutt.diff: add mutt to senddoc, thanks Gregor Hermann
         for the patch (closes: #411631)
       + added helpcontent-fr-and.diff: fix wrong function description translation
         for French, thanks Sebastien Blondeel (closes: #412117)
   * debian/libuno-cil.prerm.in:
     - use gacutil -us
   * debian/control.in:
     - remove version info from broffice.org/openoffice.orgs
       package description, hardcoded and redundant
   * debian/rules:
     - fix permission of some examples, thanks lintian
     - generalize mono-ooo.pc installation to not fail when OOO_VERSION changes
       in ooo-build
     - enable system-libwps
     - install scsolvers ChangeLog into -calc
     - fix <ooodir>/share/xdg/qstart.desktops Exec=, thanks Fabian Greffrath
       for noticing (closes: #415180)
     - bump libhunspell-dev builddep to surely build against 1.1.5s (a bit) changed
       ABI... Since libhunspell-1.1-0 so far was only in experimental, OOo was
       the only external app using it yet and 1.1.5 is the first official
       upstream version with shared lib, just build against that and forget the
       "old" ABI...
   * debian/rules, debian/control.in: fix binfilter substvar setting for
     -filter-so52 -> filter-binfilter move and fix the indentation of the
     binfilter description. Remove now superfluous Suggests at the
     openoffice.org metapackage and make -writer use the substvar for its
     Recommends:

openoffice.org (2.2.0~rc2-1) experimental; urgency=high

   * new upstream releasse candidate.
     - fixes bibliography database encoding (closes: #186010)
     - "Hide slide" option now renamed on hidden slides (closes: #335720)
     - fixes StarCalc format file parser stack overflow (CVE-2007-0238)
     - fixes escaping of hyperlinks (CVE-2007-0239)
     - internal (unused here) libwpd copy fixes CVE-2007-0002
   * ooo-build:
     - use trunk
     - update
     - src/:
       - remove obsolete GSI files
       - add OOF680 GSIs from ftp.linux.cz
   * debian/control*, debian/rules:
     - rename -filter-so52 to -filter-binfilter due to upstream move of some
       other filters to the "binfilters"
   * debian/rules:
     - build -l10n-gl/-help-gl (galician)
     - 2.2 updates
     - make desktop file changing/installation handle extension.desktop and
       make broffice target changing it
     - bump mono build-deps; the C# climaker is done but needs mono (>= 1.2.3).
       We also need mono-gmcs. Also add versioned mono-utils build-dep to work
       around #412970.
     - use br{intro,about}.bmp for BrOffice.org splash/about
     - temporarily disable smoketest build completely (idlc somehow
       fails to create temporary file)
     - add lp-solve (>= 5.5.0.10-2) builddep (we now expect the shared lib)
       and make -calc depend on it when we use system lp-solve
     - build-depend on libhunspell-dev (>= 1.1.4-6) on sid
     - use internal altlinuxhyph for etch backports, thanks Otavio Salvador
     - remove defaulting to parallel builds since the formerly biggest bottleneck
       now is none anymore (HelpLinker)
     - Bump cli-common-dev builddep. Run dh_makeclilibs. Fix comment.
     - we need to specify --enable-mono explicitly when we want mono
     - install mono-ooo.pc into libuno-cil
     - enable libuno-cil on i386 and amd64 (ppc has no suitable mono yet and
       fails due to #412967 anyway, neither has sparc a mono anyway)
   * debian/scripts/vars.*: add mips and kfreebsd-i386/-amd64
   * debian/control*.in:
     - make the openoffice.org metapackage depend on -filter-mobiledev and
       -filter-binfilter (the latter doesn't have the obvious package name
       anymore and not having it gives a confusing error)
     - verbosize libuno-cils description, put it into libs
     - make libuno-cil depend on mono-gac
   * debian/rules, debian/control.mono.in: add OOO_MONO_ARCHS variable
   * debian/broffice.org.{preinst,postrm}.in: also divert ooo-extension.desktop
   * debian/*broffice.org.{bmp,png}.uu: remove, obsolete ...
   * debian/br{intro,about}.bmp.uu: ... and use these from svx/res from
     cws_oof680_nativebroffice
   * debian/libuno-cil.{postinst,prerm}.in: add; run gacutil
   * debian/openoffice.org-filter-so52.*: remove ...
   * debian/openoffice.org-filter-binfilter.*: ... add this
   * merge from openofficeorg--unstable--2.0.4:
     - debian/rules:
       + change open-url to know ice*

openoffice.org (2.1-4) experimental; urgency=low

   * ooo-build:
     - update (r8890 / ooo-build-2-1 branch)
       + src/: add libwps-0.1.0~svn20070129.tar.gz and
               libwpd-0.8.8.tar.gz (unused...)
   * debian/control*in:
     - make -gcj Depend on libxerces2-java-gcj and libxalan2-java-gcj
   * debian/rules:
     - prepare for system-libwps by adding conditional for it, to be enabled
       once libwps gets out of NEW
     - bump libaltlinuxhyph-dev builddep to ensure we build with OOo 2.1s
       hyphenation code
     - remove obsolete --with-system-gcc
     - readd libdb4.4-java builddep until some patch ordering problems in
       ooo-build are sorted out and we actually can apply no-db-jar.diff
       (closes: #409281)
     - the smoketest hangs on amd64, disable it for amd64
   * debian/rules:
     - update cvsupdate target for svn
     - change senddoc to know iceape and iceweasel. Do it here since it's easy
       to change with sed and we don't need a debian-specific ooo-build for
       this (closes: #411387)
   * debian/openoffice.org-writer.mime:
     - add application/vnd.ms-works
   * merge from openofficeorg--unstable--2.0.4:
     - debian/control.help.in:
       + fix descriptions ("help of OpenOffice.orgs help"..)
     - debian/rules:
       + work around ooo-build not removing the generated
         openoffice{,-extra}.{applications,keys} from desktop/ by
         running make clean there before the global make distclean.
       + disable ar langpack, broken

openoffice.org (2.1-3) experimental; urgency=low

   * ooo-build:
     - update (r8669)
   * debian/changelog:
     - recode to UTF-8 to shut lintian up
   * debian/rules:
     - do not install Helvetica-Narrow*.afm because it confuses OOo...
     - stop build-depending on libdb4.4-java, not needed anymore due to
       the C++ HelpLinker
     - update for new location of 48x48 px icons in ooo-build
     - LIBSTLPORT_MINVER= (>= 5.0.99rc2-5) in the STLPORT5 case
     - use libstlport4.6 in the etch backport case, the needed 5.1 is stuck
       in sid
     - xvfb needs xauth (xbase-clients) and xfonts-base is also needed; add
       both to build-depends
     - link directly to xml-apis.jar instead of hard-coding jaxp-1.2.jar
       and remove depends on libjaxp1.2-java since libxalan2-java has the
       link we use and it depends on the right version, too (closes: #406783)
     - readd lost touch at build target
     - remove install-arch stampdir after dh_strip --dbg-package because
       dh_strip is not idempotent
     - fix stlport (build-)deps generation
   * debian/README.Debian:
     - s/oopadmin/spadmin/ (closes: #406760)
   * merge from openoffice.org_2.1-2ubuntu4.patch:
     - make packaging of SDK conditional
     - don't compress example python files

openoffice.org (2.1-2) experimental; urgency=low

   * ooo-build:
     - now in svn. update (r8549)
       + odk-no-strip.diff: don't strip ODKs programs
       + odk-platform-sparc.diff: add SPARC to settings.mk (closes: #403623)
       + cws-cmcfixes30.diff: backport cws cmcfixes30, fixes
         CVE-2006-6628 (closes: #404105)
   * debian/rules:
     - don't remove ODK programs from -dbg anymore
     - don't hardcode 680, use SRCNUM variable
     - add also links in /usr/lib/ice{ape,weasel} for libnpsoplugin.so
     - when not building using firefox/xulrunner, disable mozilla, there's no
       mozilla-dev anymore
     - uri-encode is now a binary in -core; don't try to fix it's shebang :-)
     - don't expect/install opens___.ttf in ooo-build, got removed. Remove -N
       hack when we don't want to build ttf-opensymbol, add it to control as
       other conditional packages
     - prepare to build-depend on libgtk2.0-dev (>= 2.10) when applying the
       CairoFonts patch. Do not do it yet because libgtk2.0-0 (>= 2.10) as in
       experimental removes sids GNOME on an upgrade
     - build against stlport5(.1) again (closes: #364814)
     - update get-ooo-build for svn
     - fix SDK wrapper scripts to quote $@ (closes: #405974)
     - "build" in smoketestoo_native. Add build-dep on xvfb if we do that.
   * debian/control.in:
     - update broffice.org and openoffice.org descriptions version-wise
   * debian/scripts/vars.*:
     - readd, readd LIBSUFFIX; the maintscripts target gives warnings without
       it and we might need it in future anyway (e.g. for lib diversions)
   * debian/*broffice.org*.uu: update BrOffice.org images, thanks Claudio
   * debian/changelog :):
     - mention CVE-2006-5870 in 2.0.4-1 changelogs entry
   * debian/README.Debian:
     - mention uzbek dictionary

2006

openoffice.org (2.1-1) experimental; urgency=low

   * OpenOffice.org 2.1 final
   * ooo-build:
     - update
       + add patch from Fedora to honour fontconfig font hinting
         (closes: #385798)
       + src/:
         - update GSIs from ftp.linux.cz
   * debian/control*.in:
      - one more %CONTRIB% to be removed, oops
      - update/fix -style-*'s Replaces
      - update -dev-docs replaces...
   * debian/openintro_debian.bmp.uu, debian/rules:
     - remove intro.bmp hacks again, now in ooo-build :)
   * debian/rules:
     - bump HELP_L10N_VIRTUAL_VERSION to 2.1
     - temporary disable km build; breaks in sdraws and simpress' help
   * merge 2.0.4.dfsg.1-1 to 2.0.4.dfsg.2-2

openoffice.org (2.1~rc2-1) experimental; urgency=low

   * OpenOffice.org 2.1 rc2 (OOE680_m6)
     - remove non-free afms (closes: #401325) and other non-free stuff (db 4.2
       docs, non-free ppds) from orig.tar.gz
   * ooo-build:
     - update
   * debian/control.in:
     - bump dmake builddep to dmake (>= 1:4.6)
     - fix -style-defaults short description
     - fix l10n-ins Depends:, oops
   * debian/rules:
     - remove sarge backport conditionals, prepare for etch backport
     - also extract $(TAG)/lingucomponent/inc to fix libymthes-dev-only build
       with pch
     - work around ooqstart not being able to handle 2.1's new splash image;
       install openintro_debian.bmp as intro.bmp
   * debian/rules, debian/*.menu, debian/*.overrides.lintian:
     - update menu stuff for 2.1
   * debian/rules, debian/ control.sarge_etch_transitional.in:
     - remove sarge->etch transitional packages
   * debian/openintro_debian.bmp.uu: add, original intro.bmp converted to RGB
   * debian/rules, debian/presubj, debian/*.control.bug:
     - add (report)bug stuff
   * debian/README.Debian-source: update
   * merge 2.0.4-6 and -7

openoffice.org (2.1~m190-1) experimental; urgency=low

   * OpenOffice.org SRC680_m190 on the way to 2.1
   * ooo-build:
     - use HEAD again; update
   * debian/rules:
      - update for milestone versioning
      - stop depending on libxt-java at -java-common; unneeded and xt.jar is
        removed from the installset
      - update for SRC680/ooo-build changes (ooqstart, pch)
      - re-enable -dbg; use -g1, though
   * merge from
     doko@ubuntu.com--2006-pkg-openoffice/openofficeorg--unstable--2.0.4:
     - patch-38/40: Split out the four style files into their own packages.
       - Let the -gtk package depend on the industrial style.
       - Let the -kde package depend on the crystal style.
       - Let the -common package recommend all style packages.
     ( Fix package descriptions to tell the truth )
   * debian/control.in:
      - make -common depend on the default style
      - add metapackages (l10n-in and -l10n-za for all Indic/South African
        languages)
      - add some missing VERs

openoffice.org (2.0.4.dfsg.2-3) unstable; urgency=high

   * ooo-build:
     - cws-cmcfixes30.diff: add writer parts of cws cmcfixes30, fixes
       CVE-2006-6628 (closes: #404105)
   * debian/changelog :):
     - mention CVE-2006-5870 in 2.0.4-1 changelogs entry

openoffice.org (2.0.4.dfsg.2-2) unstable; urgency=high

   * ooo-build:
     - use special debian-2-0-4 branch, merge two important fixes
       from ooo-build-2-0-4
     - ooo68047.vcl.zwj.diff: import from Fedora, fix important regression
       in 2.0.3 for South Asian scripts (closes: #403275)
     - src:
       + update to fixed dz GSI, thanks Pema Geyleg
   * debian/rules:
     - enable dz help
     - update OOO_BUILD_BRANCH
   * debian/control.in:
     - update -dev-docs replaces...
   * merge from openofficeorg--experimental--2.1:
     - debian/control.in:
       + make -l10n-{in,za} Arch: all...

openoffice.org (2.0.4.dfsg.2-1) unstable; urgency=high

   * again new .orig.tar.gz :/:
     - remove the rest of the ppds, except the two generic printers
       ("All Rights Reserved")
   * ooo-build:
     - update
     - src/:
       + add dz GSI from savannah (dzongha-gnome)
     - bin/openoffice-xlate-lang: add dz
   * debian/rules:
     - enable -l10n-dz, add FONT_SUGGESTS (ttf-dzongkha)
     - re-add free afms, thanks Frank Küster
     - add Mhz, GHz and THz to the exclusion list for the AutoCorrect
       (closes: #401651)
     - fix SDK docs install wrt index.html (closes: #397375)

openoffice.org (2.0.4.dfsg.1-1) unstable; urgency=high

   * new orig tar.gz:
     - remove non-free afms (closes: #401325) and other non-free stuff (db 4.2
       docs, non-free ppds)
   * ooo-build:
     - update (many important fixes, some translations)
   * debian/rules:
     - fix DH_COMPAT setting
   * merge from openofficeorg--experimental--2.1:
     - debian/control.in:
       + bump dmake builddep to dmake (>= 1:4.6)
     - debian/README.Debian-source: update

openoffice.org (2.0.4-7) unstable; urgency=high

   * The "Not everything which looks like sufficiently translated is" release
 
   * ooo-build
     - update
     - major printing fix
   * debian/rules:
     - prefer Lohit Hindi in -help-hi-in's *.css files
     - disable sk, mk, bg help (< 45%)
     - enable hi-IN help (51%), make -help-in Depend on ttf-devanagari-fonts
       since without Lohit Hindi we get broken headers/bold text
   * debian/control.help.in:
     - make -help-XY depend on -l10n-XY since -help-XY seems to have no
       effect when -l10n-* isn't there and the UI is switched to
       that language. By the way this closes: #258841

openoffice.org (2.0.4-6) unstable; urgency=medium

   * ooo-build:
     - update
       + new sk,cs translations
       + distro-configs/Debian*conf.in: re-enable --with-system-odbc-headers to
         actually build with the headers from system... (somewhen/-how got lost)
   * ooo-build/src:
     - add uk GSI from upstream IZ
   * ooo-build/bin/openoffice-xlate-lang:
     - add uk (ukrainian)
   * debian/rules:
     - enable uk langpack
     - re-enable build with system-boost again, works now
   * debian/*.mime:
     - use e.g. "soffice -writer" instead of "oowriter" since ooowriter returns
       immediately with ooqstart and this breaks e.g. mutt. (closes: #396276)
   * merge from openofficeorg--experimental--2.1 branch:
     + add metapackages (l10n-in and -l10n-za for all Indic/South African
       languages)
     + add some missing VERs
     + re-enable -dbg; use -g1, though
     + sort ISOS/LANGPACKISOS again

openoffice.org (2.0.4-5) unstable; urgency=medium

   * Brown paper bag or: "Don't use an older .diff.gz/.dsc for final
     building" release.
 
   * ooo-build:
     - update
     - buildfix-hsqldb-1-8-0-7.diff: fix build with hsqldb 1.8.0.6/7
   * debian/rules:
     - enable system hsqldb again..
   * debian/control.in:
     - also suggest hunspell-dictionary at openoffice.org

openoffice.org (2.0.4-4) unstable; urgency=medium

   * debian/rules:
     - build with internal hsqldb due to graitous hsqldb upload (1.8.-0.7) to
       sid breaking API....

openoffice.org (2.0.4-3) unstable; urgency=medium

   * ooo-build:
     - update
   * ooo-build/src:
     - add new/fixed ca GSI (http://people.debian.org/~jordi/ca.sdf.bz2),
       thanks Jordi Mallach
     - add updated ku GSI from http://download.ferheng.org/ooo2/GSI_ku.sdf.bz2
   * debian/rules:
     - WITH_AGG=n; not used in OOo yet (although built-in), just in the source
       because of "internal [Sun] reasons..."
     - stop adding ($(BUILDER)) to OOO_VENDOR. It ends up only in the res files
       and therfore only has an effect on the initial l10n (_all) upload
       and appears on all archs (also if they've been built on the buildd) which
       is not what was intended
     - add LOCALES_DEPENDS for or-IN, was added to glibc together with as-IN;
       update some LOCALES_DEPENDS for new locales packages
     - enable or-IN, ss, ns, nr, ve, ts langpacks
   * debian/control.*.in:
     - suggest iceweasel and iceape-browser
     - bump FONT_SUGGESTS Suggests to Recommends

openoffice.org (2.0.4-2) unstable; urgency=high

   * ooo-build:
     - update
     - fixed system-icu.diff now also working with 3.4 again
     - SDK installation fixed to not fail with many languages
     - openoffice-xlate-lang: eo added
     - allow unpacking of help_images_<iso>.tar.gz and extras_<iso>.tar.gz
     - disable "Shrink" patchset, (closes: #393857)
     - src:
       - remove de GSI, old and obsolete; thanks to Eric Hoch for finding this
       - add eo GSI from http://people.ubuntu.com/~doko/edgy
       - add help_images_sl.tar.gz and extras_sl.tar.gz from ftp.linux.cz
         to fix/update sl's help images/extras
   * debian/rules:
     - enable -gcj
     - add "locales (>= 2.3.6.ds1-1) | locales-all (>= 2.3.6.ds1-1)" Depends
       for -l10n-as-in
     - enable as-IN and eo langpacks
     - revert to building with libstlport4.6 (closes: #392698, reopens: #364814)
   * debian/control.in:
     - make -common conflict against 2.0.4~rc3-1 -core which would still expect
       the libcu*.so.26 symlinks here. See #393597.
     - once again, change the Mozilla suggestions (this time also in the
       package descriptions): remove all transitional packages except
       thunderbird (still "normal" in testing), add icedove in front of
       "thunderbird". Keep mozilla-browser since it's still present in unstable.
     - Analogous with the xlibmesa-gl | libgl1 suggestion, just keep libgl1
     - remove oooqs-kde Suggests since we conflict against it anyway now
       (closes: #389616)
   * debian/scripts/aot-compile: remove, obsolete
   * debian/README.Debian: (minor) updates, mention statd-not-running problem.

openoffice.org (2.0.4-1) unstable; urgency=medium

   * The "Happy Birthday OpenOffice.org!" release.
 
   * OpenOffice.org 2.0.4 final.
   * ooo-build:
     - update; use ooo-build-2-0-4 branch
     - system-icu.diff, cws-icuupgrade.diff: icu 3.6 support
     - soffice-detect-mozilla-certificates.diff: prefer firefox, actually
       support thunderbird. Also handle multiple profiles in e.g.
       ~/mozilla/firefox and profiles with spaces (closes: #391392), thanks
       Ben Wheeler
     - apply CalcSolver patchset for amd64, too now that it builds again
     - disable speed-chart.diff (closes: #391875)
     - sd-slideshowimpl-check-for-viewframe.diff: backport revision 1.31.60.1
       from cws impress107 to fix crash on the impress wizard (i#69530)
       (closes: #389473)
     - cws-cmcfixes28.diff: backport some important fixes (64bit,
       CVE-2006-5870, ...) (closes: #405679)
   * debian/rules:
     - build with system icu again
     - build also native versions of officebean.jar, sdbc_hsqldb.jar and
       writer2latex.jar if building -gcj
     - move scsolver also into -calc on amd64
     - make get-ooo-build use ooo-build-2-0-4 branch
     - update milestone detection for ~-versioning
     - fix regcomp wrapper installation
   * debian/control.in:
     - put firefox at the beginning of the Mozilla suggests since firefox
       should be prioritized, add thunderbird. Keep
       mozilla-{firefox,thunderbird} after it and move mozilla-browser to
       the end. (to be removed)
     - stop conflicting against openoffice.org-gcj at -java-common
     - Build-Conflict against libstlport5.0-dev (= 5.0.2-10) (see #392131)
   * debian/README.Debian-source: add
   * merge from
     doko@ubuntu.com--2006-pkg-openoffice/openofficeorg--unstable--2.0.4:
     - patch-34: Add gij as an alternative dependency for a java runtime.
     - patch-36:
       Build again the openoffice.org-gcj package using the updated
       java-gcj-compat-dev build infrastructure; don't build native
       code for ridl.jar, avoiding a crash in the JVM. Adjust
       dependencies and suggestions.
   * merge from patches.ubuntu.com:
     - use %OOO_ARCHS% at -gcjs Architecture: and add Enhances:
     - some minor rules improvements
     - make usage of ooo-build .desktop files possible
       ( add it into a USE_OOO_BUILD_DESKTOPS conditional )

openoffice.org (2.0.4~rc3-1) unstable; urgency=high

   * OpenOffice.org 2.0.4 rc3
     - handles missing Setup.xcu at unopkg (closes: #388215, 387224)
   * ooo-build:
     - update
   * debian/control.in:
     - fix typo in -gnomes description (closes: #389423)
   * debian/rules:
     - temporarily build with internal icu again. icu 3.6 doesn't seem
       to be sufficiently compatible... (closes: #390106, #390128)
       Most probably also closes: #390133, #390136.
   * debian/rules, debian/shlibs.override.icu:
     - add shlibs overrides for internal icu
   * merge from
     doko@ubuntu.com--2006-pkg-openoffice/openofficeorg--unstable--2.0.4:
     - patch-27: Build using db4.4. (closes: #341649)

openoffice.org (2.0.4~rc2-2) unstable; urgency=high

   * ooo-build:
     - update
     - debian-opt.diff: build with -O2 on i386 and sparc, too (closes: #198694)
     - src/: add ka GSI from Ubuntu
   * debian/rules:
     - build-depend against libicu36-dev
     - remove shlibs.local for libstlport5.0, fixed. Bump STLPORT_MINVER
     - remove unneeded libupdchk680*so
     - fix broffice.org resources changing
     - add new broffice target instead of doing it in binary-arch since
       it will not do what we want on the buildds. The files and diversions
       we need are only created on a "normal" build. Make binary-indep depend
       on broffice
   * debian/control.*.in:
     - make -help-* depend on -writer (closes: #388397)
     - make -common conflict against openoffice.org-debian-menus from the
       www.openoffice.org packages
     - make broffice.org Arch: all
   * merge from Ubuntu
     - Don't build the ti-ER locale; we are limited in the number of
       languages that we can build; ka (Georgian) was requested by users,
       ti-ER not.

openoffice.org (2.0.4~rc2-1) unstable; urgency=low

   * OpenOffice.org 2.0.4 rc2
   * ooo-build:
     - update [RE]
     - config_office-dbus-check.diff: proper configure check for dbus [RE]
     - soffice-detect-mozilla-certificates.diff: detect mozilla certificates
       (closes: #345703, #373224) [RE]
     - src: GSI updates from ftp.linux.cz (af, da, sl)
   * debian/rules, debian/control.in:
     - add hardcoded depends for -officebean on libgcj7-awt (libjawt.so)
       which isn't picked up by dpkg-shlibs [RE]
   * debian/rules, debian/control.in, debian/*broffice.org*:
     - add a broffice.org package; diverting necessary files from
       openoffice.org-* away. [RE, CH]
   * debian/rules:
     - only match on o*.1 for manpage symlink changing - do not move
       libxmlsec1*.so.1... [RE]
     - remove dbus workaround again, specify --disable-dbus when disabling
       dbus; enable it again for sid [RE]
     - enable amd64 debs (closes: #376134). Actually already in accident in the
       last upload but withdrawn after the buildd build.
   * debian/control.in:
     - add versioned conflicts against openoffice.org-common at
       openoffice.org-dtd-officedocument1.0 (closes: #386763) [RE]
     - add missing Replaces: against -l10n-en [RE]

openoffice.org (2.0.4~rc1-1) unstable; urgency=medium

   * OpenOffice.org 2.0.4 rc1
   * upload to unstable
   * debian/rules:
     - add shlibs.local entry for libstlport5.0 to force dependency on
       libstlport5.0 >= 5.0.2-7 to go safe
     - disable -dbg package
   * debian/control.in:
     - temporarily hack around and build-conflict against libdbus-glib1-dev
       to force disabling of the dbus things (breaks with dbus update...). Will
       be fixed properly...

openoffice.org (2.0.4~ood680m2-2) experimental; urgency=low

   * ooo-build:
     - update
     - lfs.diff: allow to build with -D_FILE_OFFSET_BITS=64 (closes: #245861)
     - configure.in: do not try to copy unowinreg.dll on non-Java builds
       (which don't have --with-mingwin specified). Really closes: #384727
     - src/: GSI updates again (bg, et, ne, sk, sl, ve). Remove ar and fa.
   * debian/rules:
     - enable build against stlport5, namely libstlport5.0 (closes: #364814)
     - binfilter builds with stlport5 now, remove disabling
     - use system-boost again since build with stlport5 fails without it
     - build against libneon26
     - chmod 644 testtoolrc, thanks lintian again
     - handle new ooo-build/current directory created by ooo-build instead of
       ooo-build/$(TAG), create symlink for ooo-build/$(TAG), thanks Matthias
       Klose
     - bump debhelper and python-dev build-deps, thanks Matthias Klose again
     - revert unneeded $(DIST) change above, wrong var and the cause was
       configure.in, see above (doh!)
     - add gstreamer0.10-ffmpeg to the gstreamer suggests
     - add missing ifeq "$(ENABLE_JAVA)" "y"'s to -qa-* packaging
     - remove creating soffice symlink; now done by ooo-build already
     - add STLPORT_VER=500 to the SDKs settings.mk if we build with STLport5 to make
       stuff using it use -lstlport instead of -lstlport_gcc
     - move qstart.desktop into -gtk (as ooqstart is in -core, and libegg* in
       -gtk..)
     - re-enable Java on amd64, seems to work on current amd64/sid now
   * debian/openoffice.org-core.manpages: remove, bogus

openoffice.org (2.0.4~ood680m2-1) experimental; urgency=low

   * new upstream milestone (OOD680_m2)
   * ooo-build:
     - update
     - new GStreamer patchset for avmedia using GStreamer. Inserting Sounds
       works now (although due Insert->Movie and Sound only) so this
       closes: #332194
     - src/: GSI updates from ftp.linux.cz (bg da et ga mk sk sl ss ve)
   * debian/rules:
     - enable gstreamer
     - chmod 644 unowinreg.dll, thanks lintian
     - fix README.qa installation
     - fix NEWS.Debian non-installation in libmythes-dev. Do not install
       the OpenOffice.org README and README.Debian into libmythes-dev
     - specify --with-mingwin also on $(DIST) Debian64/DebianSarge
       (closes: #384727)
     - enable ku langpack
     - bump python-central builddep to >= 0.5
     - move testtoolrc into -qa-tools
     - install main_transform.xsl again... (don't remove help/ in -common...)
     - remove unneeded (and broken) sed which was forgotten to be removed
   * debian/control.in, debian/rules:
     - suggest gstreamer0.10-plugins-*
     - suggest -dbg packages for libs we use at -dbg
   * debian/openoffice.org-qa-tools.overrides.lintian:
     - override binary-or-shlib-defines-rpath
     - override executable-not-elf-or-script (bogus)
   * debian/openoffice.org-calc.manpages:
     - add, forgotten at last upload
   * debian/pycompat: add, thanks lintian
   * debian/source.lintian-overrides: override openoffice.org source:
     missing-build-dependency python-central (>= 0.5). False positive...
   * debian/openoffice.org.preinst.in:
     - fix logic error - don't remove psprint.conf and sofficerc is "$2" is
       empty (we didn't have "openoffice.org" before - so that both don't
       vanish. If they vanished without you wanting that, use
       dpkg -i --force-confmiss on openoffice.org-common to restore them

openoffice.org (2.0.4~ood680m1-1) experimental; urgency=low

   * new upstream milestone (OOD680_m1)
   * ooo-build:
     - update
       + bin/package-ooo: install gid_Module_Optional_Grfflt into -draw directly
       + system-xmlsec.diff: use xmlsec1-nss for pkg-config, not xmlsec1
       + disable printer-properties-disable.diff (closes: #373974, #353595)
       + distro-configs/Common.conf.in: --with-use-shell=bash
       + src/:
         . update GSI files from ftp.linux.cz
           (be-BY bg cs da et ga lv mk nb nn sk sl ss)
         . remove ar (broken bz2)
   * debian/rules:
     - enable installation of ooqstart/libeggtray again since ooo-build is now
       fixed wrt this
     - enable -dbg package
     - enable pyuno and binfilters on amd64
     - stop creating -l10n-en-us, merge its files back into the main
       packages, install en-US' resources consequently into -common
     - remove empty /usr/lib/openoffice/help directories
     - move gcj classmap creation into the right conditional
     - fix clean target for ooo-build changes
     - remove unowinreg.dll build/strip, now done upstream, remove manual
       install; mv the one installed by OOo to the right place
     - fix no-java build (don't try to move around writer2latex.jar)
     - enable packaging of -qa-* (requested by OOo QA) and fix README.qa
       installation
     - remove .testtoolrc installing at all (seems to be a sneaked-in file);
       rm -f it when it should appear
     - add USE_GSTREAMER conditional (gstreamer support for avmedia is
       progressing...); remove .wav files only if not building with GStreamer
     - move mingw32 build-dep into ifeq "$(DIST)" "Debian" and specifiy
       --with-mingwin=i586-mingw32msvc-g++
     - install manpages using dh_installman, still not optimal but better than
       the broken manpage installation before
   * debian/control*.in:
     - fix -dbgs description
     - stop depending on -l10n-en-us at -core and -common since now merged back
       into -common (closes: #335266). Also makes sarge->etch upgrades with
       plain apt-get possible without apt trying to remove openoffice.org
       (closes: #360489)
     - add -l10n-hi and -help-en transitional packages (to -l10n-hi-in and
       -help-en-us) for sarge->etch upgrade; add Replaces:
       openoffice.org-help-en at -help-en-us
     - hardcode << 2.0 in the hardcoded help conflicts against sarge at core;
       that's what meant and using ${base-version} breaks with the ~ semantics
     - remove -gtks conflicts and fix it's description
     - remove build-dep on tcsh
     - add openoffice.orgVER-l10n-${help-l10n-virtual-version} suggest
     - add missing Replaces: for Embedding-*.xcu move upstream
     - since ooqstart now is in -core, also conflict against ooqstart-gnome and
       oooqs-kde there. Probably should be removed then after this enters
       sid...
     - add patch from Matthias Klose to improve some Replaces:/Conflicts and
       Provides:
   * debian/rules, debian/control*in:
     - introduce new BASE_VERSION variable and use this one for base-version
     - introduce HELP_L10N_VIRTUAL_VERSION and ${help-l10n-virtual-version}
       since we cannot use base-version there with ~ ( ~ not allowed in
       package names)
     - remove >= 2.4 (and python-minimal at all) at python build-deps since
       default in sid is now 2.4
   * debian/control.in, debian/rules, debian/*.xmlcatalogs:
     - split OfficeDocument 1.0 DTD out into own package (closes: #321876)
   * merge 2.0.3-5 and -6

openoffice.org (2.0.3+2.0.4m179-1) experimental; urgency=low

   * new upstream milestone m179 on the way to OOo 2.0.4
   * since we upload to experimental, which has python 2.4 as default
     we can as well build against 2.4 now (closes: #336284)
   * ooo-build:
     - use HEAD
     - apply xmlhelp-use-libxslt-from-system.diff again; crashes supposedly
       fixed
     - src: GSI updates for SRC680 from ftp.linux.cz
   * debian/control.in:
     - bump python-dev builddep to (>= 2.4) as the experimental buildds
       otherwise won't pick it up from exeperimental, version python and
       python-minimal (newly added) ones, too since iirc the experimental
       buildds still won't take it otherwise. To be removed again when this
       goes to sid.
     - remove build-conflicts on dmake 4.5 again since dmake 4.5 works here
     - make -writer provide writer2latex
     - add openoffice.orgVER-filter-mobiledev
   * debian/rules:
     - use i586-mingw32msvc-g++ now as unowinreg is now a .cxx with extern "C"'s
     - we upload to experimental anyway, so let's enable amd64 packages for the
       time this is in experimental. Will be disabled for sid again.
     - (re-)add USE_LIBXSLT conditional, enable it
     - move mobile devices filters (AportisDoc, Pocket{Word,Excel} into an own
       package
     - build with internal xmlsec
     - build pt langpack
     - rework override for internal libxmlsec libs, doesn't work with also
       overriding the UNO libs, create shlibs.local from the different
       overrides
     - add conditional to install/not install the quickstarter stuff; disable
       it for now because it crashes
   * merge from
     doko@ubuntu.com--2006-pkg-openoffice/openofficeorg--unstable--2.0.3:
      - move ooqstart to -core

openoffice.org (2.0.3-6) unstable; urgency=medium

   * debian/control.in:
     - fix Replaces: at -draw (closes: #383388)
     - remove obsolete Suggests on prelink
     - add openoffice.orgVER-l10n-${base-version} suggest
     - tighten depends at -impress to -draw - also = ${Source-Version}
     - make -gtk conflict against oooqs-kde (closes: #383405)
   * debian/openoffice.org-hunspell.overrides.lintian: obsolete, remove
   * debian/rules:
     - fix .wav removal to not leave an empty sounds/ dir behind

openoffice.org (2.0.3-5) unstable; urgency=low

   * build against python 2.4 (closes: #336284)
   * ooo-build:
     - update
       + bin/package-ooo: install gid_Module_Optional_Grfflt into -draw directly
       + system-xmlsec.diff: use xmlsec1-nss for pkg-config, not xmlsec1
       + disable printer-properties-disable.diff (closes: #373974, #353595)
   * debian/README.Debian:
     - mention new helps, pl mentioned already in 2.0.3-4 but the rest
       was forgotten...
   * debian/control.*.in:
     - some substitutions with %OOO_ARCHS% which were forgotten
     - suggest libsqliteodbc
     - add patch from Matthias Klose to tighten up dependencies and conflicts
       to force every part to be the same version
     - fix typo in conflicts for sarges openoffice.org-help-tr
   * debian/rules:
     - fix dependencies to not build libmythes*.a twice
     - fix some hardcoded occurances of /usr/lib/openoffice, use $(OODIR)
     - move fcfg_{draw,impress}graphics*.xcu out of -common into their
       respective packages (overseen at the move of libflash* and
       libsvgfilter*) and remove manual move of libflash*/libsvgfilter* to
       draw, now done by ooo-build directly
     - fix unowinreg.dll installation, it belongs into ../win
     - fix system-lp-solve conditional to readd lost libufsparse build-dep
     - fix parallel build conditional not really not use anything else than 1
       on the buildds
   * debian/README.Debian: update
   * merge from
     doko@ubuntu.com--2006-pkg-openoffice/openofficeorg--unstable--2.0.3:
     - patch-27:
       + Re-add dependency of -writer on python-uno, if python-uno is built.
       + Remove the sound files from the gallery. The media framework isn't
         yet built in 2.0.3.
       + Remove unused bitmap files.

openoffice.org (2.0.3-4) unstable; urgency=low

   * ooo-build
     - update:
       + ooqstart-honour-sofficerc.diff: fix to not segfault if
         /etc/openoffice/sofficerc cannot be fopen()'ed (closes: #380420)
     - src:
       + update da and sl GSIs from ftp.linux.cz
       + get fa and ku GSIs from Ubuntu
   * debian/rules:
     - move chmoding of files from scripts/setperms to configure target,
       and remove call to scripts/setperms. Fixes error when running
       debian/rules get-ooo-build without an existing ooo-build directory
       in the source [CH]
     - get-ooo-build - do not run configure during autogen.sh [CH]
     - fix nostrip logic to actually invoke i586-mingw32msvc-strip on
       unowinreg.dll [RE]
     - fix fcfg_*_filters.xcu installation so that they properly go into
       -java-common [RE]
     - enable pl help, thanks Mateusz Skowronski [RE]
     - readd --with-vendor=$(OOO_VENDOR) (closes: #379739) [RE]
     - make SARGE_BACKPORT=y automatically set; use new DISTREL
       (lsb_release -cs) [RE]
     - define OOO_ARCHS variable; subsitute %OOO_ARCHS% in control. [RE]
   * debian/control.in:
     - rename NO_JAVA_ARCHS to OOO_JAVA_ARCHS and reverse semantics [RE]
     - remove %AMD64%, add %OOO_ARCHS% for the Architecture field and also
       for the builddeps only needed for OOo (most) and not for libmythes-dev [RE]
   * scripts/setperms, scripts/xcftobmp, scripts/Makefile,
     scripts/gen_lib_list, debian/openoffice.org-thesaurus-en-us.post*in:
     - remove obsolete files (move fixperms stuff into rules) [CH, RE]
   * merge from patches.ubuntu.com: [RE]
     - some build fixes / enhancements / beautifications
     - parallel build facility. Enhance/fix it as following:
       when num-cpus= not specified detection using getconf. Default to 2 to
       do stuff while helpcontent2 is building. Use 1 on the buildds (see
       -devel).
       num-cpu= is still usable to manually set/override it.
     - enable bg, km, mk, ru, sk, sl help
   * merge from
     doko@ubuntu.com--2006-pkg-openoffice/openofficeorg--unstable--2.0.3: [RE]
     - patch-11 / patch-13: pycentral fixes (make pycentral stuff dependant on
       new USE_PYCENTRAL conditional, instead of SARGE_BACKPORT).

openoffice.org (2.0.3-3) unstable; urgency=low

   * ooo-build:
     - patches/src680/vcl-glyph-cjk-embolden.diff: properly conditionalize
       so that our configure check has sense and this works on sarge
     - patches/scsolver/scsolver-source-service-service-cxx.diff:
       fix g++ 3.3 build
   * debian/rules:
     - fix ibm JDK build-dep
     - re-enable system-neon
     - build unowinreg.dll using i586-mingw32msvc-gcc and install it
       (closes: #377531); build-depend on mingw32
     - run dh_makeshlibs using -n to not get useless ldconfig calls, thanks
       lintian
     - don't install .testtoolrc when not packaging the testtool; install it
       with 644 (thanks lintian) into -qa-tools instead of -common
     - move jar.sos from <oodir>/program/classes-native to
       /usr/lib/gcj-$(GCJ_VERSION); still not working, though :/
     - move libflash and libsvgfilter to draw, export filters only used
       there (and impress where flash makes most sense if at all depends on
       -draw anyway...)
     - clean up README installation (closes: #351229)
   * debian/control.in:
     - add missing %CONTRIB% at -gtk...
     - improve grammar in python-unos description, thanks Thue Janus Kristensen
       (closes: #377186)
     - add conflicts against -writer, -calc etc (<< ${base-version}) at -core
       and -common (closes: #377852); bump depends at -writer, -calc etc to
       depend on 2.0.3-2 with the border/{check,radio}boxes fix
     - build-conflict against dmake 4.5 version in experimental
     - make openoffice.org-gtk-gnome Architecture: i386 powerpc sparc %AMD64%
       to not show this on archs which never had a openoffice.org-gtk-gnome
     - move conflict against ooqstart-gnome from -gnome to -gtk
     - mention Quickstarter in -gtks description
   * debian/rules, debian/shell-lib.sh, debian/openoffice.org.*.in,
     debian/ttf-opensymbol.*.in:
     - clean up maintainer scripts and their generation. As a side effect this
       closes: #377261
     - update *rm_conffile* functions; add openoffice.org.{pre,post}.inst.in to
       remove psprint.conf and sofficrc if unchanged; fixes needless conffile
       prompts because those conffiles moved from openoffice.org to
       opanoffice.org-common (closes: #346282), thanks Justin Przyby and
       Bill Allombert
   * debian/openoffice.org-core.shlibs.local: add, local shlibs setting nothing
   * debian/openoffice.org-gtk.overrides.lintian: add, also override
     binary-or-shlib-defines-rpath for -gtk
   * debian/README.Debian: s/irc.freenode.net/irc.debian.org/

openoffice.org (2.0.3-2) unstable; urgency=low

   * ooo-build:
     - src:
       - readd lost mdbtools tarball, needed for sarge backport
       - add relicensed rhino.patch from cws misclic (old, "sun confidential"
         one was removed from the orig)
     - patches:
       - apply: fix sarge backport, add CalcSolver again
     - update; use ooo-build-2-0-3 branch
       - disable SpeedImageList patchset (closes: #376316, #376776)
       - disable disable-rhino patch
   * debian/control.in:
     - remove dbus,neon,curl,some X11 builddeps (see below why)
     - replace openoffice.org-dev (<< 2.0.3-2) at -dev-doc
     - remove duplicate depends at -gtk
   * debian/rules:
     - also set [LD_LIBRARY_]PATH at install stage, thanks Matthias Klose
     - add libdbus-glib-1-dev (>= 0.60) builddep for sid, not needed/built on
       sarge (dbus too old..)
     - remove GCC_VERSION=3.3 setting for sarge; 3.3 is default there anyway
     - add curl, libxinerama, libxkbfile and render build-deps into a
       conditional to avoid |'s in controls builddeps. Fixes apt-get build-dep
       for openoffice.org...
     - fix <oodir>/sdk/docs symlink in -dev-doc; remove the link from -dev to
       avoid file conflicts.
     - add conditional for system-neon and system-neon builddeps. Enable
       system-neon on sarge, disable it temporaily for sid to get these
       packages into testing without the neon/subversion/perl combo blocking
       the security fixes.
     - use g{cc,++} 4.1 on sparc again
   * debian/README.Debian: update dictionary/thesauri info

openoffice.org (2.0.3-1) unstable; urgency=high

   * new upstream release
     - security fix:
       - fix memory corruption bug; it was possible to write values to
         arbritrary memory when opening special files. (CVE-2006-3117)
   * ooo-build/:
     - update
     - don't enable CalcSolver patchset for amd64 [RE]
     - stop moving docdir in package-ooo [RE]
   * debian/control*.in:
     - change dependency of -gnome to gtk to (= ${Binary-Version}), needed for
       when we change the version using -v to dh_gencontrol [RE]
     - add alternative dependency for dbus on sarge [CH]
     - add missing conflicts against old help packages [RE]
     - make -help conflict with older OOos [RE]
     - stop -common depending on -core to resolve circular dependency [RE]
       (closes: #375877)
   * debian/rules:
     - reorganise debhelper/pyuno build dependencies [CH]
     - Sarge backport differences: [CH]
       - use internal agg, altlinuxhyph, bsh, hsqldb and xmlsec
       - do not use XULRunner
     - add missing -- at libmyspell-dev only builds' dh_gencontrol call [RE]
     - build using system-boost on amd64 [RE]
     - don't install scsolver on amd64 [RE]
     - fix nojava build [RE]
     - build against system-lpsolve (and system-colamd) [RE]
     - don't specify --with-vendor=Debian anymore due to ooo-build changes [RE]
     - fix file conflict between -dev/-dev-doc; remove broken ln -s, update
       SDK docs installation and move the docs to
       /usr/share/doc/openoffice.org-dev/docs with a symlink
       /usr/share/doc/openoffice.org-dev-doc/docs to it [RE, CH]
     - configure with --with-docdir=/usr/share/doc/openoffice.org

openoffice.org (2.0.2.99.2.0.3rc6-1) unstable; urgency=medium

   * new upstream release candidate (2.0.3rc6).
     - adds menu shortcut hint for "Tabelle" in German (closes: #364333)
     - drop-down boxes in KDE for RTL languages fixed (closes: #286246)
     - security fixes:
       - fix macro handling security bug; it was possible to embed macros
         in documents without OOo seeing them and executing them without
         any user interaction. (CVE-2006-2198)
       - disable Java applets feature because it's possible to write Java
         applets breaking out of the sandbox (CVE-2006-2199)
   * ooo-build:
     - update
       + now falls back to english help when no local one is there
         (closes: #345152)
       + src/: GSI updates for OOC680 [RE]
   * debian/rules:
     - enable ta-IN (Tamil), te-IN (Telugu), ti-ER (Tigrigna Eritrea),
       fa (Farsi) and tg (Tajik) langpacks [RE]
     - add conditional to build against XULRunner; enable it (closes: #364062),
       bump libxmlsec builddeps' version [RE]
     - allow locales-all in LOCALES_DEPENDS. Although it does provide
       locales we have one case a versioned depends and as we all know
       versioned provides don't work. Note that locales-all does not
       work out of the box, read its README.Debian. [RE]
     - add "soffice" symlink in /usr/bin to /usr/lib/openoffice/program/soffice
       for the UNO bootstrap... (closes: #369924) [RE]
     - native jar build/*.post* fixes; don't enable it though because again
       broken... [RE]
     - create libjava_uno -> libjava_uno.so link, again something like that
       sigh. Should find out the root cause... [RE]
     - re-enable lo langpack [RE]
     - cleanup conditionals, split definitions and tests, distro- and
       arch-specific stuff [CH, RE]
     - fix typo in makebinariestar, thanks Joo Martin [RE]
     - more updates for new python policy on sid (closes: #373468): [RE]
       + add Provides: ${python:Provides} and XB-Python-Version:
         ${python:Versions} to python-uno
       + build-depend on python-central (>= 0.4.10), python (>= 2.3.5-7)
         and debhelper (>= 5.0.37.1)
       + run dh_pycentral
     - add build-dep on dpkg-dev (>= 1.13.19) for ${source:Version] support
       when we build the native stuff [RE]
     - don't build qadevOOo when we don't package the QA tools [RE]
     - build with internal boost again to work around scscolver build failure [RE]
     - add conditional to build against system liblpsolve55, not enabled yet
       since we need to wait for a suitable lp_solve in Debian [RE]
     - (temporarily) use g{cc,++} 4.0 on sparc [RE]
     - add conditionalsfor using stlport5, not enabled yet; adapt rules for changed
       flag by the STLport5 patches [RE]
   * debian/control.*.in:
     - remove hardcoded libnss3/libnspr4 depends and subsitute it by
       ${mozilla-nss-depends} substvar replaced by hardcoded values as
       before with mozilla and nothing with XULRunner (libs gotten via
       .shlibs) [RE]
     - remove more hardcoded -core deps (mozilla); add firefox in
       Recommends; also add the OOo modules the Plugin supports file formats
       for there (all..) [RE]
     - stop recommending specific g++-x.y versions at -dev, suggest just g++
       since we use the default g++ anyway since a long time... [RE]
     - fix descriptions, thanks Fillipus Klutiero (closes: #372831) [RE]
     - use ${source:Version} at -gcjs -java-common depends to make it
       bin-NMU-safe, thanks Steve Langasek
   * debian/README.Debian: mention openoffice.org-hyphenation-*
   * merge Ubuntu changes: [RE]
     - split control.*.in lines; merge them together in control
     - merge doko@ubuntu.com--2006-pkg-openoffice/openofficeorg--unstable--2.0.1:
       + patch-84: split -gtk out of -gnome (partially merged, gconfbe* should
         remain in -gnome)

openoffice.org (2.0.2-3.4pre) UNRELEASED; urgency=low

   * rebuild against libgcj7 (closes: #369984)
   * ooo-build:
     - update
       + add Debian.dic
       + enable "simple-install mechansm" for the SDK
       + help-msg-add-package-info.diff: mention help packages names
         in the "help not found" error.
       + system-neon-0.26.diff: allow building against neon 0.26.x
       + actually apply Lockdown patchset, doh
       + ooqstart-honour-sofficerc.diff: make ooqstart handle sofficerc again
         (Logo=0/1)
       + really make kde-open-url use & (closes: #336528 again)
       + handle gnome-screensaver during Impress presentation
       + make splash progress bar black until the color is read from sofficrc
         again since a white progress bar a white background
         (OOo-standard-splash) is bad(tm) ;)
       + completely remove the Internet - Mozilla Plug-In option for now;
         we don't ship the plugin because it's buggy and we shouldn't show the
         option then (closes: #364067)
   * debian/rules:
     - update cli-common build-depends
     - run dh_makeshlibs -V to add .shlibs. You still need to set a
       LD_LIBRARY_PATH to /usr/lib/openoffice/program to catch the libs, but...
     - adapt to new SDK installation, move SDK docs to
       /usr/share/doc/openoffice.org-dev-doc with symlink from "old" location
     - disable Java for native amd64 for now - until regcomp doesn't segfault
       at registering Java components anymore
     - remove libgamin-dev workaround; not needed anymore
     - make -l10n-fi suggest openoffice.org-spellcheck-fi instead of only
       myspell-dictionary-fi to suggest both myspell-fi and Soikko.
     - remove rest of $(DIST) Debian/Ubuntu. switching.
       Getting unmaintained and old and changing too fast to keep up.
     - merge changes from doko@ubuntu.com--2006-pkg-openoffice:
       + install gsicheck into -dev
       + add application/rtf to ooo-writer.desktop
       + add X-KDE-Protocols=file,http,smb to the .desktop files
       + some cleanups
       + add ml-IN (ttf-malaylam-fonts) and or-IN (ttf-oriya-fonts) to
         FONT_SUGGESTS
       + build lv, ne, nr, ml-in langpacks
     - add ftp,webdav to X-KDE-Protocols=
     - also suggest ttf-devanagari-fonts for ne and mr-in
     - remove manual installing of hid.lst
     - extend NO_JAVA_ARCHS to all Debian supported Linux archs to make
       libmxthes-dev buildable on them because many of them have problems
       installing the Java builddeps. Better solution, also excluding the
       OOo-only build-deps pending.
     - add te-IN (ttf-telugu-fonts), ta-IN (ttf-tamil-fonts) and
       fa (ttf-farsiweb) FONT_SUGGESTS in preparation for 2.0.3
     - enable Java for sparc mow that the needed java-gcj-compat-dev is
       uploaded; bump builddep
     - make hsqldb2 symlink really work (closes: #340468)
     - remove unneeded space from desktop file Name='s when $(VER) isn't set
     - install resume.ott and project-proposal.ott templates from ooo-build
   * debian/control.in:
     - remove depends on openoffice.org-core (>> ${base-version}) from the
       arch-dep packages; now done via dpkg-shlibdeps
     - Standards-Version: 3.7.2 - no changes needed
     - make openoffice.org-gnome depend on gconf2, thanks Matthias Klose
     - merge changes from doko@ubuntu.com--2006-pkg-openoffice:
       + make -core depend on fontconfig
     - add libdbus-glib-1-dev builddep for the gnome-screensaver patch
     - build-depend on x11proto-render-dev | render-dev since render-dev now is
       a dummy package (closes: #369101)
     - add -Python-Version: current for new python policy
     - stop suggesting ooqstart-gnome at -gnome since we conflict with it,
       thanks Adam C Powell IV for noticing (closes: #370230); also don't talk
       about "Base" in -gnomes description.
   * debian/rules, debian/control*in:
     - for sarge backports move the packages to contrib since we use
       a non-free JDK as (build-)dependency.
   * debian/README.Debian: update, mention Slovak myspell dictionary

openoffice.org (2.0.2-3) unstable; urgency=low

   * ooo-build:
     - use ooo-build-2-0-2 branch
       - sensible-browser.diff: run sensible-browser with & in
         kde-open-url (closes: #336528)
     - src/: add ar, br, lo and mk GSIs
   * debian/rules:
     - update get-ooo-build (and make it actually work, doh)
     - stop trying to build the javadocs independently, doesn't really
       work. Add fat warning when executing binary-all on an arch not
       enabled for Java
     - add FONT_SUGGESTS for ar and lo
     - enable ar, br, lo and mk langpacks
     - use rm -f at libnpsoplugin.so/nsplugin rm, fixes sparc build
     - move gengal into -dev; gengal.bin is there
     - rm l10n.fdupes in clean
     - bump java-gcj-compat-dev builddep for sparc; we need gcj/gij 4.1...
       Not enabled yet since we need java-gcj-compat-dev using 4.1 which
       is only in experimental...
     - disable -lt help (closes: #361442)
     - add "OpenOffice.org Draw" also to GNOMEs/KDEs "Graphics" Menu
     - readd "openoffice" symlink as openoffice(1) mentions it
     - make it possible to build only libmythes-dev and therefore build it
       for all architectures
     - cleanup
     - don't install NEWS.Debian into libmythes-dev
     - use dh_installchangeslogs to install the ooo-build changelog
     - run dh_installdocs with -A to make README.Debian.gz appear in all
       packages. Together with the update this closes: #348780)
   * debian/control.in:
     - add missing [$(NO_JAVA_ARCHS)] pieces
     - make -core conflict against openoffice.org-gnome (<< 2.0.2)
       (closes: #358470)
     - remove one more duplicate section (closes: #356901)
     - make openoffice.org suggest openoffice.org-help-${base-version}
       (closes: #362861)
     - make libmythes-dev Architecture: any
   * debian/source.lintian-overrides: override
     "package-lacks-versioned-build-depends-on-debhelper", bogus error here.
   * debian/README{,.Debian}: update
   * merge doko@ubuntu.com--2006-pkg-openoffice/openofficeorg--unstable--2.0.1:
     + patch-73: remove empty help directories from -l10n-*

openoffice.org (2.0.2-2) unstable; urgency=low

   * debian/rules:
     - actually define CCODE in the control.help.in rule
     - revert %U -> %F change, breaks opening of remote files
     - remove /usr/lib/openoffice/share/fonts/truetype/opens___.ttf from
       -common, we have the right version from ooo-build installed into
       ttf-opensymbol
     - create symlink /usr/lib/openoffice/program/libhsqldb2 ->
       /usr/lib/openoffice/program/libhsqldb2.so, hopefully closes: #340468
     - remove README_* from /usr/lib/openoffice/share/readmes and
       /usr/lib/openoffice/readmes; install README and README.html into
       /usr/share/doc/openoffice.org-common
     - enable hu, da, en-GB, nl, lt help
     - move scsolver.uno.so into -calc
     - readd lost USE_SYSTEM_HUNSPELL variable; set it to y for sid to actually
       build with system-hunspell
     - remove USE_SABLOT/USE_LIBXSLT conditionals.
     - create wrapper scripts setting LD_LIBRARY_PATH for the SDK binaries
       again, thanks Miguel Telleira de Esteban for the report.
   * debian/control.*in:
     - make openoffice.org-help-* Suggests at -l10n-* unversioned
       (closes: #343111)
     - add missing Replaces against -common (<= 2.0.1-5) at -gnome
   * ooo-build:
     - src/: update bg, el, et, lt, ne, br, sk, sl GSIs from ftp.linux.cz
             update hu from hu.openoffice.org
     - CVS update:
       - build with --with-alloc=system instead of internal malloc/calloc/free
         implementation
       - opens___.ttf fixed wrt 0x2212 minussign glyph (closes: #357125)
       - enable CalcSolver patchset
       - stop applying xmlhelp-use-system-libxslt.diff; works on i386 but ppc
         crashes; and just not specifying --with-system-lixbslt doesn't work
         either.
   * debian/control.in, debian/control.gcj.in, debian/rules: disable -gcj
     build, the wizards don't work with it installed. move -gcj into
     control.gcj.in, conflict against openoffice.org-gcj to
     openoffice.org-java-common to force it off the system for those who
     already installed it.
   * debian/openoffice.org-gcj-{pre,post}{inst,rm}.in: use gij instead of
     gcj (closes: #356984)
   * debian/openoffice.org-common.preinst.in: rm_conffile obsolete
     /etc/bash_completion.d/ooo-wrapper.sh
   * merge doko@ubuntu.com--2006-pkg-openoffice:
     - patch-48: link to the online versions of the non-free DevelopersGuide
       stuff not in -dev-doc in the html files referencing it.
     - patch-55 (parts; without dicdir-symlinking yet) and patch-57:
       + Symlink some identical draw and impress files in the help packages.
         (4% smaller).
       + Symlink identical template files in the l10n packages (20% to 70%
         smaller)

openoffice.org (2.0.2-1) unstable; urgency=low

   * new upstream release
     - should fix behaviour on NFS (closes: #335742)
     - should fix NullPointerException with at the wizards (closes: #343761)
     - parallel building now should work (closes: #152718)
   * debian/control*in:
     - add Suggests on pstoedit and imagemagick
     - build-depend on libneon25-dev | libneon24-dev; build with neon 0.25
     - don't build -hunsell anymore, now in -core; add appropriate
       Conflicts:/Replaces:/Provides:
     - make the langpacks suggest hunspell-dictionary-@LCODE@ additionally to
       myspell-dictionary-@LCODE@
     - fix duplicate Replaces: and Section: fields, thanks lintian
     - add openoffice.org-dbg
     - make openoffice.org-gnome unconditionally conflict against
       ooqstart-gnome, -gnome now has a quickstarter
     - update Architecture: for libuno-cil, s390's gone long ago
     - add FONT_SUGGETS=", ttf-khmeros" for -l10n-km.
     - remove mozilla-openoffice.org from control.in, move it to
       control.mozilla.in.
       remove openoffice.org-dbg from control.in, move it to
       control.debug.in. Request from ftpmasters.
   * ooo-build/src: add OOB680 GSIs from ftp.linux.cz and bs GSI from
     http://vedran.root.ba/GSI_bs.sdf.bz2, thanks Vedran Ljubović
   * debian/rules:
     - remove system-myspell stuff from the CXXLIBS conditional;
       hunspell replaced myspell and we really don't need to link with
       libmyspell just for ulingu stuff.
     - specify --with-system-{xalan,xerces,xml-apis,xt} in appropriate places;
       in ooo-build the hardcoded stuff got replaced with dynamic ones. add
       appropriate conditionals.
     - enable help build
     - add system-altlinuxhyph conditional, enable it for sid; bump necessary
       build-dep to >= 0.1.1-8
     - add conditional for libxslt usage (externally) instead of internal
       libsablotron. enable it.
     - enable bs (bosnian) langpack
     - chmod 644 two SDK Documentation build.xml files, thanks lintian
     - bump libdb4.2 builddep to the non-miscompiled ones - (>= -23.1)
     - move libvbaobj* and vbaevents* into -calc, they are linked to
       libsc* and calc-only anyway (thanks Matthias Klose and Noel Power)
     - add conditionals for building a -dbg package. only possible on sid.
       disable it per default, though due to its size (324 MB deb, 1 GB i-s)
     - add mozilla-openoffice.org / -gcj to control if wanted.
     - make debian/control target depend on debian/control.help.in, thanks
       Matthias Klose
     - Recommend -gcj at -java-common
   * debian/openoffice.org-core.overrides.lintian: override
     wrong-name-for-upstream-changelog
     usr/share/doc/openoffice.org-core/changelog.ooo-build.gz
   * merge changes from doko@ubuntu.com--2006-pkg-openoffice:
     - patch-5: Only suggest the binfilter package, if it is built.
     - patch-21/22: keep unmodified uuencoded files, keep time stamps
     - SMALL_SYMBOLS logic fix
     - patch-35:
       - Unconditionally conflict with ooqstart-gnome. -gnome, now contained
         in the openoffice.org-gnome package.
       - Make ooo-wrapper aware of ooqstart
       - Recompile java code to native code from byte code.
       - don't hardcode !sparc, introduce NO_JAVA_ARCHS variable
       - build with --enable-lockdown, --enable-atkbridge
     - manpage installation fixes
     - patch-37/38/39: possibility to build openoffice.org-qa-{tools,api-tests}

openoffice.org (2.0.1-5) unstable; urgency=high

   * doh, fix broken build-depends logic wrt neon, remove hardcoded build-dep;
     make it a conditional in debian/rules; enable it for sarge
   * disable mdbtools support until mdbtools is fixed (see #34595)

openoffice.org (2.0.1-4) unstable; urgency=low

   * rebuild with internal neon; neon 0.25.x was uploaded as neon and 0.24.x
     will be gone :/. External neon (0.25.x) will be re-enabled with OOo 2.0.2

openoffice.org (2.0.1-3) unstable; urgency=low

   * debian/rules:
     - add SMALL_SYMBOLS switch to control debug symbol generation,
       and default to 'y' to reduce package build time and space [CH]
     - build he langpack [RE]
     - stop installing/packaging the mozilla plugin. At least for now. Buggy.
     - If DEB_BUILD_OPTIONS contains from=<project>, continue
       build from this project [CH]
     - Update get-ooo-build target [CH]
     - Parallel building support: set DEB_BUILD_OPTIONS=num-cpus=<n>
       for n projects to be built in parallel [CH]
   * ooo-build/src:
     - add GSI_he.sdf.gz [RE]
   * ooo-build/patches/*: disable disable-visibility-feature.diff again
     and don't apply cws-i18nshrink.diff which was the cause [RE]
   * debian/control.in:
     - fix openoffice.org-help-ko conflict (s/fff/ff), thanks Matthias
       Klose [RE]
     - remove now unneccessary python depends from -common [RE]
     - suggest the improved Bitstream Vera fonts (ttf-dejavu) as an alternative
       to ttf-bitstream-vera [RE]
   * debian/sensible-ooomua: remove, obsolete with now imporoved senddoc,
     thanks Matthias Klose (closes: #335026, #350796) [RE]
   * ooo-build/patches/cairo-smooth-curves.diff: disabled, causes drawing
     problems (closes: #349757) [AP]

openoffice.org (2.0.1-2) unstable; urgency=low

   * ooo-build/patches/src680/apply: apply full Debian patchset for Debian64
     (closes: #345611)
   * debian/rules:
     - rework/update/fix help installation
     - fix desktop files to use %F instead of %U, extracted from Ubuntus
      .diff.gz...
     - move libeggtray* and libqstart_gtk* into the right package (-gnome
       instead of -kde; they were in the wrong loop, oops)
     - re-enable hunspell and the binfilters
     - Suggest locales (>= 2.3.5-12) | belocs-locales-data for km and sr-cs
       instead of only belocs-locales-data since 2.3.5-12 apparently added
       km_KH and sr-CS support.
   * debian/control.*in:
      - bump libdb4.2-java builddep to libdb4.2-java (>= 4.2.52-21) for sid
      - remove obsolete libxp-java and libjaxp1.2-java builddeps (leave
        libjaxp1.2-java for sarge, though, as we need to use Suns JDK...)
      - fix control.help.in
      - make all of openoffice.org's dependencies on the modules versioned, to
        make sure they are all in sync
      - add Replaces: for the libeggtray* and libqstart_gtk* move
   * ooo-build/bin/openoffice-xlate-lang: ga is gaelic, not galician
     (closes: #347787)
   * ooo-build/patches/src680/disable-visibility-feature.diff: disable,
     sometimes causes segfaults, thanks YABUKI Yukiharu. This most probably
     closes: #347491.

2005

openoffice.org (2.0.1-1) experimental; urgency=low

   * OOo 2.0.1 final release.
   * ooo-build/*:
     - use ooo-build-2-0-1 branch
     - patches/src680/cws-unxlngs04.diff: backport upstream sparc build fix
       with g++-4.0 and remove g++-3.4 builddep on sparc (closes: #343011)
     - remove jurt patch introduced in 2.0.0-5 again. Not clear whether that
       really makes sense, and a similar patch for lib at the beginning makes
       the build fail. Not to mention System.mapLibraryName() does somehow
       now also give me libfoo.so also where #340468 was reproducible. To be
       investigated.
   * debian/rules:
     - install the Java UNO sources for IDEs like eclipse into -dev.
     - use ibm-j2sdk1.4 as JDK for the sarge backport on ppc
   * debian/control*:
     - fix typo in -gtk-gnomes description (closes: #343343)
   * debian/openoffice.org-writer.mime:
      - add text/rtf mimetype (closes: #344718)

openoffice.org (2.0.0+2.0.1rc4-1) experimental; urgency=low

   * update to SRC6808_m145 (2.0.1rc4)
   * debian/control.in:
     - Replace openoffice.org-dev (<< 2.0.0) from openoffice.org-dev-doc;
       index.html moved. Analogous with -core and -base with libdbp680*so.
   * debian/rules:
     - update for 2.0.1
       + rework SDK installation
       + install libeggtray* libqstart_gtk* into -gnome
       + package split fixes
       + add system-agg conditional; enable it for sid
     - new langpacks: en-za, th, sl, hi-in
     - add ttf-devanagari-fonts to @FONT_SUGGESTS@ for -l10n-hi-in
     - add Conflicts:/Replaces:/Provides: in -l10n-hi-in against -l10n-hi
     - bump hunspell package version number to 1.2-x since we need to get
       bigger and the 1.1 we have is functionally identical to 1.1. Temporary
       disable -hunspell because we'd need a epoch when we upload a rc to
       experimental and then to unstable. Avoid that, and re-enable -hunspell
       when we upload 2.0.1 final.

openoffice.org (2.0.0-5) unstable; urgency=low

   * debian/control.in:
     - add Replaces: openoffice.org-debian-files on openoffice.org to fix
       sarge/etch upgrades (it contains now README.Debian.gz) (closes: #342610)
     - fix Architecture: of libmythes-dev (s/\$/%/)
     - remove -gnomes Conflicts against openoffice.org-gtk-gnome and
       add a transitional openoffice.org-gtk-gnome packages to let
       openoffice.org-gtk-gnome "upgraded" instead of removed
     - improve -filter-so52 description to also say "StarOffice" (instead
       of only "Star Office" which apparently doesn't get recognized) and
       "format"....
     - bump oooqs-kde conflicts to also match -6+bX
     - Replace/Provide openoffice.org-java from -core, -base and -dev
       to ensure propoer upgrades when people have openoffice.org-java
       installed
   * debian/rules:
     - check for the build link using -L and not -f
     - substitute @OO_SDK_URE_HOME@ to empty value in setsdkenv*
       (closes: #341271)
     - Create also link in /usr/lib/firefox/plugins to support the
       "firefox" package.
   * ooo-build/patches/src680/jurt-ensure-dot-so-at-libname.diff: add;
     quick'n'dirty patch to ensure libname ending with .so for dynamic library
     loading from Java (closes: #340468)
   * debian/*.menu, debian/README: s/Openoffice/OpenOffice/, thanks
     Peter Eisentraut (closes: #342612)

openoffice.org (2.0.0-4) unstable; urgency=low

   * Brown paper bag release.
   * fix builddeps:
     - it has to be [!sparc] instead of [! sparc]
     - readd mozilla-dev and libnss-dev

openoffice.org (2.0.0-3) unstable; urgency=low

   * ooo-build/patches/src680/pyuno-rpath-ooodir.diff: set RPATH to
     /usr/lib/openoffice/program instead of /usr/lib/openoffice2/program
     (closes: #316030)
   * merge sarge backport fixes from 2.0.0-1bpo1 and -1bpo2, see below
   * debian/control.in:
     - move -java-common depends from -core to openoffice.org (closes: #337309)
       and add Recommends: for it to those who miss it (-base already Depends:
       on it)
     - fix typo in -gnomes Description (closes: #338523)
     - add conflicts against the completely obsolete openoffice.org-crashrep
       to force it off the systems (closes: #303543)
     - fix -gcjs depends, don't depend on openoffice.org2-common.
     - don't build-depend on libxinerama-dev and libxkbfile-dev since they
       didn't exist in sarges xfree86. Build-Depends on libxinerama-dev |
       xlibs-static-dev (<= 4.3.0.dfsg.1-15)
     - remove versioned gcj-4.0, gij-4.0, libgcj6-dev and gjdoc  builddeps, we
       don't need it on sarge and java-gcj-compat gets them in in the right
       versions anyway
     - remove java-gcj-compat, libxt, libxalan2-java, libxerces2-java  and ant
       builddeps, to be added from %BUILD_DEPS%
     - remove versioned builddeps on libaltlinuxhyph-dev, libwpd8-dev et. al
       which just were because of transitions and therfore only should apply to
       sid. Will be readded through %BUILD_DEPS%
   * debian/rules:
     - add $PYTHOMHOME/site-packages to PYTHONPATH in pythonloader.unorc
       (closes: #336655)
     - don't build-depend on libgamin-dev on sarge backports,
       thanks Jérôme Warnier
     - enable lt langpack
     - don't build empty used_libs...
     - add missing sarge backport conditional to the system-icu conditional
     - use system xt.jar also on sarge
     - add java-gcj-compat-dev and libxt-dev build-deps here in the
       ENABLE_JAVA/SARGE_BACKPORT conditional and build-depend on j2sdk1.4 on
       sarge. Also add libxalan2-java and libxerces2-java builddeps here again
       in case we are building for sid. Same for the versioned ant dependency
       which is/was just there to force using the ant in main.
     - readd libaltlinuhyph, libwpd8-dev et. al builddeps in the right
       conditionals
     - fix kdelibs4 builddep to be unversioned on sarge and add needed epoch to
       it
     - fix libstlport4.6 (build-)deps to be fullfillable on sarge
     - bump libwpd-dev and kdelibs4-dev builddeps to ensure building against
       the c2a-transitioned ones (closes: #341056)
     - move dh_fixperms in front of dh_strip in the hope that this will fix
       the stripping problems on XFS
     - Suggest openclipart-openoffice.org instead of openclipart. Actually do
       so ;) and change openoffice.org description accordingly.
     - Add a build link in the package root to make it easier to find the
       tree [CH]
     - Fix install rules so they can be rerun without errors [CH]
     - fixup .gz.gz manpage symlinks (closes: #338288)
   * debian/sensible-ooomua: remove unneeded space from shebang, thanks Matej
     Cepl (closes: #337970)
   * debian/*.mime: fix nametemplate= and two more occurances of "oodraw2"
     (closes: #315428, #335313). Also two more of the 1.1.x files'
     descriptions.
   * merge XML catalog stuff from 1.1.x
   * debian/README.Debian: readd and update/remove obsolete stuff
     (closes: #339321)
   * Fix building without debuild: [CH]
     - work around bug in tcsh: Unknown colorls variable `su'
     - add /usr/sbin to search path (some icu utils are here)

openoffice.org (2.0.0-2) unstable; urgency=low

   * ooo-build/patches/src680/use-free-xt-xp-jaxp-from-system.diff:
     use xt-0.20050823.jar instead of xt.jar; on the buildds the files are
     hardlinked into the solver and there apparently OOos installer has
     problems to acces the symlink (/usr/share/java/xt.jar) over the hardlink...
   * ooo-build/patches/src680/system-icu.diff: update to "safer patch" from IZ
     (closes: #335262)
   * debian/*.mime: fix, remove the 2 suffix which was stil there
     and fix the descriptions of the 1.1.x formats (closes: #335313)
   * fix typo in -gnome's Suggests
   * ooo-build/src: translation updates
   * debian/rules:
     - the helpimgs are missing when we don't build with help so repack
       the zips and add them during the build.
     - start adding necessary conditionals for sarge backport; when building
       a sarge backport:
       - use gcc/g++ 3.3
       - use internal xmlsec, hunspell, hsqldb, bsh, mdbtools, xt, xp, xalan,
         xerces and portaudio
       - disable cairo canvas
       - (re)enable Java but use Blackdowns Java ugh to build (otherwise we'd
         need a gcc-4.0 backport, too...)
     - don't install libcommuni* and libsimplecm* if we don't package the
       testtool and actually set PACKAGE_TESTTOOL=n
   * debian/control.in:
     - tighten libxt-java builddep to >= 0.20050823-1
   * rename openoffice.org-jars-native to openoffice.org-gcj
   * debian/*.in: fix some thinkos in the maintainer scripts wrt the shell-lib
     and remove call to the (now non-existing) openoffice.org-debian-files
     hooks. Also fix case statement so old conffiles actually are removed
     (closes: #337147)

openoffice.org (2.0.0-1) unstable; urgency=low

   * OOo 2.0 final release. (closes: #334914)
     - fixes hebrew nekudots (closes: #262156)
     - new languages:
       vi, ca, sr-CS, el, st, ts, ga
   * rename back to openoffice.org and upload to unstable.
   * ooo-build/patches/src680/sal-when-to-run-crash-report.diff: don't try to
     run crash_report if it's not built (closes: #270223)
   * ooo-build/patches/src680/help-messagebox.diff: tell that no help was
     found if it wasn't instead of some obscure message (closes: #330447)
   * patches/src680/sparc-bridges-use-g++-3.4.diff: add hack to use g++-3.4 for
     the sparc bridges
   * ooo-build/src: translation updates
   * build also ttf-opensymbol
   * ooo-build/bin/package-ooo: don't install a wrapper script for jvmsetup
     which doesn't exist anymore (closes: #324160)
   * debian/control*in:
     - let -core conflict against openoffice.org2-l10n-1.9.1{08,14,21,25}.
       Needs better automatic solution...
     - let the langpacks conflict against the numerical previous and next
       -langpack versions
     - only Recommend openoffice.org-core, analogous to 1.1.x to make
       tasksel happy
     - add ${cli:Depends} to libuno-cil
     - Suggest c-shell at -dev to make lintian happy
     - add @LOCALES_DEPENDS@
     - add libmythes-de