Skip to content

Changelog liborcus (0.15.3-3build2+9.0trisquel2)

2020

liborcus (0.15.3-3build2+9.0trisquel2) etiona-backports; urgency=medium

   * Backported from Focal

liborcus (0.15.3-3build2) focal; urgency=medium

   * No change rebuild against new boost1.71 ABI

liborcus (0.15.3-3build1) focal; urgency=medium

   * No-change rebuild to build with python3.8.

2019

liborcus (0.15.3-3) unstable; urgency=medium

   * update debian/tests/control (s/14/15/), thanks
     Sebastien Bacher (closes: #945860)

liborcus (0.15.3-2) unstable; urgency=medium

   * upload to unstable

liborcus (0.15.3-1) experimental; urgency=medium

   * New upstream version 0.15.3

liborcus (0.15.2-1) experimental; urgency=medium

   * New upstream version 0.15.2

liborcus (0.15.1-1) experimental; urgency=medium

   * New upstream version 0.15.1

liborcus (0.15.0-2) experimental; urgency=medium

   * add upstream patch to fix build on 32bit archs

liborcus (0.15.0-1) experimental; urgency=medium

   * New upstream version 0.15.0
 
   * update build dependencies

liborcus (0.14.1-6) unstable; urgency=medium

   * Team upload.
   * Update the unit autopkgtest to detect the soversion at test time, instead
     of hardcoding it, to avoid testing the just built library instead of the
     system-installed one.

liborcus (0.14.1-5) unstable; urgency=medium

   * Team upload.
   * Remove unneeded d/*.dirs file.
   * wrap-and-sort -ast.
   * Mark liborcus-doc as Multi-Arch:foreign.
   * Update d/tests/control dependencies after the SONAME bump.  Closes: #918183
   * Use HTTPS in d/copyright Format field.

2018

liborcus (0.14.1-4) unstable; urgency=medium

   * upload to unstable

liborcus (0.14.1-3) experimental; urgency=medium

   * fix spelling-error-in-description packacge package
   * fix -bins Multi-Arch: field, s/same/foreign/

liborcus (0.14.1-2) experimental; urgency=medium

   * package the binaries (closes: #912016)

liborcus (0.14.1-1) experimental; urgency=medium

   * New upstream version 0.14.1

liborcus (0.14.0+really0.14.0-3) experimental; urgency=medium

   * reupload to correct distribution

liborcus (0.14.0-2) unstable; urgency=medium

   * add upstream patch to fix test failure on i386

liborcus (0.14.0-1) experimental; urgency=medium

   * New upstream version 0.14.0
   * remove upstreamed boost-1.67.diff
   * rename libraries from 0.13-0 to 0.14-0 and bump mdds and ixion build-deps

liborcus (0.13.4-6) unstable; urgency=medium

   * actually add debian/tests/unit...

liborcus (0.13.4-5) unstable; urgency=medium

   * fix typo in unit test Depends:

liborcus (0.13.4-4) unstable; urgency=medium

   * add autopkgtest

liborcus (0.13.4-3) unstable; urgency=medium

   * debian/patches/boost-1.67.diff: as name says: fix build with boost 1.67;
     from upstraem master

liborcus (0.13.4-2) unstable; urgency=medium

   * add missing dh-python Build-Depends:

liborcus (0.13.4-1) unstable; urgency=medium

   * New upstream version 0.13.4
 
   * add Built-Using: ${sphinxdoc:Built-Using} to liborcus-doc
   * fix debian/watch and remove trailing / from Files-Excluded
   * add Vcs-*

liborcus (0.13.3-1) unstable; urgency=medium

   * New upstream version 0.13.3

liborcus (0.13.2-1) unstable; urgency=medium

   * New upstream version 0.13.2
 
   * upload to unstable
 
   * doesn't segfault anymore against a rebuilt libixion (closes: #887004=

2017

liborcus (0.13.1-3) experimental; urgency=medium

   * actually remove Files-Excluded: files...
   * debian/copyright: mention Markus Morhard (src/parser/win_stdint.h)

liborcus (0.13.1-2) experimental; urgency=medium

   * Build-dep on libboost-date-time-dev, thanks Rico Tzschichholz

liborcus (0.13.1-1) experimental; urgency=medium

   * New upstream version 0.13.1
   * add Build-Conflicts: python-sphinx to unconfuse sphinx-build

liborcus (0.12.1-3) unstable; urgency=medium

   * upload to unstable

liborcus (0.12.1-2) experimental; urgency=medium

   * Files-Excluded: needs to be in the header of copyright...
   * also use $(CURDIR)/src/python/orcus in PYTHONPATH

2016

liborcus (0.12.1-1) experimental; urgency=medium

   * [9eee68a] New upstream version 0.12.1

liborcus (0.12.0-4) experimental; urgency=medium

   * [42b61ea] move Maintainer: to Debian LibreOffice Maintainers
   * [8be5236] multiarchify (closes: #798608)

liborcus (0.12.0-3) experimental; urgency=medium

   * use PYTHONPATH=/src/python/.libs dh_auto_test (as for orcus) to fix
     python tests on some archs

liborcus (0.12.0-2) experimental; urgency=medium

   * [451c793] add missing python3-sphinx-bootstrap-theme,python3-breathe to
               Build-Depends-Indep
   * [679dd09] add sphinx-common to Build-Depends for --with sphinxdoc
   * [165fc02] use usr/lib/python*/*-packages in python3-orcus.install

liborcus (0.12.0-1) experimental; urgency=medium

   * [b3d4c5f] Imported Upstream version 0.12.0
   * [3f1c198] adapt for liborcus*-0.12.so.0
   * [e564ab1] bump libixion-dev build-dep to (>= 0.12.0~)
   * [18cc8ff] build liborcus-doc

liborcus (0.11.2-2) unstable; urgency=medium

   * upload to unstable

liborcus (0.11.2-1) experimental; urgency=medium

   * Imported Upstream version 0.11.2
   * bump libmdds-dev build-dep to (>= 1.2)

liborcus (0.11.1+dfsg-1) unstable; urgency=medium

   * upload to unstable
 
   * sigh. remove misc/OpenDocument-v1.2-os-schema.rng and
     AGAIN
   * debian/copyright: add Files-Excluded: to prevent them sneaking in
     again.
   * debian/watch: fix filenamemangle

liborcus (0.11.1-1) experimental; urgency=medium

   * New upstream release

liborcus (0.11.0-1) experimental; urgency=medium

   * New upstream release
   * add debian/watch
   * add Homepage:, update Source:

liborcus (0.11.0~git20151122+dfsg-1) experimental; urgency=medium

   * update debian/copyright
   * remove misc/OpenDocument-v1.2-os-schema.rng and misc/ooxml-ecma-376/
     again which was forgotten to get removed from the orig this time and
     actually tell in README.source what was removed.
   * remove now unneeded build-dependency: python
   * package the python bindings; add python3-dev build-dep

liborcus (0.11.0~git20151122-1) experimental; urgency=medium

   * New upstream snapshot

liborcus (0.9.2-4) unstable; urgency=medium

   * merge parts of https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=798608:
    - Enable parallel builds.
    - Remove cruft in the debian directory.
   * remove obsolete dependency on libzip-dev (closes: #798729)

2015

liborcus (0.9.2-3) unstable; urgency=medium

   * bump build-dep on ixion to 0.9.1-2 to ensure we have the v5 version...

liborcus (0.9.2-2) unstable; urgency=medium

   * libstdc++6 transition: rename liborcus*0.10-0 to
     liborcus*0.10-0v5

liborcus (0.9.2-1) unstable; urgency=medium

   * New upstream release
 
   * upload to unstable

liborcus (0.9.1-1) experimental; urgency=low

   * New upstream release

liborcus (0.9.0-1) experimental; urgency=medium

   * New upstream release

liborcus (0.7.1-1) experimental; urgency=medium

   * New upstream release
     - fixes build with gcc-5 (closes: #777963)

2014

liborcus (0.7.0+dfsg-9) unstable; urgency=low

   * sigh, fix control to remove [!ppc64el]s

liborcus (0.7.0+dfsg-8) unstable; urgency=medium

   * enable spreadsheet-model on ppc64el for consistency as ixion built now

liborcus (0.7.0+dfsg-7) unstable; urgency=medium

   * oops, forgot to remove the Depends on liborcus-spreadsheet-model-0.8-0
     for liborcus-dev on ppc64el

liborcus (0.7.0+dfsg-6) unstable; urgency=low

   * brown paper bag release.
 
   * fix -N setting

liborcus (0.7.0+dfsg-5) unstable; urgency=low

   * fix build without spreadsheet model enabled
 
   * temporarily disable spreadsheet model on ppc64el until ixion is fixed.
     (not used anywhere anyway)

liborcus (0.7.0+dfsg-4) unstable; urgency=low

   * upload to unstable

liborcus (0.7.0+dfsg-3) experimental; urgency=low

   * merge from liborcus 0.5.1-8:
     - --disable-werror (closes: #746876)

liborcus (0.7.0+dfsg-2) experimental; urgency=low

   * ENABLE_SPREADSHEET_MODEL=y; add build-dep on libixion-dev. split
     spreadsheet-model lib out to extra package due to its extra ixion
     dependency
   * remove dh_auto_clean override (fixed) and manual dh_autoreconf, use
     --with autoreconf

liborcus (0.7.0+dfsg-1) experimental; urgency=low

   * remove misc/OpenDocument-schema-v1.2-cd04.rng, misc/ooxml-ecma-376/ and
     doc/rfc4180-csv.txt from .orig again and mention misc/*.py in
     debian/copyright (BSD) (closes: #741250)

liborcus (0.7.0-1) experimental; urgency=low

   * New upstream release
   * fix typo: s/snd/and/ (closes: #732765)

liborcus (0.5.1-7) unstable; urgency=medium

   * --with-boost-libdir=/usr/lib/$(DEB_HOST_MULTIARCH) (closes: #737486)

2013

liborcus (0.5.1-6) unstable; urgency=low

   * disable tests on s390 (failure with newer boost, functionality not
     used in LO, s390 to be removed anyways)

liborcus (0.5.1-5) unstable; urgency=low

   * --disable-silent-rules
   * libmdds-dev is only needed with spreadheet-model, thus remove from
     Build-Depends: for now
   * revert back to libboost-dev (1.49) as otherwise the tests fail on s390

liborcus (0.5.1-4) unstable; urgency=low

   * upload to unstable

liborcus (0.5.1-3) experimental; urgency=low

   * merge liborcus 0.3.0-8:
     + use libboost-system1.53-dev explicitly as libmdds-dev does, too - and
       otherwise we have conflicting build-deps (closes: #713115)
   * merge from 0.5.1-2ubuntu1:
     + hotfix for autotools boost brokeness

liborcus (0.5.1-2) experimental; urgency=low

   * merge liborcus 0.3.0-7:
     + apparently builds with boost 1.53 need libboost-system-dev;
       add to Build-Depends
   * remove libzip-dev builddep (not needed anymore), replace by
     zlib1g-dev

liborcus (0.5.1-1) experimental; urgency=low

   * New upstream release

liborcus (0.3.0-5) unstable; urgency=low

   * upload to unstable

2012

liborcus (0.3.0-4) experimental; urgency=low

   * remove misc/OpenDocument-schema-v1.2-cd04.rng, misc/ooxml-ecma-376/ and
     doc/rfc4180-csv.txt from .orig..

liborcus (0.3.0-3) experimental; urgency=low

   * add missing build-depend on pkg-config

liborcus (0.3.0-2) experimental; urgency=low

   * add missing libzip-dev depends to -dev

liborcus (0.3.0-1) experimental; urgency=low

   * New upstream release

liborcus (0.1.0-1) experimental; urgency=low

   * Initial release