Skip to content

Changelog libmailtools-perl (2.18-1)

2016

libmailtools-perl (2.18-1) unstable; urgency=medium

   * New upstream release 2.18
     Closes: #842392
   * Standards version is 3.9.8

2014

libmailtools-perl (2.13-1) unstable; urgency=medium

   * New upstream release 2.13.
   * Standards version is 3.9.5
   * Use default compression for binary packages.
   * Don't split $name if it's the empty string.
     Add 03-750357-unnamed-users.patch.
     Patch by Guilhem Moulin <guilhem@guilhem.org>.
     Closes: #750357.
   * Refresh patches.

2013

libmailtools-perl (2.12-1) unstable; urgency=low

   * New upstream release 2.12
   * Standards version is 3.9.4
   * Depends on libnet-smtp-ssl-perl
     Closes: #643841

2012

libmailtools-perl (2.09-1) unstable; urgency=low

   * New upstream release
   * Standards version is 3.9.3
   * DH compatibility level is 9

2011

libmailtools-perl (2.08-1) unstable; urgency=low

   * New upstream
     Fixes:
     - respect errors on closing an Mail::Mailer::smtp/::smtps connection.
       [Tristam Fenton-May]
     - Mail::Internet should accept Net::SMTP::SSL as well.
       rt.cpan.org#68590 [Jonathan Kamens]
     Improvements:
     - document that Mail::Mailer::smtps needs Authen::SASL
   * Fix debian-rules-missing-recommended-target
   * Fix out-of-date-standards-version

libmailtools-perl (2.07-1) unstable; urgency=low

   * New upstream release
   * Debian source format is 3.0 (quilt)
   * Fix debian-rules-makemaker-prefix-is-deprecated
   * Fix out-of-date-standards-version
   * Fix copyright-refers-to-symlink-license

2010

libmailtools-perl (2.06-1) unstable; urgency=low

   * New upstream release
   * Rename 01-strip-extra-fields.patch as 01-458602-strip-extra-fields.patch
   * Update 01-458602-strip-extra-fields.patch
   * Use sendmail in /usr/sbin, not /usr/lib
     Add 02-539193-sendmail.patch
     Patch by Santiago Vila
     Closes: 539193
   * Fix out-of-date-standards-version
   * Update upstream homepage

libmailtools-perl (2.05-1) unstable; urgency=low

   * New upstream release
   * Debian source format is 3.0 (quilt)
   * Fix debhelper-but-no-misc-depends
   * Fix homepage-for-cpan-package-contains-version
   * Fix out-of-date-standards-version
   * DH compatibility level is 7

2008

libmailtools-perl (2.04-1) unstable; urgency=low

   * New upstream release
   * Standards-Version is 3.8.0

libmailtools-perl (2.03-1) unstable; urgency=low

   * New upstream release

libmailtools-perl (2.02-1) unstable; urgency=low

   * New upstream release. Closes: #453324
   * Fixed "Mail::Internet includes entire user field in Sender header".
     Patch by Christopher Schmidt <crschmidt@crschmidt.net>.
     Closes: #458602
   * Homepage field added to debian/control
   * Set Standards-Version to 3.7.3
   * Set debhelper compatibility to 6
   * Updated debian/copyright

2007

libmailtools-perl (1.77-1) unstable; urgency=low

   * Mail/Header.pm: fixed typo, closes: #374047.
   * Mail/Address.pm: fixed typo, closes: #423932.

libmailtools-perl (1.77-0) unstable; urgency=low

   * New upstream release
   * Fixed the following lintian message:
     - W: libmailtools-perl source: debian-rules-ignores-make-clean-error line 57

2006

libmailtools-perl (1.74-1) unstable; urgency=low

   * New maintainer. Closes: #400363.
   * ACK NMU. Closes: #247009, #304155, #316160, #329583, #346008.
   * Set Standards-Version to 3.7.2.
   * Set section to perl.
   * Removed patch from bug #177710 as it causes breakage.
     Closes: #287262.
   * Fixed the following lintian error:
     - build-depends-indep-should-be-build-depends debhelper

libmailtools-perl (1.74-0.1) unstable; urgency=low

   * Non-maintainer upload with maintainer's blessing
   * New upstream release (Closes: Bug#329583)
     + doesn't taint parsed addresses anymore (Closes: Bug#346008)
   * Revert patch for qmail, not needed anymore (Closes: Bug#316160)
   * Correct manual page for Mail::Field -> extract (Closes: Bug#304155)
   * Correct manual page for Mail::Header -> get (Closes: #247009)
   * Upgrade debhelper compatibitly level
   * Update upstream info
   * Drop Suggests: libmail-audit-perl as it was removed from the archive

2004

libmailtools-perl (1.62-1) unstable; urgency=low

   * New upstream release
     (Reverts: Bug#104572)
     (Closes: Bug#238732)
   * Re-applied patch from Bug#177710
     (Closes: Bug#218534)

libmailtools-perl (1.60-1) unstable; urgency=low

   * New upstream release

2003

libmailtools-perl (1.59-1) unstable; urgency=low

   * New upstream release
   * Applied patch from Marc Brockschmidt <marc@dch-faq.de>
     (Closes: Bug#104572)

libmailtools-perl (1.58-1) unstable; urgency=low

   * New upstream release
     (Closes: #191401)
   * Sorry, fixed broken patch that somehow slipped in
     and made Mail/Mailer/qmail.pm unusable.
     (Closes: Bug#179186)
   * Applied patch from 'root@khms.westfalen.de' to fix
     Mail::Address misparsing some headers.
     (Closes: Bug#177710)

libmailtools-perl (1.56-1) unstable; urgency=low

   * New upstream release

2002

libmailtools-perl (1.53-1) unstable; urgency=low

   * New upstream release

libmailtools-perl (1.51-1) unstable; urgency=low

   * New upstream release
   * Updated standards-version

libmailtools-perl (1.49-1) unstable; urgency=low

   * New upstream release

libmailtools-perl (1.48-1) unstable; urgency=low

   * New upstream release
   * debian/copyright; Updated
     (Closes: Bug#157610)

libmailtools-perl (1.47-1) unstable; urgency=low

   * New upstream release.
   * New maintainer.
   * Thanks to StevenK for the work he put in on this package.
   * Removed `mailtools' package. By now, all dependancies on mailtools
     should have been changed to `libmailtools-perl'.
   * Added real URL to copyright.
   * Added `debian/watch'.

libmailtools-perl (1.46-1) unstable; urgency=low

   * New upstream release.
   * Apply patch so that mailx is not used interactively. (Thanks, Robert!)
     (Closes: #150430)

libmailtools-perl (1.44-1) unstable; urgency=low

   * New upstream release. (Closes: #142745)

2001

libmailtools-perl (1.42-2) unstable; urgency=medium

   * Urgency medium to drop to woody.
   * Adding a Suggests on libmail-audit-perl. (Closes: #122466)

libmailtools-perl (1.42-1) unstable; urgency=low

   * New upstream release
   * Demos moved from bin/ to examples/, fixing debian/rules.
   * qmail.pm applied upstream.

libmailtools-perl (1.41-1) unstable; urgency=low

   * New upstream release. (Closes: #119823)
   * Fixed in this release. (Closes: #69223)

libmailtools-perl (1.40-3) unstable; urgency=medium

   * Providing 'libmail-perl' as it can be argued that this name is more
     correct for the package, but without the headache of another name change.

libmailtools-perl (1.40-2) unstable; urgency=high

   * New Maintainer. (Same for 1.40-1, damnit.)
   * Install the provided demos.
   * Move overview.txt to OVERVIEW.
   * Reorganize debian/rules so that the layout makes _sense_.
   * Bump to Standards-Version 3.5.6 (Changes made in 1.40-1 meet
     requirements.)
   * Change Build-Depends to Build-Depends-Indep.
   * Install a README.Debian for mailtools.
   * Fixed upstream. (Closes: #77046)
   * High urgency, so that it makes into testing.
   * Clean up OVERVIEW in clean target.

libmailtools-perl (1.40-1) unstable; urgency=low

   * New upstream release
   * Renaming source and binary package libmailtools-perl.
   * Adding Build-Depends. (Closes: #94835)
   * Use vendor install directories.
   * Cleaning up "Not in MANIFEST" spew from clean target.
   * Rewrote most of debian/rules to support vendor directories.
   * Fixed in 1.18 upstream release. (Closes: #100486)
   * Also fixed upstream. (Closes: #81189)
   * Include qmail.pm. (Closes: #47862)

2000

mailtools (1.15-1) unstable; urgency=low

   * New upstream release
   * Deals with case issues correctly in Mail::Field (closes: bug#69234)
   * Close a long-fixed bug (closes: bug#53081)

mailtools (1.14-1) unstable; urgency=low

   * New upstream version.

1999

mailtools (1.13-4) unstable; urgency=low

   * Made a quick hack to create an overview file.  Darren, if you want
     more than this, it's going to be wishlisted forever. :-) (closes:
     bug#36906)

mailtools (1.13-3) unstable; urgency=low

   * Fix for shell quoting issue in Mail::Mailer::test. (closes: bug#40134)

mailtools (1.13-2) unstable; urgency=low

   * Modified for new perl packages.
   * Modified to use debhelper.

mailtools (1.13-1) unstable; urgency=low

   * New upstream version.

mailtools (1.12-1) unstable; urgency=low

   * Update description (closes: bug#17079)
   * Mail::Address was rewritten to try and avoid taking arbitrarily long periods of time (closes: bug#31786)

1998

mailtools (1.11-2) unstable; urgency=low

   * Correct typo in control.

mailtools (1.11-1) unstable; urgency=low

   * New upstream release.

mailtools (1.1003-1) unstable; urgency=low

   * New upstream release

1997

mailtools (1.09-2) unstable; urgency=low

   * Just entirely remove .packlist---anyone using the debian package
     doesn't need it anyway

mailtools (1.09-1) unstable; urgency=low

   * New upstream release

1996

mailtools (1.06-3) unstable; urgency=low

   * Added dependency on libnet package.

mailtools (1.06-2) unstable; urgency=low

   * Updated maintainer address
   * Changed source dir name so dpkg-source doesn't barf

mailtools (1.06-1) unstable; urgency=low

   * Initial packaging.
   * Minor fix to get rid of carp