Skip to content

Changelog libbonoboui (2.24.5-5~focal+10.0trisquel1)

2021

libbonoboui (2.24.5-5~focal+10.0trisquel1) nabia-backports; urgency=medium

   * Backported from ppa

2020

libbonoboui (2.24.5-5~focal) focal; urgency=medium

   * Upload for Focal

2016

libbonoboui (2.24.5-4) unstable; urgency=medium

   [ Andreas Henriksson ]
   * Add Vcs-* fields to debian/control.in
 
   [ Michael Biebl ]
   * Add Build-Depends on gnome-common. Required by autoreconf.
     (Closes: #837821)
   * Convert from cdbs to dh.
   * Drop debian/libbonoboui2-dev.preinst, no longer needed.
   * Bump debhelper compat level to 10.
   * Bump Standards-Version to 3.9.8.

2015

libbonoboui (2.24.5-3) unstable; urgency=medium

   [ Matthias Klose ]
   * Avoid new warning with GCC 5. (Closes: #777939)

2013

libbonoboui (2.24.5-2) unstable; urgency=low

   * Add missing build-dependency on gtk-doc-tools.
   * Fix copyright file. Closes: #733487.

libbonoboui (2.24.5-1) unstable; urgency=low

   [ Josselin Mouette ]
   * Move documentation to libbonoboui2-dev. Closes: #583121.
     + Stop symlinking to /usr/share/doc.
     + Remove the sylink in libbonoboui2-dev.preinst.
 
   [ Loïc Minier ]
   * Fix globbing in watch file.
 
   [ Emilio Pozuelo Monfort ]
   * debian/source/format,
     debian/rules:
     + Switch to source format 3.0 (quilt).
   * debian/patches/01_dont_check_for_pangox.patch:
     + Stop checking for pangox during configure. It's not needed
       and pangox is going away. Closes: #702008.
 
   [ Josselin Mouette ]
   * New upstream translation & bugfix release.
   * Move to 3.0 quilt format, using tar.bz2 tarball.
   * Use dh_autoreconf.
   * 01_dont_check_for_pangox.patch. Stop using pangox entirely for
     irrelevant checks. Explicitly depend on X11 libraries since
     libbonoboui uses them regardless.
   * Convert to multi-arch:
     + Require appropriate cdbs/debhelper versions.
     + Bump requirement on libbonobo2-dev for the new server path.
     + Bump requirement on libglade2-dev for the new modules path.
     + Make libbonoboui2-common MA: foreign and libbonoboui2-0 MA: same.
     + Update installation paths.
   * Move to section oldlibs.
   * Update descriptions.
   * Drop .la files.
   * Drop gnome:version stuff.
   * Move bonobo-browser and test-moniker to a new libbonobo2-bin
     package.
     + This allows us to make libbonoboui2-dev MA: same.

2010

libbonoboui (2.24.3-1) unstable; urgency=low

   * New upstream bugfix release.
   * debian/control.in:
     - Bump Standards version to 3.8.4 (No changes needed).

2009

libbonoboui (2.24.2-1) unstable; urgency=low

   * Add libglib2.0-doc and libgtk2.0-doc to b-d-i to ensure proper
     xrefs.
   * Stop mentioning GNOME 2.
   * New upstream translation release.

libbonoboui (2.24.1-1) unstable; urgency=low

   * New upstream bugfix release.

libbonoboui (2.24.0-2) unstable; urgency=low

   * Upload to unstable.

2008

libbonoboui (2.24.0-1) experimental; urgency=low

   [ Loic Minier ]
   * Pass -s -noreset to xvfb-run as otherwise Xvfb will reset when the first
     client (test) disconnects and xvfb-run will fail killing Xvfb.
 
   [ Josselin Mouette ]
   * New upstream release.
   * Update build-dependencies and dependencies according to the
     gnome-vfs dependency removal.
   * Standards version is 3.8.0.
   * Don’t ship the .a of the glade catalog, it’s useless.

libbonoboui (2.22.0-1) unstable; urgency=low

   * New upstream stable release.

2007

libbonoboui (2.21.90-1) unstable; urgency=low

   * Build-dep on xauth instead of xbase-clients.
   * New upstream release from the development series, but only stable changes;
     no API change; bug fixes.
     - Build-dep on libpopt-dev.
   * Bump up Standards-Version to 3.7.3.

libbonoboui (2.20.0-1) unstable; urgency=low

   * New upstream release.
   * Upload to unstable, drop check-dist include.

libbonoboui (2.19.6-1) experimental; urgency=low

   * New upstream release (no ABI/API break):
     + Use check-dist.mk again.

libbonoboui (2.18.0-5) unstable; urgency=low

   * Build-dep on xbase-clients for xvfb-run; closes: #419585.
   * Use a custom check implementation.

libbonoboui (2.18.0-4) unstable; urgency=low

   * Run make in Xvfb for the test suite; build-dep on xvfb and xfonts-base.

libbonoboui (2.18.0-3) unstable; urgency=low

   * Run testsuite, ignoring failure.

libbonoboui (2.18.0-2) unstable; urgency=low

   * Upload to unstable; drop check-dist include.
   * Fix URL in copyright.
   * Add ${misc:Depends}.
   * Stop shipping /usr/lib/libglade/2.0/libbonobo.la.
   * Wrap build-deps and deps.

libbonoboui (2.18.0-1) experimental; urgency=low

   * New upstream major stable release; no API change.
     - Build-depend on libgnomevfs2-dev (>= 2.8.0) and depend on it in the -dev
       package.

libbonoboui (2.16.0-2) experimental; urgency=low

   * Merge 2.14.0-5.
   * Add a get-orig-source target to retrieve the upstream tarball.
   * Include the new check-dist Makefile to prevent accidental uploads to
     unstable; bump build-dep on gnome-pkg-tools to >= 0.10.
   * Merge 2.14.0-6; SVN r8331:9075.
   * Cleanups.

2006

libbonoboui (2.16.0-1) experimental; urgency=low

   * New upstream release.
   * Bump shlibs to 2.15.1.
   * Remove libesd and gnome-vfs requirements.
   * Bump intltool and libxml requirements.
   * Remove the horrible auto-la-dependency generator.
   * Require gnome-pkg-tools 0.7.
   * Use clean-la and ${gnome:Version}.

libbonoboui (2.15.0-1) experimental; urgency=low

   * New upstream development release.
     - Target at experimental.
     - Bump shlibs to >= 2.15.0.

libbonoboui (2.14.0-6) unstable; urgency=low

   * Add a get-orig-source target to retrieve the upstream tarball.

libbonoboui (2.14.0-5) unstable; urgency=low

   * Use ${shlib:Depends} in libbonoboui2-dev.
   * Rebuild against new libdbus; thanks Vincent Lönngren; closes: #390419.

libbonoboui (2.14.0-4) unstable; urgency=low

   * Drop avahi substvar generation too, which I left behind in 2.14.0-3.
   * Fix watch file.
   * Set Maintainer to Debian GNOME Maintainers.
   * Drop useless debian/*dirs.
   * Bump Debhelper compatibility level to 5.

libbonoboui (2.14.0-3) unstable; urgency=low

   [ Josselin Mouette ]
   * Make the package binNMU-safe.
     + Build-depend on dpkg-dev 1.13.19.
     + Use ${source:Version} and ${binary:Version}
 
   [ Loic Minier ]
   * Remove the hardcoded dependencies added in 2.10.1-2 due to *.la files
     dependency_libs: libart-2.0-dev, libatk1.0-dev, libaudiofile-dev,
     libcairo2-dev, libfreetype6-dev, libgconf2-dev, libgcrypt11-dev,
     libglib2.0-dev, libgnomevfs2-dev, libgnutls-dev, libgpg-error-dev,
     libgtk2.0-dev, liborbit2-dev, libpango1.0-dev, libpopt-dev,
     libtasn1-2-dev, libxcursor-dev, libxrender-dev.
   * Use a new la:Depends substvar generated in binary-predeb/libbonoboui2-dev
     by debian/la-deps from debian/libbonoboui2-dev/**/*.la to compute *.la
     file dependencies.
   * Simple rebuild will get rid of libtasn1-2-dev dependency.
     (Closes: #374289)
   * Bump up Standards-Version to 3.7.2.
   * Slightly change wording of description to make lintian happy again.
   * Revert hack from 2.14.0-1 with the avahi-deps substvar which is now
     covered by la:Depends.

libbonoboui (2.14.0-2) unstable; urgency=low

   * Rebuild to get rid of the reference to libXcursor.la and
     libXrender.la (closes: #363057).
     + Build-depend on the latest libgnomecanvas.
   * Remove shlibs.local (closes: #317904).
   * libbonoboui2-common.{links,install}: move documentation where
     mandated by the FHS (closes: #342063).
     + libbonoboui2-common.postinst: do the symlink dance.
   * Remove references to xlibs-dev.
   * Remove duplicate dependency on libxml2-dev.

libbonoboui (2.14.0-1) unstable; urgency=low

   [ Josselin Mouette ]
   * Remove duplicate dependency on libxml2-dev (closes: #356889).
 
   [ Ondřej Surý ]
   * New upstream release
   * Update watch file
   * Update build deps and libbonoboui-dev deps
   * Removed debian/patches/32_implicit-pointer.patch
     - Merged upstream
   * Dynamic dependency on avahi, to make installable on hurd-i386 (Closes: #357399)

libbonoboui (2.10.1-2) unstable; urgency=low

   * Update watch file. [debian/watch]
   * Drop xlibs-dev deps and build-deps.
     [debian/control, debian/control.in]
   * Massive add of deps to libbonoboui-dev due to dependency_libs in its .la
     files (libart-2.0-dev, libatk1.0-dev, libaudiofile-dev,
     libavahi-client-dev, libavahi-common-dev, libavahi-compat-howl-dev,
     libcairo2-dev, libfreetype6-dev, libgconf2-dev, libgcrypt11-dev,
     libglib2.0-dev, libgnomevfs2-dev, libgnutls-dev, libgpg-error-dev,
     libgtk2.0-dev, liborbit2-dev, libpango1.0-dev, libpopt-dev,
     libtasn1-2-dev, libxcursor-dev, libxml2-dev, libxrender-dev).
     [debian/control, debian/control.in]

2005

libbonoboui (2.10.1-1) unstable; urgency=low

   * New upstream release.
   * Fix for implicit pointer conversion. (Closes: #318651)
     [debian/patches/32_implicit-pointer.patch]
   * Add CDBS utils. [debian/rules]
   * Update FSF address. [debian/copyright]
   * Bump Standards-Version to 3.6.2. [debian/control, debian/control.in]

libbonoboui (2.10.0-1) unstable; urgency=low

   * New upstream version.

libbonoboui (2.8.1-2) unstable; urgency=high

   * GNOME Team Upload.
   * debian/control.in:
     Build-Depend on gnome-vfs2 (>= 2.8.4-2) to remove the dependency on howl.
   * Priority high, howl needs to be removed due to license issues.

libbonoboui (2.8.1-1) unstable; urgency=low

   * New upstream release:
     - merged the fixes from the toolbar-rework branch.
     - fix warnings when toolbars are destroyed.
     - fix GDK interaction problem when running a control in same process
       as the container.
     - fix include of wrong i18n header files.
     - don't install files from examples.
     - toolbar theme rendering fixes.

2004

libbonoboui (2.8.0-2) unstable; urgency=low

   * GNOME team upload.
   * Upload to unstable.

libbonoboui (2.8.0-1) experimental; urgency=low

   * Upload to Debian experimental.
   * [debian/watch] Added from SVN; updated.

libbonoboui (2.8.0-0ubuntu1) warty; urgency=low

   * New upstream release.
   * debian/control.in:
     - removed the Build-Depends on gtk-doc-tools.
   * debian/rules:
     - removed --enable-gtk-doc.

libbonoboui (2.6.1-1) unstable; urgency=low

   * GNOME team upload.
   * Upload to unstable.
   * New upstream release.

libbonoboui (2.6.0-2) experimental; urgency=low

   * [debian/control.in] Added libxt-dev build dependency. (Closes: #245979)
     Added runtime dependencies on libsm-dev, libice-dev, libx11-dev to the
     -dev package as /usr/lib/libbonoboui-2.la references them directly.

libbonoboui (2.6.0-1) experimental; urgency=low

   * GNOME team upload.
   * New upstream release.
   * debian/libbonoboui2-0.shlibs: added, include versioned shlibs for 2.6.0.

libbonoboui (2.5.4-1) experimental; urgency=low

   * GNOME Team Upload.
   * Ondřej Surý:
     - New upstream release.
     - Switch to cdbs.
   * Jordi Mallach:
     - Update dependencies for GNOME 2.6.
   * Sebastien Bacher:
     - Updated .install files.
     - Enable doc building since html are not in the upstream archive.

libbonoboui (2.4.3-2) unstable; urgency=medium

   * GNOME team upload.
   * [debian/rules] Don't include CanvDemo.
   * [debian/libbonoboui2-0.files, debian/control.in] Put
     /usr/lib/libglade/2.0/libbonobo.so into the runtime library package,
     rather than the common package.
   * [debian/control.in] libbonoboui2-common is now Architecture: all and has
     no more shared library dependencies. (Closes: #195855, #232285)

libbonoboui (2.4.3-1) unstable; urgency=low

   * New upstream release.
   * debian/control.in:
     + Build-Depends on gnome-pkg-tools.
     + Add versioned depends on libbonoboui2-common (Closes: #225850).
   * debian/rules:
     + Updated for the GNOME Team.
   * GNOME Team Upload.

2003

libbonoboui (2.4.2-1) unstable; urgency=low

   * New upstream release (Closes: #224609).
   * Gnome Team Upload.

libbonoboui (2.4.0-4) unstable; urgency=low

   * Built with gnome-vfs2 (>= 2.4.0-4).
   * debian/patches:
     + relibtoolize.patch: removed.
   * Updated Build-Depends.

libbonoboui (2.4.0-3) unstable; urgency=low

   * debian/control: sync section of packages with the overrides file.
   * debian/patches/relibtoolize.patch: added, updates libtool to fix FTBFS on
     many arches.

libbonoboui (2.4.0-2) unstable; urgency=low

   * GNOME Team Upload.
   * debian/rules: don't run gnome-autogen.sh.
   * debian/control:
     + remove Build-Conflicts on automake1.4, to resolve a dependency
       conflict with intltool.
     + remove Build-Depends on gnome-common.

libbonoboui (2.4.0-1) unstable; urgency=low

   * New upstream release.
   * Update Build-Depends.
   * Gnome Team Upload.

libbonoboui (2.2.4-2) unstable; urgency=low

   * Disable gtk-doc (--disable-gtk-doc) (closes: #192476)

libbonoboui (2.2.4-1) unstable; urgency=low

   * New upstream release

libbonoboui (2.2.2-1) unstable; urgency=low

   * New upstream release
   * seems fixed yelp SegV on statup problem (closes: #186306)

libbonoboui (2.2.0.1-2) unstable; urgency=low

   * Build-Depends: intltool (closes: #183520, #183521)

libbonoboui (2.2.0.1-1) unstable; urgency=low

   * New upstream release
   * use dbs
   * -dev: depends on libgnome2-dev (closes: #180766)

libbonoboui (2.2.0-1) unstable; urgency=low

   * New upstream release

libbonoboui (2.1.2-1) unstable; urgency=low

   * New upstream release

2002

libbonoboui (2.1.0-1) unstable; urgency=low

   * New upstream release
   * change maintainer address to @debian.org

libbonoboui (2.0.3-1) unstable; urgency=low

   * New upstream release

libbonoboui (2.0.1-2) unstable; urgency=low

   * New upstream release
   * don't compile with openssl (closes: #155703)

libbonoboui (2.0.0-1) unstable; urgency=low

   * New upstream release

libbonoboui (1.117.1-1) unstable; urgency=low

   * New upstream release

libbonoboui (1.117.0-1) unstable; urgency=low

   * New upstream release

libbonoboui (1.116.0-2) unstable; urgency=low

   * build-depends on gettext (closes: #146216)

libbonoboui (1.116.0-1) unstable; urgency=low

   * New upstream release

libbonoboui (1.115.0-1) unstable; urgency=low

   * New upstream release

libbonoboui (1.113.0-2) unstable; urgency=low

   * Fix Depends field.

libbonoboui (1.113.0-1) unstable; urgency=low

   * New upstream release

libbonoboui (1.112.1-1) unstable; urgency=low

   * New upstream release

libbonoboui (1.112.0-3) unstable; urgency=low

   * libbonoboui2-dev Depends on libglade2-dev, libesd0-dev (closes: #136427)

libbonoboui (1.112.0-2) unstable; urgency=low

   * build against libglib1.3-15, libgtk1.3-15

libbonoboui (1.112.0-1) unstable; urgency=low

   * New upstream release
   * build against libglib1.3-14, libgtk1.3-14

libbonoboui (1.111.0-3) unstable; urgency=low

   * build against libbonobo-activation4
   * update Build-Depends

libbonoboui (1.111.0-2) unstable; urgency=low

   * build against libatk12

libbonoboui (1.111.0-1) unstable; urgency=low

   * New upstream release
   * Build against liblinc1, libgconf2-4, libatk11 (closes: #133828)

libbonoboui (1.110.2-1) unstable; urgency=low

   * New upstream release

libbonoboui (1.110.0-1) unstable; urgency=low

   * New upstream release
   * build against libglib1.3-12, libgtk1.3-13

libbonoboui (1.109.2-2) unstable; urgency=low

   * Rebuild against libatk9

libbonoboui (1.109.2-1) unstable; urgency=low

   * New upstream release

libbonoboui (1.109.1-1) unstable; urgency=low

   * Initial Release.