Skip to content

Changelog lighttpd (1.4.55-1ubuntu1.20.04.1+10.0trisquel1)

2021

lighttpd (1.4.55-1ubuntu1.20.04.1+10.0trisquel1) nabia; urgency=medium

   * Fix Ubuntu references in the default index.html

lighttpd (1.4.55-1ubuntu1.20.04.1) focal; urgency=medium

   * d/control: Depend on libgamin to fix missing symbol errors (LP: #1453463)
   * d/test/control: introduce regression test for libgamin/libfam
   * d/test/libfam-libgamin-conflict-regression: check for libgamin/libfam
     conflict regressions

2020

lighttpd (1.4.55-1ubuntu1) focal; urgency=low

   * Merge from Debian unstable.  Remaining changes:
     - debian/control, debian/lighttpd-dev.install:
       + Add lighttpd-dev package.
     - debian/index.html:
       + Corrected BTS Ubuntu link and branding on the default page.
     - debian/lighttpd.conf:
       + Comment 'use-ipv6.pl' by default, which causes failure
         to bind port in ipv4.
     - debian/control:
       + Build-Depends on libgamin-dev rather than libfam-dev
         to fix startup warning.
     - debian/rules:
       + Add override_dh_installinit to set "defaults 91 09" to not
         start before apache2 but in the same runlevel with
         the same priority.
     - debian/lighttpd.dirs, debian/control, debian/rules,
       debian/lighttpd.ufw.profile:
       + Add the UFW profile.
     + Make the application build sanely:
       - Remove duplicate override on dh_install
       - Remove duplicate outdated NEWS file
       - Install updated upstream NEWS file and fix
         cp: cannot stat /debian/tmp/changelog thingy to
         fix FTBFS when built twice in a row.

lighttpd (1.4.55-1) unstable; urgency=medium

   [ Helmut Grohne ]
   * add debian/upstream/metadata
   * update expiration of Glenn's upstream signing key
   * move lighttpd to team maintenance
   * declare compliance with policy 4.5.0
 
   [ Debian Janitor ]
   * Bump debhelper from old 9 to 10.
   * Drop unnecessary dependency on dh-autoreconf.
   * Drop unnecessary dh arguments: --parallel
 
   [ Helmut Grohne ]
   * Drop --with systemd from dh as it is enabled by compat 10
   * New upstream version 1.4.55
 
   [ Glenn Strauss ]
   * add debian/conf-available/05-setenv.conf
 
   [ Helmut Grohne ]
   * pidfile now lives in /run/lighttpd.pid (Closes: #929203)

lighttpd (1.4.54-2ubuntu1) focal; urgency=low

   * Merge from Debian unstable.  Remaining changes:
     - debian/control, debian/lighttpd-dev.install:
       + Add lighttpd-dev package.
     - debian/index.html:
       + Corrected BTS Ubuntu link and branding on the default page.
     - debian/lighttpd.conf:
       + Comment 'use-ipv6.pl' by default, which causes failure
         to bind port in ipv4.
     - debian/control:
       + Build-Depends on libgamin-dev rather than libfam-dev
         to fix startup warning.
     - debian/rules:
       + Add override_dh_installinit to set "defaults 91 09" to not
         start before apache2 but in the same runlevel with
         the same priority.
     - debian/lighttpd.dirs, debian/control, debian/rules,
       debian/lighttpd.ufw.profile:
       + Add the UFW profile.
     + Make the application build sanely:
       - Remove duplicate override on dh_install
       - Remove duplicate outdated NEWS file
       - Install updated upstream NEWS file and fix
         cp: cannot stat /debian/tmp/changelog thingy to
         fix FTBFS when built twice in a row.

2019

lighttpd (1.4.54-2) unstable; urgency=medium

   * QA upload.
   * debian/control:
     + Bump Standards-Version to 4.4.1.
   * Rebuild with source-only upload to allow testing migration.

lighttpd (1.4.54-1) unstable; urgency=medium

   * QA upload.
   * New upstream release.
     + Drop all patches. All applied upstream.
   * Drop transitional dummy packages after the buster release.
   * Stop recommending lighttpd-modules-*.
   * Suggest all lighttpd modules instead.
   * Install lighttpd.socket as an example.
   * Declare compliance with policy version 4.4.0.
   * Build new module package lighttpd-mod-maxminddb.

lighttpd (1.4.53-4ubuntu2) eoan; urgency=medium

   * No change rebuild for libmysqlclient21.

lighttpd (1.4.53-4ubuntu1) eoan; urgency=low

   * Merge from Debian unstable.  Remaining changes:
     - debian/control, debian/lighttpd-dev.install:
       + Add lighttpd-dev package.
     - debian/index.html:
       + Corrected BTS Ubuntu link and branding on the default page.
     - debian/lighttpd.conf:
       + Comment 'use-ipv6.pl' by default, which causes failure
         to bind port in ipv4.
     - debian/control:
       + Build-Depends on libgamin-dev rather than libfam-dev
         to fix startup warning.
     - debian/rules:
       + Add override_dh_installinit to set "defaults 91 09" to not
         start before apache2 but in the same runlevel with
         the same priority.
     - debian/lighttpd.dirs, debian/control, debian/rules,
       debian/lighttpd.ufw.profile:
       + Add the UFW profile.
     + Make the application build sanely:
       - Remove duplicate override on dh_install
       - Remove duplicate outdated NEWS file
       - Install updated upstream NEWS file and fix
         cp: cannot stat /debian/tmp/changelog thingy to
         fix FTBFS when built twice in a row.

lighttpd (1.4.53-4) unstable; urgency=high

   * QA upload.
   * fix mixed use of srv->split_vals array (regression)
   * mod_magnet:fix invalid script return-type crash
   * fix assertion with server.error-handler
   * mod_wstunnel:fix wstunnel.ping-interval for big-endian architectures
   * fix abort in server.http-parseopts with url-path-2f-decode enabled
     CVE-2019-11072 (closes: #926885)

lighttpd (1.4.53-3ubuntu1) disco; urgency=low

   * Merge from Debian unstable.  Remaining changes:
     - debian/control, debian/lighttpd-dev.install:
       + Add lighttpd-dev package.
     - debian/index.html:
       + Corrected BTS Ubuntu link and branding on the default page.
     - debian/lighttpd.conf:
       + Comment 'use-ipv6.pl' by default, which causes failure
         to bind port in ipv4.
     - debian/control:
       + Build-Depends on libgamin-dev rather than libfam-dev
         to fix startup warning.
     - debian/rules:
       + Add override_dh_installinit to set "defaults 91 09" to not
         start before apache2 but in the same runlevel with
         the same priority.
     - debian/lighttpd.dirs, debian/control, debian/rules,
       debian/lighttpd.ufw.profile:
       + Add the UFW profile.
     + Make the application build sanely:
       - Remove duplicate override on dh_install
       - Remove duplicate outdated NEWS file
       - Install updated upstream NEWS file and fix
         cp: cannot stat /debian/tmp/changelog thingy to
         fix FTBFS when built twice in a row.

lighttpd (1.4.53-3) unstable; urgency=medium

   * QA upload.
 
   [ Glenn Strauss ]
   * rules: debian/lighttpd/var/cache/lighttpd perms
   * stronger ciphers default: ssl.cipher-list = "HIGH"
   * autopkgtest: /etc/init.d/lighttpd configtest
 
   [ Helmut Grohne ]
   * autopkgtest defconfig needs root.
     Thanks to Antonio Terceiro for diagnosis and solution (Closes: #922447)

lighttpd (1.4.53-2) unstable; urgency=medium

   * QA Upload.
 
   [ Glenn Strauss ]
   * Fix spelling mistake "autn" in package relations.
 
   [ Stefan Bühler ]
   * use php-cgi instead of php; allow php5-cgi as alternative for jessie
 
   [ Glenn Strauss ]
   * add paths to lighttpd.tmpfile.conf (Closes: #679854)
   * use persistent location for db in webdav conf
   * remove dpkg-statoverride from lighttpd.init

lighttpd (1.4.53-1ubuntu1) disco; urgency=low

   * Merge from Debian unstable.  Remaining changes:
     - debian/control, debian/lighttpd-dev.install:
       + Add lighttpd-dev package.
     - debian/index.html:
       + Corrected BTS Ubuntu link and branding on the default page.
     - debian/lighttpd.conf:
       + Comment 'use-ipv6.pl' by default, which causes failure
         to bind port in ipv4.
     - debian/control:
       + Build-Depends on libgamin-dev rather than libfam-dev
         to fix startup warning.
     - debian/rules:
       + Add override_dh_installinit to set "defaults 91 09" to not
         start before apache2 but in the same runlevel with
         the same priority.
     - debian/lighttpd.dirs, debian/control, debian/rules,
       debian/lighttpd.ufw.profile:
       + Add the UFW profile.
     + Make the application build sanely:
       - Remove duplicate override on dh_install
       - Remove duplicate outdated NEWS file
       - Install updated upstream NEWS file and fix
         cp: cannot stat /debian/tmp/changelog thingy to
         fix FTBFS when built twice in a row.

lighttpd (1.4.53-1) unstable; urgency=medium

   * QA Upload.
   * Disable libunwind support by default (unavailable on s390x).
     Rebuild with DEB_BUILD_PROFILES=pkg.lighttpd.libunwind to use it.
   * Checked compliance with policy version 4.3.0.
   * New upstream release.
     + Drop all patches.
     + debian/tests/defconfig: Require no warnings.
   * Add php to Build-Depends to increase test coverage.
   * Support parallel building.
   * As we now serve /usr/lib/cgi-bin, create the directory.

lighttpd (1.4.52-5ubuntu2) disco; urgency=medium

   * Do not use unwind on s390x

lighttpd (1.4.52-5ubuntu1) disco; urgency=low

   * Merge from Debian unstable.  Remaining changes:
     - debian/control, debian/lighttpd-dev.install:
       + Add lighttpd-dev package.
     - debian/index.html:
       + Corrected BTS Ubuntu link and branding on the default page.
     - debian/lighttpd.conf:
       + Comment 'use-ipv6.pl' by default, which causes failure
         to bind port in ipv4.
     - debian/control:
       + Build-Depends on libgamin-dev rather than libfam-dev
         to fix startup warning.
     - debian/rules:
       + Add override_dh_installinit to set "defaults 91 09" to not
         start before apache2 but in the same runlevel with
         the same priority.
     - debian/lighttpd.dirs, debian/control, debian/rules,
       debian/lighttpd.ufw.profile:
       + Add the UFW profile.
     + Make the application build sanely:
       - Remove duplicate override on dh_install
       - Remove duplicate outdated NEWS file
       - Install updated upstream NEWS file and fix
         cp: cannot stat /debian/tmp/changelog thingy to
         fix FTBFS when built twice in a row.

lighttpd (1.4.52-5) unstable; urgency=medium

   * QA Upload.
   * Fix arch-indep build. (Closes: #920448)

lighttpd (1.4.52-4) unstable; urgency=medium

   * QA Upload.
 
   [ Glenn Strauss ]
   * replace and deprecate include-conf-enabled.pl with include glob
   * provide conf-available/10-sockproxy.conf
   * explicitly add default modules to lighttpd.conf
   * load mod_compress after conf-enabled/*.conf (Closes: #822920)
 
   [ Stefan Bühler ]
   * remove reference to lighttpd 2.0 in the description for lighttpd-mod-cml
   * run dh_missing --fail-missing as override in own target
   * adapt build dependencies for xenial (and jessie) backports
   * don't generate lighttpd:ModuleProvides substvar for current package name
   * reexport upstream gpg keys with minimal options
 
   [ Glenn Strauss ]
   * strict parsing and normalization of URL (see NEWS)
   * lighttpd.init add configtest action
 
   [ Stefan Bühler ]
   * build with libunwind to log backtraces on failed asserts
 
   [ Helmut Grohne ]
   * fail the build when chown does not work
 
   [ Glenn Strauss ]
   * define alias.url in 10-cgi.conf (Closes: #837696)
   * remove obsolete index.lighttpd.html
   * update paths in starter index.html
   * NEWS: mod_cgi defines alias to /usr/lib/cgi-bin
   * enable 99-unconfigured.conf if not configured
 
   [ Helmut Grohne ]
   * connection_close.patch: cherry-picked from upstream
   * cross.patch: cherry-picked from upstream

lighttpd (1.4.52-3ubuntu1) disco; urgency=medium

   * Merge from Debian unstable.  Remaining changes:
     - debian/control, debian/lighttpd-dev.install:
       + Add lighttpd-dev package.
     - debian/index.html:
       + Corrected BTS Ubuntu link and branding on the default page.
     - debian/lighttpd.conf:
       + Comment 'use-ipv6.pl' by default, which causes failure
         to bind port in ipv4.
     - debian/control:
       + Build-Depends on libgamin-dev rather than libfam-dev
         to fix startup warning.
     - debian/rules:
       + Add override_dh_installinit to set "defaults 91 09" to not
         start before apache2 but in the same runlevel with
         the same priority.
     - debian/lighttpd.dirs, debian/control, debian/rules,
       debian/lighttpd.ufw.profile:
       + Add the UFW profile.
     + Make the application build sanely:
       - Remove duplicate override on dh_install
       - Remove duplicate outdated NEWS file
       - Install updated upstream NEWS file and fix
         cp: cannot stat /debian/tmp/changelog thingy to
         fix FTBFS when built twice in a row.

lighttpd (1.4.52-3) unstable; urgency=medium

   * QA Upload to unstable.
   * http_auth_backends_assertion.patch: Fix load-all-modules autopkgtest.
   * Update lighttpd.tmpfile.conf to use /run. (Closes: #916676)
   * Drop obsolete alternative libssl1.0-dev from Build-Depends. Thanks to
     Moritz Muehlenhoff and Stefan Bühler for considering implications on
     backports. (Closes: #917347)

lighttpd (1.4.52-2+exp2) experimental; urgency=medium

   * QA Upload.
   * Don't ship /var/www/cgi-bin. Fixes dir-or-file-in-var-www autoreject. Is
     never referenced from any config.

lighttpd (1.4.52-2+exp1) experimental; urgency=medium

   * QA Upload.
 
   [ Helmut Grohne ]
   * Add lighttpd-mod-* Provides.
   * Move mysql modules to new binary package lighttpd-modules-mysql.
   * Move ldap modules to new binary package lighttpd-modules-ldap.
 
   [ Stefan Bühler and Glenn Strauss ]
   * Add modules mod_authn_pam, mod_authn_sasl, mod_vhostdb_dbi and
     mod_vhostdb_pgsql to new binary packages.

2018

lighttpd (1.4.52-2ubuntu1) disco; urgency=low

   * Merge from Debian unstable.  Remaining changes:
     - debian/control, debian/lighttpd-dev.install:
       + Add lighttpd-dev package.
     - debian/index.html:
       + Corrected BTS Ubuntu link and branding on the default page.
     - debian/lighttpd.conf:
       + Comment 'use-ipv6.pl' by default, which causes failure
         to bind port in ipv4.
     - debian/control:
       + Build-Depends on libgamin-dev rather than libfam-dev
         to fix startup warning.
     - debian/rules:
       + Add override_dh_installinit to set "defaults 91 09" to not
         start before apache2 but in the same runlevel with
         the same priority.
     - debian/lighttpd.dirs, debian/control, debian/rules,
       debian/lighttpd.ufw.profile:
       + Add the UFW profile.
     + Make the application build sanely:
       - Remove duplicate override on dh_install
       - Remove duplicate outdated NEWS file
       - Install updated upstream NEWS file and fix
         cp: cannot stat /debian/tmp/changelog thingy to
         fix FTBFS when built twice in a row.

lighttpd (1.4.52-2) unstable; urgency=medium

   * QA Upload.
 
   [ Helmut Grohne ]
   * Bump debhelper dependency for using dh_missing.
   * Add basic autopkgtests.
   * Drop Files-Excluded from debian/copyright as we are not repacking.
   * Extend debian/clean and override_dh_clean to cover more files including
     the ones from Files-Excluded.
   * Update Standards Version to 4.2.1.
     + Document that binary-targets need root for chowning to www-data.
   * Use upstream's create-mime.conf.pl. (Closes: #904741)
   * Fix FTCBFS: (Closes: #912358)
     + Drop unused Build-Depends: libcgi-pm-perl. (No longer used)
     + Annotate Build-Depends: perl with :native.
   * Demote perl to Recommends and have lighty-enable-mod print a useful
     message in case it is missing.
   * Enable mod_openssl in 10-ssl.conf. (Closes: #907909)
 
   [ Stefan Bühler ]
   * use https link to download.lighttpd.net in debian/watch
   * fix packaging docs for mod-authn-ldap
 
   [ Glenn Strauss ]
   * fix misspelling of GSSAPI
   * lighttpd.init: full preflight test in check_syntax

lighttpd (1.4.52-1ubuntu1) disco; urgency=low

   * Merge from Debian unstable.  Remaining changes:
     - debian/control, debian/lighttpd-dev.install:
       + Add lighttpd-dev package.
     - debian/index.html:
       + Corrected BTS Ubuntu link and branding on the default page.
     - debian/lighttpd.conf:
       + Comment 'use-ipv6.pl' by default, which causes failure
         to bind port in ipv4.
     - debian/control:
       + Build-Depends on libgamin-dev rather than libfam-dev
         to fix startup warning.
     - debian/rules:
       + Add override_dh_installinit to set "defaults 91 09" to not
         start before apache2 but in the same runlevel with
         the same priority.
     - debian/lighttpd.dirs, debian/control, debian/rules,
       debian/lighttpd.ufw.profile:
       + Add the UFW profile.
     + Make the application build sanely:
       - Remove duplicate override on dh_install
       - Remove duplicate outdated NEWS file
       - Install updated upstream NEWS file and fix
         cp: cannot stat /debian/tmp/changelog thingy to
         fix FTBFS when built twice in a row.

lighttpd (1.4.52-1) unstable; urgency=medium

   * QA Upload.
   * New upstream release. (Closes: #879496)
     + Fix CVE-2018-19052. (Closes: #913528)
     + Don't append port to unix sockets. (Closes: #877039)
     + Refactor buffer API. (Closes: #857255)
     + Don't use AC_PATH_PROG to find pkg-config. (Addresses: #912358)
     + Drop patch fix-openssl-1.1.1.patch applied upstream.
     + Add new mod_sockproxy.so to main package.
   * Replace Build-Depends: dh-systemd with newer debhelper for lintian.

lighttpd (1.4.49-2ubuntu1) disco; urgency=low

   * Merge from Debian unstable.  Remaining changes:
     - debian/control, debian/lighttpd-dev.install:
       + Add lighttpd-dev package.
     - debian/index.html:
       + Corrected BTS Ubuntu link and branding on the default page.
     - debian/lighttpd.conf:
       + Comment 'use-ipv6.pl' by default, which causes failure
         to bind port in ipv4.
     - debian/control:
       + Build-Depends on libgamin-dev rather than libfam-dev
         to fix startup warning.
     - debian/rules:
       + Add override_dh_installinit to set "defaults 91 09" to not
         start before apache2 but in the same runlevel with
         the same priority.
     - debian/lighttpd.dirs, debian/control, debian/rules,
       debian/lighttpd.ufw.profile:
       + Add the UFW profile.
     + Make the application build sanely:
       - Remove duplicate override on dh_install
       - Remove duplicate outdated NEWS file
       - Install updated upstream NEWS file and fix
         cp: cannot stat /debian/tmp/changelog thingy to
         fix FTBFS when built twice in a row.

lighttpd (1.4.49-2) unstable; urgency=medium

   * Non-maintainer upload.
 
   [ Ondřej Nový ]
   * d/copyright: Change Format URL to correct one
 
   [ Ximin Luo ]
   * Add a patch to work against openssl 1.1.1. (Closes: #913251)
   * Add Depends: perl. (Closes: #913249)

lighttpd (1.4.49-1.1ubuntu1) disco; urgency=low

   * Merge from Debian unstable.  Remaining changes:
     - debian/control, debian/lighttpd-dev.install:
       + Add lighttpd-dev package.
     - debian/index.html:
       + Corrected BTS Ubuntu link and branding on the default page.
     - debian/lighttpd.conf:
       + Comment 'use-ipv6.pl' by default, which causes failure
         to bind port in ipv4.
     - debian/control:
       + Build-Depends on libgamin-dev rather than libfam-dev
         to fix startup warning.
     - debian/rules:
       + Add override_dh_installinit to set "defaults 91 09" to not
         start before apache2 but in the same runlevel with
         the same priority.
     - debian/lighttpd.dirs, debian/control, debian/rules,
       debian/lighttpd.ufw.profile:
       + Add the UFW profile.
     + Make the application build sanely:
       - Remove duplicate override on dh_install
       - Remove duplicate outdated NEWS file
       - Install updated upstream NEWS file and fix
         cp: cannot stat /debian/tmp/changelog thingy to
         fix FTBFS when built twice in a row.

lighttpd (1.4.49-1.1) unstable; urgency=medium

   * Non-maintainer upload.
   * Install mod_openssl.so and other missing modules. (Closes: #894276)

lighttpd (1.4.49-1) unstable; urgency=medium

   [ Michael Gilbert ]
   * Suggest php-cgi since php5-cgi has been removed from the archive
     (closes: #859927).
 
   [ Clint Adams ]
   * New upstream version.
   * Update control file, including setting Maintainer to Debian QA Group.

lighttpd (1.4.45-1ubuntu3) bionic; urgency=high

   * No change rebuild against openssl1.1.

lighttpd (1.4.45-1ubuntu2) bionic; urgency=medium

   * Rebuild against new libgdbm5.

2017

lighttpd (1.4.45-1ubuntu1) artful; urgency=medium

   * Merge from Debian unstable.  Remaining changes:
     - debian/patches/add-lighttpd.pc-configure.patch:
       + Add lighttpd.pc to ac_config_files to fix FTBFS: make[3]:
         *** No rule to make target `lighttpd.pc', needed by `all-am'.
     - debian/patches/build-dev-package.patch,
       debian/control, debian/lighttpd-dev.install:
       + Add lighttpd-dev package.
     - debian/index.html:
       + Corrected BTS Ubuntu link and branding on the default page.
     - debian/lighttpd.conf:
       + Comment 'use-ipv6.pl' by default, which causes failure
         to bind port in ipv4.
     - debian/control:
       + Build-Depends on libgamin-dev rather than libfam-dev
         to fix startup warning.
     - debian/rules:
       + Add override_dh_installinit to set "defaults 91 09" to not
         start before apache2 but in the same runlevel with
         the same priority.
     - debian/lighttpd.dirs, debian/control, debian/rules,
       debian/lighttpd.ufw.profile:
       + Add the UFW profile.
     + Make the application build sanely:
       - Refresh and tweak build-dev-package.patch to apply sanely
       - Remove duplicate override on dh_install
       - Remove duplicate outdated NEWS file
       - Install updated upstream NEWS file and fix
         cp: cannot stat /debian/tmp/changelog thingy to
         fix FTBFS when built twice in a row.

lighttpd (1.4.45-1) unstable; urgency=medium

   * New upstream version 1.4.45.
     - Drop kfreebsd-disable-test.patch (upstream says its fixed).
   * Fix upstream spelling errors.
   * Fix cgi-bin path on start page (closes: #763618)
   * Remove automatically generated files from the upstream tarball again.
   * Suggest the service command instead of /etc/init.d for restarting services
     (closes: #762663).

lighttpd (1.4.44-1ubuntu1) zesty; urgency=medium

   * Merge from Debian unstable.  Remaining changes:
     - debian/patches/add-lighttpd.pc-configure.patch:
       + Add lighttpd.pc to ac_config_files to fix FTBFS: make[3]:
         *** No rule to make target `lighttpd.pc', needed by `all-am'.
     - debian/patches/build-dev-package.patch,
       debian/control, debian/lighttpd-dev.install:
       + Add lighttpd-dev package.
     - debian/index.html:
       + Corrected BTS Ubuntu link and branding on the default page.
     - debian/lighttpd.conf:
       + Comment 'use-ipv6.pl' by default, which causes failure
         to bind port in ipv4.
     - debian/control:
       + Build-Depends on libgamin-dev rather than libfam-dev
         to fix startup warning.
     - debian/rules:
       + Add override_dh_installinit to set "defaults 91 09" to not
         start before apache2 but in the same runlevel with
         the same priority.
     - debian/lighttpd.dirs, debian/control, debian/rules,
       debian/lighttpd.ufw.profile:
       + Add the UFW profile.
   * Make the application build sanely:
     + Refresh and tweak build-dev-package.patch to apply sanely
     + Remove duplicate override on dh_install
     + Remove duplicate outdated NEWS file
     + Install updated upstream NEWS file and fix
       cp: cannot stat /debian/tmp/changelog thingy to
       fix FTBFS when built twice in a row.

lighttpd (1.4.44-1) unstable; urgency=medium

   * New upstream version 1.4.44
   * debian/copyright: make lintian happy
   * debian/control: add libssl1.0-dev as alternative for  libssl-dev

2016

lighttpd (1.4.43+git20161216-1) unstable; urgency=medium

   * New upstream snapshot (closes: #846917).
   * Remove unneeded perl dependencies.
   * Update debian/copyright to format 1.0.
   * Ship NEWS file as upstream's changelog.
   * Remove systemd dependency (closes: #846299).
   * Suggest php5-cgi instead of recommending it.
   * Update watch file to look for upstream's xz tarball.
   * Fix incorrect bug number in previous changelog entry.
   * Make a mod_rewrite conf file available (closes: #751957).
   * Point to /var/www/html from the placeholder page (closes: #808921).
   * Add new packages for LDAP, GSSAPI, MySQL, and GeoIP modules.
     - Thanks to Stefan Bühler.
   * Fix build hardening flags.
     - Thanks to Stefan Bühler.

lighttpd (1.4.43-1) unstable; urgency=medium

   * New upstream release (closes: #841732).
     - Fixes CVE-2016-1000212 (closes: #832571).
     - Adds support for openssl 1.1.0 (closes: #828421).
   * Update standards version.
   * Fix lsb-base lintian error.
   * Add Glenn Strauss signing key.
   * Use upstream's systemd service file.
   * Recommend php5-cgi (closes: #774644).
   * Suggest lighttpd-doc (closes: #806523).
   * Use default-libmysqlclient-dev build dependency.

lighttpd (1.4.39-1ubuntu1) yakkety; urgency=low

   * Merge from Debian unstable.  Remaining changes:
     - debian/patches/add-lighttpd.pc-configure.patch:
       + Add lighttpd.pc to ac_config_files to fix FTBFS: make[3]:
         *** No rule to make target `lighttpd.pc', needed by `all-am'.
     - debian/patches/build-dev-package.patch,
       debian/control, debian/lighttpd-dev.install:
       + Add lighttpd-dev package.
     - debian/index.html:
       + Corrected BTS Ubuntu link and branding on the default page.
     - debian/lighttpd.conf:
       + Comment 'use-ipv6.pl' by default, which causes failure
         to bind port in ipv4.
     - debian/control:
       + Build-Depends on libgamin-dev rather than libfam-dev
         to fix startup warning.
     - debian/rules:
       + Add override_dh_installinit to set "defaults 91 09" to not
         start before apache2 but in the same runlevel with
         the same priority.
     - debian/lighttpd.dirs, debian/control, debian/rules,
       debian/lighttpd.ufw.profile:
       + Add the UFW profile.

lighttpd (1.4.39-1) unstable; urgency=medium

   * New upstream release.

2015

lighttpd (1.4.37-1) unstable; urgency=medium

   * New upstream release.
     - Log file injection issue CVE-2015-3200 fixed (closes: #787132).
   * Add a debian/clean file.
   * Drop upstreamed patches.
   * Add upstream signing key.
   * Update standards version.
   * Apply the non-maintainer upload.

lighttpd (1.4.35-4.1) unstable; urgency=medium

   * Non-maintainer upload.
   * Fix "FTBFS with perl 5.22: test failures (CGI.pm)":
     Add build dependency on libcgi-pm-perl.
     CGI.pm was deprecated in Perl 5.19.x and removed in 5.21.x which makes the
     explicit build dependency necessary.
     (Closes: #789856)

lighttpd (1.4.35-4ubuntu2) xenial; urgency=medium

   * Rebuild for libmysqlclient20.
   * Add build dependency on libcgi-pm-perl to fix FTBFS. Taken from
     Debian with thanks to gregor herrmann.

lighttpd (1.4.35-4ubuntu1) vivid; urgency=low

   * Merge from Debian unstable.  Remaining changes:
     - debian/patches/add-lighttpd.pc-configure.patch:
       + Add lighttpd.pc to ac_config_files to fix FTBFS: make[3]:
         *** No rule to make target `lighttpd.pc', needed by `all-am'.
     - debian/patches/build-dev-package.patch,
       debian/control, debian/lighttpd-dev.install:
       + Add lighttpd-dev package.
     - debian/index.html:
       + Corrected BTS Ubuntu link and branding on the default page.
     - debian/lighttpd.conf:
       + Comment 'use-ipv6.pl' by default, which causes failure
         to bind port in ipv4.
     - debian/control:
       + Build-Depends on libgamin-dev rather than libfam-dev
         to fix startup warning.
     - debian/rules:
       + Add override_dh_installinit to set "defaults 91 09" to not
         start before apache2 but in the same runlevel with
         the same priority.
     - debian/lighttpd.dirs, debian/control, debian/rules,
       debian/lighttpd.ufw.profile:
       + Add the UFW profile.

2014

lighttpd (1.4.35-4) unstable; urgency=medium

   * Disable SSLv3 by default (closes: #765702).

lighttpd (1.4.35-3) unstable; urgency=medium

   * Support building with dpkg-buildpackage -g.
   * Drop libmemcache-dev build-dependency (closes: #748809).

lighttpd (1.4.35-2) unstable; urgency=medium

   * Fix a spelling error.
   * Add a lintian override.
   * Make VCS field canonical.
   * Add myself to the uploaders.
   * Use dh-autoreconf (closes: #726394, #731104).
   * Disable indeterminant test on kfreebsd (closes: #731074).

lighttpd (1.4.35-1) unstable; urgency=low

   * New upstream version (fixes CVE-2014-2323, CVE-2014-2324)
     + Delete patches: cve-2013-4508.patch, cve-2013-4559.patch,
       cve-2013-4560.patch. Those are all cumulative included since
       lighttpd 1.4.34
   * Acknowledge NMUs by the security team
   * Make the init script wait until lighttpd really terminates.
   * Change the default document root /var/www/html (Closes: #730379), add a
     Lintian override for it
   * Bump the debhelper dependency to >= 9.20130624 to ensure dh_installinit is
     recent enough for systemd (Closes: #713860)
   * Reorder LSB init dependencies, add $local_fs to it
   * Add hardening flags to lighttpd. Thanks to Michael Gilbert
     for providing a patch (Closes: #741497)
   * Remove W3C logo from index.html to avoid inclusion of images hosted
     elsewhere
   * Push standards version to 3.9.5 (no changes needed).

lighttpd (1.4.33-1+nmu2ubuntu2) trusty; urgency=medium

   * Use dh-autoreconf to regenerate autotools files, fixes FTBFS with
     automake 1.14.1 (Closes: #726934)
   * Add lighttpd.pc to ac_config_files to fix FTBFS:
     make[3]: *** No rule to make target `lighttpd.pc', needed by `all-am'.

2013

lighttpd (1.4.33-1+nmu2ubuntu1) trusty; urgency=low

   * Merge from Debian unstable.  Remaining changes:
     - debian/index.html: corrected BTS Ubuntu link for lighttpd.
     - debian/index.html: s/Debian/Ubuntu/g branding on the default page.
     - debian/lighttpd.conf: Comment 'use-ipv6.pl' by default, which causes
       failure to bind port in ipv4.
     - Add lighttpd-dev package:
       + debian/control: Added lighttpd-dev package; Build-depends on
         automake (>=1.14), libtool.
       + debian/lighttpd-dev.install: Added.
     - debian/control: libgamin-dev rather than libfam-dev to fix startup warning.
     - debian/rules: Add override_dh_installinit to set "defaults 91 09" to not
       start before apache2 but in the same runlevel with the same priority.
     - Added a UFW profile set:
       + debian/lighttpd.dirs: added etc/ufw/applications.d
       + debian/rules: install the ufw profile.
       + debian/control: Suggests on ufw.

lighttpd (1.4.33-1+nmu2) unstable; urgency=high

   * Non-maintainer upload by the Security Team.
   * Fix regression caused by the fix for cve-2013-4508 (closes: #729480).

lighttpd (1.4.33-1+nmu1) unstable; urgency=high

   * Non-maintainer upload by the Security Team (closes: #729453).
   * Fix cve-2013-4508: ssl cipher suites issue.
   * Fix cve-2013-4559: setuid privilege escalation issue.
   * Fix cve-2013-4560: use-after-free in fam.

lighttpd (1.4.33-1ubuntu1) trusty; urgency=low

   * Merge from Debian unstable (LP: #1246886).  Remaining changes:
     - debian/index.html: corrected BTS Ubuntu link for lighttpd.
     - debian/index.html: s/Debian/Ubuntu/g branding on the default page.
     - debian/lighttpd.conf: Comment 'use-ipv6.pl' by default, which causes
       failure to bind port in ipv4.
     - Add lighttpd-dev package:
       + debian/control: Added lighttpd-dev package; Build-depends on
         automake (>=1.14), libtool.
       + debian/lighttpd-dev.install: Added.
     - debian/control: libgamin-dev rather than libfam-dev to fix startup warning.
     - debian/rules: Add override_dh_installinit to set "defaults 91 09" to not
       start before apache2 but in the same runlevel with the same priority.
     - Added a UFW profile set:
       + debian/lighttpd.dirs: added etc/ufw/applications.d
       + debian/rules: install the ufw profile.
       + debian/control: Suggests on ufw.
     - debian/patches/build-dev-package.patch: Updated to reflect 1.4.33 changes.

lighttpd (1.4.33-1) unstable; urgency=low

   * Drop the connection-dos.patch - merged upstream.
   * Fix "mod_extforward missing configuration file": ship requested
     configuration file (Closes: #697304)
   * Remove access.conf, an obsolete conffiles as we should have done since
     2010 (Closes: #703215)
   * Push debhelper's compat mode to 9, the use of maintscript helper requires
     8.1 so we had to push the debhelper b-d anyway.
   * Fix "config.guess/config.sub out of date for arm64" by adding the patch
     provided by Colin Watson. Thanks (Closes: #726394).
   * Fix "[PATCH] use dh-systemd for proper systemd-related maintscripts" to
     add systemd support. Thanks to Michael Stapelberg (Closes: #713859)

lighttpd (1.4.31-4) unstable; urgency=high

   * CVE-2013-1427: Switch the socket path for PHP when using FastCGI. /tmp is
     world-writable which may cause security implications if an attacker
     manages to control /tmp/php.socket before the web server (re-)starts.
   * Switch VCS to git
   * Push standards version (no changes)

lighttpd (1.4.31-3ubuntu3) saucy; urgency=low

   * Use the autotools-dev dh addon to update config.guess/config.sub for
     arm64.

lighttpd (1.4.31-3ubuntu2) raring; urgency=low

   * Import change from debian version 1.4.31-4:
     - CVE-2013-1427: Switch the socket path for PHP when using FASTCGI. /tmp
       is world-writable which may cause security implications if an attacker
       manages to control /tmp/php.socket before the web server (re-)starts.

2012

lighttpd (1.4.31-3ubuntu1) raring; urgency=low

   * Merge from debian unstable, remaining changes:
     - debian/control: libgamin-dev rather than libfam-dev to fix startup warning.
     - debian/index.html: s/Debian/Ubuntu/g branding on the default page.
     - Added a UFW profile set:
       + debian/lighttpd.dirs: added etc/ufw/applications.d
       + debian/rules: install the ufw profile.
       + debian/control: Suggests on ufw.
     - Add lighttpd-dev package:
       + debian/control: Added lighttpd-dev package; Build-depends on
         automake, libtool
       + debian/lighttpd-dev.install: Added.
     - debian/rules: Add override_dh_installinit to set "defaults 91 09" to not
       start before apache2 but in the same runlevel with the same priority.
     - debian/patches/build-dev-package.patch: Updated
     - debian/lighttpd.conf: Comment 'use-ipv6.pl' by default, which causes
       failure to bind port in ipv4
   * debian/index.html: corrected BTS Ubuntu link for lighttpd

lighttpd (1.4.31-3) unstable; urgency=high

   * Fix "configuration files refer to wrong path for documentation"
     by merging a patch supplied by  Denis Laxalde <denis@laxalde.org>
     (Closes: #676641)
   * CVE-2012-5533: Fix Denial Of Service attacks against Lighttpd by sending
     faulty Connection headers

lighttpd (1.4.31-1) unstable; urgency=low

   * New upstream release
   * Be more careful when removing dangling symlinks, as introduced in 1.4.30-1.
     Under some configurations the postrm script could fail previously.
   * Change the use-ipv6.pl script to read the default listening port as a
     command line argument, fall back to the old default behavior otherwise
     (Closes: #632723, #642604). Thanks to Sebastian Pipping to accidentally
     give a hint how to fix this old problem by driving by.
   * Push standards version to 3.9.3.1 - no further changes
   * Fix "[lighttpd] "ldap" lowercase in extended description" by fixing the
     typo (Closes: #670206)
   * Update my maintainer address

2011

lighttpd (1.4.30-1) unstable; urgency=medium

   * New upstream release
     + Fix integer overflow (CVE-2011-4362) (Closes: #652726)
     + Fix attack vector as disclosed by the SSL BEAST attack (related:
       CVE-2011-3389). Note: If you are upgrading from an older version you need
       to change your configuration to mitigate effects of the attack. See the
       corresponding NEWS file for details.
     + Count SSL renegotiations to prevent client renegotiations
   * Urgency set to medium due to security updates.
   * Adapt to dpkg 1.16.1 API changes regarding build flags. This enables
     hardening build flags. This means, lighttpd is now being built with
     -fstack-protector and other security related build flags.
   * Add dpkg-dev (>= 1.16.1~) to build-depends to make sure our buildflags are
     properly supported. That's guaranteed for Testing, but might be helpful to
     know for backporters.
   * Fix "Doesn't remove /etc/lighttpd on purge" by removing dangling symlinks
     /only/. This does not entirely fix the problem of the maintainer, but we can
     not simply remove all files in /etc/lighttpd as other packages or the user
     himself might have left configuration files back (Closes: #642494)
   * Fix "please include systemd service file" Support systemd as alternative to
     sysvinit, ship systemd and tempfiles.d configuration files. Thanks to
     Michael Stapelberg for providing the required files (Closes: #652442)

lighttpd (1.4.29-1) unstable; urgency=low

   * New upstream release
   * Fix "lighty-enable-mod should return non-zero on fail" Update script to
     leave with appropriate exit status (Closes: #629638)
   * Remove the following patches:
     + silence-errors.diff - applied upstream
     + patches/ssl-fix.patch - applied upstream
   * Add `debian/source/options' to make dpkg-source ignore glitches done by
     upstream's Makefile in `src/mod_ssi_exprparser.c' and `src/configparser.c'
   * Run maintainer scripts with `set -e'

lighttpd (1.4.28-5) unstable; urgency=low

   * Build with sbuilder to avoid linking to non-existed packages.

lighttpd (1.4.28-4) unstable; urgency=low

   [ Krzysztof Krzyżaniak (eloy) ]
   * Add  Arno Töll to Uploaders
 
   [ Arno Töll ]
   * Fix "leaves dangling alternatives on upgrade" add preinst script which
     removes the dangling symlink (Closes: #614716)
   * Fix "/etc/lighttpd/conf-available/15-fastcgi-php.conf: fastcgi-php
     file missing a required directive" add a dependency based recursive module
     enable system in lighty-enable-mod (Closes: #600050)
   * Fix "binNMU for openssl 1.0.0 broke SSL support" backport fix from upstream
     to avoid name clashes between OpenSSL and Lighty's MD5 implementation
     (Closes: #622733)

lighttpd (1.4.28-3) unstable; urgency=low

   [ Krzysztof Krzyżaniak (eloy) ]
   * Updated debian/control and debian/copyright files
   * fix for debhelper-overrides-need-versioned-build-depends (>= 7.0.50~)
   * debian/compat: increased to 8
 
   [ Olaf van der Spek]
   * Don't fail install if server fails to start (closes: #383425)
   * Fix index-file.names typo (closes: #609890)

lighttpd (1.4.28-2ubuntu4) precise; urgency=low

   * debian/patches/CVE-2011-4362.patch: Fix DoS because of incorrect code in
     src/http_auth.c:67 (LP: #906792)
     - CVE-2011-4362

lighttpd (1.4.28-2ubuntu3) precise; urgency=low

   * Rebuild for libmysqlclient transition

lighttpd (1.4.28-2ubuntu2) oneiric; urgency=low

   * No-change rebuild for openssl0.9.8 -> openssl1.0.0 transition.

2010

lighttpd (1.4.28-2ubuntu1) natty; urgency=low

   * Merge from debian unstable. Remaining changes:
     - debian/control:
       + libgamin-dev rather than libfam-dev to fix startup warning.
       + debhelper Build-depends bumped to (>= 7.0.50) for
         overrides in rules file.
     - debian/index.html: s/Debian/Ubuntu/g branding on the default page.
     - Added a UFW profile set:
       + debian/lighttpd.dirs: added etc/ufw/applications.d
       + debian/rules: install the ufw profile.
       + debian/control: Suggests on ufw.
     - Add lighttpd-dev package:
       + debian/control: Added lighttpd-dev package; Build-depends on
         automake, libtool
       + debian/lighttpd-dev.install: Added.
     - debian/rules:
       + Add override_dh_installinit to set "defaults 91 09" to not start
         before apache2 but in the same runlevel with the same priority.
     - debian/patches/build-dev-package.patch: Updated
     - debian/lighttpd.conf: Comment 'use-ipv6.pl' by default, which causes
       failure to bind port in ipv4 (LP: #551211)

lighttpd (1.4.28-2) unstable; urgency=medium

   [ Olaf van der Spek ]
   * Use relative instead of absolute links for conf-enabled (closes: #541645)
   * Fix /doc/ for IPv6 (closes: #512583)
 
   [ Krzysztof Krzyżaniak (eloy) ]
   * Added patch patches/silence-errors.diff (closes: #601177)

lighttpd (1.4.28-1ubuntu1) natty; urgency=low

   * Merge from debian unstable, remaining changes:
     - debian/control:
       + libgamin-dev rather than libfam-dev to fix startup warning.
       + debhelper Build-depends bumped to (>= 7.0.50) for
         overrides in rules file.
     - debian/index.html: s/Debian/Ubuntu/g branding on the default page.
     - Added a UFW profile set:
       + debian/lighttpd.dirs: added etc/ufw/applications.d
       + debian/rules: install the ufw profile.
       + debian/control: Suggests on ufw.
     - Add lighttpd-dev package:
       + debian/control: Added lighttpd-dev package; Build-depends on
         automake, libtool
       + debian/lighttpd-dev.install: Added.
     - debian/rules:
       + Add override_dh_installinit to set "defaults 91 09" to not start
         before apache2 but in the same runlevel with the same priority.
     - debian/patches/build-dev-package.patch: Updated
     - debian/lighttpd.conf: Comment 'use-ipv6.pl' by default, which causes
       failure to bind port in ipv4 (LP: #551211)
   * debian/patches/build-dev-package.patch: updated
   * Dropped changes:
     - debian/lighttpd.init: clean environment; Check syntax during start/reload:
       this change has been applied in the debian package
     - syntax_check function defined in init script. (LP: #600767): this change
       has been applied in the debian package
     - debian/patches/build-dev-package.patch: Updated: patch updated newly

lighttpd (1.4.28-1) unstable; urgency=low

   [ Olaf van der Spek ]
   * New upstream release (closes: 521235, 572031, 564556)
   * Add check_syntax() from Ubuntu (closes: 589200)

lighttpd (1.4.26-3ubuntu2) maverick; urgency=low

   * syntax_check function defined in init script. (LP: #600767)

lighttpd (1.4.26-3ubuntu1) maverick; urgency=low

   * Merge from debian unstable (LP: #599010), remaining changes:
     - debian/control:
       + libgamin-dev rather than libfam-dev to fix startup warning.
       + debhelper Build-depends bumped to (>= 7.0.50) for
         overrides in rules file.
     - debian/lighttpd.init: clean environment; Check syntax during start/reload
       restart/force-reload.
     - debian/index.html: s/Debian/Ubuntu/g branding on the default page.
     - Added a UFW profile set:
       + debian/lighttpd.dirs: added etc/ufw/applications.d
       + debian/rules: install the ufw profile.
       + debian/control: Suggests on ufw.
     - Add lighttpd-dev package:
       + debian/control: Added lighttpd-dev package; Build-depends on
         automake, libtool
       + debian/lighttpd-dev.install: Added.
     - debian/rules:
       + Add override_dh_installinit to set "defaults 91 09" to not start
         before apache2 but in the same runlevel with the same priority.
     - debian/patches/build-dev-package.patch: Updated
     - debian/lighttpd.conf: Comment 'use-ipv6.pl' by default, which causes
       failure to bind port in ipv4 (LP: #551211)

lighttpd (1.4.26-3) unstable; urgency=low

   * Ack for NMU, fix for SSL incompatibility (closes: #572031)

lighttpd (1.4.26-2) unstable; urgency=low

   [ Krzysztof Krzyżaniak (eloy) ]
   * Switch to dpkg-source 3.0 (quilt) format
   * debian/control:
    + removed Franz Pletz from Uploaders, he's MIA (closes: #579366)
    + change dependency from libmysqlclient15-dev to more general
      libmysqlclient-dev
 
   [ Olaf van der Spek ]
   * take conf dir as an optional parameter (closes: 489854)
   * don't try to make /var/run/lighttpd when invoked with status
     (closes: 538662)
   * split FastCGI PHP conf from FastCGI conf (closes: 515699)
   * reduce max-procs from 2 to 1 (closes: 456200)
   * move debian doc handling into it's own file
   * set default vhost dir to /srv/<host>/htdocs (closes: 471054)
   * use delaycompress instead of copytruncate for logrotate (closes: 563626)
   * don't wait for old process to stop before starting new one for reload
     (closes: 504315)
   * use reopen-logs for logrotate (closes: 504319)
   * add no-www.conf (for use with evhost and simple-vhost, closes: 471055)
   * move evhost conf into it's own file

lighttpd (1.4.26-1.1ubuntu3) lucid; urgency=low

   * debian/control: Rebuild for libmysqlclient transition.

lighttpd (1.4.26-1.1ubuntu2) lucid; urgency=low

   * debian/lighttpd.conf: Comment 'use-ipv6.pl' by default, which causes
     failure to bind port in ipv4 (LP: #551211)

lighttpd (1.4.26-1.1ubuntu1) lucid; urgency=low

   * Merge from debian unstable (LP: #407722).  Remaining changes:
     - debian/control: libgamin-dev rather than libfam-dev to fix startup
       warning.
     - debian/init.d: clean environment; Check syntax during start/reload
       restart/force-reload.
     - debian/index.html: s/Debian/Ubuntu/g branding on the default page.
     - Added a UFW profile set:
       + debian/lighttpd.dirs: added etc/ufw/applications.d
       + debian/rules: install the ufw profile.
       + debian/control: Suggests on ufw.
     - Add lighttpd-dev package:
       + debian/control: Added lighttpd-dev package; Build-depends on
         automake, libtool
       + debian/lighttpd-dev.install: Added.
   * debian/control: debhelper Build-depends bumped to (>= 7.0.50) for
     overrides in rules file.
   * debian/rules:
     - Add override_dh_installinit to set "defaults 91 09" to not start
       before apache2 but in the same runlevel with the same priority.
   * debian/patches/build-dev-package.patch: Updated
   * Also closes: (LP: #521659, LP: #523682)

lighttpd (1.4.26-1.1) unstable; urgency=low

   * Non-maintainer upload.
   * Apply upstream patch to fix openssl (closes: #572031)

lighttpd (1.4.26-1) unstable; urgency=low

   * New upstream release (closes: #568735)
   * Use provided patch from  Andres Rodriguez <andreserl@ubuntu.com>
     to implement status action in init.d script (closes: #539955)

2009

lighttpd (1.4.25-2) unstable; urgency=low

   * Change behaviour of use-ipv6.pl script (closes: #560837)

lighttpd (1.4.25-1) unstable; urgency=low

   * New upstream release (closes: #558045)
   * debian/watch: updated
   * debian/control: Section field changed to web

lighttpd (1.4.24-1) unstable; urgency=low

   * New upstream release (closes: #530892) (closes: #538135) (closes: #482601)
     (closes: #541428)
   * debian/control:
    + Standards-Version: 3.8.3
   * debian/init.d renamed to debian/lighttpd.init
   * Added $syslog to LSB header in init script (closes: #545576)
     (Jeremy Lal <kapouer@melix.org>)
   * debian/init.d: force-reload moved to reload section (closes: #538661)
     (Peter Eisentraut <petere@debian.org>)

lighttpd (1.4.23-3) unstable; urgency=low

   * debian/rules: make sure that scripts have proper rights
    (closes: #536668), (closes: #536681), (closes: #536688) (closes: #536668)

lighttpd (1.4.23-2) unstable; urgency=low

   * Add lighttpd.docs with README & NEWS file
   * New upstream closes wishlist bugs (closes: #535065) (closes: #515777)

lighttpd (1.4.23-1) unstable; urgency=low

   * New upstream release
   * spawn-fcgi is now separate package, recommends it debian/control
   * Update Standards-Version to 3.8.2 without changes
   * Remove cdbs, patchutils from Build-Depends, debian/rules uses
     debhelper 7 scripts
   * lighttpd.logrotate apply patch (closes: #535523)
     from Ubuntu (Daniel Hahler, https://launchpad.net/bugs/393792)

lighttpd (1.4.22-1ubuntu4) karmic; urgency=low

   * Fix FTBFS, replaced automake with automake1.10 on Build-Depends
     (LP #447672)

lighttpd (1.4.22-1ubuntu3) karmic; urgency=low

   * debian/lighttpd.logrotate: check if lighttpd is running, before
     calling reload, which would start the daemon if it is not running
     currently (LP: #393792)

lighttpd (1.4.22-1ubuntu2) karmic; urgency=low

   * Introduce patches to introduce a -dev package for lighttpd. Closes
     (LP: #326899). Should merge seamlessly in the future.
 
   [ Andreas Moog ]
   * debian/control
     - add lighttpd-dev package
   * debian/patches
     - add build-dev-package.patch to include pkg-config files for lighttpd
   * debian/
     - add lighttpd-dev.install
 
   [ Morten Kjeldgaard ]
   * debian/rules: add DEB_AUTO_UPDATE_* variables to ensure autotool
     files get updated with our patches.
   * Minor cleanups and update Andreas' patches to version 1.4.22.

lighttpd (1.4.22-1ubuntu1) karmic; urgency=low

   * Merge from debian unstable (LP: #384367), remaining changes:
     - debian/control: Depend on lsb (>= 3.2-14), which has the status_of_proc()
       function; libgamin-dev rather than libfam-dev to fix startup warning.
     - debian/init.d: Add the 'status' action, clean environment; Check syntax
       during start/reload/restart/force-reload.
     - debian/rules: set DEB_UPDATE_RCD_PARAMS to "defaults 91 09" to not start
       lighty before apache2 but in the same runlevel with the same priority;
       Make sure that upgrades succeed, even if we can't restart lighttpd.
     - debian/index.html: s/Debian/Ubuntu/g branding on the default page.
     - Added a UFW profile set:
       + debian/lighttpd.dirs: added etc/ufw/applications.d
       + debian/rules: install the ufw profile.
       + debian/control: Suggests on ufw.
   * debian/patches/fix-conf-doc.patch: Update headers to match package version

lighttpd (1.4.22-1) unstable; urgency=low

   * New upstream release (closes: #520124) (closes: #516897) (closes: #441173)
   * debian/control: Update to Standards-Version 3.8.1 (no changes so far),
     debhelper dependency updated to 7, utfize my name, satisfy lintian
   * Remove all patches, all fixed upstream but rewrite_redirect_decode_url
     Do NOT use rewrite/redirect to protect specific urls.

lighttpd (1.4.19-5ubuntu7) jaunty; urgency=low

   * debian/index.html: do not point to edge.launchpad.net
     (LP: #302845)
   * Fix documentation reference to virtual hosting by referring
     to mod_simple_vhost (LP: #247271)
     - debian/patches/fix-conf-doc.patch

lighttpd (1.4.19-5ubuntu6) jaunty; urgency=low

   * Finally provide what ~ubuntu3 should have been already, fixing
     another shell script error (LP: #329595)

lighttpd (1.4.19-5ubuntu5) jaunty; urgency=low

   * Fix bashism in init.d (LP: #329595)

lighttpd (1.4.19-5ubuntu4) jaunty; urgency=low

   * Remove check-syntax-on-startup from debian/patches/series because there is
     not a patch with this name (changes in the last revision were all inside
     the debian dir)

lighttpd (1.4.19-5ubuntu3) jaunty; urgency=low

   * init.d: check sytax during start/reload/restart/force-reload.
     Patch provided by Nic Ferrier. (LP: #286887)

lighttpd (1.4.19-5ubuntu2) jaunty; urgency=low

   * Added a UFW profile set. (LP: #317994)
     - debian/lighttpd.dirs: added etc/ufw/applications.d
     - debian/rules: install the ufw profile
     - debian/control: lighttpd: suggest ufw

2008

lighttpd (1.4.19-5ubuntu1) jaunty; urgency=low

   * Merge from debian unstable, remaining changes:
    - debian/control: Depend on lsb >= 3.2-14, which has the
      status_of_proc() function; libgamin-dev rather than libfam-dev
      to fix startup warning
    - debian/init.d: Add the 'status' action, clean environment
    - debian/rules: set DEB_UPDATE_RCD_PARAMS to "defaults 91 09" to not
      start lighty before apache2 but in the same runlevel with the same
      priority
    - debian/index.html: s/Debian/Ubuntu/g branding on the default page
    - debian/compat: standards version 3.7.3, bump compat to 6, adjusted
      build-dep of debhelper accordingly
   * Dropped changes
    - debian/lighttpd.install: all changes upstream now, order adjusted
      accordingly

lighttpd (1.4.19-5) unstable; urgency=high

   * Remove the alias.url stanza from 10-cgi.conf (Closes: #499334).
   * Add patches for lighttpd security 2008-05 to 2008-07 (no CVE yet):
     + patches/lighttpd-1.4.x_request_header_memleak.patch
     + patches/lighttpd-1.4.x_rewrite_redirect_decode_url.patch
     + patches/lighttpd-1.4.x_userdir_lowercase.patch
   * Urgency set to high for security fix.

lighttpd (1.4.19-4ubuntu2) intrepid; urgency=low

   * debian/control: Depend on lsb >= 3.2-14, which has the
     status_of_proc() function.
   * debian/init.d: Add the 'status' action (LP: #251924).

lighttpd (1.4.19-4ubuntu1) intrepid; urgency=low

   * Merge from debian unstable (LP: #233966), remaining changes:
     - debian/rules: (From Debian)
     - Remove spurious mkdir in debian/rules (Closes: dbts 448160).
     - debian/conf-available/10-rrdtool: (From Debian)
       + Add sample configuration for the mod_rrdtool (Closes: dbts 462907).
     - debian/lighttpd.install:
       + Install 10-rrdtool
     - debian/patches/ldap-deprecated.dpatch:
       + Force use of deprecated ldap interfaces (Closes: dbts 463368),
         thanks to Dann Frazier (patches/ldap-deprecated.dpatch).
     - debian/rules: (LP: #174289)
       + set DEB_UPDATE_RCD_PARAMS to "defaults 91 09" to not start lighty before
         apache2 but in the same runlevel with the same priority
     - Build against libgamin-dev rather than libfam-dev (fixes a warning
       during startup)
     - Make sure that upgrades succeed, even if we can't restart lighttpd.
     - Clean environment in init.d script.

lighttpd (1.4.19-4) unstable; urgency=high

   * Make debian/use-ipv6.pl executable in debian/rules, thanks to Marco d'Itri
     for finding about this inexcusable mistake.

lighttpd (1.4.19-3) unstable; urgency=medium

   * Fix /var/cache/lighttpd/uploads permissions in postinst (Closes: 476870).
   * Update patches/ssl-connection-errors.patch using upstream r2144, thanks to
     upstream for noticing.
   * cherokee and lighttpd both provide spawn-fcgi, fix that using alternatives
     (Closes: 479501):
     + add spawn-fcgi.lighttpd.1 shamelessly stolen from cherokee packaging
       (thanks Gunnar).
     + install spawn-fcgi as spawn-fcgi.lighttpd.
     + install master alternatives on spawn-fcgi.lighttpd and
       spawn-fcgi.lighttd.1.
     + add Conflict against cherokee <= 0.6.1-1.
   * Quote "dangerous" bits of conf-available/10-cgi.conf (Closes: 479276).

lighttpd (1.4.19-2) unstable; urgency=low

   * Add patches/ssl-connection-errors.patch for CVE-2008-1531
     (Closes: 475438).
   * Test for /var/cache/lighttpd/compress in lighttpd.cron.daily to avoid
     spurious errors for uninstalled and not purged lighttpd's
     (Closes: 472175).
 
   * Add handling of /var/cache/lighttpd/uploads (Closes: 408521):
      + add it in lighttpd.dirs.
      + add it as a server.upload-dirs in lighttpd.conf.
      + purge it daily in lighttpd.cron.daily.
 
   * Fix typo in lighttpd.preinst causing failure to update 05-auth symlink
     properly (Closes: 472119).
 
   * init.d: stopping an already stopped lighttpd, or starting an already
     running one should not fail (Closes: 472122).
 
   * Use $HTTP["remoteip"] =~ "127.0.0.1" in configuration snipplets so that it
     works when ipv6 is enabled by default too (Closes: 473510).
 
   * Use perl to detect if the host has ipv6, and generate the server.use-ipv6
     snipplet on the fly instead of forcing it to true (Closes: 473053).

lighttpd (1.4.19-1~bpo40+1) etch-backports; urgency=low

   * Rebuild for etch-backports.

lighttpd (1.4.19-1) unstable; urgency=low

   * New upstream release.
 
   * debian/control:
      + add Build-Depends upon quilt, remove dpatch.
      + Bump Standards-Version to 3.7.3 (no changes required).
      + Move Homepage pseudo-headers as real headers.
 
   * debian/patches:
      + migrate to quilt.
      + remove 05_fdevent_fix.patch (merged upstream).
      + remove 06_mod_cgi_vuln_fix.patch (merged upstream).
      + refresh the rest of the series.
 
   * debian/lighty-enable-mod:
      + Reindent and remove trailing spaces.
      + don't fail to remove a module that is already removed.
        Patch from Michal Čihař (Closes: 448682).
      + Allow full stops in module names (Closes: 462199).
 
   * debian/lighttpd.conf:
      + enable ipv6 by default (Closes: 448054).
      + remove mod_status stanza, create conf-available/10-status.conf with it.
 
   * debian/lighttpd.cron.daily: new file, cleanup compressed cache.
     Thanks to Michal Čihař (Closes: 445224).
 
   * be sure mod_auth is loaded first (Closes: 419176):
      + add debian/lighttpd.preinst to rename 10-auth.conf into 05-auth.conf
        automagically (when it's a sane thing to do).
      + Document all that in NEWS.Debian.
      + debian/lighttpd.install: add 10-status.conf and 05-auth.conf.
 
   * debian/lighttpd.postinst:
      + chmod'ing /var/cache/lighttpd recursively is useless and too long. Just
        chmod the base directory, content is likely to be only created by
        lighty anyways. (Closes: 468297).
 
   * debian/init.d:
      + Add $remote_fs and $network (instead of networking) to
        Required-{Start,Stop}.
      + Add fam to Should-{Start,Stop} (Closes: 461180).
 
   * debian/lighttpd.links: add symlinks on lighty-* so that lighttpd-*
     commands exists as well (Closes: 435131).

lighttpd (1.4.19-0ubuntu3) hardy; urgency=low

   * SECURITY UPDATE: (LP: #209627)
    + debian/patches/92_CVE-2008-1531.dpatch
     - lighttpd 1.4.19 and earlier allows remote attackers to cause a denial
       of service (active SSL connection loss) by triggering an SSL error,
       such as disconnecting before a download has finished, which causes
       all active SSL connections to be lost.
   * References
    + CVE-2008-1531">http://nvd.nist.gov/nvd.cfm?cvename=CVE-2008-1531
    + http://trac.lighttpd.net/trac/changeset/2136
    + http://trac.lighttpd.net/trac/changeset/2139

lighttpd (1.4.19-0ubuntu2) hardy; urgency=low

   * debian/rules: (LP: #174289)
     - set DEB_UPDATE_RCD_PARAMS to "defaults 91 09" to not start lighty before
       apache2 but in the same runlevel with the same priority

lighttpd (1.4.19-0ubuntu1) hardy; urgency=low

   * New upstream release (LP: #201439)
     For Changes please read the NEWS file
     All security patches we have in 1.4.18 of hardy are included now upstream
   * debian/patches/*: All changes introduced by this patches are now applied
     upstream
     - Dropped 90_CVE-2008-1111.dpatch
     - Dropped 91_CVE-2008-1270.dpatch
     - Dropped 90_maxfds_crash_fix.dpatch
     - Dropped 03_ldap_leak_bugfix.dpatch
     - Dropped 04_ldap_build_filter_fix.dpatch
     - Dropped 90_accept_ranges_fix.dpatch
   * debian/lighttpd.conf: (From Debian)
     -  Move the aliases on /doc/ and /images/ mandated by policy at the end to
        circumvent #445459.
   * debian/rules: (From Debian)
     - Remove spurious mkdir in debian/rules (Closes: dbts 448160).
   * debian/conf-available/10-rrdtool: (From Debian)
     - Add sample configuration for the mod_rrdtool (Closes: dbts 462907).
   * debian/lighttpd.install:
     - Install 10-rrdtool
   * debian/patches/ldap-deprecated.dpatch:
     - Force use of deprecated ldap interfaces (Closes: dbts 463368),
       thanks to Dann Frazier (patches/ldap-deprecated.dpatch).
   * Bumped Standards Version to 3.7.3, Bumbed Compat to 6, adjusted build-dep
     of debhelper accordingly

lighttpd (1.4.18-4) unstable; urgency=high

   * The “I HATE DPATCH”-release.
   * Add patches for real as dpatch-edit-patch is stupid enough for not doing
     it by itself (Closes: 463368, 469307).

lighttpd (1.4.18-3) unstable; urgency=high

   * Force use of deprecated ldap interfaces (Closes: 463368),
     thanks to Dann Frazier (patches/ldap-deprecated.dpatch).
   * Add sample configuration for the mod_rrdtool (Closes: 462907).
   * add patches/06_mod_cgi_vuln_fix.dpatch to fix CVE-2008-1111
     (Closes: 469307).
   * Remove spurious mkdir in debian/rules (Closes: 448160).
   * Bump urgency for RC bug fixes.

lighttpd (1.4.18-2) unstable; urgency=high

   * Move the aliases on /doc/ and /images/ mandated by policy at the end to
     circumvent #445459.
   * Add patches/05_fdevent_fix.dpatch to fix possible remote DoS
     (Closes: 466663).
   * bump urgency for security fix.

lighttpd (1.4.18-1ubuntu6) hardy; urgency=low

   * SECURITY UPDATE: (LP: #200987)
    + debian/patches/91_CVE-2008-1270.dpatch
     - mod_userdir in lighttpd 1.4.18 and earlier, when userdir.path is not set,
       uses a default of $HOME, which might allow remote attackers to read arbitrary
       files, as demonstrated by accessing the ~nobody directory.
   * References
    + CVE-2008-1270
    + http://trac.lighttpd.net/trac/ticket/1587
    + http://trac.lighttpd.net/trac/changeset/2120

lighttpd (1.4.18-1ubuntu5) hardy; urgency=low

   * debian/patches/90-CVE-2008-1111.dpatch:
     - Fixes CVE-2008-1111
       "mod_cgi in lighttpd 1.4.18, when a fork failure occurs, sends the source
       code of CGI scripts instead of a 500 error, which might allow remote attackers
       to obtain sensitive information."
       Upstream Patch: http://trac.lighttpd.net/trac/changeset/2107

lighttpd (1.4.18-1ubuntu4) hardy; urgency=low

   * debian/patches/90_accept_ranges_fix.dpatch:
     - Fixes a problem serving PDF files or other files who are in need of no
       Accept-Ranges header (http://trac.lighttpd.net/trac/ticket/541)
       (Patch: http://trac.lighttpd.net/trac/changeset/2090)
   * debian/index.html:
     - replaced all occurances of debian with ubuntu (LP: #115565)

lighttpd (1.4.18-1ubuntu3) hardy; urgency=low

   * debian/patches/90_maxfds_crash_fix.dpatch:
     - added patch from upstream to fix the maxfds issue
     - See: http://trac.lighttpd.net/trac/ticket/1562

lighttpd (1.4.18-1ubuntu2) hardy; urgency=low

   * Rebuild against libldap2.4-2

2007

lighttpd (1.4.18-1ubuntu1) gutsy; urgency=low

   * Merge from Debian unstable, remaining changes:
     - Update maintainer field in debian/control.
     - Build against libgamin-dev rather than libfam-dev (fixes a warning
       during startup)
     - Make sure that upgrades succeed, even if we can't restart lighttpd.
     - Clean environment in init.d script.

lighttpd (1.4.18-1) unstable; urgency=low

   * New upstream release, fixes CVE-2007-4727 (closes: #441787)
   * lighttpd-angel is installed but not used yet

lighttpd (1.4.17-1ubuntu1) gutsy; urgency=low

   * Merge from Debian unstable, remaining changes:
     - Update maintainer field in debian/control.
     - Build against libgamin-dev rather than libfam-dev (fixes a warning
       during startup)
     - Make sure that upgrades succeed, even if we can't restart lighttpd.
     - Clean environment in init.d script.

lighttpd (1.4.17-1) unstable; urgency=low

   * New upstream release
   * patches/05_mysql_autoreconnect.dpatch - dropped, fixed in upstream

lighttpd (1.4.16-5~bpo40+2) etch-backports; urgency=low

   * Rebuild in an etch chroot doh.

lighttpd (1.4.16-5~bpo40+1) etch-backports; urgency=low

   * Rebuild for Etch backports.

lighttpd (1.4.16-5) unstable; urgency=low

   * debian/control: Drop conflict with gamin as it appears it was not the
     issue. (Closes: #438058). For real this time.

lighttpd (1.4.16-4) unstable; urgency=low

   * debian/control: Drop conflict with gamin as it appears it was not the
     issue. (Closes: #438058).
   * src/mod_mysql_vhost.c: Enable mysql auto-connect mode, as it's not default
     in mysql 5.x anymore. (Closes: #428677).

lighttpd (1.4.16-3) unstable; urgency=high

   * Urgency set to high due to RC bug fix.
   * debian/lighttpd.logrotate: fix stupid typo (closes: #437341).
   * debian/control: add Conflict against gamin, to avoid #437307.

lighttpd (1.4.16-2) unstable; urgency=low

   * patches/04_ldap_build_filter_fix.dpatch: add patch from Peter Colberg to
     fix first LDAP search that fails because of the filter being
     uninitialized. (closes: #419661)
   * Enable fam support (closes: #407820):
      + debian/rules: add --enable-fam configure flag.
      + debian/control: add libfam-dev to Build-Depends, and also wrap
        build-dependencies to make diff more understandable.
   * Enable support for kerberos (with openssl):
      + debian/rules; add --enable-kerberos5 configure flag.
      + debian/control: add libkrb5-dev to the Build-Depends.
   * lighttpd.logrotate: redirect stderr to /dev/null as well to prevent
     defunct processes (presumably due to full unread pipes/buffers)
     (closes: #419992).
   * debian/control: replace lighttpd dependency on perl with
     libterm-readline-perl-perl as Readline.pm is needed for lighty-enable-mod
     (closes: #435077).
   * debian/control:
      + Add myself to uploaders (closes: #401575).
      + Drop Recommands on php5-cgi, there is absolutely no reason to have it,
        or we would have to recommend ruby, python, lua, perl, .... and every
        $language on earth to be fair.  (closes: #435587).
   * debian/conf-available/10-webdav.conf: add default configuration for webdav.
     (closes: #406641).
   * debian/conf-enabled: remove directory, it is already installed through
     lighttpd.dirs.
   * lighttpd.postinst, lighttpd.postrm, init.d: be sure there is a
     /var/run/lighttpd owned by www-data:www-data, helpful to store locks and
     things like that.

lighttpd (1.4.16-2ubuntu2) gutsy; urgency=low

   * Build against libgamin-dev rather than libfam-dev (fixes a warning during
     startup about mismatched sizes of a data type).

lighttpd (1.4.16-1ubuntu1) gutsy; urgency=low

   * Merge from Debian unstable, remaining changes:
     - Add fam/gamin stat cache engine support.
     - Replace Depends: on perl with Depends: on libterm-readline-perl-perl.
     - Make sure that upgrades succeed, even if we can't restart lighttpd.
     - Clean environment in init.d script.
     - Update maintainer field in debian/control.

lighttpd (1.4.16-1) unstable; urgency=low

   * New upstream release (closes: #434546)
   * Acknowledge NMU by Pierre Habouzit for CVE-2007-2841 (closes: #428368)
   * Added static-file.exclude-extensions section to lighttpd.conf (closes: #408374)
   * Fixed description of conf-available/10-fastcgi.conf (closes: #430469)
   * Added mod_extforward to debian/lighttpd.install (closes: #434717)
   * config.guess taken from upstream (closes: #419664)
   * turn on compression (closes: #397514)
   * debian/control: XS-Vcs-Svn header added

lighttpd (1.4.15-1.1ubuntu1) gutsy; urgency=low

   * Merge from Debian unstable, remaining changes:
     - Add fam/gamin stat cache engine support.
     - Replace Depends: on perl with Depends: on libterm-readline-perl-perl.
     - Make sure that upgrades succeed, even if we can't restart lighttpd.
     - Clean environment in init.d script.
     - Update maintainer field in debian/control.

lighttpd (1.4.15-1.1) unstable; urgency=low

   * Non-maintainer upload.
   * add patches/04_wrapping_headers_bugfix.dpatch to fix crash with wrapping
     headers (Closes: 428368).

lighttpd (1.4.15-1ubuntu1) gutsy; urgency=low

   * Merge from Debian unstable. Remaining Ubuntu changes:
     - Add fam/gamin stat cache engine support
     - Clean environment in init.d script
     - Replace Depends: on perl with Depends: on libterm-readline-perl-perl
     - Make sure that upgrades succeed, even if we can't restart lighttpd
     - DebianMaintainerField update

lighttpd (1.4.15-1) unstable; urgency=low

   * New upstream release (closes: #419131)
   * 01_mod_fastcgi_missing_cleanup.dpatch is now in upstream so it's removed from
     patches
   *  04_pidfile_bugfix.dpatch is now in upstream so it's removed from patches

lighttpd (1.4.13-10) unstable; urgency=medium

   * 03_ldap_leak_bugfix.dpatch added from yann@pleiades.fr.eu.org (Yann Rouillard)
     (closes: #413917)
   * Lowered priority of index.lighttpd.html (closes: #397492)
   * We don't need now check md5 sum of index.html since we provide our own
     index.lighttpd.html (closes: #407794)
   * 04_pidfile_bugfix.dpatch by Chris Webb <chris@arachsys.com> added - some fixes
     with graceful restart

lighttpd (1.4.13-9ubuntu4) feisty; urgency=low

   * Added LDAP connection leak fix from Debian (Bug: #413917)
     - debian/patches/03_ldap_leak_bugfix.dpatch
   * Added security fixes from 1.4.14 (Closes LP: #106416)
     - Remote DOS in CRLF parsing (CVE-2007-1869)
        debian/patches/04_security_crlf_parsing_dos.dpatch
     - DOS with files with mtime 0 (CVE-2007-1870)
        debian/patches/05_security_zero_mtime_crash.dpatch

lighttpd (1.4.13-9ubuntu3) feisty; urgency=low

   * Make sure that upgrades succeed, even if we can't restart lighttpd
     (LP: #86882)

lighttpd (1.4.13-9ubuntu2) feisty; urgency=low

   * Add fam/gamin stat cache engine support (Closes: LP#80818)

lighttpd (1.4.13-9ubuntu1) feisty; urgency=low

   * Merge from Debian unstable. Remaining Ubuntu changes:
      - Clean environment in init.d script
      - Replace Depends: on perl with Depends: on libterm-readline-perl-perl

lighttpd (1.4.13-9) unstable; urgency=low

   * debian/lighttpd.default - removed, it is not ready yet. We'll back after
     etch release (closes: #406021)
   * debian/index.html.md5 - fixed path to file (full path to index.html)

lighttpd (1.4.13-8) unstable; urgency=medium

   * Typo fixed in debian/lighttpd.postinst (closes: #405123)

2006

lighttpd (1.4.13-7ubuntu1) feisty; urgency=low

   * Merge from debian unstable, remaining changes:
     - Clean environment in init.d script
     - Replace Depends: on perl with Depends: on libterm-readline-perl-perl

lighttpd (1.4.13-7) unstable; urgency=low

   [ Franz Pletz ]
   * debian/conf-available/10-cgi.conf:
     + match /cgi-bin/ only at the beginning of a path
     + convert match for host == localhost to remoteip == 127.0.0.1 like in
       lighttpd.conf; due to bugs in mod_alias, the cgi-bin, doc and images
       aliases didn't work anymore
   * debian/lighttpd.logrotate
     + use reload instead of force-reload for graceful restart
       (closes: #398169, #380080)
   * added debian/patches/01_mod_fastcgi_missing_cleanup.dpatch
     + source: http://trac.lighttpd.net/trac/ticket/910
     + fixes memleak in mod_fastcgi (closes: #400167)
   * added debian/patches/02_fastcgi_detach.dpatch
     + disconnect stderr/stdout from the terminal (closes: #368670)
     + point them either to errorlog or /dev/null
   * debian/control: added myself to Uploaders
   * Don't touch /var/www/index.html, create /var/www/index.lighttpd.html
     instead (closes: #397492)
     + debian/lighttpd.postinst: copy to /var/www/index.lighttpd.html
     + debian/lighttpd.conf: add index.lighttpd.html as first index-filename
 
   [ Krzysztof Krzyzaniak (eloy) ]
   * Typo fixed in index.html (closes: #403620)

lighttpd (1.4.13-6ubuntu3) feisty; urgency=low

   * Fix typo in init-script

lighttpd (1.4.13-6ubuntu2) feisty; urgency=low

   * Clean the environment before starting. Fixes: LP#53840

lighttpd (1.4.13-6ubuntu1) feisty; urgency=low

   * Merge from debian unstable, remaining changes:
     - Replace Depends: on perl with Depends: on libterm-readline-perl-perl

lighttpd (1.4.13-6) unstable; urgency=low

   * debian/lighttpd.postinst: change only permission for /var/log/lighttpd/

lighttpd (1.4.13-5) unstable; urgency=low

   * debian/control:
    + perl added to dependencies (closes: #396629)
   * debian/conf-available/10-fastcgi.conf:
    + /usr/bin/php4-cgi changed to /usr/bin/php-cgi (closes: #397142)
   * debian/lighttpd.postinst: fix permission of /var/log/lighttpd
     (closes: #398834)
   * debian/lighty-enable-mod - fixed bug with undefined values (closes: #397493)

lighttpd (1.4.13-4) unstable; urgency=low

   * fixed config file for logrotote (reload action changed to force-reload)

lighttpd (1.4.13-3) unstable; urgency=low

   * debian/control: libxml2-dev added to Build-Depends (closes: #394882)

lighttpd (1.4.13-2) unstable; urgency=medium

   * Patch from Pierre Habouzit <madcoder@debian.org> to init.d applied
     (closes: #380080)
   * Patch from Adrian Friendli <adi@koalatux.ch> to lighttpd.conf applied
     (closes: #392890)

lighttpd (1.4.13-1) unstable; urgency=low

   * New upstream release
   * mod_webdav as separate lighttpd-mod-webdav package
   * Compiled with --with-webdav-locks, added uuid-dev to Build-Depends

lighttpd (1.4.13~r1385-1) unstable; urgency=low

   * New upstream release

lighttpd (1.4.13~r1370-1ubuntu1) edgy; urgency=low

   * Merge from Debian unstable (Closes: Malone #64900). Remaining changes:
     - Add an additional dependency on libterm-readline-perl-perl
       (Malone #43895)

lighttpd (1.4.13~r1370-1) unstable; urgency=low

   * New upstream release (closes: #390877) (closes: #389911)
   * Compiled with --with-attr param (closes: #389712)
   * dropped 01-lua5.1.dpatch, issue fixed by upstream

lighttpd (1.4.12-1) unstable; urgency=low

   * New upstream release
   * fixes in debian/lighttpd.install (closes: #377802)
   * mod_cml is deprecated from now on and it will be removed in 1.5.0
     mod_magnet provides the same functionality and more with a
     cleaner syntax and in a more generic form
   * added separate module for mod_magnet (closes: #389578)
   * changed dependency from lua-5.0 to lua-5.1
   * added patch patches/01-lua5.1.dpatch
   * added pkg-config to Build-Depends

lighttpd (1.4.12~20060907-1ubuntu1) edgy; urgency=low

   * Merge from debian unstable:
     -> Keep the additional dependency on libterm-readline-perl-perl.

lighttpd (1.4.12~20060907-1) unstable; urgency=low

   * New upstream release
   * Removed debian/patches/01_use_bin_sh.dpatch - fixed in upstream

lighttpd (1.4.12~20060901-1) unstable; urgency=low

   * New upstream release
   * Removed debian/patches/02_ssl_fix.dpatch - it's now fixed in upstream

lighttpd (1.4.11-8) UNRELEASED; urgency=low

   * debian/lighttpd.dirs:
    + usr/lib/cgi-bin added
   * debian/conf-available/10-cgi.conf
    + proper configuration for localhost as well (again Bug#345554)
   * debian/lighttpd.conf:
    + server.bind commented out as in default configuration (closes: #380267)
   * debian/patches/02_ssl_fix.dpatch - added fix for ssl connection with POST
     request (http://trac.lighttpd.net/trac/ticket/607), thanks to
     RISKO Gergely <risko@debian.org> (closes: #381455)
   * debian/lighttpd.logrotate - some values changes (now rotate weekly
     and keep 12 logfiles)

lighttpd (1.4.11-7ubuntu1) edgy; urgency=low

   * Merge from debian unstable:
     -> Restore B-D on libmemcache-dev.
     -> Keep the additional dependency on libterm-readline-perl-perl.
   * debian/patches:
     -> Add 02_mod_ssl_post_fix.dpatch: fix a stall with POST requests between
        8317 and 16381 bytes long when mod_ssl is enabled.

lighttpd (1.4.11-7) unstable; urgency=low

   * debian/create-mime.assign.pl - catchup error when /etc/mime.types is not
     readable (closes: #375347)

lighttpd (1.4.11-6) unstable; urgency=low

   * debian/control:
    - Recommends: Changed to alternative: php4-cgi | php5-cgi (closes: #368215)
   * include-conf-enabled.pl script changed according to patch from
     Tobias Gruetzmacher <tobias@portfolio16.de> (closes: #368352)
   * debian/lighttpd.conf: removed global for local aliases (/images/, /doc/)
     (closes: #366801)

lighttpd (1.4.11-5) unstable; urgency=low

   * debian/init.d:
    - --oknodo added to section "stop" to close finally #35979
    - --retry 30 added to section "reload", to prevents problems with
      logrotating (closes: #366366)
   * debian/control:
    Standards-Version: increased to 3.7.2 without additional changes

lighttpd (1.4.11-4) unstable; urgency=low

   [ Krzysztof Krzyzaniak (eloy) ]
   * debian/init.d:
    - "exit 1" after failed actions removed (closes: #359792)
   * debian/conf-available/10-fastcgi.conf updated (closes: #362827)
     thanks to Joerg Rieger <a.mailinglists#lumrix.net>
 
   [ Torsten Marek ]
   * Change my email address to shlomme@debian.org
   * Remove --background from the start action, since it
     breaks the error checking of start-stop-daemon.
     The behaviour described in #355865 is not reproducable
     any more.
   * make reload action in initscript more well-behaved

lighttpd (1.4.11-3ubuntu3) dapper; urgency=low

   * debian/control
     + Added depends on libterm-readline-perl-perl. (Closes: Malone #43895)

lighttpd (1.4.11-3ubuntu2) dapper; urgency=low

   * Rebuild against the new libmysqlclient15off with correct symbols.

lighttpd (1.4.11-3ubuntu1) dapper; urgency=low

   * Sync with Debian:
     + Removed B-D on libmemcache-dev as we don't have it in dapper, needs to be
       re-enabled for dapper+1

lighttpd (1.4.11-3) unstable; urgency=low

   * debian/lighttpd.conf - added dir-listing.encoding = "utf-8", suggested
     by Silvestre Zabala <silvestre(at)zabala.name> (closes: #359100)
   * debian/lighttpd.install - fix bug with installing *.conf files

lighttpd (1.4.11-2) unstable; urgency=low

   * Provide debian/conf-available/10-ssl.conf, (closes: #355868)

lighttpd (1.4.11-1) unstable; urgency=low

   * New upstream release (closes: #356496)
   * init.d script - added --background to "start" (thanks goes to
      Marcello Nuccio <marcenuc@cicaia160.unimo.it>) (closes: #355865)

lighttpd (1.4.10-6) unstable; urgency=low

   * Patch from <tobias@portfolio16.de> on lighty-enable-mod
     (closes: #355773)

lighttpd (1.4.10-5) unstable; urgency=low

   [ Krzysztof Krzyzaniak (eloy) ]
   * debian/control - libmysqlclient14-dev have to be removede because is not
     available in debian/sid
 
   [ Torsten Marek ]
   * debian/rules - build with support for LUA, libmemcache and GDBM
   * debian/lighttpd.install - install mod_evasive into lighttpd package
   * debian/control - own packages for  mod_trigger_b4_dl and mod_cml
   * debian/control - small fixes
   * debian/conf-available/10-ssi.conf - comment out link to web documentation

lighttpd (1.4.10-4) unstable; urgency=low

   * bugfix release
   * Fixed bug with 10-fastcgi.conf, (closes: #353964)

lighttpd (1.4.10-3) unstable; urgency=low

   * lighttpd.conf - changed configuration for /images/ & /doc/ handling

lighttpd (1.4.10-2) unstable; urgency=low

   * debian/control - libmysqlclient14-dev added as alternative (will be easier for
     backports.org)
   * lighty-enable-mod script fixed - files with dash were skipped, thanks
     to Silvester Zabala for patch (closes: #352577)
   * install doc/lighttpd.conf as example (closes: #344961)

lighttpd (1.4.10-1) unstable; urgency=low

   * New upstream release

lighttpd (1.4.9-5) unstable; urgency=low

   * Properly fixed bug with overwritting index.html (closes: #349676)

lighttpd (1.4.9-4) unstable; urgency=low

   [ Krzysztof Krzyzaniak (eloy) ]
   * Fixed bug with 10-userdir.conf, (closes: #349821)
   * index.html is not replaced when md5 string desn't match (closes: #349676)

lighttpd (1.4.9-3) unstable; urgency=low

   [ Torsten Marek ]
   * Added some configuration examples from upstream sample
     configuration
   * Implement "reload" init.d action with graceful restart,
     taken from http://trac.lighttpd.net/trac/ticket/267 (Closes: #346038)
   * ssi, auth, fastcgi, proxy and simple-vhost are now in separte
     config files
   * Put path to plugin documentation into every config snippet
   * Build against libmysqlclient15

lighttpd (1.4.9-2) unstable; urgency=low

   [ Krzysztof Krzyzaniak (eloy) ]
   * mod_alias enabled by default - removed conf-avaiable/00-alias.conf
   * Added handling of http://localhost/doc/ & http://localhost/images/
     (closes: #348823)

lighttpd (1.4.9-1) unstable; urgency=low

   * New upstream release
   * Closing bug from not uploaded release 1.4.8-5, (closes: #347737)

lighttpd (1.4.8-5) unstable; urgency=low

   * create /var/www directory (closes: #347737), default /var/www/index.html
     added (based on apache2 index.html file).

lighttpd (1.4.8-4) unstable; urgency=low

   * fixed permissions and directories (closes: #347565)

lighttpd (1.4.8-3) unstable; urgency=low

   * New configuration layout (closes: #345554) (closes: #344959),
     read /etc/lighttpd/conf-available/README
     - conf-available directory for all templates
     - conf-enabled directory for enabled modules

2005

lighttpd (1.4.8-2) unstable; urgency=low

   [ Krzysztof Krzyzaniak (eloy) ]
   * debian/control: lsb-base dependency narrowed to (>= 3.0-3)
   * create-mime.assign.pl set as executable (closes: #344938)

lighttpd (1.4.8-1) unstable; urgency=low

   * New upstream version (closes: #304271)
   * Does not rely on $SHELL to execute external commands

lighttpd (1.4.7-1) unstable; urgency=low

   * New upstream version, Initial debian version
   * Better debian/rules file
   * Split mysql vhost module into separate package
   * Create separate package for documentation
   * Create a better init script