Skip to content

Changelog keybinder (0.3.1-2ubuntu1)

2020

keybinder (0.3.1-2ubuntu1) focal; urgency=medium

   * Remove empty Object Hierarchy section from documentation index to fix
     build with gtk-doc 1.32.

2019

keybinder (0.3.1-2) unstable; urgency=medium

   [ Ondřej Nový ]
   * d/control: Remove ancient X-Python-Version field
   * d/copyright: Use https protocol in Format field
   * d/control: Remove trailing whitespaces
   * d/control: Set Vcs-* to salsa.debian.org
 
   [ Jeremy Bicha ]
   * Drop unused python-keybinder package (Closes: #885377, #936786)
   * Build-Depend on debhelper-compat 12 and drop debian/compat
   * Build-Depend on dh-sequence-gir

2015

keybinder (0.3.1-1) unstable; urgency=medium

   * New upstream release.
    - Fix memory leak Closes: #804148).
      Thanks to Dmitry Eremin-Solenikov!
   * Bump Standards-Version to 3.9.6, no changes.

2014

keybinder (0.3.0-3) unstable; urgency=medium

   * Adopt package (Closes: #741021).
   * Bump Standards-Version to 3.9.5 , no changes needed.
   * Update homepage.
   * Update watch file.

2013

keybinder (0.3.0-2) unstable; urgency=low

   * Upload to unstable.
   * debian/patches/python-multiarch-header-path.patch:
     - Define python multiarch header include paths (Closes: #697825).
   * debian/control:
     - Add libgtk2.0-dev to libkeybinder-dev Depends field, thanks to
       Alessandro Ghedini for the bug report (Closes: #687457).
     - Bump Standards-Version to 3.9.4.
     - Move VCS repository under collab-maint.

2012

keybinder (0.3.0-1) experimental; urgency=low

   * New upstream release.
   * Add introspection support.
   * debian/patches/ACLOCAL_AMFLAGS.patch:
     - Removed, applied upstream.
   * debian/patches/Xkb.patch:
     - Refresh for new upstream release.
   * debian/control:
     - Build-depend on gtk-doc-tools (>= 1.14).
     - Provide keybinder-doc documentation package.
   * debian/libkeybinder0.symbols.amd64:
     - Refresh to pick new symbols.
   * debian/rules:
     - Allow to build source twice in a row.
     - Build with --enable-gtk-doc option.
     - Bump dh_makeshlibs version to >= 0.3.0 for the new symbols.

keybinder (0.2.2-4) unstable; urgency=low

   * debian/patches/Xkb.patch:
     - Fix crash with Xkb extension (Closes: #593371).
   * debian/compat:
     - Bump compatibility level to 9.
   * debian/control:
     - Bump Standards-Version to 3.9.3.
   * debian/copyright:
     - Format now points to copyright-format site.
   * debian/libkeybinder0.symbols.amd64:
     - Refresh to pick new symbols.
   * debian/rules:
     - Bump dh_makeshlibs version to >= 0.2.2 for the new symbols.

2011

keybinder (0.2.2-3) unstable; urgency=low

   * Switch to dh_python2.
   * Use autoreconf sequencer.
   * debian/patches/ACLOCAL_AMFLAGS.patch:
     - Define ACLOCAL_AMFLAGS, set to -I m4.
   * debian/control:
     - Bump Standards-Version to 3.9.2, no changes required.
   * debian/copyright:
     - Update copyright information.
   * debian/rules:
     - Do not install .la files.

2010

keybinder (0.2.2-2) unstable; urgency=low

   * debian/control:
     - Adjust Homepage field to new URL.
     - Bump Standards.Version to 3.9.0, no changes required.
   * debian/libkeybinder-dev.install:
     - Install keybinder.pc file (Closes: #585077).

keybinder (0.2.2-1) unstable; urgency=low

   * New upstream release.
   * debian/control:
     - Fix Vcs fields to point to new repository.
   * debian/rules:
     - Compile with --as-needed flag enabled.

keybinder (0.2.1-1) unstable; urgency=low

   * New upstream release.
   * Package is no longer maintainer under DPMT.
   * New binary packages:
     - libkeybinder0, shared library
     - libkeybinder-dev, development headers
   * Update copyright information

keybinder (0.1.1-1) unstable; urgency=low

   * New upstream release.
     - Fix incorrect Super modifier binding (Closes: #578651).

keybinder (0.1.0-1) unstable; urgency=low

   * New upstream release.
   * Switch to format 3.0 (quilt).
   * debian/control:
     - Build-depend on libgtk2.0-dev (>= 2.20).
   * debian/copyright:
     - Refresh copyright information.

keybinder (0.0.4-2) unstable; urgency=low

   * debian/control:
     - Add autoconf, automake and libtool to Build-Depends.
     - Add autoconf2.13 and automake1.4 to Build-Conflicts.
     - Bump Standards-Version to 3.8.4, no changes required.
   * debian/rules:
     - Run "autoreconf -fi -I m4" for every Python build instance to get
       proper libtool fixes (Closes: #558567).

2009

keybinder (0.0.4-1) unstable; urgency=low

   * New upstream release.
   * Remove gnome-doc-utils and python-gnomeapplet from Build-Depends.
   * Update my e-mail address.
   * Bump Standards-Version to 3.8.3, no changes required.

keybinder (0.0.3-1) unstable; urgency=low

   * Initial release (Closes: #535619).