Skip to content

Changelog jansson (2.12-1build1)

2019

jansson (2.12-1build1) disco; urgency=medium

   * No change rebuild to see if fPIC is picked up

2018

jansson (2.12-1) unstable; urgency=medium

   * New upstream release
   * Bump Standards-Version to 4.2.1 (no change needed)
   * Mark libjansson-doc Multi-Arch: foreign

jansson (2.11-1) unstable; urgency=medium

   * New upstream release
   * Fix useless-autoreconf-build-depends dh-autoreconf
   * Switch to Python3 version of Sphinx
   * Update symbols file
   * Use SOURCE_DATE_EPOCH instead of dpkg-parsechangelog output
   * Update doc-base paths

2017

jansson (2.10-1) unstable; urgency=medium

   * New upstream release
   * Update Standards-Version to 4.0.0 (no changes needed)
   * Update symbols file

2016

jansson (2.9-1) unstable; urgency=medium

   * New upstream release
   * Drop 01_CVE-2016-4425.patch (merged upstream)
   * Update symbols file

jansson (2.7-5) unstable; urgency=high

   * Bump Standards-Version to 3.9.8 (no changes needed)
   * Fix stack exhaustion when parsing JSON as per CVE-2016-4425
     (Closes: #823238)

jansson (2.7-4) unstable; urgency=medium

   * Make build reproducible (Closes: #789748)
     Thanks to Juan Picca for the patch
   * Drop -dbg package
   * Update Vcs links
   * Improve cross Build-Depends satisfiability (Closes: #807848)
     Thanks to Helmut Grohne for the patch

2015

jansson (2.7-3) unstable; urgency=medium

   * Always build the documentation (Closes: #789675)

jansson (2.7-2) unstable; urgency=medium

   * Use dh_sphinxdoc before installing documentation (Closes: #769327)
   * Bump Standards-Version to 3.9.6 (no changes needed)

2014

jansson (2.7-1) unstable; urgency=medium

   * New upstream release
     - Support ``\u0000`` escapes in the decoder (Closes: #739207)
   * Update symbols file
   * Update upstream copyright

jansson (2.6-1) unstable; urgency=high

   * New upstream release
     - Fix hash function so that it is not susceptible to predictable hash
       collisions as per CVE-2013-6401 (Closes: #738647)
     - Set urgency=high accordingly
   * Update symbols file

2013

jansson (2.5-2) unstable; urgency=medium

   * Fix vcs-field-not-canonical
   * Bump Standards-Version to 3.9.5 (no changes needed)
   * Use dh-autoreconf instead of autotools-dev to fix FTBFS on ppc64el.
     Thanks to Logan Rosen for the patch (Closes: #732822)

jansson (2.5-1) unstable; urgency=low

   * New upstream release
   * Bump Standards-Version to 3.9.4
   * Update upstream copyright years

2012

jansson (2.4-1) unstable; urgency=low

   * New upstream release
     - Fix FTBFS on ppc64. Thanks to Aurelien Jarno (Closes: #684468)
   * Update *.symbols file

jansson (2.3.1-2) unstable; urgency=low

   * Make -dev package Multi-Arch: same too
   * Move python-sphinx to build-depends-indep

jansson (2.3.1-1) unstable; urgency=low

   * New upstream release
   * Update debian/copyright format as in Debian Policy 3.9.3
   * Bump Standards-Version to 3.9.3
   * Bump debhelper compat level to 9
   * Email change: Alessandro Ghedini -> ghedo@debian.org
   * Add Multi-Arch headers
   * Use multi-arch aware paths in *.install files
   * Update upstream copyright years

jansson (2.3-2) unstable; urgency=low

   * Do not use dh_sphinxdoc anymore (should fix the various FTBFS)

jansson (2.3-1) unstable; urgency=low

   * New upstream release
   * Use dh_sphinxdoc script
     - Build depends on python-sphinx (>= 1.0.7+dfsg)
     - Link to and depend on libjs-backbone in -doc package
   * Add libjansson-dbg debug package
   * Update *.symbols file

2011

jansson (2.2.1-1) unstable; urgency=low

   * New upstream release

jansson (2.2-1) unstable; urgency=low

   * New upstream release
   * Do not use upstream tarball from GitHub anymore,
     update watch file accordingly
   * Replace dh-autoreconf with autotools-dev
   * Bump debhelper compat level to 8
   * Update *.symbols file
   * Make -doc package Architecture: all
   * Do not bundle underscore.js library included by sphinx
   * Don't depend on libjansson4 from -doc package
     (fixes not-binnmuable-all-depends-any lintian error)
   * Move libjansson4 package up in debian/control
   * Remove dh_install override from debian/rules (not needed)

jansson (2.1-1) unstable; urgency=low

   * New upstream release
     - Fix set-but-not-used warning/error in a test (Closes: #625359)
   * Update libjansson4 *.symbols file
   * Bump Standards-Version to 3.9.2 (no changes needed)

jansson (2.0.1-1) unstable; urgency=low

   * Initial release (Closes: #561051)