Skip to content

Changelog gtk2-engines-xfce (3.2.0-3)

2018

gtk2-engines-xfce (3.2.0-3) unstable; urgency=medium

   * debian/patches:
     - 01_convert-source-utf8 added, convert source file to UTF-8 to fix FTBFS
     with glib 2.54.                                             closes: #870738
   * Run wrap-and-sort.
   * debian/control:
     - update standards version to 4.1.3.

2015

gtk2-engines-xfce (3.2.0-2) unstable; urgency=medium

   * Upload to unstable.

gtk2-engines-xfce (3.2.0-1) experimental; urgency=low

   [ Evgeni Golov ]
   * Correct Vcs-* URLs to point to anonscm.debian.org
 
   [ Jackson Doak ]
   * Bump standards version to 3.9.4
   * debian/rules: Use disable-silent-rules
 
   [ Mateusz Łukasik ]
   * New upstream release.
   * Bump standards version to 3.9.6
   * Enable build gtk3 themes.

2013

gtk2-engines-xfce (3.0.1-2) unstable; urgency=low

   * Upload to unstable.

2012

gtk2-engines-xfce (3.0.1-1) experimental; urgency=low

   * New upstream stable release:
     - fix graduent pattern leak at each draw.

gtk2-engines-xfce (3.0.0-1) experimental; urgency=low

   * New upstream stable release.

gtk2-engines-xfce (2.99.3-1) experimental; urgency=low

   [ Yves-Alexis Perez ]
   * New upstream development release.
   * debian/patches:
     - 01_link-against-libm dropped, included upstream.
 
   [ Lionel Le Folgoc ]
   * debian/control: drop build-deps on xfce4-dev-tools, autoconf, automake
     and libtool, not used anymore.
   * debian/rules: no need to run xdt-autogen, libm patch has been upstreamed.

gtk2-engines-xfce (2.99.2-1) experimental; urgency=low

   [ Lionel Le Folgoc ]
   * New upstream development release, introducing gtk+3.0 support.
   * Add a new gtk3-engines-xfce binary package for the new ported themes.
   * debian/rules:
     - run xdt-autogen since we patch configure.in/Makefile.am files
     - updated the path to clean up .la files.
     - pass --fail-missing to dh_install.
   * debian/patches:
     - 01_link-against-libm.patch: added, fix missing -lm for the gtk2 engine.
   * debian/control: add b-dep on libgtk-3-dev (>= 3.0.0), xfce4-dev-tools,
     autoconf, automake and libtool.
 
   [ Yves-Alexis Perez ]
   * debian/rules:
     - build with --parallel.
     - use debhelper 9 and dpkg-dev 1.16.1 hardening support.
   * debian/compat bumped to 9.
   * debian/control:
     - update debhelper build-dep to 9.
     - add build-dep on dpkg-dev 1.16.1.
     - drop hardening-includes build-dep.
     - update standards version to 3.9.3.
   * debian/*.install:
     - use multiarch paths.

2011

gtk2-engines-xfce (2.9.0-1) experimental; urgency=low

   * New upstream unstable release.
   * debian/copyright updated.
   * debian/copyright:
     - build-dep refreshed for new upstream release.

gtk2-engines-xfce (2.8.1-3) unstable; urgency=low

   * debian/control:
     - update long description, thanks to Martin Eberhard Schauer and
       Justin B Rye.                                             closes: #636779

gtk2-engines-xfce (2.8.1-2) unstable; urgency=low

   * Upload to unstable.
   * debian/control:
     - remove Emanuele and Simon from uploaders, add Lionel.
     - update standards version to 3.9.2.
     - update short description.

gtk2-engines-xfce (2.8.1-1) experimental; urgency=low

   * New upstream release.

gtk2-engines-xfce (2.8.0-1) experimental; urgency=low

   [ Stefan Ott ]
   * debian/watch edited to track Xfce archive reorganisation.
 
   [ Yves-Alexis Perez ]
   * New upstream release.
   * Switch to 3.0 (quilt) source format.
   * debian/rules:
     - switch to dh 7 tiny rules
     - pick {C,LD}FLAGS from dpkg-buildflags.
     - add hardening flags to {C,LD}FLAGS.
     - add -O1, -z,defs and --as-needed to LDFLAGS
   * debian/control:
     - add build-dep on hardening-includes.
     - update standards version to 3.9.1.
   * debian/copyright file updated for new release.

2009

gtk2-engines-xfce (2.6.0-2) unstable; urgency=low

   * Upload to unstable and mark fixed bugs as such:
     - xfce4-icon-theme dependency dropped.                      closes: #492007
   * debian/rules:
     - add -Wl,--as-needed to LDFLAGS.
     - replace dh_clean -k by dh_prep.
   * debian/compat: bump dh compatibility to 7.
   * debian/control:
     - bump build-dep on dh accordingly.
     - update standards version to 3.8.1.
     - move to section xfce.

gtk2-engines-xfce (2.6.0-1) experimental; urgency=low

   [ Xfce 4.6 Beta 1 “Fuzzy”]
   * new upstream beta release.
   * debian/control:
     - update standards version to 3.8.0.
     - remove Martin Loschwitz from uploaders.
   * debian/copyright:
     - update dates.
   * debian/rules:
     - stop messing with config.{guess,sub}.
   [ Xfce 4.6 Beta 2 “Hopper”]
   * new upstream beta release.
   * debian/control:
     - update depends on xfce4-icon-theme.
   [ Xfce 4.6 Beta 3 “Tuco-tuco”]
   * new upstream beta release.
   * debian/control:
     - remove dependency on xfce4-icon-theme. Rodent is not yet XDG
       compliant so there's no 4.5.92. We may have a situation when user
       doesn't have any icon theme installed.
 
   [ Xfce 4.6 RC1 “Capybara” ]
   * new upstream release candidate.
   * debian/copyright: update copyright dates.
 
   [ Xfce 4.6 ]
   * new upstream release.
   * debian/copyright:
     - precise that the license is GPL-2+.

2008

gtk2-engines-xfce (2.4.2-2) unstable; urgency=low

   * debian/copyright:
     - converted to UTF-8.
     - use © sign.
   * debian/rules: don't use Rodent stock icons.
   * debian/control:
     - update my email address.
   	- update standards version to 3.7.3.
   	- don't build-dep on a -1 revision to ease backports.

2007

gtk2-engines-xfce (2.4.2-1) unstable; urgency=low

   [ Mike Massonnet (mmassonnet) ]
   * Fix typo in the description of the package.
 
   [ Simon Huggins ]
   * debian/control: Move fake Homepage field to a real one now dpkg
     supports it.
 
   [ Yves-Alexis Perez ]
   * New upstrean release.
   * debian/rules: don't ignore all make errors at clean stage.
 
   [ Simon Huggins ]
   * Add Vcs-* headers to debian/control

gtk2-engines-xfce (2.4.1-1) unstable; urgency=low

   * New upstream release.
   * debian/copyright: updated copyright holders.

gtk2-engines-xfce (2.4.0-1) experimental; urgency=low

   * (Yves-Alexis Perez)
     - New upstream release
 
   * (Emanuele Rocca)
     - Convert the package to the new Gtk modules handling.      closes: #406874
     - Bump up the libgtk2.0-dev build-dep to >= 2.10.1-1.
     - Call dh_gtkmodules.
     - Add ${misc:Depends}.
     - Use the correct gtk version number in debian/rules.
 
     Thanks to Loïc Minier for the patch.

2006

gtk2-engines-xfce (2.3.99.2-1) unstable; urgency=low

   * New upstream release.

gtk2-engines-xfce (2.3.99.1-1) unstable; urgency=low

   * New upstream release

gtk2-engines-xfce (2.3.90.2-1) unstable; urgency=low

   * New upstream release
   * debian/control: updated standards version to 3.7.2

gtk2-engines-xfce (2.3.90.1-1) unstable; urgency=low

   * New Upstream Release
   * Added libx11-dev build dependency
   * Removed pointless .la files

2005

gtk2-engines-xfce (2.2.8-1) unstable; urgency=low

   * New Upstream Release

gtk2-engines-xfce (2.2.7-1) unstable; urgency=low

   * New Upstream Release
   * Change suite to unstable

gtk2-engines-xfce (2.2.6-1) experimental; urgency=low

   * ML: New Upstream Release (Xfce 4.2.1)
   * ML: Upload to experimental to prevents problems with NEW packages
   * ML: debian/control: Added/fixed Maintainer/Uploaders fields

gtk2-engines-xfce (2.2.5-2) experimental; urgency=low

   * Use the Rodent stock icons by default
   * Add a Homepage: to the description

gtk2-engines-xfce (2.2.5-1) experimental; urgency=low

   * New upstream release
   * Depend on xfce4-icon-theme

2004

gtk2-engines-xfce (2.2.2-1) experimental; urgency=low

   * New upstream release

gtk2-engines-xfce (2.1.10-1) unstable; urgency=low

    * New upstream release
    * Remove Norbert (as requested) and add self to Uploaders

gtk2-engines-xfce (2.1.8-1.1) unstable; urgency=low

    * NMU, with maintainer approval, to avoid breakage with new GTK+.
    * Rebuilt with GTK+ 2.4.

gtk2-engines-xfce (2.1.8-1) unstable; urgency=low

   * New upstream release
   * Add Daniel Silverstone <dsilvers@debian.org> to Uploaders as approved by
     madkiss
   * Thanks to Daniel for checking and uploading these packages

2003

gtk2-engines-xfce (2.1.7-1) unstable; urgency=low

   * New upstream release

gtk2-engines-xfce (2.1.6-1) unstable; urgency=low

   * New upstream release
   * New Co-Maintainer: Norbert Tretkowski.

gtk2-engines-xfce (2.1.0+cvs.20030421-1) unstable; urgency=low

   * New CVS Checkout (2003-04-21)
   * Updated for GTK 2.2 (Closes: #177975)

gtk2-engines-xfce (2.0.10+cvs.20030301-1) unstable; urgency=low

   * New CVS checkout (Using Xfce CVS, 2003-03-01)
   * Official release (really this time) (last release was never made public)
   * debian/control: Changed Maintainer: E-Mail address

gtk2-engines-xfce (2.0.10+cvs.20030216-1) unstable; urgency=low

   * New CVS checkout (Using Xfce CVS, 2003-02-16)
   * Official release (last release was never made public)

gtk2-engines-xfce (2.0.10+cvs.20030119-1) unstable; urgency=low

   * New CVS Checkout (Using Xfce CVS, 2003-01-19)

2002

gtk2-engines-xfce (2.0.10+cvs.20021222-1) unstable; urgency=low

   * New CVS Checkout (using Xfce CVS, 2002-12-10)
   * debian/rules: Moved files into correct directory (Closes: #171484)

gtk2-engines-xfce (2.0.10+cvs.20021127-1) unstable; urgency=low

   * Initial Release. (Closes: #170987)