Skip to content

Changelog gnome-twitch (0.4.1-2ubuntu0.18.04.1)

2018

gnome-twitch (0.4.1-2ubuntu0.18.04.1) bionic; urgency=medium

   * Backport the https fix to bionic (lp: #1777049):
     - Use https to talk to Twitch servers, because Twitch deprecated some http
       APIs

2017

gnome-twitch (0.4.1-2) unstable; urgency=medium

   * Set priority to optional because extra has been deprecated
   * Bump standards version from 3.9.8 to 4.1.1
   * Fix typo in meson build file (Closes: 880842)

gnome-twitch (0.4.1-1) experimental; urgency=medium

   * New upstream release (0.4.1)
   * Increase required meson version to 0.37.0
   * Update copyright information in d/copyright
   * Set locale to C.UTF-8 in d/rules because
     unicode support is needed

2016

gnome-twitch (0.3.1-1) unstable; urgency=medium

   * New upstream release (0.3.1)
   * Set priority to "extra"
   * Make gnome-twitch recommend the player
     backends instead of depending on them (Closes: #838830)
   * Update dependency on libgtk-3-dev to ">=3.20"
   * Add missing runtime-dependencies on gstreamer plugins:
     * gstreamer1.0-libav
     * gstreamer1.0-plugins-base
     * gstreamer1.0-plugins-good
     * gstreamer1.0-plugins-bad
   * Remove unnecessary dependency on gstreamer1.0-plugins-ugly
   * Add new and updated translation files to d/copyright

gnome-twitch (0.3.0-2) unstable; urgency=medium

   * Fix bug to correctly append the client ID
     only once per request

gnome-twitch (0.3.0-1) unstable; urgency=medium

   * New upstream release (0.3.0)
     * Build player backends in multiple binary packages
     * Add build-depends on libpeas-dev for new plugin system
     * Add build-depends on libmpv-dev for mpv player backend

gnome-twitch (0.2.1-1) unstable; urgency=medium

   * New upstream release (0.2.1)

gnome-twitch (0.2.0-4) unstable; urgency=low

   * Make ninja output all compiler commands (Closes: #832157)

gnome-twitch (0.2.0-3) unstable; urgency=medium

   * replace unsafe calls to sprintf-like functions
     with safer alternatives

gnome-twitch (0.2.0-2) unstable; urgency=medium

   * Use new meson syntax for gettext (Closes: #828714)
   * Updated dependency on meson accordingly

gnome-twitch (0.2.0-1) unstable; urgency=low

   * New upstream release (0.2.0)
   * Use hardening options
   * Updated dependencies:
     * Only link to needed libraries
     * Added gstreamer1.0-plugins-ugly for x264 codec
   * Bumped standard version from 3.9.6 to 3.9.8

2015

gnome-twitch (0.1.0-1) unstable; urgency=low

   * Initial release (Closes: #802226)