Skip to content

Changelog asunder (2.9.5-1+10.0trisquel3)

2021

asunder (2.9.5-1+10.0trisquel3) nabia; urgency=medium

   * Removed non-free formats. Closes #4061

2019

asunder (2.9.5-1) unstable; urgency=medium

   * New upstream version 2.9.5
   * Use sign-tags and filter debian in gbp.conf
   * Migrate to Standards Version 4.4.1 (No changes required)

asunder (2.9.4-1) unstable; urgency=medium

   * New upstream version 2.9.4
   * Use debhelper compat 12
   * Use Standards Version 4.4.0 (No changes required)

asunder (2.9.3-3) unstable; urgency=medium

   * Use asunder.maintscript instead of post/pre-inst/rm
   * Update Standards-Version to 4.3.0 (No changes required)
   * Use Debhelper compat level 12

2018

asunder (2.9.3-2) unstable; urgency=medium

   * Upgrade to Standards-Version 4.1.5 (No changes required)
   * Move icon to proper icon folder according to size
   * Add asunder.links to add symlinking from usr/share/icons/<size>/apps
     to pixmaps folder
   * Remove patch icons.diff, we want to read the icon from the pixmaps
     folder

asunder (2.9.3-1) unstable; urgency=medium

   * Add gbp.conf to enable pristine-tar by default
   * New upstream version 2.9.3
   * Refresh patches
   * Fix insecure-copyright-format-uri
   * Migrate VCS- fields to salsa
   * Update to debhelper compat version 11
   * Update Standards-Version to 4.1.3
   * Add upstream metadata file
   * Use DEP-14 branch naming

2017

asunder (2.9.2-1) unstable; urgency=medium

   * New upstream version 2.9.2
   * Update Standard-Version to 4.1.1 (No changes required)
   * Remove patch remove_file_when_it_should_be_folder.patch, applied upstream
   * Use space instead of tab, and fix spelling error in changelog

asunder (2.9.1-4) unstable; urgency=medium

   * Add patch to remove config file if blocks config folder
     creation (Closes: #872723)
   * Update Standards Version to 4.0.1 (No changes required)

asunder (2.9.1-3) unstable; urgency=medium

   * Fix Vcs-Git field

asunder (2.9.1-2) unstable; urgency=medium

   * Don't remove config.guess and config.sub on clean
   * Use git instead of mercurial
   * No need to use autotools-dev with compatibility level 10

asunder (2.9.1-1) unstable; urgency=medium

   * mercurial-importorig imported new upstream version.
     - Consolidate config files (Closes: #857359)
   * Bump Standards-Version to 4.0.0 (No changes required)
   * Update Debian packaging copyright year
   * Add hardening flags
   * Migrate to compat level 10

2016

asunder (2.8-5) unstable; urgency=medium

   * Remove Cleto Martin from Uploaders field (Closes: #846289)

asunder (2.8-4) unstable; urgency=medium

   * Update Standards Version to 3.9.8 (No changes required)
   * Add fix_freebsd_build_warning_implicit_declatation.patch:
       Fixes build warning on kfreebsd

asunder (2.8-3) unstable; urgency=medium

   * Remove incorrect logrotate files (Closes: #812179)
   * Use secure Vcs field uri

2015

asunder (2.8-2) unstable; urgency=medium

   * Remove menu file, not needed when desktop file is present
     - Closes lintian warning command-in-menu-file-and-desktop-file

asunder (2.8-1) unstable; urgency=medium

   * mercurial-importorig imported new upstream version.

asunder (2.7-2) unstable; urgency=medium

   * Fix typo in patch description
   * Add Vcs-Browser field
   * Make copyright use machine-readable copyright format 1.0

asunder (2.7-1) unstable; urgency=medium

   * Import new upstream version (Closes: #785199)
   * Add myself to maintainer field, rearrange previous
     maintainer to uploaders field
   * Add myself to the copyright file
   * Update to standards version 3.9.6 (No change required)
   * Add patch fix_desktop_mime_but_no_exec_code, quieting
     lintian warning

2014

asunder (2.5-3) unstable; urgency=medium

   * Bug fix: "broken logrotate file", thanks to Sven Joachim (Closes:
     #742858).

asunder (2.5-2) unstable; urgency=medium

   * Bug fix: "broken logrotate file", thanks to Sven Joachim (Closes:
     #742858). Removing logrotate.

asunder (2.5-1) unstable; urgency=medium

   * New upstream release.
   * Updating maintainer field at debian/control and debian/copyright
   * Adding Spanish translation to .desktop file

2012

asunder (2.2-1) unstable; urgency=low

   * New upstream release.

2011

asunder (2.1-2) unstable; urgency=low

   * Adopting package and updating related information (Closes: #628920).
   * Bumped Standards-Version to 3.9.2, no change.
   * Bug fix: "Typo in a .desktop entry", thanks to Andrea Carpineti
     (Closes: #619894).

asunder (2.1-1) unstable; urgency=low

   * New upstream version.
     (Closes: #610898, #610897)
   * Bumped Standards-Version to 3.9.1, no change.

2010

asunder (2.0-1) unstable; urgency=low

   * New upstream version, which now includes the GNU/kFreeBSD patch and
     Brazilian patch.
   * Added get-orig-source target in debian/rules.
   * Build-depend on a proper quilt-handling version of dpkg-source instead
     of quilt itself.
   * Bumped Standards-Version to 3.9.0, no change.

asunder (1.9.3-2) unstable; urgency=low

   * Updated Portuguese (Brasil) translation from Sérgio Cipolla.
     (Closes: #578980)

asunder (1.9.3-1) unstable; urgency=low

   * New upstream version, including Portuguese (Brasil) translation from
     Sérgio Cipolla.
     (Closes: #575867)
   * Added watch file.
   * Fix grammar in description.
     (Closes: #568697)
   * Bump Standards-Version to 3.8.4, no change.

asunder (1.9.1-1) unstable; urgency=low

   * New upstream version.
     (Closes: #567883)

asunder (1.6.2-6) unstable; urgency=low

   * Allow digits and dashes in filename simplification mode, and describe
     this mode in NEWS.Debian.
   * Converted to dpkg-source format 3.0 (quilt).
   * Now using mercurial-buildpackage for public maintenance at
     http://hg.debian.org/hg/collab-maint/asunder.

2009

asunder (1.6.2-5) unstable; urgency=low

   * New maintainer.
     (Closes: #543831)
   * Added VCS fields for new repository.
   * Added instructions for how to use the patch system.
   * Added filename simplification options %a, %t, and %l (cf. %A, %t, %L)
     which make all letters lowercase and replaces all non-ascii letters
     with underscores.

asunder (1.6.2-4) unstable; urgency=low

   * QA upload.
   * Fix FTBFS on GNU/kFreeBSD by using the FreeBSD parts when one of
     either __FreeBSD__ or __FreeBSD_kernel__ is defined. Add patch:
      + 02-kfreebsd.patch

asunder (1.6.2-3) unstable; urgency=low

   * Minimizing rules.
   * Updating package to standards version 3.8.3.
   * Removing vcs fields.
   * Orphaning package.

asunder (1.6.2-2) unstable; urgency=low

   * Using quilt rather than dpatch.
   * Updating version number in manpage.
   * Removing trailing slash from install file.
   * Adding description in menu file.
   * Passing flags to configure directly.
   * Updating year in copyright.

2008

asunder (1.6.2-1) unstable; urgency=low

   * Replacing obsolete dh_clean -k with dh_prep.
   * Prefixing debhelper files with package name.
   * Merging upstream version 1.6.2.

asunder (1.6.1-1) unstable; urgency=low

   * Initial release (Closes: #489772).